• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

RX580 won't show BIOS when disabling CSM


New Member
Jul 14, 2022
9 (0.03/day)

I tried contacting Asus, but they told me the original vBios was "intern/insider's information" so they wouldn't disclose it (isn't it funny?).
Well, I got a third party (the distributor) to take action, as it's quite certain they won't speak with a uninterested clerk (i had to suffer for more than 4 weeks of mailing, and doing things such as disconecting everything but proccessor, RAM, and GPU).
The card is still in warranty, but I'm just annoyed of their continous curve balls ("I've never seen that", "Please make a video", or "Are you sure you have the card properly plugged" are some of the -as we say here- "seabream's conversation" (nonsense talk).

I attached the last ROM I tried out, unsuccessfully.

I must admit I didn't try my luck with the GOPupd because of the warranty. Maybe that would have solved it, but...


  • 223505.rom
    256 KB · Views: 13


Freshwater Moderator
Staff member
Oct 6, 2004
57,065 (8.38/day)
System Name Rainbow Sparkles (Power efficient, <350W gaming load)
Processor Ryzen R7 5800x3D (Undervolted, 4.45GHz all core)
Motherboard Asus x570-F (BIOS Modded)
Cooling Alphacool Apex UV - Alphacool Eisblock XPX Aurora + EK Quantum ARGB 3090 w/ active backplate
Memory 2x32GB DDR4 3600 Corsair Vengeance RGB @3866 C18-22-22-22-42 TRFC704 (1.4V Hynix MJR - SoC 1.15V)
Video Card(s) Galax RTX 3090 SG 24GB: Underclocked to 1700Mhz 0.750v (375W down to 250W))
Storage 2TB WD SN850 NVME + 1TB Sasmsung 970 Pro NVME + 1TB Intel 6000P NVME USB 3.2
Display(s) LG 32" 4K60 | Kogan 32" 4K60 | Gigabyte G32QC (1440p165) | Phillips 328m6fjrmb (1440p144)
Case Fractal Design R6
Audio Device(s) Logitech G560 | Corsair Void pro RGB |Blue Yeti mic
Power Supply Fractal Ion+ 2 860W (Platinum) (This thing is God-tier. Silent and TINY)
Mouse Logitech G Pro wireless + Steelseries Prisma XL
Keyboard Razer Huntsman TE ( Sexy white keycaps)
VR HMD Oculus Rift S + Quest 2
Software Windows 11 pro x64 (Yes, it's genuinely a good OS) OpenRGB - ditch the branded bloatware!
Benchmark Scores Nyooom.
He needs your original BIOS, one that definitely works on your card so he can add the UEFI content manually (the GOP file)


New Member
Jul 14, 2022
9 (0.03/day)
Those Bios all work, the ones which subsystem ID was teh same as mine. I got "wattman" messages when the asus software gputweak was installed, but my main problem was that I receive no output in the monitor until the windows login screen, so I don't receive video signal while in Bios or POST. The performance was allright with the two Bios listed in for my card.
These are the Bios eidairaman1 kindly found for my card in the repository

I don't have the original Bios right now. I'm trying to get Asus to provide one to the distributor.