• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Ryzen 5 5600x cpu fan wont spin

Joined
Dec 2, 2009
Messages
3,335 (0.69/day)
System Name Dark Stealth
Processor Ryzen 5 1600
Motherboard Gigabyte B450M Gaming
Cooling Snowman dual fan
Memory 16x2 DDR4 Corsair Dominator Pro
Video Card(s) RX 580 4GB
Storage 1TB SSD, 1TB HDD
Display(s) Omen 25"
Case Zalman S2
Power Supply Corsair 750TX
Mouse Razer DeathAdder v1.0
Keyboard Logitech EX100
Software Windows 10
Benchmark Scores Maybe it is time to benchmark :D
Hi everyone,
So yesterday I just installed the ryzen 5 5600x over my previous 1600.
The cpu fan doesn't spin and in some software, it cannot recognize the cpu temps.
Same for the motherboard, even after flashing the latest bios, it wont recognize the cpu temps.

The AMD stock cooler though kept spinning, despite the unknown 0 temperature.
I changed the cooler to a beefier one. Snowman 6 pipes, double fans cooler.

Motherboard is b450m gaming gigabyte.
 
Joined
Mar 15, 2021
Messages
36 (0.05/day)
Have you tried (as a workarround) turning off the the fan control / regulation in BIOS/UEFI? If that would work you could control the fan using FanControl by Rem0o (from github)
 
Joined
Sep 3, 2019
Messages
2,714 (2.16/day)
Location
Thessaloniki, Greece
System Name PC on since Aug 18th 2019, 1st CPU R5 3600
Processor Ryzen 9 5900X, ECO mode 88W PPT
Motherboard Gigabyte X570 Aorus Pro (Rev1.0), BIOS F35, V2 1.2.0.7
Cooling Corsair H110i 280mm (w/ Contuctonaut since Jan 2020)
Memory 2x16GB G.Skill Trident Z Neo (GTZN) 3600MHz 1.40V CL16-16-16-16-32-48 1T, tRFC:274, B-die
Video Card(s) MSI RX 5700XT Gaming X, GPU 2100MHz, VRAM 1750MHz
Storage Samsung NVMe: 980Pro 1TB (OS 2022), 970Pro 512GB(2019) / SATA-III: 850Pro 1TB(2015) 860Evo 1TB(2020)
Display(s) Dell Alienware AW3423DW 34" QD-OLED curved by Samsung, 3440x1440
Case None... naked on desk
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W, Logitech G935 headset
Power Supply Corsair HX750i
Mouse Logitech MX Master (Gen1)
Keyboard Logitech G15 (Gen2) w/ LCDSirReal applet
Software Windows 10 Home 64bit (21H2)
Try HWiNFO64 (sensors mode only) for CPU temperatures report and maybe fan control too
 
Joined
Nov 16, 2020
Messages
151 (0.19/day)
Location
USA
System Name Testing stuff, always..
Processor i5-8600k / Ryzen 7 1700 / i7-7820x ES / i5-10300H
Motherboard z370 ITX / x570 Extreme4 (Woking w/ 1st Gen) / Evga x299 FTW-K
Cooling Noctua NH-D15S / Wraith Prism / EK-AIO 240 D-RGB
Memory 2x16 Crucial 3200 Mhz / 2xLPX 2x8 2666 Mhz / 2x8 2666 MHz SODIMM
Video Card(s) RTX 2080 Super Founders / RX 580 2048sp/ GTX 1650
Storage 500 GB WD SN750 / 1TB WD Blue M.2 / 870 Evo 500 GB / Kingston 480 GB SSD / HDDs Everywhere
Display(s) Alienware 34 aw3418dw / ROG Swift pg27q
Case Open air bench / Phanteks 719 / NZXT H210
Power Supply Seasonic Focus Plus Platinum 750w / Evga 600w Gold GD
Mouse Model O / Logitech G203
Keyboard GMMK Pro w/ SP Magic Girls / Frozen Llama Ducky One 2 Mini MX Silvers / Ducky One 2 Mini MX Reds
Software WIndows 10 Pro / Windows 11 Home
Kind of a silly question is the CPU fan plugged in correctly/to the right header?
 
Joined
Dec 2, 2009
Messages
3,335 (0.69/day)
System Name Dark Stealth
Processor Ryzen 5 1600
Motherboard Gigabyte B450M Gaming
Cooling Snowman dual fan
Memory 16x2 DDR4 Corsair Dominator Pro
Video Card(s) RX 580 4GB
Storage 1TB SSD, 1TB HDD
Display(s) Omen 25"
Case Zalman S2
Power Supply Corsair 750TX
Mouse Razer DeathAdder v1.0
Keyboard Logitech EX100
Software Windows 10
Benchmark Scores Maybe it is time to benchmark :D
Fixed it.
For some reason, I unplugged then plugged back in the CPU fan and it worked.
 
Top