• We've upgraded our forums. Please post any issues/requests in this thread.

Sapphire 6870 and Arctic Twin Turbo Pro fan speed

supaethan

New Member
Joined
Jan 24, 2011
Messages
4 (0.00/day)
Likes
0
#1
I just installed the cooler, the temp looks good. Fan speed is 21% at idle, and loading FurMark is only 27% yet still keeps the temp around 63C, before with the stock cooler, the temp goes up to 89C. And even I turn the fan speed to 100% using Catalyst fan control, it's silent.
But look at the fan speed, crazy number, sometimes it jumps to those huge numbers and sometimes it drops to 1800, 2300, 4500 or some sort of normal RPM, any ideas?

WIN 7 ultimate 64bit
ga-p55a-ud4p F14 BIOS
Sapphire 6870 reference, default setting and BIOS, not the new released one
Catalyst 10.12, nothing much changed except some 3D settings


Here is some screen shots, please take a look at.
 

Attachments

Last edited:

GreyGhost

New Member
Joined
Jan 26, 2011
Messages
5 (0.00/day)
Likes
0
#2
I have the same problem with a Twin Turbo Pro on my ASUS EAH6850. Jumping between high 600000 and 4000 and 1900, no real trend.

Reported it to Arctic, no reply yet.
 
Joined
Mar 24, 2010
Messages
4,574 (1.62/day)
Likes
918
Location
Independent in Imperialistic
System Name Oh the name!
Processor i7 7700K
Motherboard MSI Z270 Xpower
Cooling EK 360 Extreme
Memory 16Gb G.Skill TridentZ 3866
Video Card(s) nVidia 1080 Ti Flanders Edition
Storage 1 Intel PCIE SSD750, 2 Sam 840Evo 1TB SSD, WD Black 2TB, Toshiba 3TB
Display(s) Acer Predator X1 (32")
Case Rajintek Paean
Audio Device(s) onboard
Power Supply Corsair AX860
Mouse Mad Catz Pro X
Keyboard Corsair K70
Software W10Pro
#4
Arctic fans are nearly silent, also at 100% : )

The video card drives the fans as need to be. The reporting software of the fans can read whatever it doesnt realy matter!
Better write to the software creators...
 

GreyGhost

New Member
Joined
Jan 26, 2011
Messages
5 (0.00/day)
Likes
0
#6
Arctic fans are nearly silent, also at 100% : )

The video card drives the fans as need to be. The reporting software of the fans can read whatever it doesnt realy matter!
Better write to the software creators...
I know, its just a detail, the PWM ramps up just fine when the card is under load.

However, I would have to write to quite a lot of software developers, since the values are the same or all of them, makes me wonder about a hardware issue (or maybe Catalyst issue)

btw, my definition of silent differs from yours, the TT pro at 100% is definitely not silent.
 

GreyGhost

New Member
Joined
Jan 26, 2011
Messages
5 (0.00/day)
Likes
0
#7
Strange observation: when I put the %PWM at 100, the card normally reports 1812 RPM....

Maybe its to slow at low %PWM?

Edit: 90 %PWM is messed up already. 95 also. even 98 is too low, 99 works.
 
Last edited:
Joined
Mar 24, 2010
Messages
4,574 (1.62/day)
Likes
918
Location
Independent in Imperialistic
System Name Oh the name!
Processor i7 7700K
Motherboard MSI Z270 Xpower
Cooling EK 360 Extreme
Memory 16Gb G.Skill TridentZ 3866
Video Card(s) nVidia 1080 Ti Flanders Edition
Storage 1 Intel PCIE SSD750, 2 Sam 840Evo 1TB SSD, WD Black 2TB, Toshiba 3TB
Display(s) Acer Predator X1 (32")
Case Rajintek Paean
Audio Device(s) onboard
Power Supply Corsair AX860
Mouse Mad Catz Pro X
Keyboard Corsair K70
Software W10Pro
#8
As a consolation for you Ati-lim Brotherhood, I suffer the same. AIDA64 reports my Arctic Twin Turbo Pro at speeds like 6.000.000 rpm, so I just disabled it. This is on a nvidia 470 card.
 

supaethan

New Member
Joined
Jan 24, 2011
Messages
4 (0.00/day)
Likes
0
#9
Arctic replied me:
Thank you for your e-mail, we would like to help you regarding this issue.

We are sorry to hear that you have problem with one of our products.If your computer were unable to detect the fan speed of the Accelero TWIN TURBO Pro,it could be the reason that the fan speed to too low to detect which you check the following instruction for solution.

Due to the default voltage regulation on the fan, a low RPM value for the fan was created by the BIOS so as to prevent noise.

Accelero Twin Turbo is using 2 ultra quiet PWM fans which allow optimal air flow rate but operate at an extremely low noise level.To achieve the best result, it is recommended to use RivaTuner for controlling the fan speed.

The latest RivaTuner can be download from here(by Guru3D.com)

Step 1
Download and install the RivaTuner from here(by Guru3D.com)

Step 2
Run RivaTuner
It will take a few seconds to scan your hardware in the first run. Then, you can see the main menu as below:

Step 3
If you have more than one display, select the target in the drop down menu

Step 4
Select the VGA card logo for "Low-level system setting" by clicking on the downward arrow next to the "Customize..."




Step 5
Select the "Fan" tag and check the box of "Enable low-level fan control"

Step 6
Select "Fixed" and then change the % of fan speed by adjusting the bar

It is recommended to use around 70% for achieving the best noise-performance ratio. You can also adjust the % for different fan speed according to your preference.
Step 7
Check the box of "Apply fan settings at Windows startup" to make sure that this setting will be activated every time you boot up the PC.




Step 8Finally, click "OK" to confirm all settings



You can now enjoy the Silence and the Ultimate Power

We hope, this was helpful for you.

Best regards,
ARCTIC SUPPORT

Arctic Switzerland AG
Huobstr. 4 | 8808 Pfaeffikon | Switzerland


www.arctic.ac
 
Joined
Mar 24, 2010
Messages
4,574 (1.62/day)
Likes
918
Location
Independent in Imperialistic
System Name Oh the name!
Processor i7 7700K
Motherboard MSI Z270 Xpower
Cooling EK 360 Extreme
Memory 16Gb G.Skill TridentZ 3866
Video Card(s) nVidia 1080 Ti Flanders Edition
Storage 1 Intel PCIE SSD750, 2 Sam 840Evo 1TB SSD, WD Black 2TB, Toshiba 3TB
Display(s) Acer Predator X1 (32")
Case Rajintek Paean
Audio Device(s) onboard
Power Supply Corsair AX860
Mouse Mad Catz Pro X
Keyboard Corsair K70
Software W10Pro
#10
Nice answer, really :)
But no echo at all about 'speed readings'... :)
 

GreyGhost

New Member
Joined
Jan 26, 2011
Messages
5 (0.00/day)
Likes
0
#11
Nearly the same "copy paste" answer here, with a small difference in the first pararaph:

"If you were unable to detect the fan speed of the Accelero TWIN TURBO Pro, it could be the reason that the fan speed is too low to detect by your software.You may following the instruction below to set a high speed for your software to detect."

Meaning that it's my fault ;-)