• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire HD 5770 BIOS Botchup Leaves Users with Just 720 Stream Processors

Joined
Oct 26, 2008
Messages
1,908 (0.55/day)
Likes
285
System Name Budget AMD System
Processor FX-8320 @ 4Ghz (5.2Ghz when gaming)
Motherboard Gigabyte 970A-UD3P 1.0
Cooling Corsair H100i V2
Memory G-Skill X Series 2x4GB 1866
Video Card(s) XFX Radeon RX Vega₆⁴ Liquid @ 1,820Mhz
Storage 3x SATA (320GB/ 160GB/160GB Seagates)
Display(s) Vizio 22" 1080p 60hz TV (Samsung Panel)
Case Corsair 570X
Audio Device(s) Onboard
Power Supply Seasonic X Series 850W KM3
Software Windows 10 Pro x64
#52
that note has always been next to the updated bios download
heh, I was always told and showed otherwise by Sapphire's corporate offices and tech support... :-o
 
Joined
Apr 6, 2009
Messages
907 (0.27/day)
Likes
85
Processor i5 3570k
Motherboard Gigabyte Z77 UD5h
Cooling XSPC Raystrom
Memory 4x4GB DDR3 1600mhz
Video Card(s) 7950 crossfire
Storage a few
Display(s) 27" Catleap
Case Xigmatek Elysium
Audio Device(s) Xonar STX
Power Supply Seasonic X1050
Software Windows 7 X64
#53
This is exactly why I would never buy a product from Sapphire. This isn't the first time that they have released a card with a botched bios. I can't beleive that they denied that there was an issue to begin with and it took so much convincing. On top of all of that their customer service is horrific.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,399 (5.38/day)
Likes
6,173
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#54
This is exactly why I would never buy a product from Sapphire. This isn't the first time that they have released a card with a botched bios. I can't beleive that they denied that there was an issue to begin with and it took so much convincing. On top of all of that their customer service is horrific.
well your post here wasnt productive was it, the People who have the 5770s with the wrong bios are now having a blast with their boards that they have fixed themselves.
 
Joined
Mar 14, 2009
Messages
3,620 (1.08/day)
Likes
1,518
Location
Ohio
System Name Fractured puke.
Processor Intel I7-8700k
Motherboard MSI z370 Gaming M5
Cooling Corsair H110i
Memory 16GB G.Skill TridentZ 3200MHZ
Video Card(s) Nvidia 1070ti
Storage 960 EVO 500gb/256gb WD Black 2280 M2/Patriot Ignite 480gb SSD/ Inland Pro 256gb SSD
Display(s) Acer 32" 2560x1440
Case Fractal Design Meshify-C
Audio Device(s) Onboard/ TBD
Power Supply Seasonic
Mouse Epicgear
Keyboard Razer Deatstalker
Software Windows 10Pro x64
#55
This is exactly why I would never buy a product from Sapphire. This isn't the first time that they have released a card with a botched bios. I can't beleive that they denied that there was an issue to begin with and it took so much convincing. On top of all of that their customer service is horrific.
This may sound crazy to you but I Have had nothing but a Great experience (1 Time) with Sapphires tech support and guess what it was with The very same Sapphire 4830 That I'm using for my main card in XF and it's also the reason I'm a TechpowerUp member.....

I originally discovered the problem after reading about it on Yahoo Answers and somebody suggested That I download GPU-Z to check my Card and they also suggested I contact Sapphire.

After contacting Sapphire the option to send it in, or Flash the bios, was Given to Me. I did not really want to wait so i opted to Flash the Bios myself Unsure of how to do this I decided to Check the site that had helped me figure I had a problem TechPowerUp.com.

From there I believe that I found rather detailed instructions that was unmatched anywhere else, that I could find on the WEB, and Flashed my bios

After that I don't remember the Reason but i had another problem that I could not figure out, or find info on, So I decided to join The only Community that was able to help me with my "only Not able to solve myself problem" (at the time)


I like the fact that once called out Sapphire does own up to there mistakes.
I like TechPowerUp
See great Tech support experience!!

EDIT: and after reading through this post I see TechPowerUp just got some new members for the same thing
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,399 (5.38/day)
Likes
6,173
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#56
That's one reason this site is here, This site gets tons of press, that's why many of the big companies listen up when we do find problems. Example the 4830 and the 5770. This just proves that Sapphire is a very good company.

Anyone else want to try to downplay need not be here as they are worthless anyway.
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,309 (9.31/day)
Likes
13,857
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon (really nice board, bad vdroop under load w/ an 8 core)
Cooling Corsair H155i Pro (yay for maglev fans!)
Memory 16GB 2133 generic @ 3066 C18
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5 White Gold edition + RGB lighting
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 + Corsair Void RGB, Blue Yeti mic
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G703 + PowerPlay mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#57
That's one reason this site is here, This site gets tons of press, that's why many of the big companies listen up when we do find problems. Example the 4830 and the 5770. This just proves that Sapphire is a very good company.

Anyone else want to try to downplay need not be here as they are worthless anyway.
well, no. it proves they cave in fast when they think it could hurt their reputation - as the orginal member who reported the issue found out, he was quickly ignored and shoved in a corner.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,399 (5.38/day)
Likes
6,173
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#58
ya by a crap tech support person who hates their job. Thats when you have to jump the Command Chain.
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,309 (9.31/day)
Likes
13,857
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon (really nice board, bad vdroop under load w/ an 8 core)
Cooling Corsair H155i Pro (yay for maglev fans!)
Memory 16GB 2133 generic @ 3066 C18
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5 White Gold edition + RGB lighting
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 + Corsair Void RGB, Blue Yeti mic
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G703 + PowerPlay mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#59
ya by a crap tech support person who hates their job. Thats when you have to jump the Command Chain.
to me, thats still poor support. if i complained about a product not being as advertised, i'd expect them to get on their knees begging me not to sue (or at least, offering me a fully working replacement under warranty)
 
Joined
Mar 14, 2009
Messages
3,620 (1.08/day)
Likes
1,518
Location
Ohio
System Name Fractured puke.
Processor Intel I7-8700k
Motherboard MSI z370 Gaming M5
Cooling Corsair H110i
Memory 16GB G.Skill TridentZ 3200MHZ
Video Card(s) Nvidia 1070ti
Storage 960 EVO 500gb/256gb WD Black 2280 M2/Patriot Ignite 480gb SSD/ Inland Pro 256gb SSD
Display(s) Acer 32" 2560x1440
Case Fractal Design Meshify-C
Audio Device(s) Onboard/ TBD
Power Supply Seasonic
Mouse Epicgear
Keyboard Razer Deatstalker
Software Windows 10Pro x64
#60
well, no. it proves they cave in fast when they think it could hurt their reputation - as the orginal member who reported the issue found out, he was quickly ignored and shoved in a corner.
Mussels you have to consider That member could not have been more than the third person to report this to Sapphire....

Think about it there's not many programs out like GPU-Z, I have actually never seen another

People in Tech hear it all and can't do more than it says on the "Decision Flow Program" they use. As I see it this could have simply been a New Tech Support Person as a more experienced Tech support would have Known to file a case for the Engineering teams to figure out if in fact there is an Issue,
However I Actually Believe W1ZZ beat em to it...

And soon as he did, Being the reputable person he is, the Fix was OUT...

I think it only took W1ZZ what 3 people to Narrow down the Issue with "His Program"
That I don't believe Sapphire uses..

I do agree they should be a little more willing to listen but consider how many Loons would be calling in (like they already do) To bitch and moan about Phantom problems
 
Joined
Apr 6, 2009
Messages
907 (0.27/day)
Likes
85
Processor i5 3570k
Motherboard Gigabyte Z77 UD5h
Cooling XSPC Raystrom
Memory 4x4GB DDR3 1600mhz
Video Card(s) 7950 crossfire
Storage a few
Display(s) 27" Catleap
Case Xigmatek Elysium
Audio Device(s) Xonar STX
Power Supply Seasonic X1050
Software Windows 7 X64
#61
well your post here wasnt productive was it, the People who have the 5770s with the wrong bios are now having a blast with their boards that they have fixed themselves.
Yes, it was. What if I bought this card never ran GPU-z and didn't stumble onto this thread? It's not like this is the first time that they have done this, recently. Apparently there was a problem with their 4870. I didn't know about that. I was referring to the botched bios on their 4850s. I would be willing to bet that those user weren't having a blast before they discovered a fix that didn't void their warranty. These types of mistakes are unacceptable especially when made this often.

This may sound crazy to you but I Have had nothing but a Great experience (1 Time) with Sapphires tech support and guess what it was with The very same Sapphire 4830 That I'm using for my main card in XF and it's also the reason I'm a TechpowerUp member.....

I originally discovered the problem after reading about it on Yahoo Answers and somebody suggested That I download GPU-Z to check my Card and they also suggested I contact Sapphire.

After contacting Sapphire the option to send it in, or Flash the bios, was Given to Me. I did not really want to wait so i opted to Flash the Bios myself Unsure of how to do this I decided to Check the site that had helped me figure I had a problem TechPowerUp.com.

From there I believe that I found rather detailed instructions that was unmatched anywhere else, that I could find on the WEB, and Flashed my bios

After that I don't remember the Reason but i had another problem that I could not figure out, or find info on, So I decided to join The only Community that was able to help me with my "only Not able to solve myself problem" (at the time)


I like the fact that once called out Sapphire does own up to there mistakes.
I like TechPowerUp
See great Tech support experience!!

EDIT: and after reading through this post I see TechPowerUp just got some new members for the same thing
The 4830, too!! Come on four cards in less than two years thats just insane.

On a side note. I just modded the bios on my GTX280 thanks to some great instructions from Kursah, a user here. There is definitely some good info here and the community is without a doubt top notch.
 
Last edited:
Joined
Mar 14, 2009
Messages
3,620 (1.08/day)
Likes
1,518
Location
Ohio
System Name Fractured puke.
Processor Intel I7-8700k
Motherboard MSI z370 Gaming M5
Cooling Corsair H110i
Memory 16GB G.Skill TridentZ 3200MHZ
Video Card(s) Nvidia 1070ti
Storage 960 EVO 500gb/256gb WD Black 2280 M2/Patriot Ignite 480gb SSD/ Inland Pro 256gb SSD
Display(s) Acer 32" 2560x1440
Case Fractal Design Meshify-C
Audio Device(s) Onboard/ TBD
Power Supply Seasonic
Mouse Epicgear
Keyboard Razer Deatstalker
Software Windows 10Pro x64
#62
Yes, it was. What if I bought this card never ran GPU-z and didn't stumble onto this thread? It's not like this is the first time that they have done this, recently. Apparently there was a problem with their 4870. I didn't know about that. I was referring to the botched bios on their 4850s. I would be willing to bet that those user weren't having a blast before they discovered a fix that didn't void their warranty. These types of mistakes are unacceptable especially when made this often.



The 4830, too!! Come on four cards in less than two years thats just insane.

On a side note. I just modded the bios on my GTX280 thanks to some great instructions from Kursah, a user here. There is definitely some good info here and the community is without a doubt top notch.
I dunno...When you look at the process as a whole i'm actually surprised it does not happen more often...

Ever see all those Recertified cards at Newegg.......

My guess is those are from stuff just like this....

Your right the average user would never figure this stuff out... That's what makes sites like this so important...

W1ZZ keeps em honest and on guard

But you have to Give Sapphire Credit here too, it's not like once they tried to deny it after someone reputable reported the problem....
and I do not believe more than 3 people reported this before the fix was out

EDIT: I think Sapphire should pay W1ZZ for this as he saved them most likely a large sum of money...

I think this post Should turn to a Thank you to W1ZZ for his role in helping keeping prices low...
 
Last edited:
Joined
Apr 6, 2009
Messages
907 (0.27/day)
Likes
85
Processor i5 3570k
Motherboard Gigabyte Z77 UD5h
Cooling XSPC Raystrom
Memory 4x4GB DDR3 1600mhz
Video Card(s) 7950 crossfire
Storage a few
Display(s) 27" Catleap
Case Xigmatek Elysium
Audio Device(s) Xonar STX
Power Supply Seasonic X1050
Software Windows 7 X64
#63
I dunno...When you look at the process as a whole i'm actually surprised it does not happen more often...

Ever see all those Recertified cards at Newegg.......

My guess is those are from stuff just like this....

Your right the average user would never figure this stuff out... That's what makes sites like this so important...

W1ZZ keeps em honest and on guard

But you have to Give Sapphire Credit here too, it's not like once they tried to deny it after someone reputable reported the problem....
and I do not believe more than 3 people reported this before the fix was out

EDIT: I think Sapphire should pay W1ZZ for this as he saved them most likely a large sum of money...

I think this post Should turn to a Thank you to W1ZZ for his role in helping keeping prices low...
I don't see how something like this could possibly slip by. It's as if the bios wasn't tested at all. It makes me wonder what their RMA service is like. You know the same people that denied the problem to begin with. I honestly don't hear about stuff like this coming from other "manufactures". I remember reading about all of those headaches people were having with 4850s in crossfire that turned out to be a botched sapphire bios, they obvously didn't know it at the time. It took a long time for that problem to even be acknowledged. Like I said what happens to the people that don't check these forum news sections daily or bench or run gpu-z?
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,309 (9.31/day)
Likes
13,857
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon (really nice board, bad vdroop under load w/ an 8 core)
Cooling Corsair H155i Pro (yay for maglev fans!)
Memory 16GB 2133 generic @ 3066 C18
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5 White Gold edition + RGB lighting
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 + Corsair Void RGB, Blue Yeti mic
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G703 + PowerPlay mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#64
I don't see how something like this could possibly slip by. It's as if the bios wasn't tested at all. It makes me wonder what their RMA service is like. You know the same people that denied the problem to begin with. I honestly don't hear about stuff like this coming from other "manufactures". I remember reading about all of those headaches people were having with 4850s in crossfire that turned out to be a botched sapphire bios, they obvously didn't know it at the time. It took a long time for that problem to even be acknowledged. Like I said what happens to the people that don't check these forum news sections daily or bench or run gpu-z?
gigabyte had the same issues with crossfire and 4850's, it was due to using non-reference memory (not memory clocks, brand of memory) on the cards - ATI updated the drivers and broke compatibility.
 
Joined
Oct 26, 2008
Messages
1,908 (0.55/day)
Likes
285
System Name Budget AMD System
Processor FX-8320 @ 4Ghz (5.2Ghz when gaming)
Motherboard Gigabyte 970A-UD3P 1.0
Cooling Corsair H100i V2
Memory G-Skill X Series 2x4GB 1866
Video Card(s) XFX Radeon RX Vega₆⁴ Liquid @ 1,820Mhz
Storage 3x SATA (320GB/ 160GB/160GB Seagates)
Display(s) Vizio 22" 1080p 60hz TV (Samsung Panel)
Case Corsair 570X
Audio Device(s) Onboard
Power Supply Seasonic X Series 850W KM3
Software Windows 10 Pro x64
#65
I still think it was done on purpose. I would think the 2nd time a mistake like this happened the people/procedures used during the BIOS implementation process would be replaced/fixed... but this is the 4th or 5th time this has happened.. so it looks like Sapphire is just crap.. it should kill off its retail brand and stick to OEM'n.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,399 (5.38/day)
Likes
6,173
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#66
well heres the thing, probably the same people who inspected the 4830s got complacent again, they probably don't document who inspected what serial number. Also when something bad happens no one has Integrity to take responsibility for their actions. All I can say is that without someone giving press such as TPU these companies probably wouldn't take responsibility. Also on another point there are several companies with some bad tech-support personnel because they hire people who really don't want to be there. TBH majority of the TPU community know more than the techsupport personnel do.
 
Joined
Mar 14, 2009
Messages
3,620 (1.08/day)
Likes
1,518
Location
Ohio
System Name Fractured puke.
Processor Intel I7-8700k
Motherboard MSI z370 Gaming M5
Cooling Corsair H110i
Memory 16GB G.Skill TridentZ 3200MHZ
Video Card(s) Nvidia 1070ti
Storage 960 EVO 500gb/256gb WD Black 2280 M2/Patriot Ignite 480gb SSD/ Inland Pro 256gb SSD
Display(s) Acer 32" 2560x1440
Case Fractal Design Meshify-C
Audio Device(s) Onboard/ TBD
Power Supply Seasonic
Mouse Epicgear
Keyboard Razer Deatstalker
Software Windows 10Pro x64
#67
well heres the thing, probably the same people who inspected the 4830s got complacent again, they probably don't document who inspected what serial number. Also when something bad happens no one has Integrity to take responsibility for their actions. All I can say is that without someone giving press such as TPU these companies probably wouldn't take responsibility. Also on another point there are several companies with some bad tech-support personnel because they hire people who really don't want to be there. TBH majority of the TPU community know more than the techsupport personnel do.
Plus lets face it We all know where this Tech support is (country) and they pay these people like $.60 an hour and that's if they can speak english clearly
 
Last edited:

Arntor

New Member
Joined
Jan 1, 2010
Messages
1 (0.00/day)
Likes
1
#68
Thanks!

Thanks to all that work on getting this issue fixed. I will try the new BIOS and see how it goes.

My 8800 GTS died so I bought the Shappire card on December 21st. The card was working great, but after I used gpu-z I saw that the card had only 720 streams processors. I spent a good part of the evening trying to figure out why, when all the reviews show 800. I was curious to know if the card was defective, if it was a BIOS problem, or if Shappire was using 5750 parts to try to save some cash (I didn't know exactly how the card was made).

I emailed Shappire tech support on December 22, their answer was fast and but confusing:


800 is the stream processor not the unified shader, unified shaders on this card is 720.


Hi, I bought an vapor-x 5770 HD yesterday. When using gpu-z 3.0.8, we only see 720 unified shaders instead of 800 like the card is suppose to have. I'm curious why and if you have a tool that can confirm the number of shaders


I tried to email directly ATI to get confirmation with them, but their tech support is down until January 4th and I was leaving for holiday.

I have mix feelings about this. Working in IT, I know tech support vary greatly depending of the employees, number of people. They seem to have fix the issues fast. Tho if its just a small number of cards, it would have been easy to check all the tickets for that card and make sure to email back saying there is a bios fix. I will email them back tho, I didnt like the shader vs stream processors denying.

Shappire made a good guide on their website how to flash your BIOS. Not sure I would have use PowerPoint for the document, but in one of the screenshot:



Not sure Vista SP1 crack is a default Windows folder :shadedshu
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
46,309 (9.31/day)
Likes
13,857
Location
Australalalalalaia.
System Name Daddy Long Legs
Processor Ryzen R7 1700, 3.9GHz 1.375v
Motherboard MSI X370 Gaming PRO carbon (really nice board, bad vdroop under load w/ an 8 core)
Cooling Corsair H155i Pro (yay for maglev fans!)
Memory 16GB 2133 generic @ 3066 C18
Video Card(s) MSI GTX 1080 Gaming X (BIOS modded to Gaming Z - faster and solved black screen bugs!)
Storage 1TB Intel SSD Pro 6000p (60TB USB3 storage)
Display(s) Samsung 4K 40" HDTV (UA40KU6000WXXY) / 27" Qnix 2K 110Hz
Case Fractal Design R5 White Gold edition + RGB lighting
Audio Device(s) Pioneer VSX-519V + Yamaha YHT-270 + Corsair Void RGB, Blue Yeti mic
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G703 + PowerPlay mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
#69
LOL

not only are sapphire pirates, but they still haven't updated to SP2
 
Joined
Dec 28, 2009
Messages
7 (0.00/day)
Likes
0
#70
Got my vapor X - DOA :(

I start to get a bad feeling about AMD graphic cards AND Sapphire products.

1. Last graphic card i bought was a Sapphire (!) HD2600XT, that was said to offload HD video and produce HD audio (PLCM).
The problem was that AMD never successfully released drivers that could support 1080p under XP with AGP and as of today still have not. Not even in conjunction with Power DVD. You have to choose
- have a decent deconign of 720p using very old drivers.
- have a quite bad decoding using newer but modded drivers.
Both solutons require: register mod + media player classic special setup + lots of other stuff to ven get DXVA active. HD sound - never even started bothering to get that working since that seemed to be an even bigger long shot. Have today 720p working fine, but that PC will be replaced by the new HTPC below.

2. Now i bought a Sapphire HD5770 Vapor X. Did not even get a bios picture, bios beep or nothing. Swapped the card around in pci-e slots, tested different power outlets from the psu to the gpu. Probably tried 5-10 diffrent things and then i got a bios post :D good times huh...yes for 1 hour, then it completely died :( Tested it in friends PC, samt problem. Tested his GFX card (asus) in mine and that worked fine. Have now RMA'd the card and waiting for a new one...just to probably need to flash the bios the first thing I do :banghead:

Only reason I chose 5770 was that it is the only realtively cool card that can output HD audio in bitstream+LPCM and said to have working hardware acceleration (must be sloved by now and will be running PCIe + Win7 so should be no wories there I hope). Only reason i choose vaporX was that it was said to be quiet. When my fan spun up to max at startup of the pc...I was not to sure. But then it went to very low rpm's that was very hard to hear without putting ear next to it. Will see if I have to try to make a passive solution with thermaltakes cooler. Wish that power color had released a passively cooled 5770 as they did with 5750...but really cant wait for that. It will probalby pop up in the near future :)

The problem is that the graphic business reacts extremely slow to the HTPC market.They really dont seem to care if they promise gold and green forest...but really cant supply more than rusty nails and some old plant :p


Good evening guys
Boogie
 
Last edited:
Joined
Dec 28, 2009
Messages
7 (0.00/day)
Likes
0
#72
new ati low end cards coming out very soon, in performance below 5770, but all the htpc features
Good to know but...
The performance of th 5770 will fit me fine, since I also want to play games in full HD (HTPC with gaming option :) ).
Just a pity that no-one released a passively cooled version....yet :)
By the time I have modded mine with some expensive passive cooler, I guess the will be released to the market :banghead:
I allmost went for the passively cooled 5750 from power color, but I think in one year I will run cross fire to be able to play the new games in FullHD so 5770 is a better choice then :)
 

btarunr

Editor & Senior Moderator
Staff member
Joined
Oct 9, 2007
Messages
35,007 (9.03/day)
Likes
17,773
Location
Hyderabad, India
System Name Crypto-plague Survival Kit
Processor Intel Core i7-4770K
Motherboard ASUS Z97-A
Cooling Xigmatek Aegir CPU Cooler
Memory 2x 8GB Kingston HyperX Beast DDR3-1866
Video Card(s) 2x ZOTAC GeForce GTX 970
Storage ADATA SU800 512GB + Intel SSD320 120GB + Patriot WildFire 120GB
Display(s) Samsung U28D590 28-inch 4K UHD
Case Cooler Master CM690 1st Gen
Audio Device(s) Creative Sound Blaster Recon3D PCIe
Power Supply Corsair HX850W
Mouse Razer Abyssus
Keyboard Microsoft Sidewinder X4
Software Windows 10 Pro
#73
Thanks to all that work on getting this issue fixed. I will try the new BIOS and see how it goes.

My 8800 GTS died so I bought the Shappire card on December 21st. The card was working great, but after I used gpu-z I saw that the card had only 720 streams processors. I spent a good part of the evening trying to figure out why, when all the reviews show 800. I was curious to know if the card was defective, if it was a BIOS problem, or if Shappire was using 5750 parts to try to save some cash (I didn't know exactly how the card was made).

I emailed Shappire tech support on December 22, their answer was fast and but confusing:


800 is the stream processor not the unified shader, unified shaders on this card is 720.


Hi, I bought an vapor-x 5770 HD yesterday. When using gpu-z 3.0.8, we only see 720 unified shaders instead of 800 like the card is suppose to have. I'm curious why and if you have a tool that can confirm the number of shaders


I tried to email directly ATI to get confirmation with them, but their tech support is down until January 4th and I was leaving for holiday.

I have mix feelings about this. Working in IT, I know tech support vary greatly depending of the employees, number of people. They seem to have fix the issues fast. Tho if its just a small number of cards, it would have been easy to check all the tickets for that card and make sure to email back saying there is a bios fix. I will email them back tho, I didnt like the shader vs stream processors denying.

Shappire made a good guide on their website how to flash your BIOS. Not sure I would have use PowerPoint for the document, but in one of the screenshot:

http://img527.imageshack.us/img527/5244/vistav.jpg

Not sure Vista SP1 crack is a default Windows folder :shadedshu
Stream processor == unified shader, period. Stream processors can be assigned to perform pixel or vertex shader operations. So by definition it's a unified shader. Sapphire fucked up, and are using BS to cover up.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,399 (5.38/day)
Likes
6,173
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Joined
Dec 24, 2009
Messages
26 (0.01/day)
Likes
5
Location
ATHENS GREECE
#75
I bought vapor-x because i thought it had a great cooler, i am not a o/c fan but i like low tempetures.

Tested the card stock after unlocking all the 800 sp's and the tempeture's was
40 oC for idle and 76 oC in 100% stress.

Bought A.C.ACCELERO L2 PRO + A.C. MX-3 THERMAL COMPOUND, and did the same test.
33 oC idle and 57 oC 100% stress.

i wrought this because my final conclusion is that vaporX is not worth the extra money.

here is a photo of my 5770 now.

1.jpg