1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire HD4830 Problems

Discussion in 'AMD / ATI' started by Vadersblade, Apr 20, 2009.

  1. Vadersblade New Member

    Joined:
    Apr 20, 2009
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    Hey everyone. Having some issues with my video card, I think. I started to notice some of the text in firefox and some windows menus was looking blurry. Now I swear when I am viewing myspace or other sites smaller thumbnail images are blurry as well. Yesterday I went to turn on my monitor, and it looked like the whole thing was in the darker "text" mode, instead of vivid as it usually is. I rebooted and that went away.

    I had all the updated drivers from ATI, and thought one of those might be the cause. I rolled back the drivers, uninstalled and re-installed the video card. No luck. I also thought it might have something to do with Cleartype, but disabling that only helps a little bit. All drivers are up to date. Bios is up to date.

    I should note that I have my video card running my monitor through VGA and a Sony Bravia XBR6 running through the HDMI. Initially they both mirrored each other and all was well. Didn't need to install the catalyst control center or anything, they worked fine. Now somewhere in the process of reinstalling drivers my display on the Sony doesn't seem to fill the screen, leaving a gap of about 1/2" to an 1" on either side of the screen.

    Finally, I ran 3DMark free edition and pulled a score of 5500 on video? I read some comparable reviews and most 4830s pulled a 11000 or so. My average Frame Rate was 11-15.

    Did my card just start to die out, or is there anything I am missing? Of course, it is exactly 31 days after I bought the card, so my RMA just went up in smoke.

    Thanks for reading all this!!
     
  2. exon1 New Member

    Joined:
    Feb 23, 2009
    Messages:
    99 (0.03/day)
    Thanks Received:
    7
    I get about 5900 points in 3DMark Vantage. (Stock clocks)
    11k points in 3DMark Vantage??!! A 4870x2 gets 15k. xD
     
  3. JrRacinFan

    JrRacinFan Served 5k and counting ...

    Joined:
    Mar 17, 2007
    Messages:
    19,642 (5.53/day)
    Thanks Received:
    4,745
    Location:
    Youngstown, OH
    If thats 3dmark06 your speaking of, 5500 seems very on par for SM2 scoring.
     
  4. Vadersblade New Member

    Joined:
    Apr 20, 2009
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    Alrighty. LOL, the 3DMark score was the least of my concerns. I am more worried about the display of text and the sizing problem on my LCD.
     
  5. Vadersblade New Member

    Joined:
    Apr 20, 2009
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    Any ideas?
     
  6. Kursah

    Kursah

    Joined:
    Oct 15, 2006
    Messages:
    9,745 (2.63/day)
    Thanks Received:
    3,607
    Location:
    Missoula, MT, USA
    Reset image/monitor defaults in CCC, reset your LCD's settings to default, reseat connections @ monitor and vid card.

    Edit: Do you have any other connections you can try on the sony like DVI? See if it performs similar, maybe another vid card or PC to connect the sony to to narrow out a monitor issue? I would say install CCC if you don't have it installed and see if it helps.
     
    10 Year Member at TPU
  7. Vadersblade New Member

    Joined:
    Apr 20, 2009
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    I have the TV hooked up through a PS3 on HDMI, and a Xbox 360 on component inputs, no problems with either of those. I have tried CCC and without CCC. I've even tried uninstalling and physically removing the video card and reinstalling it. I'm waiting on a DVI cable to see if that helps the monitor display at all, otherwise I am about ready to reformat. :mad:
     
  8. Vadersblade New Member

    Joined:
    Apr 20, 2009
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    Finally got my DVI cable in today. Plugged it in, and

    Nothing. Picture still looks the same.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)