• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire HD7850 OC Gpu-z Bug or defective card??)

Joined
Mar 18, 2013
Messages
3 (0.00/day)
Likes
0
#1
Hello guys, i have a Sapphire HD7850 OC that was bought in July 2012. During the first month it was normal to have black screens with the fan at 100% at windows login, but i think it was probably a driver issue because that didn't happen anymore since catalyst 12.8.

On the other side, GPU-Z always reported some strange things at startup that didn't go away with newer versions of catalyst and neither of GPU-Z.

Here are some screenshots which illustrate what i mean by "strange things".

https://www.dropbox.com/s/vyw6ygqxf5exlhf/Sapphire HD 7850 OC gpu-z 1.gif

https://www.dropbox.com/s/2m0kefm00stao3f/Sapphire HD 7850 OC gpu-z 2.png

https://www.dropbox.com/s/mmllkv07ksrsblu/Sapphire HD 7850 OC gpu-z 3.png

https://www.dropbox.com/s/dk15zlgyo3nnftr/Sapphire HD 7850 OC gpu-z 4.gif

Here goes a screenshot of GPU-Z when it's closed and opened again:

https://www.dropbox.com/s/ym1t4aj8a16f8i7/Sapphire HD 7850 OC gpu-z normal.gif

As you can see the stats are "normal" and the things you can see above can't be replicated during Windows, unless i restart the computer, and even doing it, the "bug" doesn't always occurs!

Could this be a GPU-Z bug or could this be a defective card / defective memory chips? Should i contact Sapphire for an RMA?

If someone can answer me and easy my mind i would be very grateful! Thank you guys!

Carlos
 
Last edited:

W1zzard

Administrator
Staff member
Joined
May 14, 2004
Messages
17,186 (3.44/day)
Likes
18,169
Processor Core i7-4790K
Memory 16 GB
Video Card(s) GTX 1080
Display(s) 30" 2560x1600 + 19" 1280x1024
Software Windows 7
#2
That happens when GPU-Z can't properly read the BIOS. Strange thing is that reading the BIOS version (mostly) works. Maybe some other application is trying to read the BIOS at the same time during startup?
 
Joined
Mar 18, 2013
Messages
3 (0.00/day)
Likes
0
#3
Not that i know of, the only application that opens too at startup is my anti-virus (ESET NOD32), i always excluded the catalyst control center from startup but there is a process opened (atiedxx.exe).

Edit: I've been wandering in Sapphire website and found an application called Trixx and it shows the card stats kinda like the first page of GPU-Z. I don't think GPU-Z has any kind of bug because Trixx showed incorrect stats too (and even weirder)-> https://www.dropbox.com/s/8yf9cu0rxh8yc5l/Trixx.png
 
Last edited: