• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sapphire RX550 fan running - no output

Riq808

New Member
Joined
Nov 6, 2019
Messages
3 (0.27/day)
My dad upgraded to a 4k monitor lately and realized his old ATI Radeon HD 6850 doesnt support 4k output. We looked up for the cheapest 4k compatible cards (since he doesnt game) and ended up with the Sapphire RX550 2gb.
On the original page of Sapphire they said the card is compatible with PCI-E 2.0 16x (same as the former card). The power consumption is almost half as high as the HD 6850 and i updated the BIOS version to 7.15 (the latest i could find for that board).
Unfortunately the BIOS doesnt look like any "normal" BIOS i've ever seen (its a Pegatron 2ab6) - never heard of that company before.

Is there anything "obvious" thats uncompatible that i've overlooked in my research?
I was wondering about the troubleshooting since quite a few people tested the cpu and gpu combination and it worked very well.

kind regards,
Patrick

--------------------------------------
All Specs:
Case: HP ATX-Case (former Pre-Build-PC)
CPU: i5 2600 @ 3,4GHz
(old) GPU: ATI HD 6850
RAM: 6Gb DDR3
PSU: 460Watt (not 80+ certified)
SSD: 250gb Samsung EVO
HDD: Seagate Barracuda 1TB
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,873 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
What's the specific motherboard, the model will be somewhere on the furface or on a white sticker.

Get hwinfo64 and post the info here
 
Joined
Jun 2, 2017
Messages
1,442 (1.61/day)
System Name Best AMD Computer
Processor AMD TR4 1920X
Motherboard MSI X399 SLI Plus
Cooling Alphacool Eisbaer 420 x2 Noctua NHU-14S TR4
Memory Gskill RIpjaws 4 3000MHZ 48GB
Video Card(s) Sapphire Vega 64 Nitro, Gigabyte Vega 64 Gaming OC
Storage 6 x NVME 480 GB, 2 x SSD 2TB, 5TB HDD, 2 TB HDD, 2x 2TB SSHD
Display(s) Acer 49BQ0k 4K monitor
Case Thermaltake Core X9
Audio Device(s) Corsair Void Pro, Logitch Z523 5.1
Power Supply Corsair HX1200!
Mouse Logitech g7 gaming mouse
Keyboard Logitech G510
Software Windows 10 Pro 64 Steam. GOG, Uplay, Origin
Benchmark Scores Firestrike: 24955 Time Spy: 13500

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,873 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Please get pics of white stickers located on back of card or side of the card heatsink.

SKU/PN are needed.

Use old monitor on the 6850, then plug the 550 in another pcie slot and get a gpu-z screenshot of the 550 info

(Might need to remove uefi from the gpu but info is needed)
 

Riq808

New Member
Joined
Nov 6, 2019
Messages
3 (0.27/day)
If he is running DIsplay Port that could be the source of the problem. DIsplay Port cables can be very flaky. I purchased this one and have had no issues since.

Hi,
I used the old card with DVI and later with HDMI wich worked perfectly fine. I tested the RX550 with all possible outputs (DisplayPort, HDMI and DVI) on both the old and the new monitor and the result was always a blackscreen :/

Please get pics of white stickers located on back of card or side of the card heatsink.

SKU/PN are needed.

Use old monitor on the 6850, then plug the 550 in another pcie slot and get a gpu-z screenshot of the 550 info

(Might need to remove uefi from the gpu but info is needed)
I'll definitely send you the exact info as soon as i get back home to take a photo. The mainboard only has one PCI-E so thats not an option :/
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,873 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Hi,
I used the old card with DVI and later with HDMI wich worked perfectly fine. I tested the RX550 with all possible outputs (DisplayPort, HDMI and DVI) on both the old and the new monitor and the result was always a blackscreen :/


I'll definitely send you the exact info as soon as i get back home to take a photo. The mainboard only has one PCI-E so thats not an option :/

The motherboard should have video out port (s) as your cpu has a built in igp, plug monitor into that and verify.
 

Riq808

New Member
Joined
Nov 6, 2019
Messages
3 (0.27/day)
Please get pics of white stickers located on back of card or side of the card heatsink.

SKU/PN are needed.

Use old monitor on the 6850, then plug the 550 in another pcie slot and get a gpu-z screenshot of the 550 info

(Might need to remove uefi from the gpu but info is needed)
Those were the only stickers i could find on the board...
 

Attachments

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
27,873 (6.17/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Those were the only stickers i could find on the board...
Pull the gpu, look on back of it or on heatsink side closest to pcie slot contact, post those stickers
 
Top