• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sennheiser GSP 350. Microphone stops working when I open any game

Status
Not open for further replies.
Joined
Jun 19, 2008
Messages
1,540 (0.42/day)
Likes
89
Location
Shepparton, Victoria, Australia
System Name Toaster!
Processor Intel Core i7 5930k @ stock
Motherboard ASUS x99 Deluxe
Cooling Phanteks PH-TC14PE CPU Cooler (Blue). Stock on GPU.
Memory Corsair Vengeance LPX CMK16GX4M4A2800C16 16GB (4x4GB) DDR4 @ 2750mhz
Video Card(s) MSI 980 Ti Gaming 6GB
Storage Samsung 850 series 512GB SSD
Display(s) AOC D2757Ph 27" 3D IPS Widescreen LED Monitor + Viewsonic VX2753MH 27 Inch + Benq 27''
Case Corsair Obsidian 900D
Audio Device(s) ASUS ROG Phoebus 7.1 + Logitec X530 speakers. Sennheiser GSP 350 7.1 Gaming Headset
Power Supply Antec High Current Pro Platinum 1300W Modular Power Supply
Mouse Razer Deathadder
Keyboard Corsair K70.
Software ALL HAIL WINDOWS 10.
Benchmark Scores http://www.3dmark.com/fs/6805248
#1
So I've never experienced anything like this.

What I've tried so far.
- Restarting PC.
- Reinstalling the official software and restarting.
- Unplugging and re-plugging it in. (different USB slots too)
- Unchecking/rechecking exclusive control setting.

Seriously, I'm already out of ideas. Not sure what to do. Help me TPU, you're my only hope.
Edit: I have not installed any new software or games recently either. This is totally out of the blue and only happened today. I can use the microphone fine as long as Im not running a game. I'm even speaking in Teamspeak with it.
 
Last edited:
Joined
Jun 19, 2008
Messages
1,540 (0.42/day)
Likes
89
Location
Shepparton, Victoria, Australia
System Name Toaster!
Processor Intel Core i7 5930k @ stock
Motherboard ASUS x99 Deluxe
Cooling Phanteks PH-TC14PE CPU Cooler (Blue). Stock on GPU.
Memory Corsair Vengeance LPX CMK16GX4M4A2800C16 16GB (4x4GB) DDR4 @ 2750mhz
Video Card(s) MSI 980 Ti Gaming 6GB
Storage Samsung 850 series 512GB SSD
Display(s) AOC D2757Ph 27" 3D IPS Widescreen LED Monitor + Viewsonic VX2753MH 27 Inch + Benq 27''
Case Corsair Obsidian 900D
Audio Device(s) ASUS ROG Phoebus 7.1 + Logitec X530 speakers. Sennheiser GSP 350 7.1 Gaming Headset
Power Supply Antec High Current Pro Platinum 1300W Modular Power Supply
Mouse Razer Deathadder
Keyboard Corsair K70.
Software ALL HAIL WINDOWS 10.
Benchmark Scores http://www.3dmark.com/fs/6805248
#2
Wow, ok. I think I've fixed it by accident while fiddling around.

It appears to be the Realtek audio being the issue here. I don't use my onboard sound card as my headset is a USB headset only and my speakers are plugged into an ASUS sound card.

Step by step fix:
  1. I went into recording devices
  2. I enabled STEREO MIX (Realtek High Definition Audio)
  3. Then I set that Stereo Mix as the DEFAULT DEVICE (At this point it took over both input and output devices without my permission )
  4. Then set my Sennheiser headset as default recording and playback devices in their respective windows even though they both still said they were the default devices when they weren't
Headset microphone is currently functioning while in game now. I'll update the thread if it goes again. Should I completely disable Realtek audio??? Or will windows just force it to work again?
 
Status
Not open for further replies.
Top