• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Single core clock goes up to 1.5 GHz - 2.5 GHz Ryzen 3200G

CabanaBanana

New Member
Joined
Mar 21, 2020
Messages
21 (0.07/day)
Single core frequency is hanging around 1.5 GHz to 2.5 GHz during load Cinebench R20.

Hardware:
Ryzen 3 3200G
Gigabyte A320-S2H (latest BIOS)
8GB DDR4 3200mhz
GTX 960
Fresh install Windows 10 2004

After a fresh install of windows 10 pro 2004, I installed chipset drivers, ryzen master and Cinebench R20 to benchmark test it. My multi-core frequency is perfectly fine boosting all cores @ 3.8 GHz and maintains it during multi CPU bench.

My single-core frequency is faulty as it barely rises above idle downclock. It stays around 1.5 GHz-2.5 GHz. It will does go above 3.0 GHz for a micro second. This is obviously wrong. (this is single-core bench)

I have enabled High Performance Mode in power settings, I have updated the motherboard bios, cleared CMOS with all default settings, and still I am nowhere.

Please help me as I don't know where to go from here. At this point I would be happy to just run constant 3.6 GHz with no boost and no downclocking.

Bump I really could use any help
 
Joined
May 12, 2006
Messages
1,352 (0.25/day)
Location
The Gulag Casino
System Name ROG By purecain
Processor AMD Ryzen 9 5950X
Motherboard ASUS Crosshair VIII Hero
Cooling Noctua NH U12A
Memory 32Gb G.Skill Trident RGB 4150@3600mhz
Video Card(s) EVGA RTX3090 ULTRA GAMING / Titan V
Storage 1TbSamsung EvoM.2/1TbSamsung SSD/120gbKingston ssd
Display(s) LG 65UN85006LA 65" Smart 4K Ultra HD HDR LED TV with Google Assistant & Amazon Alexa
Case Thermaltake CoreX71 Limited Edition Etched Tempered Glass Door
Audio Device(s) On board/NIcomplete audio 6
Power Supply Seasonic FOCUS 1000w 80+
Mouse Logitech MX MASTER
Keyboard Corsair Strafe Keyboard
Software Windows10pro
Benchmark Scores [url=https://valid.x86.fr/gtle1y][img]https://valid.x86.fr/cache/banner/gtle1y-6.png[/img][/url]
Go into bios and check that precision overdrive is turned on, there may also be an option to select an overclock state. Select oc2 or 3. Not sure what the BIOS is like on gigabyte amd boards but it cant be that different than ASUS. Make sure your ram is running double the infinity fabric speed. 1800-2000 infinity fabric should mean you set 3600 to 4000mhz for the ram. Let me know how you get on.
Post some pics of your bios and I'll tell you what to set and why. Hope that helps buddy!!!! :toast:
 
Top