• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

SOLUTION: ATIFlash 'Adapter not found' 'Error 0FL01' X1950 AGP used.


New Member
Nov 25, 2007
27 (0.01/day)
System Name VERITAS-PC
Processor Intel Pentium 4 3.00GHz Prescott
Motherboard Intel D848PFT2 800MHz FSB AGP 8x
Cooling Zalman ZM-MFC1
Memory Kingston 1GB 2x1024 PC3200 DDR@400MHz
Video Card(s) Sapphire ATi Radeon X1950 Pro AGP 512mb *custom*
Storage Maxtor 80GB & Western Digital 250GB
Display(s) DCLCD 22" Widescreen
Audio Device(s) Creative Sound Blaster Live!
Power Supply Coolmax V-500
Software Dual: XP Professional SP3 Build 3311 RC2 & Vista Ultimate OEM SP0
Benchmark Scores XP/Vista 3DMark 2006: 4006/3886 3DMark 2005: 6443/tba 3DMark 2003: 12054/tba
Ok. I'm fairly new to overclocking graphic cards, but this is the first time ive ever killed a card...or so i thought :D

I recently purchased an ATi Radeon X1950 Pro AGP 512mb [Sapphire]. After google'ing around i found a lot of other people running X1950's at higher clocks, Me personally, Right now I'm running stable at 600/715 [Default 580/700]. Anyway, I should have quit there, but no. I found some people saying that their Sapphire X1950 Pro AGP BIOS needed to be updated or they were purposely updating or modding it for overclocking purposes.

So after seeking out BIOS flashing info and tools I eventually ended up with RaBiT 2.2.0, ATIWinFlash and ATIFlash, I already had ATITool [0.27b2]. Now I've flashed my mainboard bios before and i understand its a risky procedure, but all X1950 BIOS's are the same right? Wrong. BIOS's as far as i know contain info on voltages and default clock speeds. Not sure if it contains interface info [PCI/PCI-E/AGP], but I'd imagine it does. Anyway VERY IMPORTANT Backup/DUMP/Save your BIOS using whatever means works best. Be it RaBiT or ATITool or i think even TPU Has a Bios Saver.exe util that i used too :p The bios i ended up using to save my card was this very bios that i dumped before i started to screw with it.

My error, I ended up flashing my X1950PRO AGP 512mb card with a BIOS for a X1950PRO PCI-E 512mb. I did this flash with ATIWinFlash as well. Probably not a good idea either.

After this of course my card was effectively dead, Black screen on boot. Just about everyone has on board lan/sound/video these days, so naturally i tried using that. Nope, Had to clear the CMOS on my mainboard [ECS P4VMM2 Rev 7.3] I'd imagine this is cuz i either had my on board video disabled as i might have done when i got the card, dont remember :p Anyway thats what i had to do, If your at the black screen and cant boot stage of a bad flash, try clearing your CMOS/BIOS [for me this was done via a jumper, you probably have one too, check your manual]

After clearing my CMOS and using my on board video im back up and running, but the card is still dead, not detected nothing. This is where it all starts. After downloading just about every version of ATIFlash for DOS and trying a couple windows versions as well the card is still invisible. As of posting the latest version of ATIFlash is v3.49, DONT use it. It always crashed out for me. Try it if you must, But I'd suggest getting v3.15

Apparently it is a very very good idea to flash from DOS, unfortunately Windows XP doesnt exactly have DOS. Now, some of you might even have an old school 9x Boot Disk lying around. Thats great, I dont even have a floppy drive [well i do, but i never hooked it up and its collecting dust in my closet]. So I'm going to route of USB Keys and Bootable CD's

Now this is probably the 2nd day into my X1950's coma. Regret and stress is x2. Now assuming most of you are running XP, dont know anything about rebuilding bootable images and certainly dont know much about DOS and Filesystems and NTFS/Fat32 and (in)compatibilities or that...oh i dunno maybe the fact that DOS cant read your NTFS XP Partition.

Luckily for me I had this wonderful collection of tools called the 'Roadstarter Boot CD' or Ultimate Boot Disc. Find something that looks like that and burn yourself off a copy. This CD is an absolute god send for what i had to do, its also just handy for tons of other stuff too :p

The RSCD [RoadStarter bootCD] has a great assortment of options and pre-made configs for booting into DOS with support for things like reading USB Keys, CDROM's, ZipDrives and yes NTFS HardDrives. The option that worked best for me i believe was DOS -> DOS-No EMM386 used in conjunction with NTFS 4 DOS 1.3 or something like that. Dont use HIMEM or EMM386 and avoid RamDrive if you can, but i believe it worked with RamDrive on as well. I ran into a lot of delays here cuz not only do the latest ATIFlash versions require more memory [DOS is a very limited enviroment, especially in this scenario] ATIFlash v3.15-3.2x ran for me in cases where 3.4x wouldnt run cuz of memory issues.

Anyway, Provided you can get into DOS and get the tool running correctly this is when you'll run into the 'Adapter not found' and Error 0FL01 messages. Which is probably what brought you here which is probably where your at. [just being thorough, i want others in this situation to be able to revive their cards!]


Unfortunately this was the case for me, not sure if its like that for everyone, but...logic tells me it would be. You may have read that you can revive your card by reflashing with a PCI card. However PCI Cards are quite old and not really the mainstream anymore, Lucky for me, I had one lying around :p So to revive an AGP Card you need a PCI card, ANY PCI card.

After getting the PCI Card booted my AGP Started showing up in my POST as IRQ 5 listed under my PCI Devices, this is another way to tell if your card is detected so keep an eye out for it. ATIFlash -i started detected my card fine and the flash went fine as well, well...not exactly. I tried a bios provided by Sapphire for X1950 AGP cards with fan issues, but it didnt work. Oh well, the original bios did. I'm not complaining. [and i dont have fan issues]

I hope this post has helped you
Last edited:
Jan 8, 2009
436 (0.13/day)
System Name AMD RyZen PC
Processor AMD RyZen 1800x
Motherboard ASUS Crosshair VI Hero 370x
Cooling Corsair H100i
Memory 64GB G.Skill Trident Z DDR4 3200 MHz 14C x2
Video Card(s) AMD Radion VEGA 64 / 280x
Storage Seagate 3TB + 2TB + 2TB external + 256 Samsung M.2
Display(s) Samsung UN65KS8000F 4K, LG 4K 27UD69P-W
Case NZXT - H440
Audio Device(s) XI-FI 8.1
Power Supply EVGA 700W
Mouse Microsoft
Keyboard Microsoft
Software Windows 10 x64
Benchmark Scores https://valid.x86.fr/njplmm
hi buddy here is what i have

i was flashing my bios and after the flash my computer booted back and i noticed my w7 Aero was not working and then i realized that my driver was not installed and when i used GPUZ... OMFG my card is weird..

its booting to desktop and SVGA works fine :(

with REB is get an error

Look at the Dev ID :( and ATIFLASH, winflash or flashrom wont detect my card. but REB was able to export the corrupt bios.

but my bios is detecting my card and shows the below information on Bios screen \\

BUS -----DEV---FUN------Vendor----Device-----SVID------SSID-----Class ---IRQ

use atiflash using SVID or SSID....also failed:banghead: