1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

[solved(??)] 2.4Ghz ping spikes/packet loss on TP-LINK Archer C5 v2 AC1200 router

Discussion in 'Networking & Security' started by TRWOV, Feb 17, 2017.

Thread Status:
Not open for further replies.
  1. TRWOV

    TRWOV

    Joined:
    Aug 11, 2011
    Messages:
    4,335 (1.97/day)
    Thanks Received:
    3,024
    Location:
    Mexico
    EDIT:
    SOLUTION: For my case, disabling IPv6 and setting the wireless to B/G only was the fix.

    - Lag seemed to be fixed by disabling IPv6.
    - The packet drop issue was fixed by disabling Wireless N. Only my Roku Express is affected by this but Wireless G is enough for streaming to the Express with it being 720p. The connection is solid and without losses so it's the preferable setup I suppose.



    PROBLEM:
    I have a TP-LINK Archer C5 v2 AC1200 wireless Dual Band router that experiences intermittent and seeming random ping spikes/packet loss on the 2.4Ghz band:

    Capture532.png

    The connection does not drop. The connection and signal keeps strong; is just that no data passes through the router intermittently at random intervals.

    I have it connected to an ARRIS TG832 router in bridged mode but that isn't the culprit since a wired connection to the TP-LINK router doesn't present any kind of problem so it isn't ISP related.

    I have also determined that the 5Ghz band doesn't suffer from the issue either. Running a ping while the 2.4Ghz band experiences packet loss shows a steady 2ms ping.



    TROUBLESHOOTHING:

    1. I ran a wifi analyzer tool and found that there is practically 0 congestion issues.

    Capture531.png

    Nevertheless, I went and setup channel 1 for the 2.4Ghz band although the auto setting had already selected it as shown in the screenshot. That didn't make any discernible difference.


    2. I saw this wordpress post:

    https://kempniu.wordpress.com/2012/09/13/wmm-and-delays-on-tp-link-routers/

    and disabled WMM as indicated. Again, there's no discernible difference in performance.


    3. This might be a clue: whenever the packet loss begins to happen, if I disconnect from the network and connect again the issue seems to go away. I tested by having two laptops side by side looking at the same youtube video. When the video chocked I re-connected to the network with one of the laptops and left the other as is. The laptop that reconnected to the network began to run the video right away while the other kept buffering for 10 more seconds or so.

    I thought it was related to dynamic IPs so I set static IPs for them but that doesn't seem to help either.



    CURRENT 2.4G SETTINGS:

    Capture533.png
    Capture534.png
     

    Attached Files:

    Last edited: Mar 16, 2017
    Crunching for Team TPU
  2. Kursah

    Kursah Moderator Staff Member

    Joined:
    Oct 15, 2006
    Messages:
    10,594 (2.67/day)
    Thanks Received:
    4,799
    Location:
    Missoula, MT, USA
    I have read with some of the C5 V2 AC1200 units that disabling IPv6 might fix the 2.4GHz dropout issue, have you tried that?

    Go to IPv6 support and uncheck IPv6 Enabled, reboot the device.

    I would also consider changing to DD-WRT firmware to see if that helps resolve an issue with what could be a bug in the TP-Link firmware.
     
    TRWOV says thanks.
    10 Year Member at TPU
  3. TRWOV

    TRWOV

    Joined:
    Aug 11, 2011
    Messages:
    4,335 (1.97/day)
    Thanks Received:
    3,024
    Location:
    Mexico
    Capture536.png


    That helped immensely, although I still see some packet loss but the issue isn't as dire as before. ping average is down nevertheless, although still very far from optimal. Thank you very much for the suggestion. :D

    I'll see if I can correct the situation 100%, if not I'll try DD-WRT. I don't know if the Archer is supported though.
     
    Last edited: Feb 17, 2017
    Kursah says thanks.
    Crunching for Team TPU
  4. eidairaman1

    eidairaman1 The Exiled Airman

    Joined:
    Jul 2, 2007
    Messages:
    17,933 (4.84/day)
    Thanks Received:
    4,138
    No cordless phones right?
     
    10 Year Member at TPU
  5. TRWOV

    TRWOV

    Joined:
    Aug 11, 2011
    Messages:
    4,335 (1.97/day)
    Thanks Received:
    3,024
    Location:
    Mexico
    No
     
    Crunching for Team TPU
  6. TRWOV

    TRWOV

    Joined:
    Aug 11, 2011
    Messages:
    4,335 (1.97/day)
    Thanks Received:
    3,024
    Location:
    Mexico
    Still having the issue, although not as bad as before disabling IPv6
     
    Crunching for Team TPU
  7. TRWOV

    TRWOV

    Joined:
    Aug 11, 2011
    Messages:
    4,335 (1.97/day)
    Thanks Received:
    3,024
    Location:
    Mexico
    I finally got the 2.4Ghz band working fine. In fact what gave me the tip were the recent PS4 wifi issues.

    I disabled Wireless N in the 2.4Ghz band and everything is peachy now (running just B/G). Bummer that you have to disable features in order to get a working connection. :banghead:
     
    Last edited: Mar 16, 2017
    eidairaman1 says thanks.
    Crunching for Team TPU
  8. eidairaman1

    eidairaman1 The Exiled Airman

    Joined:
    Jul 2, 2007
    Messages:
    17,933 (4.84/day)
    Thanks Received:
    4,138
    That is something to report to Sony and TP - link
     
    10 Year Member at TPU

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Thread Status:
Not open for further replies.