• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

[SOLVED] Install my printer just fine in Ubuntu but can't get it to print

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
I have an Epson Ecotank L355 printer and, using Ubuntu 18.04.4 LTS, i can install my printer just fine as it gets recognized, with everything appearing to be in order ... and when i attempt to print a test page it appears successful ... but nothing happens ...

Tried repeatedly to un-install / re-install but i just can't get it to work.

Any help is appreciated.

EDIT

The printer is hooked up via USB.
 
Joined
Sep 17, 2014
Messages
12,753 (5.93/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
Does the printer have a wireless access point? If so, double check what Printer device you are sending documents over. It may well end up on the wrong queue and never print.

Next step would be inspection of ink and paper tray, if the software and PC sends correctly the printer might fail on something mechanically or there is an error message on it... hopefully.
 
Joined
Jul 2, 2008
Messages
7,625 (1.73/day)
Location
Hillsboro, OR
System Name Main/DC
Processor i7-3770K/i7-2600K
Motherboard MSI Z77A-GD55/GA-P67A-UD4-B3
Cooling Phanteks PH-TC14CS/H80
Memory Crucial Ballistix Sport 16GB (2 x 8GB) LP /4GB Kingston DDR3 1600
Video Card(s) Asus GTX 660 Ti/MSI HD7770
Storage Crucial MX100 256GB/120GB Samsung 830 & Seagate 2TB(died)
Display(s) Asus 24' LED/Samsung SyncMaster B1940
Case P100/Antec P280 It's huge!
Audio Device(s) on board
Power Supply SeaSonic SS-660XP2/Seasonic SS-760XP2
Software Win 7 Home Premiun 64 Bit
Have you tried a different USB port?
 
Joined
Oct 24, 2004
Messages
1,206 (0.21/day)
System Name Seriously ?
Processor Core i7 4790K @ 4.4Ghz
Motherboard MSI Z97 Gaming 5
Cooling Alpenföhne Broken 120 + 2 huge coolermaster chassis fans
Memory 2x8GB DDR3 2133Mhz Crucial Ballistix
Video Card(s) Gigabyte Geforce RTX 2070
Storage 1x Kingston SA400 128GB / 1x Crucial CT1050MX300 1TB / 1x Sandisk SSD Plus 1TB
Display(s) 40" Samsung UE40ES5500
Case Cooler Master HAF932
Audio Device(s) onboard realtek audio
Power Supply Corsair AX1200
Mouse Microsoft intellimouse optical
Keyboard Logitech K270
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/vmb641
Hi, did you try to play with the settings, and decrease the printing resolution to 600dpi ?
 

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Have you tried a different USB port?
Yes, and i get the same result: says active job, then it disappears as if it's done, except it's not.
Does the printer have a wireless access point? If so, double check what Printer device you are sending documents over. It may well end up on the wrong queue and never print.

Next step would be inspection of ink and paper tray, if the software and PC sends correctly the printer might fail on something mechanically or there is an error message on it... hopefully.
How do i do this?

No errors: it's as if it finishes the job, except it didn't start it :(
Hi, did you try to play with the settings, and decrease the printing resolution to 600dpi ?
The highest is 360x216.
 
Joined
Sep 17, 2014
Messages
12,753 (5.93/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
Yes, and i get the same result: says active job, then it disappears as if it's done, except it's not.

How do i do this?

No errors: it's as if it finishes the job, except it didn't start it :(

The highest is 360x216.
Depends on each printer but usually if it has a wireless protocol it also has a separate device in Devices and Printers for it. Check what device is set as default.

It might also be sending over a PDF writer of some sort.
 

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Depends on each printer but usually if it has a wireless protocol it also has a separate device in Devices and Printers for it. Check what device is set as default.

It might also be sending over a PDF writer of some sort.
Screenshot from 2020-05-12 19-04-51.png Screenshot from 2020-05-12 19-05-03.png Screenshot from 2020-05-12 19-05-15.png Screenshot from 2020-05-12 19-05-26.png

Screenshot from 2020-05-12 19-05-39.png Screenshot from 2020-05-12 19-06-01.png Screenshot from 2020-05-12 19-09-01.png
Spot any problems?
 
Joined
Sep 17, 2014
Messages
12,753 (5.93/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
No, seems to be on the USB port.

Should it report ink/toner levels? If its does, the printer might not communicate properly, as they do not show.

Can you clean the print heads with that button there?
 

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
No, seems to be on the USB port.

Should it report ink/toner levels? If its does, the printer might not communicate properly, as they do not show.
Doesn't report: not supported :(
 
Joined
Jul 2, 2008
Messages
7,625 (1.73/day)
Location
Hillsboro, OR
System Name Main/DC
Processor i7-3770K/i7-2600K
Motherboard MSI Z77A-GD55/GA-P67A-UD4-B3
Cooling Phanteks PH-TC14CS/H80
Memory Crucial Ballistix Sport 16GB (2 x 8GB) LP /4GB Kingston DDR3 1600
Video Card(s) Asus GTX 660 Ti/MSI HD7770
Storage Crucial MX100 256GB/120GB Samsung 830 & Seagate 2TB(died)
Display(s) Asus 24' LED/Samsung SyncMaster B1940
Case P100/Antec P280 It's huge!
Audio Device(s) on board
Power Supply SeaSonic SS-660XP2/Seasonic SS-760XP2
Software Win 7 Home Premiun 64 Bit
???Generic ESC/P Dot matrix printer?????
 

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
???Generic ESC/P Dot matrix printer?????
I noticed that too, but the installation got the driver from Epson: can't select the exact model, since it's not listed.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,722 (3.76/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
Printers and Ubuntu are a little bit of a pain in the ass. It really depends on the vendor and how much effort they put into making their drivers not garbage. I have an HP LaserJet MFP, mainly because I print and scan a lot of documents (and I hate ink drying out.) Out of the box, it prints fine when using it as a network attached printer and not via USB. Out of the box, I'm missing a boatload of features, like the ability to scan documents. Most of the time to get things to work, I need software from the vendor and you need to follow instructions to the letter. It seems to be really easy to screw up installing printer drivers which seems ass backwards to me.

I just checked the vendor's site for your EcoTank printer you have and it doesn't appear that they even support Linux, however I would try downloading the x86_64 .deb driver from here and try re-adding the printer to see where that gets you: https://www.openprinting.org/printer/Epson/Epson-L355_Series

I personally like to stick with HP when using Linux because their driver support isn't half bad, but printers on Linux just kind of suck... but that's because printers... well... just kind of suck.
 
Joined
Jul 2, 2008
Messages
7,625 (1.73/day)
Location
Hillsboro, OR
System Name Main/DC
Processor i7-3770K/i7-2600K
Motherboard MSI Z77A-GD55/GA-P67A-UD4-B3
Cooling Phanteks PH-TC14CS/H80
Memory Crucial Ballistix Sport 16GB (2 x 8GB) LP /4GB Kingston DDR3 1600
Video Card(s) Asus GTX 660 Ti/MSI HD7770
Storage Crucial MX100 256GB/120GB Samsung 830 & Seagate 2TB(died)
Display(s) Asus 24' LED/Samsung SyncMaster B1940
Case P100/Antec P280 It's huge!
Audio Device(s) on board
Power Supply SeaSonic SS-660XP2/Seasonic SS-760XP2
Software Win 7 Home Premiun 64 Bit

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,722 (3.76/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Printers and Ubuntu are a little bit of a pain in the ass. It really depends on the vendor and how much effort they put into making their drivers not garbage. I have an HP LaserJet MFP, mainly because I print and scan a lot of documents (and I hate ink drying out.) Out of the box, it prints fine when using it as a network attached printer and not via USB. Out of the box, I'm missing a boatload of features, like the ability to scan documents. Most of the time to get things to work, I need software from the vendor and you need to follow instructions to the letter. It seems to be really easy to screw up installing printer drivers which seems ass backwards to me.

I just checked the vendor's site for your EcoTank printer you have and it doesn't appear that they even support Linux, however I would try downloading the x86_64 .deb driver from here and try re-adding the printer to see where that gets you: https://www.openprinting.org/printer/Epson/Epson-L355_Series

I personally like to stick with HP when using Linux because their driver support isn't half bad, but printers on Linux just kind of suck... but that's because printers... well... just kind of suck.
I've been to that site earlier today: when i press the link "how to install" after that .deb link, i get "This topic does not exist yet" ... which is most helpful ...

I never installed stuff via deb files so dunno how to proceed after downloading both the .rpm and the .deb files.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,722 (3.76/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
I never installed stuff via deb files so dunno how to proceed after downloading both the .rpm and the .deb files.
I can help you there, installing `.deb` files is very easy, however not typically recommended. If you're downloading files to your `/home/username/Downloads` directory, you should be able to run this after downloading it:
Code:
sudo dpkg -i ~/Downloads/epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb
I actually install `.deb` files on a regular basis since I tend to run mainline kernels to get the latest GPU enhancements.
 
  • Like
Reactions: HTC

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
I can help you there, installing `.deb` files is very easy, however not typically recommended. If you're downloading files to your `/home/username/Downloads` directory, you should be able to run this after downloading it:
Code:
sudo dpkg -i ~/Downloads/epson-inkjet-printer-201207w_1.0.0-1lsb3.2_amd64.deb
I actually install `.deb` files on a regular basis since I tend to run mainline kernels to get the latest GPU enhancements.
Screenshot from 2020-05-12 19-31-44.png

Not cooperating ... :banghead:

Tried installing "lsb" and got this:

Screenshot from 2020-05-12 19-33-35.png

EDIT

I use "UKUU" to install the newest kernels.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,722 (3.76/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
View attachment 154946

Not cooperating ... :banghead:

Tried installing "lsb" and got this:

View attachment 154947

EDIT

I use "UKUU" to install the newest kernels.
Do as it suggests. The installed .deb file is probably in a half-baked state.
Code:
sudo apt --fix-broken install lsb
This is why using dpkg sucks. Managing dependencies is a pain in the ass.
 
  • Like
Reactions: HTC

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Do as it suggests. The installed .deb file is probably in a half-baked state.
Code:
sudo apt --fix-broken install lsb
This is why using dpkg sucks. Managing dependencies is a pain in the ass.
With the package name, it didn't work. Without the package name, it's installing "something" ...

Screenshot from 2020-05-12 19-43-07.png


Did it work?

In the Devices / Printer i see no apparent changes.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,722 (3.76/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
With the package name, it didn't work. Without the package name, it's installing "something" ...
What does it say it's going to do? I've seen weird behavior in the past where it thinks uninstalling everything is a good idea.

Did it work?

In the Devices / Printer i see no apparent changes.
Looks like it. Remove the printer in the interface and re-add it. Let Ubuntu try to auto-detect and see if it comes up with a different driver.

Edit: You might have to manually select the driver that was installed, but it's best to not hunt around for it if you don't have to.
 
  • Like
Reactions: HTC

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
What does it say it's going to do? I've seen weird behavior in the past where it thinks uninstalling everything is a good idea.


Looks like it. Remove the printer in the interface and re-add it. Let Ubuntu try to auto-detect and see if it comes up with a different driver.
Screenshot from 2020-05-12 19-45-27.png

It added this.

SUCCESS :clap:

Attempting to print now: @ least the job no longer disappears, but it's taking a heck of a long time to print.

EDIT

Printing right now: YES!!!!!!

Thank you!

It's ALIVE ...
 

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
Something's not right: when i print a document, it gets held after printing about 1/3 of the page, like so:

Screenshot from 2020-05-13 17-00-01.png


When i try to resume, it starts over instead but gets held again after printing about 1/3 of the page, and if i try to resume again, it does the exact same thing.

Any ideas?
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,722 (3.76/day)
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.6Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-2T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898, FIIO Alpen 2 Headphone DAC + Amp
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100, Cherry MX Blues with O-rings
Software Ubuntu 20.04 LTS (Stock 5.4.0-33 kernel)
Benchmark Scores Benchmarks aren't everything.
I have never experienced that before. Does anything fun or exciting happen in `/var/log/syslog` when you're printing?

Before you start printing, run something like `tail -f /var/log/syslog` and then watch the output when you go to print.
 

HTC

Joined
Apr 1, 2008
Messages
4,148 (0.92/day)
Location
Portugal
System Name HTC's System
Processor Ryzen 5 2600X
Motherboard Asrock Taichi X370
Cooling NH-C14, with the AM4 mounting kit
Memory G.Skill Kit 16GB DDR4 F4 - 3200 C16D - 16 GTZB
Video Card(s) Sapphire Nitro+ Radeon RX 480 OC 4 GB
Storage 1 Samsung NVMe 960 EVO 250 GB + 1 3.5" Seagate IronWolf Pro 6TB 7200RPM 256MB SATA III
Display(s) LG 27UD58
Case Fractal Design Define R6 USB-C
Audio Device(s) Onboard
Power Supply Corsair TX 850M 80+ Gold
Mouse Razer Deathadder Elite
Software Ubuntu 19.04 LTS
I have never experienced that before. Does anything fun or exciting happen in `/var/log/syslog` when you're printing?

Before you start printing, run something like `tail -f /var/log/syslog` and then watch the output when you go to print.
Got held, same as before :(

Screenshot from 2020-05-13 19-14-14.png


Anything "fun" in that pic?

EDIT

I entered the command in the terminal BEFORE starting to print.
 
Joined
Sep 17, 2014
Messages
12,753 (5.93/day)
Location
Mars
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
Top