• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sound Blaster Connect MB5 - device is disabled or not a supported device

Sammy15

New Member
Joined
May 4, 2023
Messages
8 (0.02/day)

AAF Optimus said:

Creative Sound Blaster X-Fi MB5 Custom Installer Updated!
Driver Fixed!
Sound Blaster X-Fi MB5 Custom Installer still dont working on MSI MPG B650I EDGE WIFI
HWID
USB\VID_0DB0&PID_36E7&MI_00
USB\VID_0DB0&PID_36E7&REV_0001&MI_00

But AAFOptimusDCHAudioPack9492 much better

in older version all components dint working
X-Fi MB 5 "The current selected audio device is disabled, not present, not supported by the application, or has unplugged jack connections."
Dolby Atmos, DTS Sound Unbond, DTS X Ultra "this is the broblem accessing theDolby Digital Atmos driver. Please, restart the computer or reinstall the driver if the problem persist"
Nahimic "Nahimic can not be used. Yor aidio driver is not up date or your system is not capable"
Sonic Studio "Current system isnot supported, or theaudiodriver has not been properly installed"
Sound Blaster connect 1/2 - please connect a sound blaster supported device

9492 (before install 9492 uninstall older version and clean by Driver Store Explorer):
Dolby Atmos, DTS Sound Unbond, DTS X Ultra - working, licence installing
Nahimic - dont install from pack anymore, but if unrar pack manually and install Nahimic.AppxBundle - installing, working
Sonic Studio - working
X-Fi MB5: from pack dont installing, custom install work, but after install X-Fi MB5 - The current selected audio device is disabled, not present, not supported by the application, or has unplugged jack connections
Sound Blaster connect 1/2 - please connect a sound blaster supported device

so X-Fi MB5 and SBConnect - nothing changes

X-Fi MB5 install with /RegisterSKU

Sound Blaster Connect 1/2: "please connect a sound blaster supported device"
Sound Blaster X-Fi MB5: "The current selected audio device is disabled, not present, not supported by the application, or has unplugged jack connections."

I spotted at least 3 poor guys facing the same problem in just one single thread. It is a common issue with Sound Blaster installation

so I decide to open this thread.
Reply here with info if you got the same prompt, please. Maybe someone will fix it for us or we just solve it here. @AAF Optimus

I am sure everyone has followed those steps
X-Fi MB5 install with /RegisterSKU
In case Sound Blaster Connect doesn't work, download the KGA tool to solve the problem
But that did not tackle the exact problem, did it?

Anyone who can locate the exact problem and telling us what is causing this prompt would be the HERO here.
 

Tommaso

New Member
Joined
May 12, 2023
Messages
5 (0.01/day)
Hello I have the same problem, with connect 2 no he works, but with xfimb5 no! and it is him that I would like to use since I have always used it .. wanting I can use my old but does not show me any preset so I deduce that it is not good! but the one modified with more presets also for headphones does not really want to know .. I hope that we can solve the problem. Thank you all
 

Tommaso

New Member
Joined
May 12, 2023
Messages
5 (0.01/day)
Hello guys, thanks for the welcome.. Has anyone managed to get AAf OPTIMUS' modified xfimb5 creative app to work? I have an asus rog xiii extreme with driver realtek usb2.0...

All the other apps seem to work fine except this one! xfimb5, and if I can get it to start it does not see any presets, very strange .. thanks for the help

This is my hardware ID
USBVID_0B05&PID_19AC&REV_0025&MI_00
USBVID_0B05&PID_19AC&MI_00
 

Sammy15

New Member
Joined
May 4, 2023
Messages
8 (0.02/day)
It is not a problem of installation steps. so you may not achieve your goal if you just encounter ordinary users happen to be able to use modded xfimb5 after installation.

Except AAF Optimus himself or poor guys like us because we experienced the problem.
Sound Blaster X-Fi MB5: "The current selected audio device is disabled, not present, not supported by the application, or has unplugged jack connections."
If you also saw this unpleasant message before, reply here thank you. we are all here trying to figure it out.

This is a FLAW within modded driver / control panel so that xfimb5 pops up this "unsupported device" message only the authors of modded drivers know a better way to fix their bugs and remain their reputation.
 

AAF Optimus

Account Closed - Will not update Projects
Joined
Mar 1, 2017
Messages
1,163 (0.43/day)
Location
Rio de Janeiro, Brazil
System Name NEW AAF OPTIMUS RIG
Processor AMD Ryzen 5 5600X (6C/12T)
Motherboard ASUS TUF Gaming B550M-Plus
Cooling DEEPCOOL Gammax L120T
Memory CRUCIAL Pro Gaming 32GB DDR4-3200 (@3733) (2x16GB)
Video Card(s) NVIDIA GeForce RTX 3060 12GB MSI Ventus 2X OC LHR
Storage ADATA Legend 700 PCIe Gen3 x4 256GB; ADATA Legend 800 PCIe Gen4 x4 2TB; GoldenFir SSD 1TB
Display(s) AOC VIPER 27" 165Hz 1ms (27G2SE)
Case DARKFLASH DK100-BK
Audio Device(s) REALTEK S1200A (ALC1200) with AAF Optimus Audio
Power Supply REDRAGON RGPS 600W 80 PLUS Bronze Full Modular
Mouse CLAHM CL-MM386 7200DPI
Keyboard MOTOSPEED CK-108 Mechanical Keyboard
Software Windows 11 Pro x64 23H2

Tommaso

New Member
Joined
May 12, 2023
Messages
5 (0.01/day)
Sound Blaster X-Fi MB5 - Last Installer funziona perfettamente!

Continua a nn funzionare, l applicazione si installa il kga funziona ma nell applicazione non ci sono preset .. Gianluca

Ancora non funziona, l'applicazione installa il kga funziona ma non c'è preimpostato nell'applicazione.

Translated by mod.

It still doesn't work, the application installs the kga it works but there are no presets in the application .. Gianluca

It still doesn't work, the application installs the kga it works but there is no preset in the application.
 
Last edited by a moderator:

the54thvoid

Intoxicated Moderator
Staff member
Joined
Dec 14, 2009
Messages
12,677 (2.38/day)
Location
Glasgow - home of formal profanity
Processor Ryzen 7800X3D
Motherboard MSI MAG Mortar B650 (wifi)
Cooling be quiet! Dark Rock Pro 4
Memory 32GB Kingston Fury
Video Card(s) Gainward RTX4070ti
Storage Seagate FireCuda 530 M.2 1TB / Samsumg 960 Pro M.2 512Gb
Display(s) LG 32" 165Hz 1440p GSYNC
Case Asus Prime AP201
Audio Device(s) On Board
Power Supply be quiet! Pure POwer M12 850w Gold (ATX3.0)
Software W10
^^ English only, please. I'll not translate the next one.
 

rhoxx

New Member
Joined
Nov 28, 2021
Messages
2 (0.00/day)
I tried to install this setup on a fresh system. After this, I have the same error/popup in SB5 tool.
My chip is Realtek ALC1220 and the mainboard page claims that it supports Sound Blaster Cinema 3.
 
Top