• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Sound Blaster Z / Zx / ZxR Modded Driver for Windows 10

Joined
Apr 17, 2011
Messages
113 (0.03/day)
That game is going to have RT support for Win7/8/8.1 users. No need to "upgrade" just for that..
... ohhh??? I guess I just assumed that was going to be some DirectX12 Ultimate feature or something.

That.... would make me extremely happy. I'm no Win10 hater per-say, but I deal with enough win10 "os as a service" BS at work everyday that coming home to a machine that ISN'T required every 6 months to re-install it's core OS and whine that I'm still a local user account (you're not on a Microsoft Account? how DARE you) is sadly refreshing.

And the constant f*ckery with audio drivers of course. And scanners. And DCH driver enforcement (seriously just so you can force the stupid App Store version?) etc...

back in the win7 days I'd NEVER have thought I would come to appreciate win8.1 (with classic shell) as the last bastion before the whole software as a service hell. I guess I could run some hacked up version of windows server after that but ugh.... I'm going to take a long look at ReactOS and linux + WINE in 2023. But who am I kidding - it will be whatever OS that can run Steam games, with available video drivers for recent cards (FU Nvidia) all without crapping the bed running Rosetta@Home in the background under BOINC. And sadly that will probably still be exclusively whatever Windows flavor is still offered.

end rant ;op

So off topic, so the only reason I originally bought the Zx was after my X-Fi PCI literally died (which WTH how does a PCI card just die?) was that I stupidly assumed that as a Creative card it would still support the 'old SoundFont Bank Manager so I could still jam out to MIDI AWE32 style. This being after the SBLive! that worked really well for me... ironically the AWE32 still works, where's that ISA to USB adapter when you need it lol.
 
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
(which WTH how does a PCI card just die?)
I had an Audigy die on me. Turned out to be the caps. Replaced them and the card came back to life. You might want to look into that if you still have the card.
 

RiPe

New Member
Joined
Oct 6, 2020
Messages
1 (0.02/day)
Hello, I have a question ... the soundblaster AE 5 PLUS has support for Dolby and DTS, but the AE 5 Normal card does not have support for these technologies.
The SoundBlaster Command program shows support for AE 5 Plus only, but not for AE 5 Normal.
So is it possible to have a modified program that releases or unlocks Dolby and DTS for the AE 5 Normal card ??????

One idea would be to copy the installed files from the sound blaster command from someone who has AE 5 PLUS and then run the program in AE 5 Normal to see if the "encoder" option appears.

sound_blaster_command_19.png
 
Last edited:
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
So is it possible to have a modified program that releases or unlocks Dolby and DTS for the AE 5 Normal card ??????
It is entirely possible that the AE-5 does not have the hardware to output Dolby or DTS at all. The AE-5Plus is a new hardware revision. So modding the software would likely do nothing but break copyright law. Sorry to be a party pooper...

Welcome to TPU though!
 

Zulith

New Member
Joined
Oct 24, 2020
Messages
1 (0.03/day)
Thanks for the useful thread. I've been having clipping sounds/brief distortion when using headphones on my ZxR setup. I'm on Win 10 64bit 20H2 right now, but the problem started with a prior update (like many of you, i'm sure) Out of desperation, I've tried Daniel_K's updated drivers. While I had to jump through some additional hoops to get the CINEMATIC tab of my Pro Studio Control Panel (a problem I've ran into in the past, you have to completely remove registry entries to Dolby and DTS packs to get them to properly install again, and no DDU does not remove this for you), the driver works well. Sadly it did not fix the issue for me. I'm not sure but it's possible that it's happening LESS, but that could just be placebo. Has anyone done extensive testing with any of these unofficial drivers when using both A) headphones in the ZxR's headphone jack and B) an audio source plugged into the optical audio in jack (in my case, a TV for PS4 and soon PS5 play -- and i've tried multiple optical cords including brand new ones), It would be incredibly helpful if anyone found a way to eliminate the issue.

So yeah just to reiterate, I'm not having any sound chirping/clicking/distortion/whatever other issues when using my speakers -- for me it's just the headphones.

FWIW I tried the July 2020 driver pack on the blog, not the newer Aug ones which are Beta so i'm hesitant to go through the entire process again unless others have had better success with them.

Anyway, I guess i'm going to have to break down and get a newer sound card at some point because with my setup I really need an optical input solution and not a lot of soundcards have that feature anymore.
 
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
not the newer Aug ones which are Beta so i'm hesitant to go through the entire process again unless others have had better success with them.
Actually they are working, give them a try.

And Welcome to TPU!
 

InfamousByte2

New Member
Joined
Nov 8, 2020
Messages
4 (0.18/day)
I have tried everything. Device is recognized some times and some is not. Maybe on startup or maybe on the 10th restart. its random. I have tried every driver available. What else can I do ?
 
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
I have tried everything. Device is recognized some times and some is not. Maybe on startup or maybe on the 10th restart. its random. I have tried every driver available. What else can I do ?
A little more detail is needed. What model card do you have? What version of Windows are you running?
 

wiggum123

New Member
Joined
Nov 13, 2020
Messages
1 (0.06/day)
0/
New here but thought I would wade in with my experience with this. Bought a new Soundblaster Z for the DTS/Dolby stuff via the digital optical to my old surround sound. Have a Win10 PC on 2004 release and was having real issues with the card sometimes not showing up in device manager and getting the No compatible hardware error. I have to say I haven't had the latency issues described here but maybe I haven't been using it for long enough.

Reading around I tried a load but the thing that currently seems to be working for me utilises local group policy to prevent windows updating the drivers. Mine has been stable through a few reboots now.

Requirements - The card must be in a functioning state for this to work - I ended up moving it to a new PCI slot as it seems to work the first time, its subsequent reboots etc where it breaks.

  1. Once the card is functioning head to device manager and find the card. Mine seems to have 2 entries, one is "Sound Blaster Audio Controller" and the other (which is the one that often disappears) is "Sound Blaster Z", open up the properties > Details and select Hardware IDs
  2. Open up gpedit.msc and head to Local Computer Policy > Computer Configuration > Administrative Templates > System > Device Installation > Device Installation Restrictions and find "Prevent installation of devices that match any of these device instance IDs"
  3. Enable the policy and press the Show button, enter in the Hardware IDs from device manager, I had 6 in total, 2 from one card and 4 from another.
  4. Make sure the "also apply to matching devices that are already installed" is unchecked. If you check this you will essentially disable the current working drivers.
  5. Press OK and you're done.
 

InfamousByte2

New Member
Joined
Nov 8, 2020
Messages
4 (0.18/day)
A little more detail is needed. What model card do you have? What version of Windows are you running?
Well I have a Soud Blaster Z on Windows 10 latest update now, I have also tried returning to previous updates. Also tried every possible driver here or official. Its simes like the card is not recognized as a hardware sometimes. I say this because it does not matter what setup I have, some times it is recognized some times not. Lately in Windows I might need 10 restarts, its random. I have the same problem one Ubuntu 20.04 but not so often. I wonder if its a faulty card, but it was working perfectly for 3-4 months. Is there a way to check the hardware on Windows ? In Linux there is a way to check all PCIE devices. If you asked I tried every thing on this threat. They all worked at some point but then they didn't.

For example: $ lspci

...
01:00.0 VGA compatible controller: NVIDIA Corporation GP106 [GeForce GTX 1060 6GB] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GP106 High Definition Audio Controller (rev a1)
03:00.0 USB controller: ASMedia Technology Inc. ASM2142 USB 3.1 Host Controller
0a:00.0 Audio device: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series] (rev 01) <---------------------

Although card is not recognized on Linux ether.

What else can I try ?
 
Last edited:
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
What else can I try ?
Have you tried Windows 7 on a spare drive(if you have one)? If the card works in Windows 7, then your Windows 10 Install might be borked up in some way and you'll need to do a fresh install.
 

InfamousByte2

New Member
Joined
Nov 8, 2020
Messages
4 (0.18/day)
Have you tried Windows 7 on a spare drive(if you have one)? If the card works in Windows 7, then your Windows 10 Install might be borked up in some way and you'll need to do a fresh install.
That's not an options for me now. I verified that the PCIE Controller recognizes my card even when the driver does not work.

Multimedia controllerCreative LabsSound Core3D [Sound Blaster Recon3D / Z-Series]SB1570 SB Audigy FxAudio device1102:0012 1102:0010

In one time that the drivers worked I exported the Device manager event which is this:


Log Name: Microsoft-Windows-Kernel-PnP/Configuration
Source: Microsoft-Windows-Kernel-PnP
Date: 17/11/2020 6:22:11 μμ
Event ID: 430
Task Category: None
Level: Information
Keywords:
User: SYSTEM
Computer: DESKTOP-B49NO88
Description:
Device HDAUDIO\FUNC_01&VEN_1102&DEV_0011&SUBSYS_11020023&REV_1009\5&d8cb7a&1&0101 requires further installation.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
<System>
<Provider Name="Microsoft-Windows-Kernel-PnP" Guid="{9c205a39-1250-487d-abd7-e831c6290539}" />
<EventID>430</EventID>
<Version>0</Version>
<Level>4</Level>
<Task>0</Task>
<Opcode>0</Opcode>
<Keywords>0x4000000000000000</Keywords>
<TimeCreated SystemTime="2020-11-17T16:22:11.2871778Z" />
<EventRecordID>1445</EventRecordID>
<Correlation />
<Execution ProcessID="4" ThreadID="11544" />
<Channel>Microsoft-Windows-Kernel-PnP/Configuration</Channel>
<Computer>DESKTOP-B49NO88</Computer>
<Security UserID="S-1-5-18" />
</System>
<EventData>
<Data Name="DeviceInstanceId">HDAUDIO\FUNC_01&amp;VEN_1102&amp;DEV_0011&amp;SUBSYS_11020023&amp;REV_1009\5&amp;d8cb7a&amp;1&amp;0101</Data>
</EventData>
</Event>

Can I get anything from that ? Is there a way to force that event or the proper driver ?
 
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Can you show pictures of the card so we can see the labels and part number?
 
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Is these OK ?
Yuppers, that helped.

First, uninstall all audio drivers and apps relating to your SBZ. Then try these drivers;

And if those don't fix your issue, uninstall them and try these;

Your problem should be gone with one of those as long as your Windows installation isn't borked. However as recent updates have proven problematic you may be forced to do a fresh install of Windows to fix the issue.
 
Last edited:

piajartist

New Member
Joined
Nov 22, 2020
Messages
1 (0.13/day)
Im having similar issues with Soundblaster Z card not being recognized during installation process. Error Message: Setup is unable to detect a supported product on your system. Any Ideas? I turned off driver signature enforcement but keep hitting a wall once I try and run setup as admin. Its curious, because Device Manager shows my audio card controller connected and working properly. What helped other users get past this setup hurdle?
 
Joined
Jul 5, 2013
Messages
11,244 (4.16/day)
Location
USA
System Name GPD-Q9
Processor Rockchip RK-3288 1.8ghz quad core
Motherboard GPD Q9_V6_150528
Cooling Passive
Memory 2GB DDR3
Video Card(s) Mali T764
Storage 16GB Samsung NAND
Display(s) IPS 1024x600
Im having similar issues with Soundblaster Z card not being recognized during installation process.
You are either not trying the correct driver pack or you have damaged hardware. Have you used the card model number to identify the card( example SBXXXX )? Have you tried a different slot?
 
Top