• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

SpeedFan does not recognize RX 580 after Adrenaline 22.5.2 upgrade!

Joined
Sep 24, 2005
Messages
305 (0.05/day)
Anyone having similar experience with this upgrade? Reverted to 22.5.1 and reinstalled SpeedFan and still no luck!
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
17,738 (3.21/day)
Location
UK\USA
Processor 2500k \ AMD 3900X+NH-D15
Motherboard ASRock Z68 \ ASRock AM4 X570 Pro 4
Memory Samsung low profile 2x8GB \ Patriot 2x16GB PVS432G320C6K
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X +Antec P12 fans
Storage 2xIntel 80Gb (SATA2) Crucial MX500 \ Samsung 860 1TB +Samsung Evo 250GB+500GB Sabrent 1TB Rocket
Display(s) Samsung 1080P \ LG 43UN700
Case HTPC400 \ Fractal Design Torrent.
Audio Device(s) Yamaha RX-V677 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000\Paradigm P Studio 20, Blue Yeti
Power Supply Seasonic Focus 650w \ Seasonic Prime TX-750
Mouse Steelseries Sensei wireless \ Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
Joined
Sep 24, 2005
Messages
305 (0.05/day)
I use it across a dozen systems currently without issues ( except the 22.5.2 upgrade). Been using it since 2004 since SpeedFan 4.20!
 
Last edited:

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
17,738 (3.21/day)
Location
UK\USA
Processor 2500k \ AMD 3900X+NH-D15
Motherboard ASRock Z68 \ ASRock AM4 X570 Pro 4
Memory Samsung low profile 2x8GB \ Patriot 2x16GB PVS432G320C6K
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X +Antec P12 fans
Storage 2xIntel 80Gb (SATA2) Crucial MX500 \ Samsung 860 1TB +Samsung Evo 250GB+500GB Sabrent 1TB Rocket
Display(s) Samsung 1080P \ LG 43UN700
Case HTPC400 \ Fractal Design Torrent.
Audio Device(s) Yamaha RX-V677 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000\Paradigm P Studio 20, Blue Yeti
Power Supply Seasonic Focus 650w \ Seasonic Prime TX-750
Mouse Steelseries Sensei wireless \ Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
I use it across a dozen systems currently without issues ( except the 22.5.2 upgrade). Been using it since 2004 / SpeedFan 4.20!

Maybe down grade your drivers to see if the problem goes away, and if you must MAYBE try DDU and try to remove every thing driver wise for the card. Make sure your not connected to the net when you do and in safe mode so you don't install the default windows driver.

One thing to love about Fan control is that you can control the GPU fans too.
 
Joined
Oct 16, 2018
Messages
438 (0.31/day)
Location
Uttar Pradesh, India
Processor AMD R7 1700X @ 4100Mhz
Motherboard MSI B450M MORTAR MAX (MS-7B89)
Cooling Phanteks PH-TC14PE
Memory Crucial Technology 16GB DR (DDR4-3600) - C9BLM:045M:E BL16G36C16U4W.M16FE1 X2 @ CL14
Video Card(s) XFX RX480 GTR 8GB @ 1408Mhz (AMD Auto OC)
Storage Samsung SSD 850 EVO 250GB
Display(s) Acer KG271 1080p @ 81Hz
Power Supply SuperFlower Leadex II 750W 80+ Gold
Keyboard Redragon Devarajas RGB
Software Microsoft Windows 10 (10.0) Professional 64-bit
Benchmark Scores https://valid.x86.fr/mvvj3a
I use it across a dozen systems currently without issues ( except the 22.5.2 upgrade). Been using it since 2004 / SpeedFan 4.20!
The latest version is Speedfan ver is 4.52. Try updating it.
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
Thank you for the input. I downgraded to 22.5.1 and I removed and reinstalled SpeedFan 4.52. I did not try erasing my SpeedFan settings and I will try that next. edit: Tried removing and reinstalling SpeedFan 4.52 and removed my customizations. Nowhere does RX 580 appear anywhere in the SpeedFan app after the 22.5.2 Adrenalin upgrade. MSI Afterburner and GPU-Z work just fine! I think I'll pass on installing Adrenalin 22.5.2 on anything else.
 
Last edited:
Joined
Jun 16, 2019
Messages
118 (0.10/day)
System Name Compaq Presario
Processor AMD K6-2 400MHz
Cooling Yes
Memory 128MB SD RAM
Video Card(s) Diamond Stealth III S540 Savage4 Pro 32MB AGP 4X
Storage 10.1GB IDE, 52x CD-ROM
Display(s) 15" SVGA CRT
Software Widows 98 SE
Benchmark Scores Higher than yours, nerd!
Why not Afterburner?
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
@Arkz I do use Afterburner. I opened it immediately when I saw that SpeedFan was not recognizing my RX 580. Everything was working fine on the RX580, fans, voltage, etc. This is a dual boot Windows 10 Gaming/Movie PC. I installed the Adrenalin 22.5.2 update on the Gaming drive. I like to check the SpeedFan temperature graphs after gaming for a while. I did not install the 22.5.2 drivers on the Movie drive. On the Movie drive SpeedFan recognizes the RX 580 right after (Found ACPI temperature). Also on the Gaming drive the Exotics panel is missing GPU fan speed, temperature and voltage readings. I wonder what the 22.5.2 drivers did to bork SpeedFan?!#* I'll survive but I'm just a little irritated by the changes.
 
Joined
Jun 16, 2019
Messages
118 (0.10/day)
System Name Compaq Presario
Processor AMD K6-2 400MHz
Cooling Yes
Memory 128MB SD RAM
Video Card(s) Diamond Stealth III S540 Savage4 Pro 32MB AGP 4X
Storage 10.1GB IDE, 52x CD-ROM
Display(s) 15" SVGA CRT
Software Widows 98 SE
Benchmark Scores Higher than yours, nerd!
@Arkz I do use Afterburner. I opened it immediately when I saw that SpeedFan was not recognizing my RX 580. Everything was working fine on the RX580, fans, voltage, etc. This is a dual boot Windows 10 Gaming/Movie PC. I installed the Adrenalin 22.5.2 update on the Gaming drive. I like to check the SpeedFan temperature graphs after gaming for a while. I did not install the 22.5.2 drivers on the Movie drive. On the Movie drive SpeedFan recognizes the RX 580 right after (Found ACPI temperature). Also on the Gaming drive the Exotics panel is missing GPU fan speed, temperature and voltage readings. I wonder what the 22.5.2 drivers did to bork SpeedFan?!#* I'll survive but I'm just a little irritated by the changes.
Does seem a bit weird. I've not used SF for about 16 years but, does it have any other detection methods you can pick? Could try using DDU and then installing 22.5.1 fresh.
 
Joined
Jan 5, 2006
Messages
13,169 (2.17/day)
System Name AlderLake / Laptop
Processor Intel i7 12700K / Intel i3 7100U
Motherboard Gigabyte Z690 Aorus Master / HP 83A3 (U3E1)
Cooling Noctua NH-U12A 2 fans + Thermal Grizzly Kryonaut Extreme + 5 case fans / Fan
Memory 32GB DDR5 Corsair Dominator Platinum RGB 6000MHz CL36 / 8GB DDR4 HyperX CL13
Video Card(s) MSI RTX 2070 Super Gaming X Trio / Intel HD620
Storage Samsung 980 Pro 1TB + 970 Evo 500GB + 850 Pro 512GB + 860 Evo 1TB x2 / Samsung 256GB M.2 SSD
Display(s) 23.8" Dell S2417DG 165Hz G-Sync 1440p / 14" 1080p IPS Glossy
Case Be quiet! Silent Base 600 - Window / HP Pavilion
Audio Device(s) ALC1220-VB + ESS ES9118 DAC / Realtek onboard + B&O speaker system
Power Supply Seasonic Focus Plus Gold 750W / Powerbrick
Mouse Logitech MX Anywhere 2 Laser wireless / Logitech M330 wireless
Keyboard RAPOO E9270P Black 5GHz wireless / HP backlit
Software Windows 11 / Windows 10
Benchmark Scores Cinebench R23 (Single Core) 1911 @ stock Cinebench R23 (Multi Core) 22813 @ stock
Last time I used speedfan was over a decade ago.
Nice little piece of software though once you figured it out how to use it.
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
Yes weird it is. I will probably end up going the DDU route and installing 22.5.1 fresh. I just spent a couple of hundred bucks and a couple of months trying to upgrade my 1000GB SSHD's to 2000GB SSHD's. I couldn't get MiniTool partition wizard to properly copy the old SSHD's to the new SSHD's. I ended up removing them and reinstalling the old SSHD's. Then I copied all my movies and excess files to the 2000GB drives which now reside in a couple of external enclosures. There is something to be said about "if it ain't broke don't fix it."

Yes, Alfredo had a tutorial that helped to set it up and tweak it. Once you had it tweaked you were good to go. I was also quite fond of ATITool and Gainwards ExpertTool back in the day.:peace:
 
Joined
Jun 16, 2019
Messages
118 (0.10/day)
System Name Compaq Presario
Processor AMD K6-2 400MHz
Cooling Yes
Memory 128MB SD RAM
Video Card(s) Diamond Stealth III S540 Savage4 Pro 32MB AGP 4X
Storage 10.1GB IDE, 52x CD-ROM
Display(s) 15" SVGA CRT
Software Widows 98 SE
Benchmark Scores Higher than yours, nerd!
Yes weird it is. I will probably end up going the DDU route and installing 22.5.1 fresh. I just spent a couple of hundred bucks and a couple of months trying to upgrade my 1000GB SSHD's to 2000GB SSHD's. I couldn't get MiniTool partition wizard to properly copy the old SSHD's to the new SSHD's. I ended up removing them and reinstalling the old SSHD's. Then I copied all my movies and excess files to the 2000GB drives which now reside in a couple of external enclosures. There is something to be said about "if it ain't broke don't fix it."

Yes, Alfredo had a tutorial that helped to set it up and tweak it. Once you had it tweaked you were good to go. I was also quite fond of ATITool and Gainwards ExpertTool back in the day.:peace:
Uff that sounds like a right ball ache. I've noticed MPW has taken away features in the newer versions unless you buy it. I keep to 10.3 so I can still create copy partitions of my C drive as backups.
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
I used MPW 9 which used to work great for copying my partitions and drives. I also learned not to upgrade MPW for the same reason as you. I must have copied the drives 5 or 6 times but I couldn't get them to dual boot as with the 1000GB SSHD's. I'd get the dreaded checking disc loops. Then one of the 2000GB drives would disappear from the bios. I even tried with 2 or 3 fresh installs of Windows 10 on the 2000GB drives. I finally gave up. I'm glad I didn't erase the 1000GB drives as I had planned! What a Nightmare.:cry: After all of that this 22.5.2 issue is just a nuisance when compared.
 
Joined
Jun 16, 2019
Messages
118 (0.10/day)
System Name Compaq Presario
Processor AMD K6-2 400MHz
Cooling Yes
Memory 128MB SD RAM
Video Card(s) Diamond Stealth III S540 Savage4 Pro 32MB AGP 4X
Storage 10.1GB IDE, 52x CD-ROM
Display(s) 15" SVGA CRT
Software Widows 98 SE
Benchmark Scores Higher than yours, nerd!
Ughh what a headache. Throw it in the bin and get an Amiga!
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
Lol we're drifting off topic toward the bin are we? Great Idea, I'll be going to the recycling bin tomorrow. Look what I found at the recycling bin yesterday, a pair of Stirling MX5's in great condition:toast:. My kind of Headache!
 

Attachments

  • MX5.jpg
    MX5.jpg
    890.3 KB · Views: 33
  • binfind.jpg
    binfind.jpg
    888.5 KB · Views: 36

ssateneth

New Member
Joined
May 14, 2020
Messages
11 (0.01/day)
just adding, 22.5.2 breaks fan control for msi afterburner too, on rx 570, 580, 590, and 6600xt. rolled back to 22.5.1, still broken. had to DDU everything off the system and install 22.5.1 again, works again in msi afterburner.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,330 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Well its a problem with SF and AB then, file the problems with them
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
37,330 (6.76/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Looks like I'll be sticking with the 22.5.1's for sure. Thanks for the update @ssateneth :cool:
You know in that Inspite of DDU or the regular uninstaller the C:/AMD directory with Crimson/Adrenalin is still in there, you must remove the Crimson/Adrenalin Folder to purge it (its used for system restore)

This is why I set a System Restore Point (Feature Since Windows Millenium Edition) before any drivers are updated.

This has worked for me many years now.
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
Thanks for that tip. Windows restore point saved my butt many times in XP, Vista, Windows 7 and 8.1. Windows 10 just took the steam out of my computer enthusiasm. I got real lazy when Microsoft black screened my Windows 7 game drive and forced me to upgrade to 10. I haven't ever set a restore point since Windows 8.1. I guess it pays to stay on top of the game to prevent 22.5.2's from spoiling your day.o_O
 
Joined
Aug 27, 2021
Messages
74 (0.21/day)
Thanks for that tip. Windows restore point saved my butt many times in XP, Vista, Windows 7 and 8.1. Windows 10 just took the steam out of my computer enthusiasm. I got real lazy when Microsoft black screened my Windows 7 game drive and forced me to upgrade to 10. I haven't ever set a restore point since Windows 8.1. I guess it pays to stay on top of the game to prevent 22.5.2's from spoiling your day.o_O
The 22.6.1 driver has just been released. AMD has fixed this problem. I would like to ask if the speedfan problem has been completely solved after using the 22.6.1 driver.
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
I have been thinking about trying 22.6.1. on my game drive. I'll soon find out if it resolves the issues.
 
Joined
Mar 10, 2010
Messages
10,297 (2.27/day)
Location
Manchester uk
System Name RyzenGtEvo/ Asus strix scar II/Trig
Processor Amd R5 5600G/ Intel 8750H/3800X
Motherboard Crosshair hero8 impact/Asus/crosshair hero 7
Cooling 360EK extreme rad+ 360$EK slim all push, cpu ek suprim Gpu full cover all EK
Memory Corsair Vengeance Rgb pro 3600cas14 16Gb in four sticks./16Gb/16GB
Video Card(s) Sapphire refference Rx vega 64 EK waterblocked/Rtx 2060/GTX 1060
Storage Silicon power 1TB nvme/8Tb external/1Tb samsung Evo nvme 2Tb sata ssd/1Tb nvme
Display(s) Samsung UAE28"850R 4k freesync.dellshiter
Case Lianli p0-11 dynamic/strix scar2/aero cool shiter
Audio Device(s) Xfi creative 7.1 on board ,Yamaha dts av setup, corsair void pro headset
Power Supply corsair 1200Hxi/Asus stock /850 watt ?
Mouse Roccat Kova/ Logitech G wireless
Keyboard Roccat Aimo 120
VR HMD Oculus rift
Software Win 10 Pro
Benchmark Scores 8726 vega 3dmark timespy/ laptop Timespy 6506
Ishhh, ICUe that last bastion of turdyness now doesn't see my Vega after that driver install, it ran the GPU cooling, yaaaaaaay ,not.
 
Joined
Sep 24, 2005
Messages
305 (0.05/day)
Well I played the guinea pig again. Adrenalin 22.6.1 magically restores everything to normal in SpeedFan, HWmonitor, GPU-Z, And Afterburner. So far 22.6.1 is a Win!!!:peace:
 
Top