• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

SSD-Z: Information tool for Solid State Drives and other disk devices

Joined
Oct 22, 2014
Messages
7,165 (3.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E5-2680 10c/20t 2.8GHz @ 3.0GHz
Motherboard Asrock X79 Extreme 11
Cooling Coolermaster 240 RGB A.I.O.
Memory G. Skill 16Gb (4x4Gb) 2133Mhz
Video Card(s) Nvidia GTX 710
Storage Sandisk X 400 256Gb
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Home Premium 64 bit
Works for me, no more instant freeze up or failed hard drive reported.
 
Joined
Nov 18, 2011
Messages
234 (0.08/day)
Just thought I'd give an update on an issue I had a few days ago, that is now fixed. Originally both of my Spinpoints were reporting failing, now they are correctly showing as fine like Samsung's tools say. Good, straight forward tool, something I've needed for awhile to be honest.
 
Joined
Nov 28, 2004
Messages
30 (0.01/day)
Location
Germany
Processor Core i7 7800X @ 4.4 GHz
Motherboard MSI X299 SLI Plus
Cooling Thermalright HR-02 Macho
Memory 32 GB Corsair LPX DDR4 3000 CL15 @ 3466 CL17 1T
Video Card(s) EVGA GTX 1070 FTW @ 2052/4253 @ 1,0v
Storage 2x Samsung 256 GB NVMe, 9x 1 TB WD RE4 @ RAID5
Display(s) Acer XF270HUA + Eizo S2431WH-GY
Case Corsair Obsidian 750D
Audio Device(s) Creative Labs SoundBlasterX AE-5
Power Supply EVGA SuperNova G2 650w
Mouse Logitech G403
Keyboard Logitech K120
Software Windows 10 Pro x64
Very nice tool, thanks for this.

Tried it on both my SSDs, and here're the results:



The Vertex 3 gets detected correctly except for the "Bytes written" value.



The Mushkin Europe 2 (was called "IO" in USA) is mostly unknown to SSD-Z. The official product page is long gone but you can still find information in reviews, like here: http://www.hardwaresecrets.com/article/128-GB-Solid-State-Drive-Round-Up/971
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
16,144 (3.59/day)
Location
UK\US
Processor 2500k \ 3770k
Motherboard ASRock Z68 \ Z77
Memory Samsung low profile 1600
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage Intel 80Gb (SATA2) WD 250Gb \ Team SSD+Samsung Evo 250Gb+500Gb+ 2xCorsair Force+WD250GbHDD
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( original ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000 Paradigm 5SE + Tannoy Mercury F4
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse MS intelimouse \ Logitech G700s + Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
Be nice if it supported custom DPI settings.
 
Joined
Jul 14, 2006
Messages
2,047 (0.42/day)
System Name It's just a computer
Processor i9-9900K
Motherboard eVGA Z390 Dark
Cooling D5, PA140.3, HK Rev. 3.0
Memory G.Skill F4-4500C19D-16GTZKKE
Video Card(s) eVGA RTX2080 FTW3 Ultra
Storage Samsung 960 EVO M.2
Display(s) LG 32GK650F
Case Thermaltake Xaser VI
Audio Device(s) Onboard /Z-5500
Power Supply Corsair AX1200
Mouse Logitech
Keyboard Logitech
Software Win7 Ultimate x64 SP1
Does not read my external drive S.M.A.R.T.



Also, what about RAID?
 
Joined
May 19, 2009
Messages
1,326 (0.35/day)
Location
Latvia
System Name Personal \\ Work - HP EliteBook 840 G3
Processor i7-4790K \\ i7-6500U
Motherboard MSI Z97 Gaming 7
Cooling Noctua DH-15
Memory Corsair Vengeance Pro 32GB 2400 MHz \\ 16GB DDR4-2133
Video Card(s) ASUS RoG Strix 1070 Ti\\ Intel 520 HD
Storage Samsung 850 Pro 512GB, WD Black 2 TB, Samsung 970 Pro 512GB \\ Samsung 256GB SSD
Display(s) BenQ XL2411Z \\ FullHD + 2x HP Z24i external screens via docking station
Case Fractal Design Define Arc Midi R2 with window
Audio Device(s) Realtek ALC1150 with Logitech Z323
Power Supply Corsair AX860i
Software Windows 10
Samsung 850 Pro 512 GB

Looks... correct?
 

Attachments

Joined
Aug 10, 2007
Messages
1,983 (0.45/day)
Location
TEXAS
System Name Hexy
Processor Ryzen 5 2600 @4.1Ghz (All Core)
Motherboard Gigabyte x470 Ultra Gaming
Cooling Custom Liquid W/ 3x120 Radiator
Memory 16Gb Gskill @3200 CL14
Video Card(s) Founders Edition GTX 1070
Storage 2x 480Gb AIC Intel 750's + 8TB Seagate
Display(s) Pixio 32" 1080p 144Hz
Case Custom Lian Li V100L
Audio Device(s) Sennheiser HD58X + Syba Sonic Dac
Power Supply Antec Earth Watts 450w
Mouse Logitech G403
Keyboard Bloody 845R
Software Windows 10 Pro
Benchmark Scores Timespy: 6294 | Firestrike: 16190 | Heaven: 2583 | Valley: 3979 |Super Pos: 3591
working fine now :D
 

Ebo

Joined
May 9, 2013
Messages
778 (0.33/day)
Location
Nykoebing Mors, Denmark
System Name the little fart
Processor AMD Ryzen 2600X
Motherboard MSI x470 gaming plus
Cooling Noctua NH-C14S
Memory 16 GB G.Skill Ripjaw 2400Mhz DDR 4
Video Card(s) Sapphire RX Vega 56 Pulse
Storage 1 Crucial MX100 512GB SSD,1 Crucial MX500 2TB SSD, 1 1,5TB WD Black Caviar, 1 4TB WD RED HD
Display(s) IIyama XUB2792QSU IPS 2560x1440
Case White Lian-Li PC-011 Dynamic
Audio Device(s) Asus Xonar SE pci-e card
Power Supply Thermaltake DPS G 1050 watt Digital PSU
Mouse Steelseries Sensei
Keyboard Corsair K70
Software windows 10 64 pro bit
just tried it, and it works fine for meo_O
 

Attachments

Joined
Nov 28, 2004
Messages
30 (0.01/day)
Location
Germany
Processor Core i7 7800X @ 4.4 GHz
Motherboard MSI X299 SLI Plus
Cooling Thermalright HR-02 Macho
Memory 32 GB Corsair LPX DDR4 3000 CL15 @ 3466 CL17 1T
Video Card(s) EVGA GTX 1070 FTW @ 2052/4253 @ 1,0v
Storage 2x Samsung 256 GB NVMe, 9x 1 TB WD RE4 @ RAID5
Display(s) Acer XF270HUA + Eizo S2431WH-GY
Case Corsair Obsidian 750D
Audio Device(s) Creative Labs SoundBlasterX AE-5
Power Supply EVGA SuperNova G2 650w
Mouse Logitech G403
Keyboard Logitech K120
Software Windows 10 Pro x64
Missing some information on these SSD:

 
Last edited:
Joined
Aug 9, 2008
Messages
4,929 (1.21/day)
Location
Kingston, Ontario Canada
System Name My Rig | Kids Rig
Processor Ryzen R7 2700 | FX 8350 @4 ghz
Motherboard Gigabyte B450 Aorus Elite|Gigabyte 990FXA UD3 (rev 4.0)
Cooling AMD Wraith spire rgb stock hsf| CM Hyper 212
Memory 8GB X 2 DDR4 3000mhz Team Group Vulcan |G. Skill 4GB x 2 DDR3 1866mhz
Video Card(s) Sapphire RX 480 8GB | Asus Strix R9 390X 8GB
Storage Adata XPG 8200 PRO 512GB SSD OS / 240 SSD+480 GB M.2 SSD Games / 1000 GB Data| 320GB OS / 500GB Data
Display(s) Asus VA32AQ 32" IPS 60hz 1440P |Samsung S24D590 24" PLS 1080P
Case NZXT H500 Black |Thermaltake Soprano Snow Edition
Audio Device(s) Onboard Realtek | Onboard Realtek
Power Supply EVGA SuperNOVA G3 650w 80+ Gold | CoolerMaster GS750M 80+ Bronze
Mouse Steelseries Rival 500 15 button mouse w/ Razor Goliathus Chroma XL mousemat | Redragon Mammoth M801
Keyboard Razor Ornata Chroma | MadCatz S.T.R.I.K.E. TE w/ Kailh brown
Software Windows 10 Pro | Windows 10 Pro
my Kingston SSD NOW's are both missing Controller, Tech, Cells and NAND info as well.
 

qubit

Overclocked quantum bit
Joined
Dec 6, 2007
Messages
15,925 (3.68/day)
Location
Quantum Well UK
System Name Quantumville™
Processor Intel Core i7-2700K at stock (hits 5 gees+ easily)
Motherboard Asus P8Z68-V PRO/GEN3
Cooling Noctua NH-D14
Memory 16GB (4 x 4GB Corsair Vengeance DDR3 PC3-12800 C9 1600MHz)
Video Card(s) Zotac GTX 1080 AMP! Extreme Edition
Storage Samsung 850 Pro 256GB | WD Green 4TB
Display(s) BenQ XL2720Z | Asus VG278HE (both 27", 144Hz, 3D Vision 2, 1080p)
Case Cooler Master HAF 922
Audio Device(s) Creative Sound Blaster X-Fi Fatal1ty PCIe
Power Supply Corsair HX 850W v1
Software Windows 10 Pro 64-bit
This is so cool! Can't wait for the final version.
 
Joined
Jan 19, 2013
Messages
87 (0.04/day)
Location
Beer-Sheva@Israel
System Name RyZEN Build + XBOX One
Processor AMD Ryzen 1600 3.2Ghz
Motherboard ASUS Prime B350-Plus
Cooling Stock cooling
Memory Kingston HyperX FURY Black 24GB DDR4 2400Mhz
Video Card(s) Sapphire Radeon HD 7950 OC
Storage Samsung 860Evo 250GB SSD M.2 + Corsair Force GT 60GB SSD + WD Blue 500GB Sata
Case Antec Three Hundred TWO
Power Supply Seasonic M12II 620Watt
Software Win 10 Pro
ללא שם.png

What did i do wrong?
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
16,144 (3.59/day)
Location
UK\US
Processor 2500k \ 3770k
Motherboard ASRock Z68 \ Z77
Memory Samsung low profile 1600
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage Intel 80Gb (SATA2) WD 250Gb \ Team SSD+Samsung Evo 250Gb+500Gb+ 2xCorsair Force+WD250GbHDD
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( original ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000 Paradigm 5SE + Tannoy Mercury F4
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse MS intelimouse \ Logitech G700s + Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
Dunno, but maybe a firmware update would help, although you might of put this of just in case you lose data on the drive. I know i did not but you never know so always back up.

I still would like a resolve for custom DPI.
 
Joined
Feb 25, 2015
Messages
21 (0.01/day)
Location
Denmark
I've fixed most of the issues reported so far, including custom DPI scaling. RAID and SMART for USB are on the list of things to do, they are a little more complicated. I'll try to get out an update this week.

I've added details for all SSDs that has been posted in this thread, so keep posting! You don't necessarily have to post a screenshot, posting the Device Name and stating this is an unrecognised SSD, is enough.

@TommyT I am unsure why it says ATA for you, but could you try this: Right-click on the program caption to bring up the system menu, then click Add Debug Tab, and press F5 to refresh. On the debug tab you should find the IOCTL_STORAGE_QUERY_PROPERTY entry and the BusType property for both Device and Adaptor as in the following screenshot.

debug_bus.png
 
Joined
Feb 25, 2015
Messages
21 (0.01/day)
Location
Denmark
For anyone using a DPI scaling other than 100%, and trying out today's update, could you let me know how well it works. I've never made anything DPI aware before, and I've never used anything but 100% DPI myself, so there is most likely a few things that needs tweaking.

Other than that, most of the changes today was to increase the amount of known devices, as well as improving the SMART interpretation.
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
16,144 (3.59/day)
Location
UK\US
Processor 2500k \ 3770k
Motherboard ASRock Z68 \ Z77
Memory Samsung low profile 1600
Video Card(s) eVga GTX1060 SSC \ XFX R9 390X
Storage Intel 80Gb (SATA2) WD 250Gb \ Team SSD+Samsung Evo 250Gb+500Gb+ 2xCorsair Force+WD250GbHDD
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( original ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-A820 \ Yamaha CX-830+Yamaha MX-630 Infinity RS4000 Paradigm 5SE + Tannoy Mercury F4
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse MS intelimouse \ Logitech G700s + Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
For anyone using a DPI scaling other than 100%, and trying out today's update, could you let me know how well it works. I've never made anything DPI aware before, and I've never used anything but 100% DPI myself, so there is most likely a few things that needs tweaking.

Other than that, most of the changes today was to increase the amount of known devices, as well as improving the SMART interpretation.
Thanks, some info missing for the TEAM L3
 
Joined
Jun 28, 2014
Messages
2,258 (1.17/day)
Location
Shenandoah Valley, Virginia USA
System Name Home Brewed
Processor i9-7900X and i7-8700K
Motherboard ASUS ROG Rampage VI Extreme & ASUS Prime Z-370 A
Cooling Corsair 280mm AIO & Thermaltake Water 3.0
Memory 64GB DDR4-3000 GSKill RipJaws-V & 32GB DDR4-3466 GEIL Potenza
Video Card(s) 2X-GTX-1080 SLI & 2 GTX-1070Ti 8GB G1 Gaming in SLI
Storage Both have 2TB HDDs for storage, 480GB SSDs for OS, and 240GB SSDs for Steam Games
Display(s) ACER 28" B286HK 4K & Samsung 32" 1080P
Case NZXT Source 540 & Rosewill Rise Chassis
Audio Device(s) onboard
Power Supply Corsair RM1000 & Corsair RM850
Mouse Generic
Keyboard Razer Blackwidow Tournament & Corsair K90
Software Win-10 Professional
Benchmark Scores yes
Works good for a BETA Program. I like it, and thanks too!
 
Joined
Oct 22, 2014
Messages
7,165 (3.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E5-2680 10c/20t 2.8GHz @ 3.0GHz
Motherboard Asrock X79 Extreme 11
Cooling Coolermaster 240 RGB A.I.O.
Memory G. Skill 16Gb (4x4Gb) 2133Mhz
Video Card(s) Nvidia GTX 710
Storage Sandisk X 400 256Gb
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Home Premium 64 bit
All cells populated and info present and accounted for, Suh!
Only gripe is no desktop icon and downloading new version doesn't replace old version.
Minor issues indeed. :D :clap:
 

HammerON

The Watchful Moderator
Staff member
Joined
Mar 2, 2009
Messages
7,900 (2.04/day)
Location
Up North
System Name Cruncher
Processor E5 2683 v3
Motherboard ASRock X99 Extreme4/3.1
Cooling EK Supremacy
Memory G.Skill Trident Z 32 GB 3200
Video Card(s) EVGA 980 Ti Classified
Storage Samsung 960 Pro 512 GB + Mushkin Reactor 1 TB / OCZ Vertex 4 256 GB
Display(s) Dell UltraSharp U3011 30"
Case TT Core V51
Audio Device(s) On-board
Power Supply Corsair AX1200
Software Win 10 Pro
Benchmark Scores Always changing~
Not working right for me:


Two OCZ Vertex 4 256 GB in RAID 0.
 
Joined
Aug 29, 2005
Messages
5,150 (1.00/day)
Location
Whatever my internet protocol shows I guess O.o
System Name Lynni The Great White Dragon in Zen Glass | Lynni-Stick
Processor AMD Ryzen 9 3900X "ZEN2"| Intel Atom X5-Z8300 "Cherry Trail"
Motherboard MSI B450 Gaming Pro Carbono AC | Intel Compute Stick board
Cooling Fractal Design Celsius S24 | Fan xD
Memory Geil Dragon 4x8GB@3000mhz 15-17-17-35 (GWW416GB3000C15DC) | 2GB DDR3-L @ 1600mhz
Video Card(s) Nvidia GTX 1080 Ti FE "Pascal" Hybrid Core/Mem: +130MHz GPU Boost: 2000MHz+ | Intel HD Graphics
Storage OS/Games:Samsung 970 EVO 500GB NVME|Samsung EVO 850 1TB SSD|Data:3xWD Red/Purple 4TB & WD SE 1TB
Display(s) Dell S2417DG 1440p@165hz G-Sync | LG 55UK6100PLB IPS 4K HDR
Case Phantek Eclipse P400 Black/White | Intel Compute Case
Audio Device(s) Audio-Technica A550Z @ Creative Sound Blaster Z (Retail) | Intel HD Audio
Power Supply Seasonic Prime 1200 watt 80Plus Platinum | Generic Intel Power Adapter (3amp)
Mouse Logitech G502 | Logtech MK270 kit
Keyboard Razer Blackwidow Chroma X UK-Logitech G305 | Logitech MK270 kit
Software Win10 Pro SCU UK x64 | Win10 Home SCU x86
Benchmark Scores Time Spy: https://www.3dmark.com/3dm/33868867?
So far it works good with my Crucial SSD in my laptop but, it can't tell how many bytes that's written on to it, CrystalDiskInfo can ^^

and some other info is missing, just look at the attached pic.

SSD-Z.bytes.written.empty.jpg
 
Joined
Oct 22, 2014
Messages
7,165 (3.93/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E5-2680 10c/20t 2.8GHz @ 3.0GHz
Motherboard Asrock X79 Extreme 11
Cooling Coolermaster 240 RGB A.I.O.
Memory G. Skill 16Gb (4x4Gb) 2133Mhz
Video Card(s) Nvidia GTX 710
Storage Sandisk X 400 256Gb
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Home Premium 64 bit
Not working right for me:


Two OCZ Vertex 4 256 GB in RAID 0.
That's because you have them in RAID, it is trying to read them as one unit.
 
Joined
Feb 25, 2015
Messages
21 (0.01/day)
Location
Denmark
Not working right for me:

Two OCZ Vertex 4 256 GB in RAID 0.
Unfortunately, It's currently not working fully for RAID.

So far it works good with my Crucial SSD in my laptop but, it can't tell how many bytes that's written on to it, CrystalDiskInfo can ^^

and some other info is missing, just look at the attached pic.
Thanks for reporting this, it's just a minor issue. If you notice, the Bytes Written is shown on the SMART tab for attribute 246, it's just not displayed on the Device tab. I've fixed that issue, and made sure the mSATA M500 is detected properly.
 
Joined
Nov 28, 2004
Messages
30 (0.01/day)
Location
Germany
Processor Core i7 7800X @ 4.4 GHz
Motherboard MSI X299 SLI Plus
Cooling Thermalright HR-02 Macho
Memory 32 GB Corsair LPX DDR4 3000 CL15 @ 3466 CL17 1T
Video Card(s) EVGA GTX 1070 FTW @ 2052/4253 @ 1,0v
Storage 2x Samsung 256 GB NVMe, 9x 1 TB WD RE4 @ RAID5
Display(s) Acer XF270HUA + Eizo S2431WH-GY
Case Corsair Obsidian 750D
Audio Device(s) Creative Labs SoundBlasterX AE-5
Power Supply EVGA SuperNova G2 650w
Mouse Logitech G403
Keyboard Logitech K120
Software Windows 10 Pro x64
Top