• We've upgraded our forums. Please post any issues/requests in this thread.

Steam for linux beta!

Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
Do not forget to turn of the "talking" of the system to Amazon. It will give you more privacy and it saves you from a lot of bloat in the applications menu (when searching in it).
I think I have a bigger problem than that now. I partitioned one of my 500gb hard drives in half to use Ubuntu. on. From what it appears, somehow it took my 240gb SSD and decided to write itself over my windows installation. So now I lost my windows installation after I specifically specified it to write over the blank partition I had set. Yipee. This is why I don't fuck with Linux often unless I have a standalone or virtual machine. Apparently plenty of people have had this problem says Google.

It apparently saw my windows partition as free space. What stupid horseshit.
 
Last edited:
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
Always choose for manual partitioning in the OS's drive assignment phase, mounting the installment partition (the "root" partition) as "/" and making a swap partition mounted as "swap" (the latter is for virtual memory and hibernation stuff).

I am doing it mannually as well, when installinhg Windows, BTW.
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
I did. I partitioned the drive beforehand, and it said there was 2xx of free space, which is what I partitioned. So I clicked install on that drive, and with / as the mount point, and it installed. It gave me a Windows 7 option when I booted, so I figured I was fine and continued to mess with it. But nooo, apparently 2xx of free space means what Windows is installed on. Makes complete sense. :rolleyes:
 
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
If it literally said "use free space" you did select what I call the "No-No Method". Even when partitioning the matter beforehand, you still need to select "partition manually", which is way down below.
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
I'm not sure what you're saying. I personally partitioned the drive, and instead of using "beside Windows 7" etc, I chose the last option, and selected the disk. The disk said 2xx FREE SPACE. So I thought that was my blank partition I had just created. Apparently, FREE SPACE means Windows was installed here but fuck Windows I'm Ubuntu. It said NOTHING about NTFS, nothing about it having space, nothing at all.
 
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
Then I misunderstood you. It is indeed very weird. I know that Linux Mint and Sabayon should do it right. Maybe consider those?
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
Then I misunderstood you. It is indeed very weird. I know that Linux Mint and Sabayon should do it right. Maybe consider those?
Steam only works under Ubuntu right? That is the only thing I'm dual booting for, else I'd dual boot Fedora if anything because that is more of what I actually "need" to learn. Luckily all my data is on other drives and Windows and Steam games are the only thing on my C drive, but losing my FireFox bookmarks and everything = not fun.
 
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
Well, Sabayon has got Steam in their package depository and IIRC Steam for Linux is available as a deb file from Valve's website (which works with Linux Mint too, because its package management related software is the same as that from Ubuntu/Debian/Aptosid).

Edit: if you don't know what to choose, choose Mint.
 
Joined
Jul 23, 2011
Messages
1,555 (0.67/day)
Likes
1,459
Location
Kaunas, Lithuania
System Name Eternal WIP ][ HP ProLiant server blade
Processor AMD FX-8320 @ 4.4/4.1 GHz ][ 2x Intel Xeon L5520 @ 2.27GHz
Motherboard Asus Crosshair V Formula-Z ][ -
Cooling Corsair H55 ][ Stock
Memory 2x4GB Kingston HyperX Genesis @ 1866MHz ][ 4x4 GiB Hynix @ 1333 MHz; ECC on
Video Card(s) 2x MSI GeForce GTX 770 DirectCU II OC ][ None
Storage 1TB WD Black + 1.5TB WD Green + 750GB Samsung + 64GB OCZ Agility 4 ][ 3x 1 TB Hitachi
Display(s) Asus VG278H + Asus VH226H ][ None
Case Antec Nine Hundred ][ it's a server blade, lol
Audio Device(s) Supreme FX II (Integrated); Using optical S/PDIF output ][ none
Power Supply Corsair AX1200i ][ [stock]
Software Gentoo Linux ][ Linux Mint 16
Benchmark Scores 65970 BogoMIPS. Ha. Ha. Ha. >=|
Sorry to hear about what happen to Your partitioning.

And alas, yet another example of "one should always triple check which device is being worked on when partitioning."
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
On Mint now, this time it installed correctly, and yet it STILL listed my 240gb drive as non NTFS and free space. That is stupid as hell. Anyways, installing Steam now, hopefully it actually takes unlike the Ubuntu install which didn't actually install the 10 times I tried it.
 
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
Maybe it is related to the SSD one way or another? Firmware or anything like that...

NTFS is supported by default in case of Mint etc. because those OSes ship with ntfsprogs included into the .iso image.
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
So I got everything installed and running, tried to install ATI driver, didn't work so well. Tried beta driver first, didn't act right at all, then installed the non beta driver over it, and it didn't act right and recognized the PC as a laptop. Removed using this post http://forum.linuxmint.com/viewtopic.php?f=208&t=110025#p621085 and rebooted.

How do I get the drivers installed for my card correctly?
 
Joined
Aug 30, 2009
Messages
4,001 (1.32/day)
Likes
1,652
Location
Sarasota, Florida, USA
System Name Awesomesauce 4.3 | Laptop (MSI GE72VR 6RF Apache Pro-023)
Processor Intel Core i7-5820K 4.16GHz 1.28v/3GHz 1.05v uncore | Intel Core i7-6700HQ @ 3.1GHz
Motherboard Gigabyte GA-X99-UD5 WiFi LGA2011-v3| Stock
Cooling Corsair H100i v2 w/ 2x EK Vardar F4-120ER + various 120/140mm case fans | Stock
Memory G.Skill RJ-4 16GB DDR4-2666 CL15 quad channel | 12GB DDR4-2133
Video Card(s) ASUS ROG Strix A8G Gaming GTX 1080 @ 2075/1368 boost | NVIDIA GTX 1060 6GB +200/+500 + Intel 530
Storage Samsung 840 EVO 500GB + Seagate 3TB 7200RPM + others | Kingston 256GB M.2 SATA + 1TB 7200RPM
Display(s) Acer G257HU 1440p 60Hz AH-IPS 4ms | 17.3" 1920*1080 60Hz wide angle TN notebook panel
Case Fractal Design Define XL R2 | MSI
Audio Device(s) Creative Sound Blaster Z | Realtek with quad stereo speakers and subwoofer
Power Supply Corsair HX850i Platinum | 19.5v 180w Delta brick
Software Windows 10 Pro x64 | Windows 10 Home x64
Benchmark Scores GTX 1080 please?
So I got everything installed and running, tried to install ATI driver, didn't work so well. Tried beta driver first, didn't act right at all, then installed the non beta driver over it, and it didn't act right and recognized the PC as a laptop. Removed using this post http://forum.linuxmint.com/viewtopic.php?f=208&t=110025#p621085 and rebooted.

How do I get the drivers installed for my card correctly?
I'm in the same boat with the AMD drivers. Installing the NVIDIA drivers is a walk in the park.
 
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
So I got everything installed and running, tried to install ATI driver, didn't work so well. Tried beta driver first, didn't act right at all, then installed the non beta driver over it, and it didn't act right and recognized the PC as a laptop. Removed using this post http://forum.linuxmint.com/viewtopic.php?f=208&t=110025#p621085 and rebooted.

How do I get the drivers installed for my card correctly?
Did you try drivers from the AMD website or from the package manager?

On a sidenote: it is silly how "user friendly" distros always let folks have issues.
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
I'm in the same boat with the AMD drivers. Installing the NVIDIA drivers is a walk in the park.
Damn.
Did you try drivers from the AMD website or from the package manager?

On a sidenote: it is silly how "user friendly" distros always let folks have issues.
Those were the drivers I downloaded, from the website. Tried both the beta and other drivers, no dice. Same thing happened on Ubuntu when I tried to install them too, it screwed the system up.
 
Joined
Aug 30, 2009
Messages
4,001 (1.32/day)
Likes
1,652
Location
Sarasota, Florida, USA
System Name Awesomesauce 4.3 | Laptop (MSI GE72VR 6RF Apache Pro-023)
Processor Intel Core i7-5820K 4.16GHz 1.28v/3GHz 1.05v uncore | Intel Core i7-6700HQ @ 3.1GHz
Motherboard Gigabyte GA-X99-UD5 WiFi LGA2011-v3| Stock
Cooling Corsair H100i v2 w/ 2x EK Vardar F4-120ER + various 120/140mm case fans | Stock
Memory G.Skill RJ-4 16GB DDR4-2666 CL15 quad channel | 12GB DDR4-2133
Video Card(s) ASUS ROG Strix A8G Gaming GTX 1080 @ 2075/1368 boost | NVIDIA GTX 1060 6GB +200/+500 + Intel 530
Storage Samsung 840 EVO 500GB + Seagate 3TB 7200RPM + others | Kingston 256GB M.2 SATA + 1TB 7200RPM
Display(s) Acer G257HU 1440p 60Hz AH-IPS 4ms | 17.3" 1920*1080 60Hz wide angle TN notebook panel
Case Fractal Design Define XL R2 | MSI
Audio Device(s) Creative Sound Blaster Z | Realtek with quad stereo speakers and subwoofer
Power Supply Corsair HX850i Platinum | 19.5v 180w Delta brick
Software Windows 10 Pro x64 | Windows 10 Home x64
Benchmark Scores GTX 1080 please?
Mine wouldn't install right on 12.04 even though I built them from the .run file using the instructions from an Ubuntu guide. Kept getting an OpenGL error when I tried to launch TF2 and I couldn't increase my refresh rate to 120Hz.
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
Code:
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
threadtools.cpp (1439) : Assertion Failed: Permission denied
Assert( Assertion Failed: Permission denied ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier0/threadtools.cpp:1439

Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130103094918_1.dmp
success = no
error:  Failed to open/read local data from file/application
threadtools.cpp (1089) : Assertion Failed: semaphore creation failed No such file or directory
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 6572 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 6572 with name 0eSteamEngineLock
threadtools.cpp (1439) : Assertion Failed: Permission denied
Shutting down. . .
unlinked 0 orphaned pipes
FATAL: exception not rethrown
/home/tristan/.local/share/Steam/steam.sh: line 287:  6856 Aborted                 $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
I also get that when I try to run Steam. Got a similar error on Ubuntu.
 

Easy Rhino

Linux Advocate
Joined
Nov 13, 2006
Messages
14,405 (3.56/day)
Likes
4,257
System Name VHOST01 | Desktop
Processor i7 980x | i5 7500 Kaby Lake
Motherboard Gigabyte x58 Extreme | AsRock MicroATX Z170M Exteme4
Cooling Prolimatech Megahelams | Stock
Memory 6x4 GB @ 1333 | 2x 8G Gskill Aegis DDR4 2400
Video Card(s) Nvidia GT 210 | Nvidia GTX 970 FTW+
Storage 4x2 TB Enterprise RAID5 |Corsair mForce nvme 250G
Display(s) N/A | Dell 27" 1440p 8bit GSYNC
Case Lian Li ATX Mid Tower | Corsair Carbide 400C
Audio Device(s) NA | On Board
Power Supply SeaSonic 500W Gold | Seasonic SSR-650GD Flagship Prime Series 650W Gold
Mouse N/A | Logitech G900 Chaos Spectrum
Keyboard N/A | Posiden Z RGB Cherry MX Brown
Software Centos 7 | Windows 10
Code:
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
threadtools.cpp (1439) : Assertion Failed: Permission denied
Assert( Assertion Failed: Permission denied ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier0/threadtools.cpp:1439

Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130103094918_1.dmp
success = no
error:  Failed to open/read local data from file/application
threadtools.cpp (1089) : Assertion Failed: semaphore creation failed No such file or directory
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 6572 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 6572 with name 0eSteamEngineLock
threadtools.cpp (1439) : Assertion Failed: Permission denied
Shutting down. . .
unlinked 0 orphaned pipes
FATAL: exception not rethrown
/home/tristan/.local/share/Steam/steam.sh: line 287:  6856 Aborted                 $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"
I also get that when I try to run Steam. Got a similar error on Ubuntu.
permissions denied. run it as sudo.
 
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
Damn.


Those were the drivers I downloaded, from the website. Tried both the beta and other drivers, no dice. Same thing happened on Ubuntu when I tried to install them too, it screwed the system up.
Use the package manager (software centre, or Synaptic) to install the drivers. Make sure you select the propietary drivers from AMD.
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
When I open up the package manager, it says I have these installed already. Are these correct?

 
Joined
Aug 30, 2009
Messages
4,001 (1.32/day)
Likes
1,652
Location
Sarasota, Florida, USA
System Name Awesomesauce 4.3 | Laptop (MSI GE72VR 6RF Apache Pro-023)
Processor Intel Core i7-5820K 4.16GHz 1.28v/3GHz 1.05v uncore | Intel Core i7-6700HQ @ 3.1GHz
Motherboard Gigabyte GA-X99-UD5 WiFi LGA2011-v3| Stock
Cooling Corsair H100i v2 w/ 2x EK Vardar F4-120ER + various 120/140mm case fans | Stock
Memory G.Skill RJ-4 16GB DDR4-2666 CL15 quad channel | 12GB DDR4-2133
Video Card(s) ASUS ROG Strix A8G Gaming GTX 1080 @ 2075/1368 boost | NVIDIA GTX 1060 6GB +200/+500 + Intel 530
Storage Samsung 840 EVO 500GB + Seagate 3TB 7200RPM + others | Kingston 256GB M.2 SATA + 1TB 7200RPM
Display(s) Acer G257HU 1440p 60Hz AH-IPS 4ms | 17.3" 1920*1080 60Hz wide angle TN notebook panel
Case Fractal Design Define XL R2 | MSI
Audio Device(s) Creative Sound Blaster Z | Realtek with quad stereo speakers and subwoofer
Power Supply Corsair HX850i Platinum | 19.5v 180w Delta brick
Software Windows 10 Pro x64 | Windows 10 Home x64
Benchmark Scores GTX 1080 please?
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
Those look like the generic open source drivers. Should say FGLRX for the proprietary AMD ones.
Cool. Got those installed, now am getting a different Steam error message. I've tried sudo apt-get remove Steam and sudo apt-get purge steam and tried to reinstall it. When I do reinstall it, it installs in around 5 seconds. Assuming it isn't correctly installing the files it needs to?

Code:
sudo steam
[sudo] password for tristan: 
Installing breakpad exception handler for appid(steam)/version(1355957371_client)
Looks like steam didn't shutdown cleanly, scheduling immediate update check
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
unlinked 0 orphaned pipes
removing stale semaphore last operated on by process 3627 with name 0eBlobRegistryMutex_4A4D3296624CC04BB8668F8514D434D6
removing stale semaphore last operated on by process 3627 with name 0eBlobRegistrySignal_4A4D3296624CC04BB8668F8514D434D6
removing stale semaphore last operated on by process 3627 with name 0emSteamEngineInstance
removing stale semaphore last operated on by process 3627 with name 0eSteamEngineLock
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)

(process:3811): Gtk-WARNING **: This process is currently running setuid or setgid.
This is not a supported use of GTK+. You must create a helper
program instead. For further details, see:

    http://www.gtk.org/setuid.html

Refusing to initialize GTK+.
surface_linux.cpp (1383) : Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt...

Assert( Assertion Failed: X context is not using direct rendering. Unfasten your seatbelt...
 ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/vgui2/src/surface_linux.cpp:1383

Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130105121527_1.dmp
success = no
error:  Failed to open/read local data from file/application
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Generating new string page texture 2: 48x256, total string texture memory is 49.15 KB
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Generating new string page texture 3: 384x256, total string texture memory is 442.37 KB
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Adding license for package 71
Adding license for package 1070
Adding license for package 34
Adding license for package 1170
Adding license for package 218
Adding license for package 1532
Adding license for package 636
Adding license for package 305
Adding license for package 383
Adding license for package 292
Adding license for package 2294
Adding license for package 63
Adding license for package 2075
Adding license for package 2464
Adding license for package 2051
Adding license for package 37
Adding license for package 546
Adding license for package 1662
Adding license for package 3098
Adding license for package 2554
Adding license for package 4138
Adding license for package 2752
Adding license for package 1220
Adding license for package 605
Adding license for package 4060
Adding license for package 1679
Adding license for package 1579
Adding license for package 1886
Adding license for package 2318
Adding license for package 2064
Adding license for package 2272
Adding license for package 1602
Adding license for package 6056
Adding license for package 4991
Adding license for package 6896
Adding license for package 2996
Adding license for package 7135
Adding license for package 2967
Adding license for package 4073
Adding license for package 4687
Adding license for package 6749
Adding license for package 663
Adding license for package 2916
Adding license for package 7816
Adding license for package 6346
Adding license for package 603
Adding license for package 1064
Adding license for package 7427
Adding license for package 4772
Adding license for package 2207
Adding license for package 2209
Adding license for package 7733
Adding license for package 482
Adding license for package 4085
Adding license for package 335
Adding license for package 8666
Adding license for package 2031
Adding license for package 6951
Adding license for package 8866
Adding license for package 288
Adding license for package 11106
Adding license for package 11733
Adding license for package 11785
Adding license for package 4077
Adding license for package 6945
Adding license for package 6577
Adding license for package 11563
Adding license for package 13734
Adding license for package 13735
Adding license for package 14977
Adding license for package 14871
Adding license for package 14870
Adding license for package 994
Adding license for package 15407
Adding license for package 4638
Adding license for package 13743
Adding license for package 8466
Adding license for package 13756
Adding license for package 11183
Adding license for package 13981
Adding license for package 15918
Adding license for package 16128
Adding license for package 4097
Adding license for package 4275
Adding license for package 4564
Adding license for package 4566
Adding license for package 4565
Adding license for package 4418
Adding license for package 4567
Adding license for package 4568
Adding license for package 15479
Adding license for package 14481
Adding license for package 16189
Adding license for package 17423
Adding license for package 17250
Adding license for package 8962
Adding license for package 18011
Adding license for package 7440
Adding license for package 7970
Adding license for package 2118
Adding license for package 18058
Adding license for package 16720
Adding license for package 16222
Adding license for package 17111
Adding license for package 11755
Adding license for package 0
Adding license for package 1295
Adding license for package 16446
Adding license for package 18740
Adding license for package 14335
Adding license for package 8186
Adding license for package 17982
roaming config store loaded successfully - 5571 bytes.
migrating temporary roaming config store
ExecCommandLine: "/home/tristan/.local/share/Steam/ubuntu12_32/steam"
Generating new string page texture 75: 1024x256, total string texture memory is 1.49 MB
Generating new string page texture 76: 128x256, total string texture memory is 1.62 MB
Generating new string page texture 77: 128x256, total string texture memory is 131.07 KB
Generating new string page texture 78: 256x256, total string texture memory is 1.88 MB
Generating new string page texture 79: 64x256, total string texture memory is 1.95 MB
Generating new string page texture 80: 32x256, total string texture memory is 1.98 MB
Generating new string page texture 83: 128x256, total string texture memory is 2.11 MB
Generating new string page texture 85: 128x256, total string texture memory is 2.24 MB
Generating new string page texture 86: 256x256, total string texture memory is 2.51 MB
Generating new string page texture 87: 8x256, total string texture memory is 2.51 MB
System startup time: 7.48 seconds
ExecSteamURL: "steam://open/driverhelperready"
Generating new string page texture 116: 512x256, total string texture memory is 3.04 MB
Generating new string page texture 117: 24x256, total string texture memory is 3.06 MB
CAPIJobRequestUserStats - Server response failed 2
Generating new string page texture 121: 48x256, total string texture memory is 3.11 MB
Generating new string page texture 123: 384x256, total string texture memory is 3.51 MB
Generating new string page texture 124: 256x256, total string texture memory is 3.77 MB
Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Generating new string page texture 143: 128x256, total string texture memory is 3.90 MB
Generating new string page texture 153: 128x256, total string texture memory is 4.03 MB
CAPIJobRequestUserStats - Server response failed 2
Generating new string page texture 155: 64x256, total string texture memory is 4.10 MB
CAPIJobRequestUserStats - Server response failed 2
Generating new string page texture 157: 128x256, total string texture memory is 4.23 MB
Generating new string page texture 158: 16x256, total string texture memory is 4.24 MB
Generating new string page texture 159: 256x256, total string texture memory is 4.51 MB
Generating new string page texture 163: 384x256, total string texture memory is 4.90 MB
threadtools.cpp (2888) : Assertion Failed: Illegal termination of worker thread 'UICEFThread'
Assert( Assertion Failed: Illegal termination of worker thread 'UICEFThread' ):/home/buildbot/buildslave_steam/steam_rel_client_ubuntu12_linux/build/src/tier0/threadtools.cpp:2888

Installing breakpad exception handler for appid(Steam)/version(1355957371_client)
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20130105121549_2.dmp
success = no
error:  Failed to open/read local data from file/application
threadtools.cpp (2889) : Assertion Failed: Deleting thread object from the thread, this is bad
steamservice.cpp (50) : Assertion Failed: m_hServiceLib == NULL
CAsyncIOManager: 0 threads terminating.  0 reads, 0 writes, 0 deferrals.
CAsyncIOManager: 172349 single object sleeps, 108 multi object sleeps
CAsyncIOManager: 0 single object alertable sleeps, 2 multi object alertable sleeps
steamservice.cpp (49) : Assertion Failed: m_hSteamPipe == NULL
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
surface_opengl.cpp (541) : Assertion Failed: glIsTexture( id )
/home/tristan/.local/share/Steam/steam.sh: line 287:  3811 Segmentation fault      $DEBUGGER "$STEAMROOT/$PLATFORM/$STEAMEXE" "$@"


EDIT: Removed with package manager, restarted, reinstalled, Steam came up (clicking on the icon).
Now I get this error. It comes up, runs for a bit, then shuts down putting the last line of code in the terminal. When I run it clicking or non sudo, it quits with the same error or hangs (usually when I just open the icon) at Connecting to Account .....


Now the other issue I have is after restarting, I had to disable my second display to put my first display in 1920x1200. I cannot enable the other display, 1440x900, without getting this error:

The requested configuration for the displays could not be applied
required virtual size does not fit available size: requested=(3360, 1200), minimum=(320, 200), maximum=(1920, 1920)
 
Last edited:
Joined
Sep 3, 2010
Messages
3,443 (1.29/day)
Likes
1,685
Location
NL, Europe
Processor Intel Core i5-4460
Motherboard Gigabyte GA-Z97-D3H
Cooling Arctic Freezer i11
Memory Crucial Ballistix Sport, DDR3-1600, 2x4 GB kit
Video Card(s) Sapphire Radeon R9 270X Vapor-X
Storage Kingston SSDNow V300 (120GB) + Seagate Barracuda 7200.14 (1TB)
Display(s) AOC G2260VWQ6 | Acer AL1916 (in reserve)
Case Cooler Maste Centurion 5
Audio Device(s) integrated
Power Supply Seasonic G450
Mouse Logitech G500
Keyboard Qpad MK-50
Software Windows 10
Did you do the display stuff in the Catalyst Control Center?
 
Joined
Oct 12, 2008
Messages
1,584 (0.47/day)
Likes
750
It won't let me in CCC, it is blurred out.

Okay, so this time it wasn't blurred out, and let me try it. It has you restart every time you make a change, FYI. So I switched it to extend my display, and it booted me into laptop mode, and running my mouse across the main display made it come from the other side like an infinite loop. The second display showed "picture", a clear white background, so it was being recognized. It also gave me two of everything, two trays, two start menus, two folder icons.
 
Last edited: