• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Steam issue

Joined
Feb 24, 2009
Messages
2,339 (0.69/day)
Likes
1,431
Location
Riverside, California
System Name Red Monster
Processor Intel Core i7 7800X @ 4.7GHz
Motherboard MSI X299 Gaming M7 ACK
Cooling Corsair Hydro Series H115i 280mm
Memory Corsair Vengeance LED 32GB DDR4 3466
Video Card(s) evga GTX 1080 Ti FTW3 iCX
Storage Intel 535 Series 2.5" 480GB SATA /WD Blue 1TB SSD /Radeon R7 240GB SSD /1TB, & 4TB HHD
Display(s) Samsung UN55KS8500 55" 4K & Oculus Rift CV1
Case Corsair Carbide Series Air 540
Audio Device(s) Creative Sound Blaster ZX > Pagoda DAC > multiple amps
Power Supply Corsair HX1000i
Mouse Logitech G600
Keyboard Corsair K70 Cherri MX
Software Windows 10
#1
So I have been experiencing this issue for awhile now. Steam normally boots up instantly. Click on a game and it loads...instantly. For the past 4 months though when I turn steam on it takes about 2-3 minutes before I see it actually load up. So I click the steam icon and then nothing happens at all but 3-4 minutes later steam pops up on the screen and is ready to be used. The next issue is games. Some games when I click the icon they load up immediately like they should but other games when I click them they take 3-4 minutes or longer to load. Sometimes it will be like the game has not been started. I'm just sitting at my desktop wondering if it will load up or not, or it will load to a black screen and then nothing...for several minutes then the game loads and I can play.

A couple of games no longer load at all but go into the "not responding" mode.

I reformatted my PC and the problem went away for a short time and now ( a month later) it is back to not working correctly.

The SSD steam is on shows that it is A-OK. Windows 10 is fully updated as well as my video card drivers. No anti virus, fire wall has been disabled, windows 10 game mode deactivated. (maybe I should reactivate it and see if that helps)

I usually have no problems solving my own issues but I am at a loss right now. Origin works fine, loads fast and games load fast. Games installed directly to my HDD load up fine. It seems to be Steam related. I verified integrity of game files multiple times. Uninstalled games and steam several times and still this issue persists.

I think next i will uninstall steam and reinstall it to another SSD to rule that out but my current SSD game drive is fairly new and according to WD dashboard: healthy.

I suppose I'm putting this on the board just to see if anyone else has experienced this and what you did to fix it.
 

AsRock

TPU addict
Joined
Jun 23, 2007
Messages
15,558 (3.90/day)
Likes
4,970
Location
US
Processor 2500k \ 3770k
Motherboard ASRock Z68 \ Z77
Memory Samsung low profile 1600
Video Card(s) XFX 6770 \ XFX R9 390X
Storage Intel 80Gb (SATA2) WD 250Gb \ Team SSD+Samsung Evo 250Gb+500Gb+ 2xCorsair Force+WD250GbHDD
Display(s) Samsung 1080P \ Toshiba HDTV 1080P
Case HTPC400 \ Thermaltake Armor case ( original ), With Zalman fan controller ( wattage usage ).
Audio Device(s) Yamaha RX-V475 \ Yamaha CX-830\Yamaha MX630 Tannoy Mercury MKII Paradigm 5SE + Tannoy Mercury F4
Power Supply PC&Power 750w \ Seasonic 750w MKII
Mouse MS intelimouse \ Logitech G700s + Steelseries Sensei wireless
Keyboard Logitech K120 \ ROCCAT MK Pro ( modded amber leds )
Benchmark Scores Meh benchmarks.
#2
Tried redownloading steam and trying that ?, all so use a NEW install directory. apart from that and maybe re-downloading problem games.

I guess you could try verifying the integrity of each game too ( right click game select properties \ local files.)
 
Joined
Nov 13, 2007
Messages
6,363 (1.65/day)
Likes
1,841
Location
Austin Texas
System Name TimeDumpster
Processor Intel i7 7820X Delidded @ 4.75Ghz / 3.1Ghz Mesh
Motherboard MSI X299 Tomahawk
Cooling 240mm Corsair H105 Intake
Memory 32 GB Quad 3434Mhz DDR4 15-16-16-38-300-1T
Video Card(s) Gigabyte GTX 1080 Ti Gaming
Storage 1Tb Samsung 960 Pro m2, 1TB Samsung 850 Pro SSD
Display(s) Dell 24" 2560x1440 144hz, G-Sync @ 165Hz
Case NZXT S340 Elite Black
Audio Device(s) Arctis 7
Power Supply FSP HydroG 750W
Mouse zowie ec-2
Keyboard corsair k65 tenkeyless
Software Windows 10 64 Bit
Benchmark Scores Cb: 2103 Multi, 209 Single, 10450 Timespy - 10150 GPU/11900 CPU, superpi 1M - 7.71s
#3
try changing your DNS to 1.1.1.1 or 8.8.8.8 (google) instead of the ISP assigned one.

it might be chilling in the background trying to connect to servers and having issues finding them...

It takes steam about 30 seconds to start up for me... but nowhere near 2-3 mins.


You can also try to put it in offline mode for those games that freeze to see if that solves it.
 
Joined
Feb 24, 2009
Messages
2,339 (0.69/day)
Likes
1,431
Location
Riverside, California
System Name Red Monster
Processor Intel Core i7 7800X @ 4.7GHz
Motherboard MSI X299 Gaming M7 ACK
Cooling Corsair Hydro Series H115i 280mm
Memory Corsair Vengeance LED 32GB DDR4 3466
Video Card(s) evga GTX 1080 Ti FTW3 iCX
Storage Intel 535 Series 2.5" 480GB SATA /WD Blue 1TB SSD /Radeon R7 240GB SSD /1TB, & 4TB HHD
Display(s) Samsung UN55KS8500 55" 4K & Oculus Rift CV1
Case Corsair Carbide Series Air 540
Audio Device(s) Creative Sound Blaster ZX > Pagoda DAC > multiple amps
Power Supply Corsair HX1000i
Mouse Logitech G600
Keyboard Corsair K70 Cherri MX
Software Windows 10
#4
Tried redownloading steam and trying that ?, all so use a NEW install directory. apart from that and maybe re-downloading problem games.

I guess you could try verifying the integrity of each game too ( right click game select properties \ local files.)
Did all that. Didn't help but thanks.

try changing your DNS to 1.1.1.1 or 8.8.8.8 (google) instead of the ISP assigned one.

it might be chilling in the background trying to connect to servers and having issues finding them...

It takes steam about 30 seconds to start up for me... but nowhere near 2-3 mins.


You can also try to put it in offline mode for those games that freeze to see if that solves it.
I will try this thanks. I'll report back if it helps or not.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
21,716 (6.19/day)
Likes
10,865
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) PowerColor PCS+ 390 8 GiB DVI + HDMI
Storage Crucial MX300 275 GB, Seagate 6 TB 7200 RPM
Display(s) Samsung SyncMaster T240 24" LCD (1920x1200 HDMI) + Samsung SyncMaster 906BW 19" LCD (1440x900 DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek Onboard, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
#5
You can delete everything in Steam folder except:
steam.exe
userdata\ folder has saves
common\ folder has games

Then run steam.exe again. It will force Steam to reinstall itself and rebuild its caches.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
21,479 (5.40/day)
Likes
6,197
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#6
You can delete everything in Steam folder except:
steam.exe
userdata\ folder has saves
common\ folder has games

Then run steam.exe again. It will force Steam to reinstall itself and rebuild its caches.
You don't thing a WUD is screwing with it, i mean he reinstalled and updated and it is doing it again, W10 loves to autoupdate too.
 
Joined
Jan 31, 2010
Messages
2,604 (0.86/day)
Likes
870
System Name Xtreme PC's AMDx8
Processor AMD FX8320 @ 4.0GHz NB/HT @ 2.6GHz
Motherboard Asus Crosshair V Formula
Cooling ThermoLab Baram 2x 120mm Gentle Typhoons 1850rpm
Memory 8GB (2x4GB) Mushkin Blackline DDR3 2400MHz 11/13/13/34/1T 1.65V
Video Card(s) Sapphire Nitro+ RX580 8GB OC 1342/2000 (Core/Mem) BIOS Modded
Storage 2x Kingston V300 120GB SSD's Raid0: 1x Sandisk 128GB SSD 1xWD 2TB red, 1xWD 1TB black 1xWD 2TB nas
Display(s) ViewSonic VX2457 75Hz FreeSync 1920x1080p
Case SilverStone Raven RV02B-W + 3x SS AP181 + USB3.0 upgrade
Audio Device(s) Creative SB X-Fi Xtreme PCIe + Pioneer VSX-D457 amp Technics Speaker set
Power Supply SilverStone ST75F-P Modular 750W
Mouse Logitech G402 Hyperion Fury
Keyboard Logitech G105
Software Windows 10 X64 PRO (build 1607)
Benchmark Scores it sucks even less much now ;)
#7
I've had the problem before turned out to be Windows Defender rescanning everything because it updated the main program so I added the steam save/game folders to the excluded list and that fixed it
 
Joined
Feb 24, 2009
Messages
2,339 (0.69/day)
Likes
1,431
Location
Riverside, California
System Name Red Monster
Processor Intel Core i7 7800X @ 4.7GHz
Motherboard MSI X299 Gaming M7 ACK
Cooling Corsair Hydro Series H115i 280mm
Memory Corsair Vengeance LED 32GB DDR4 3466
Video Card(s) evga GTX 1080 Ti FTW3 iCX
Storage Intel 535 Series 2.5" 480GB SATA /WD Blue 1TB SSD /Radeon R7 240GB SSD /1TB, & 4TB HHD
Display(s) Samsung UN55KS8500 55" 4K & Oculus Rift CV1
Case Corsair Carbide Series Air 540
Audio Device(s) Creative Sound Blaster ZX > Pagoda DAC > multiple amps
Power Supply Corsair HX1000i
Mouse Logitech G600
Keyboard Corsair K70 Cherri MX
Software Windows 10
#8
I've had the problem before turned out to be Windows Defender rescanning everything because it updated the main program so I added the steam save/game folders to the excluded list and that fixed it
I haven't been on my PC in two days so I haven't tried anything since I posted but this does look promising.

The only thing that trips me out is I have 4 gaming rigs running daily. Mine, my daughter's, my son's, and the kitchen game rig that is used by everyone. None of these computers suffer from this issue. All are on the same network. Just seems strange.
 
Joined
Jul 16, 2014
Messages
1,861 (1.32/day)
Likes
925
Location
SE Michigan
System Name Dumbass
Processor AMD-9370BE @4.6
Motherboard ASUS SABERTOOTH 990FX R2.0 +SB950
Cooling CM Nepton 280L
Memory G.Skill Sniper 16gb DDR3 2400
Video Card(s) GreenTeam 1080 Gaming X 8GB
Storage C:\SSD (240GB), D:\Seagate (2TB), E:\Western Digital (1TB)
Display(s) 2x Dell S2440L (16:9)
Case Phanteks Enthoo Primo w/8 140mm SP Fans
Audio Device(s) onboard (realtek?) SPKRS:Logitech Z623 200w 2.1
Power Supply Corsair HX1000i
Mouse Logitech G700s
Keyboard Logitech G910 Orion Spark
Software windows 10
Benchmark Scores https://i.imgur.com/12OuxaI.jpg
#9
I run into this occasionally when starting Steam. I do not have a problem starting games because I changed the default install folders. Games I play occassionally get put on platter drives, the games that get played a lot will go on an SSD in a folder all its own. The only thing thing left to default is where Steam saves game backups, if I could change this too, I would.
 
Joined
Mar 23, 2016
Messages
1,246 (1.57/day)
Likes
1,454
Location
AK, USA
Processor Ryzen 5 2600X - Stock Clocked
Motherboard MSI B350M Gaming Pro
Cooling Stock Cooling
Memory TEAMGROUP Team DDR4 3000 8GB Kit @ 3,400 MHz 16-18-18-18-38-tRFC 64
Video Card(s) XFX RS RX 480 GPU @ 1288 MHz - 1.040 mV from 1.175 | GDDR5 @ 2100 MHz
Storage Samsung 850 EVO 250 GB, SanDisk Ultra II 480 GB
Display(s) IP2362 OCed refresh rate - 76Hz (Freesync supported over HDMI with CRU)
Case Phantek Eclipse P400S (PH-EC416PS)
Audio Device(s) Realtek ALC887 (on-board)
Power Supply EVGA 850 BQ
Mouse Kingston HyperX Pulsefire FPS
Keyboard Logitech K520
Software Windows 10 Professional 64-bit
#10
Ran into this issue out of the blue a few weeks back. Uninstall then reinstall fixed it for me, and it wasn't interfere caused by Windows Defender. Also before the Windows 10 April update.

Steam is installed on the boot drive, and games are on the second SSD.
 
Joined
Feb 24, 2009
Messages
2,339 (0.69/day)
Likes
1,431
Location
Riverside, California
System Name Red Monster
Processor Intel Core i7 7800X @ 4.7GHz
Motherboard MSI X299 Gaming M7 ACK
Cooling Corsair Hydro Series H115i 280mm
Memory Corsair Vengeance LED 32GB DDR4 3466
Video Card(s) evga GTX 1080 Ti FTW3 iCX
Storage Intel 535 Series 2.5" 480GB SATA /WD Blue 1TB SSD /Radeon R7 240GB SSD /1TB, & 4TB HHD
Display(s) Samsung UN55KS8500 55" 4K & Oculus Rift CV1
Case Corsair Carbide Series Air 540
Audio Device(s) Creative Sound Blaster ZX > Pagoda DAC > multiple amps
Power Supply Corsair HX1000i
Mouse Logitech G600
Keyboard Corsair K70 Cherri MX
Software Windows 10
#11
I may try that too. My boot drive has a ton of free space and I could install steam there and games on another SSD.

Thanks everyone. You have all given me some hope. lol
 
Top