• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

SteelSeries Arctis Nova Pro Wireless doesn't get found by Xiaomi Poco F5

Joined
Nov 30, 2020
Messages
47 (0.04/day)
Hi, I'm attempting to connect my SteelSeries Arctis Nova Pro Wireless headset to my Poco F5 via Bluetooth. However, for some reason, the headset isn't showing up on my phone's device list. While my phone can detect other devices, it fails to locate the headset. Previously, I used a Poco F4 and had no such issues. I don't believe there's a problem with either the phone or the headset, yet they won't connect. Both devices are updated to the latest versions. Can anyone offer some assistance? Thank you.
 

silentbogo

Moderator
Staff member
Joined
Nov 20, 2013
Messages
5,488 (1.41/day)
Location
Kyiv, Ukraine
System Name WS#1337
Processor Ryzen 7 3800X
Motherboard ASUS X570-PLUS TUF Gaming
Cooling Xigmatek Scylla 240mm AIO
Memory 4x8GB Samsung DDR4 ECC UDIMM
Video Card(s) Inno3D RTX 3070 Ti iChill
Storage ADATA Legend 2TB + ADATA SX8200 Pro 1TB
Display(s) Samsung U24E590D (4K/UHD)
Case ghetto CM Cosmos RC-1000
Audio Device(s) ALC1220
Power Supply SeaSonic SSR-550FX (80+ GOLD)
Mouse Logitech G603
Keyboard Modecom Volcano Blade (Kailh choc LP)
VR HMD Google dreamview headset(aka fancy cardboard)
Software Windows 11, Ubuntu 20.04 LTS
Have you tried to pair it it on another phone or laptop? Have you tried to reset the headset? There's a small hole under the earpad, which you need to push with a paperclip (or something thin, like SIM ejector).
 
Top