• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Stock Bios needed for my Asus RX550 4GB card

Zsoca72

New Member
Joined
Jan 14, 2020
Messages
3 (0.19/day)
Hello!
Please help me to restore the original Bios to my VGA. I modded it with Polaris editor "one click timing".
I send the picture of my Bios opened with Polaris editor.
 

Attachments

Joined
Feb 11, 2012
Messages
1,421 (0.49/day)
Location
Anchorage Alaska
System Name Matter's / Helios 300 Predator
Processor Ryzen 7 2700 / i7 7700HQ
Motherboard B450 Tomahawk / Acer Helios 300 Predator
Cooling Arctic Freezer eSports Duo
Memory Patriot Viper ddr4 32gb / 32gb gskill ddr4
Video Card(s) MSI RTX 2080 Super Ventus OC / GTX 1060 6gb
Storage Patriot Viper nvme M2, crucial MX300 275gb, Samsung 860 qvo 1tb
Display(s) Acer 24" 1080p / 15.6 1080p HD
Case Antec 300 / Acer Helios 300 Predator
Audio Device(s) On Board - Steel Series Arctis Pro Wireless Cans
Power Supply Antec 850watt high current pro
Mouse Steel series Rival 600
Keyboard Corsair K70 / Acer Helios 300 Predator
Software Win 10 Pro / Win 10 Home
You will need to provide pictures of the white stickers on the gpu, make sure they are clear to read and if you still have the box picture of the white sticker off that. @eidairaman1 may be to help when he gets time and all the proper info. You will need gpu-z screenshot too.
 

Zsoca72

New Member
Joined
Jan 14, 2020
Messages
3 (0.19/day)
Thank You. I will send all the pictures.
Meantime, I checked many "unverified" Bioses on this site, and I found one ( https://www.techpowerup.com/vgabios/198254/198254 ), what I though will be good for sure, because straps till 1375 were the same as in my modded Bios, and when I patched this (one click timing patch) with Polaris editor, I got exactly same straps what are in my modded Bios. Unfortunately, after I flashed it to my card (of course without patch) and reboot, there it is still showed with "exclamation mark" in device manager (windows stopped the device, code:43). What mean, I still need the "atikmdag-patcher" to use the card and that was what I wanted to avoid.
 

Attachments

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
29,084 (6.33/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Nobody can help me with this? :(
Give me time, im only 1 person

Hello!
Please help me to restore the original Bios to my VGA. I modded it with Polaris editor "one click timing".
I send the picture of my Bios opened with Polaris editor.
Use this tool

Heres a slew that are for your card.




 
Top