• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Strange HD4870 issue!

BrosephJ

New Member
Joined
Mar 31, 2013
Messages
5 (0.00/day)
Likes
0
Location
Oregon
#1
Hello techPowerUp! forums, my first post is a cry for help. I've searched and seached but came up empty, or just used the wrong words? Not sure, lol. Anyways my GTX260 has begun resting on its deathbed and my only choice now is my dad's old card. Playing games in fullscreen mode works fine, no issue.

But whenever I attempt to play in windowed mode the high performance clock speeds never kick in, they always stay 200 core 500 mem. :( On top of that, the graphics overdrive never displays the correct clock speeds on the sliders and if I attempt to correct them the driver crashes. (says 500/500 there because I'm watching a flash video on my other monitor, GPU-Z doesn't show that, weird?)



Using 13.1 driver, Windows 7 x64 (while I typed this the text would randomly be blurry wtf?)
Would any of these choices fix this?
-BIOS flash
-Downgrade my driver
-3rd party utility
 
Joined
Mar 9, 2013
Messages
340 (0.19/day)
Likes
44
Location
Central Illinois
Processor AMD FX-8370 Black Edition
Motherboard MSI 990FXA Gaming Board
Cooling Corsair H-105 liquid cooler
Memory Gskill ripjaws 16GB 1866 RAM
Video Card(s) EVGA GTX 980 Ti FTW
Storage Samsung 840 250GB SSD/ Samsung 850 EVO 500GB Storage
Display(s) Acer 25 inch 2560x1440
Case Corsair 760-T
Audio Device(s) onboard
Power Supply EVGA Supernova Full Modular 750w
Mouse CM Storm
Keyboard CM Storm
#2

BrosephJ

New Member
Joined
Mar 31, 2013
Messages
5 (0.00/day)
Likes
0
Location
Oregon
#3
Wait so...Catalyst Control Center and AMD VISION Engine Control Center are 2 different things? Perhaps 13.1 driver for this card is a bad thing? :eek: But yeah, I'm mainly an Nvidia guy too. Hoping once I get this sorted I may be an AMD guy. ;)
 
Joined
Mar 9, 2013
Messages
340 (0.19/day)
Likes
44
Location
Central Illinois
Processor AMD FX-8370 Black Edition
Motherboard MSI 990FXA Gaming Board
Cooling Corsair H-105 liquid cooler
Memory Gskill ripjaws 16GB 1866 RAM
Video Card(s) EVGA GTX 980 Ti FTW
Storage Samsung 840 250GB SSD/ Samsung 850 EVO 500GB Storage
Display(s) Acer 25 inch 2560x1440
Case Corsair 760-T
Audio Device(s) onboard
Power Supply EVGA Supernova Full Modular 750w
Mouse CM Storm
Keyboard CM Storm
#4
Intel CPU? or is an AMD?
 
Joined
Sep 8, 2012
Messages
829 (0.42/day)
Likes
323
Location
Sydney, Australia
System Name The White Breeze||Medion Akoya Ultrabook
Processor i7-3770k||Core i5-3317U
Motherboard MSI Z77 MPOWER||Laptop?
Cooling Custom TEC waterloop||Laptop?
Memory 16GB Kingston HyperX @ 2133MHz||8GB SDRAM
Video Card(s) 2X SLI MSI GeForce GTX 680 Lightning||Intel 4000
Storage Corsair GT 120GB, WD Caviar Black 1TB||500GB HDD with 32gb MSATA cache
Display(s) Samsung U28D590D 4k||14" LED
Case NZXT Switch 810||Laptop shell?
Audio Device(s) Creative Sound Blaster X-Fi surround pro 5.1||Dolby Home Theatre V4
Power Supply Seasonic XP-860 Platinum||Laptop Power Brick
Software Windows 7||Windows 8
#6
Try using catalyst 10.10 or 10.11
From the knowledge of another user, these are the last well working drivers for this card.
 

BrosephJ

New Member
Joined
Mar 31, 2013
Messages
5 (0.00/day)
Likes
0
Location
Oregon
#7
Alright, I'll give those a try. Thanks! I'll report my results here later, going to sleep now.
 
Joined
Sep 8, 2012
Messages
829 (0.42/day)
Likes
323
Location
Sydney, Australia
System Name The White Breeze||Medion Akoya Ultrabook
Processor i7-3770k||Core i5-3317U
Motherboard MSI Z77 MPOWER||Laptop?
Cooling Custom TEC waterloop||Laptop?
Memory 16GB Kingston HyperX @ 2133MHz||8GB SDRAM
Video Card(s) 2X SLI MSI GeForce GTX 680 Lightning||Intel 4000
Storage Corsair GT 120GB, WD Caviar Black 1TB||500GB HDD with 32gb MSATA cache
Display(s) Samsung U28D590D 4k||14" LED
Case NZXT Switch 810||Laptop shell?
Audio Device(s) Creative Sound Blaster X-Fi surround pro 5.1||Dolby Home Theatre V4
Power Supply Seasonic XP-860 Platinum||Laptop Power Brick
Software Windows 7||Windows 8
#8
Also just a heads up, I do believe that with some cards/games/drivers, playing games in window can cause overdrives to not enable, and for the card to stay underclocked.
 

BrosephJ

New Member
Joined
Mar 31, 2013
Messages
5 (0.00/day)
Likes
0
Location
Oregon
#9
I've determined that the card has a manufacturer error and have since then taken it out and put my GTX 260 back in. Tried with 13.1 drivers, 10.11 and 12.6 with same problems. I could probably flash the BIOS with a fixed one but I'd rather not risk that on a card that isn't mine. So, I'm done here!