• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Terrible experience with XFX RX 580

Status
Not open for further replies.
Joined
Oct 26, 2005
Messages
652 (0.13/day)
Likes
525
#1
Last month I ordered a brand new XFX Radeon RX 580 GTS XXX Edition 8GB (RX-580P8DFD6) from Amazon during Black Friday to replace aging GTX 970.

I've been using the card for a week and my experience with it been terrible. Unbelieve amount of issues.

* Poor rendering performance of 640x480 (BIOS, POST, DOS, Linux).
* The card is buzzing when the computer is POWERED OFF if plugged to a monitor via DP (outlet is grounded and everything is plugged to a UPS).
* Black screen on Windows' startup when using dual monitors via DVI and HDMI.
* AMD WattMan cannot overclock the memory (Hynix) more than 100 MHz (hard lockup). MSI Afterburner works fine.
* AMD Overlay and ReLive sometimes crash games.
* PC automatically powers on after a shutdown (WTF).
* Random "CPU overclocking failed" errors at POST.
* Fans are loud and sometimes run at 100 percent during boot.
* Artifacts appear in low-perf 3D (PUBG in-game inventory screen) on stock clocks.

Today I plugged the GTX 970 back, everything works perfectly again.

I already requested a replacement from Amazon... hope its just a defective card and not a flawed design. @XFXSupport
 
Last edited:

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,027 (4.32/day)
Likes
6,191
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.5Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 18.04 (5.0-rc2 Mainline Kernel)
Benchmark Scores Benchmarks aren't everything.
#2
Report back when you get the replacement because that sounds really odd. I've had a number of graphics cards fail, but nothing has caused issues like that. What about the specs for the rest of the machine? The 580 is likely going to pull more power than a 970 so if the same issues exist with the new card, I would instantly suspect the power supply because it could cause the machine to become unstable. Also for the PCI-e power cable, they're all cables right off the PSU and no adapters, right?
 
Joined
Oct 26, 2016
Messages
436 (0.53/day)
Likes
327
Location
BGD
System Name KING-XEON
Processor E5645 (4,1Ghz) 6c/12t
Motherboard P6X58D Premium
Cooling Xigmatek LOKI SD963 double-Fan
Memory 24 gb DDR3 1333Mhz
Video Card(s) RX 480 8gb/Red-Devil/
Storage 2 ssd/Samsung 128Gb/Kingston 240Gb + HDD 500Gb
Display(s) 1x Acer 1080P Ips 2x Eizo(Triple Monitor Setup)
Case Lian Lee
Power Supply F S P Hyper S 700W
Mouse SteelSeries Kana V2
Keyboard Func FUNC-KB-460/Mechanical Keyboard
Benchmark Scores Fire Strike 11710 Score(Physics 14182),Cinebench 963
#3
Last month I ordered a brand new XFX Radeon RX 580 GTS XXX Edition 8GB (RX-580P8DFD6) from Amazon during Black Friday to replace aging GTX 970.

I've been using the card for a week and my experience with it been terrible. Unbelieve amount of issues.

* Poor rendering performance of 640x480 (BIOS, POST, DOS, Linux).
* The card is buzzing when the computer is POWERED OFF if plugged to a monitor via DP (outlet is grounded and everything is plugged to a UPS).
* Black screen on Windows' startup when using both DVI and HDMI.
* AMD WattMan cannot overclock the memory (Hynix) more than 100 MHz. MSI Afterburner works fine.
* AMD Overlay and ReLive sometimes crash games.
* PC automatically powers on after a shutdown (WTF).
* Random "CPU overclocking failed" errors at POST.
* Fans are loud and sometimes run at 100 percent during boot.
* Artifacts appear in low-perf 3D (PUBG in-game inventory screen) on stock clocks.

Today I plugged the GTX 970 back, everything works perfectly again.

I already requested a replacement from Amazon... hope its just a defective card and not a flawed design. @XFXSupport
Man...I feel for you....last week I replace my MSI GTX 970 with RX 480 Red Devil....but so far I have good&positive experience tho this card is not much faster and depend of the games sometimes could be even slower in some titles...Anyway I prefered this over the 970 as I have triple monitor setup and for me personally AMD have better settings when it comes to this(especially as my side monitors have different res then my main central monitor).....
Everything that you described point on GPU memory problem....only that I can suggest to you is to try to clean the card and change the thermal paste but if your card is new then just ask for replacment...GL
 
Joined
Oct 26, 2005
Messages
652 (0.13/day)
Likes
525
#4
Report back when you get the replacement because that sounds really odd. I've had a number of graphics cards fail, but nothing has caused issues like that. What about the specs for the rest of the machine? The 580 is likely going to pull more power than a 970 so if the same issues exist with the new card, I would instantly suspect the power supply because it could cause the machine to become unstable. Also for the PCI-e power cable, they're all cables right off the PSU and no adapters, right?
GTX 970 is highly overclocked, GPU power draw around 200w, more than RX 580.

750w PSU, no adapters, nothing is shortening. I've taken everything apart.

Perhaps a faulty VRM. Buzzing even when the PSU AC is off.
 
Joined
Mar 10, 2010
Messages
6,034 (1.86/day)
Likes
2,263
Location
Manchester uk
System Name RyzenGtEvo
Processor Amd R5 2600X@4.1
Motherboard Crosshair hero7 @bios 1201
Cooling 360EK extreme rad+ 360$EK slim all push, cpu Monoblock Gpu full cover all EK
Memory Gigabyte Aurus Rgb 16Gb in two sticks.
Video Card(s) Sapphire refference Rx vega 64 waterblockedEK
Storage Samsung Nvme Pg981 samsung 840, WD 1Tb+2Tb +3Tbgrn, 1tb seagate sshd hybrid(games)
Display(s) Samsung uea28"850R 4k freesync, LG 49" 4K 60hz ,Oculus
Case Lianli p0-11 dynamic
Audio Device(s) Xfi creative 7.1 on board ,Yamaha dts av setup, corsair void pro
Power Supply corsair 1200Hxi
Mouse Roccat Kova
Keyboard Roccat Iksu force fx
Software Win 10 Pro
Benchmark Scores 8056 vega 3dmark timespy
#5
GTX 970 is highly overclocked, GPU power draw around 200w, more than RX 580.

750w PSU, no adapters, nothing is shortening. I've taken everything apart.

Perhaps a faulty VRM. Buzzing even when the PSU AC is off.
The buzzing ,peaks my interest, i read somewhere that display port passes out power to monitors(they have to be compatible), and I also read somewhere that this can cause issues with some monitors that are not built with it in mind and hence cause issues , did you try hdmi?.
I'm not suggesting permanently but as a diagnostic step.

I have had corrupt bios screen (initially on boot with orig bios on card never touched) but it was momentarily present not while in the bios.

The cpu power issue is also indicative of some sort of power issue, and it may not be the 12v lines , if you load up the 5V or 3V on some PSUs beyond spec they can act flakey.
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,027 (4.32/day)
Likes
6,191
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.5Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 18.04 (5.0-rc2 Mainline Kernel)
Benchmark Scores Benchmarks aren't everything.
#6
Buzzing even when the PSU AC is off.
That's the weird bit because the GPU shouldn't be getting supplied any power when the machine is off. There are no standby lines that should be going there.
 
Joined
Oct 17, 2012
Messages
9,197 (4.02/day)
Likes
11,464
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MGK-1 RGB (Kaith Blue)
Software Win 10 Professional 64 bit
#8
last week I replace my MSI GTX 970 with RX 480 Red Devil.
Not much of an upgrade is it? I tested My gtx970 with a RX 580 when the 580 was fairly new, the performance difference was 10% , often less
 

Aquinus

Resident Wat-man
Joined
Jan 28, 2012
Messages
11,027 (4.32/day)
Likes
6,191
Location
Concord, NH
System Name Kratos
Processor Intel Core i7 3930k @ 4.5Ghz
Motherboard ASUS P9X79 Deluxe
Cooling Corsair H100i V2
Memory G.Skill DDR3-2133, 16gb (4x4gb) @ 9-11-10-28-108-1T 1.65v
Video Card(s) Sapphire AMD Radeon RX Vega 64
Storage 2x120Gb SATA3 SSD Raid-0, 4x1Tb RAID-5, 1x500GB, 1x512GB Samsung 960 Pro NVMe
Display(s) 1x LG 27UD69P (4k), 2x Dell S2340M (1080p)
Case Antec 1200
Audio Device(s) Onboard Realtek® ALC898 8-Channel High Definition Audio
Power Supply Seasonic 1000-watt 80 PLUS Platinum
Mouse Logitech G602
Keyboard Rosewill RK-9100
Software Ubuntu 18.04 (5.0-rc2 Mainline Kernel)
Benchmark Scores Benchmarks aren't everything.
#9
Not much of an upgrade is it? I tested My gtx970 with a RX 580 when the 580 was fairly new, the performance difference was 10% , often less
Until you need >4GB of VRAM. I would expect it to be pretty close for less than 3.5GB used.
 
Joined
Dec 25, 2012
Messages
1,083 (0.49/day)
Likes
1,602
Location
Spencerport NY
#10
Last month I ordered a brand new XFX Radeon RX 580 GTS XXX Edition 8GB (RX-580P8DFD6) from Amazon during Black Friday to replace aging GTX 970.

I've been using the card for a week and my experience with it been terrible. Unbelieve amount of issues.

* Poor rendering performance of 640x480 (BIOS, POST, DOS, Linux).
* The card is buzzing when the computer is POWERED OFF if plugged to a monitor via DP (outlet is grounded and everything is plugged to a UPS).
* Black screen on Windows' startup when using both DVI and HDMI.
* AMD WattMan cannot overclock the memory (Hynix) more than 100 MHz. MSI Afterburner works fine.
* AMD Overlay and ReLive sometimes crash games.
* PC automatically powers on after a shutdown (WTF).
* Random "CPU overclocking failed" errors at POST.
* Fans are loud and sometimes run at 100 percent during boot.
* Artifacts appear in low-perf 3D (PUBG in-game inventory screen) on stock clocks.

Today I plugged the GTX 970 back, everything works perfectly again.

I already requested a replacement from Amazon... hope its just a defective card and not a flawed design. @XFXSupport
Send the card back. I have that card and suffer none of the problems you describe. Works flawlessly.
 
Joined
Jun 3, 2018
Messages
540 (2.29/day)
Likes
176
Location
Jeddah , Saudi Arabia.
System Name POTATO
Processor Core 2 Duo E7600 @ 3.38 GHz stock voltage
Motherboard GA-945GCM-S2C
Cooling Intel stock cooler
Memory 3 GB DDR2 800 MHz @ 745 MHz
Video Card(s) Asus GTX 750 TI FML OC 2GB
Storage Western Digital 500 GB 7.2K RPM (5000AAKX) + Western Digital 200 GB 7.2K RPM (2000 JS)
Display(s) Samsung E1920
Case Unbranded , Mini tower
Audio Device(s) Creative inspire 4.1 4400
Power Supply Microdigit MD2111P , unknown wattage!(probably around 400-500W)+Buying this thing was a huge mistake
Mouse Genius NetScroll 120
Keyboard HP SK-2885
Software Windows 10 Enterprise 32 bit
#13
I already did. Amazon has a great customer service, already sent me a replacement, and willing to pay for international shipping for the defective one.
How is the new one running ?
 

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,525 (6.03/day)
Likes
8,372
Location
Houston
System Name All the cores || Bedroom Gamer
Processor 2990WX || 6700T
Motherboard Asrock X399M || MSI H170l
Cooling XSPC RayStorm Neo, MCR220-Stack+MCR220+MCR320, D5-PWM+EK X-RES 140 || Intel copper cored stocker
Memory 4x8GB G.Skill Trident Z 3200 CL16 || 2x8GB EVGA 2400
Video Card(s) (2) EVGA SC BLACK 1080Ti's || AMD Vega FE 16GB
Storage Samsung SM951 512GB, PM961 512GB, PM 951 512GB || PM951 128GB+evo 850 500GB+OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || 42" Plasma
Case Caselabs Mercury S5 || GEEEK A50
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Corsair 450w SFX
Mouse Thermaltake Theron || Steam controller
Keyboard Thermaltake Poseidon ZX || Steam controller
Software W10P
Benchmark Scores Zoom zoom mofo
#15
I have one of those and have zero of those issues. It has been in multiple rigs, with multiple powersupplies. Would be curious if it was just a bad card or some weird hardware incompatibility.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
24,416 (5.78/day)
Likes
8,062
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#17

cdawall

where the hell are my stars
Joined
Jul 23, 2006
Messages
27,525 (6.03/day)
Likes
8,372
Location
Houston
System Name All the cores || Bedroom Gamer
Processor 2990WX || 6700T
Motherboard Asrock X399M || MSI H170l
Cooling XSPC RayStorm Neo, MCR220-Stack+MCR220+MCR320, D5-PWM+EK X-RES 140 || Intel copper cored stocker
Memory 4x8GB G.Skill Trident Z 3200 CL16 || 2x8GB EVGA 2400
Video Card(s) (2) EVGA SC BLACK 1080Ti's || AMD Vega FE 16GB
Storage Samsung SM951 512GB, PM961 512GB, PM 951 512GB || PM951 128GB+evo 850 500GB+OCZ Vector 180 480GB
Display(s) Dell UP2414Q 3840X2160@60hz || 42" Plasma
Case Caselabs Mercury S5 || GEEEK A50
Audio Device(s) Fischer HA-02->Fischer FA-002W High edition/FA-003/Jubilate/FA-011 depending on my mood
Power Supply Seasonic Prime 1200w || Corsair 450w SFX
Mouse Thermaltake Theron || Steam controller
Keyboard Thermaltake Poseidon ZX || Steam controller
Software W10P
Benchmark Scores Zoom zoom mofo
#18

newtekie1

Semi-Retired Folder
Joined
Nov 22, 2005
Messages
25,800 (5.36/day)
Likes
12,177
Location
Indiana, USA
Processor Intel Core i7 8700K@4.8GHz(Quick and dirty)
Motherboard AsRock Z370 Taichi
Cooling Corsair H110i GTX w/ Noctua NF-A14 Fans
Memory 32GB Corsair DDR4-3000
Video Card(s) ASUS Strix GTX 1080Ti
Storage 500GB Crucial MX500 + 2TB Seagate Solid State Hybrid Drive with 480GB MX200 SSD Cache
Display(s) QNIX QX2710 1440p@120Hz
Case Fractal Design Define S
Audio Device(s) Onboard is good enough for me
Power Supply Corsair HX850
Software Windows 10 Pro x64
#19
Going from a GTX970 to a RX580 seems like a pretty big waste of money to me...
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
23,876 (6.36/day)
Likes
13,012
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire NITRO+ RX 590 Special Edition 8 GiB DVI + HDMI
Storage Crucial MX300 275 GB, Seagate Exos 12 TB 7200 RPM
Display(s) Samsung SyncMaster T240 24" LCD (1920x1200 HDMI) + Samsung SyncMaster 906BW 19" LCD (1440x900 DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek Onboard, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
#20
The extra memory should help a lot at least. Seeing a lot of games these days ~5 GiB on 1920x1200.
 

Ware

New Member
Joined
Oct 26, 2018
Messages
8 (0.09/day)
Likes
6
#22
I suspect it was a rigged card
I see you already returned the card, but I didn't see any mention here of the fact that these XFX RX 580 cards have switchable dual bios.
Did you confirm that you were not simply using the 'mining bios'?
 
Joined
Feb 13, 2016
Messages
296 (0.28/day)
Likes
317
Location
Buenos Aires, Argentina
System Name Monster
Processor Ryzen 5 2600X
Motherboard Asus ROG Crosshair Hero VII WiFi
Cooling Corsair H100i V1.0
Memory Corsair Vengeance 16GB (2x8GB) 2400Mhz
Video Card(s) Asus ROG Strix RX580 OC 8Gb
Storage 250Gb Samsung EVO SSD, OCZ 500Gb SSD WD M.2 500Gb, plus three spinners up to 1.5Tb
Display(s) Samsung C27F591 curved monitor 27" with FreeSync
Case Cooler Master Storm Trooper
Audio Device(s) Supreme FX on board
Power Supply Corsair RM850X full modular
Mouse AFX LMO216
Keyboard Corsair Strafe RGB Silent
Software Windows 10 x64
Benchmark Scores 3DMark 4053 (lower with freesync off)
#23
Going from a GTX970 to a RX580 seems like a pretty big waste of money to me...
I disagree.
I moved from an MSI GTX970 to an Asus RX580 and the difference was noticeable, especially in games like Forza Horizon 3 and Rise of the Tomb Raider, both of which can be very demanding on Ultra.
To be sure, the 8Gb Vram makes a big difference and I'm pretty sure it wasn't the placebo effect.
 
Joined
Oct 26, 2005
Messages
652 (0.13/day)
Likes
525
#24
I see you already returned the card, but I didn't see any mention here of the fact that these XFX RX 580 cards have switchable dual bios.
Did you confirm that you were not simply using the 'mining bios'?
The card came in 'gaming mode' by default. I moved the switch just to be sure, but with the same results.

And by the way, there is no indication on the card or manual which position is mining and which is gaming.
 

Ware

New Member
Joined
Oct 26, 2018
Messages
8 (0.09/day)
Likes
6
#25
I moved the switch just to be sure, but with the same results.
OK, good deal. I know they are supposed to ship in gaming mode, and as you said, the switch is not labelled or well documented.
I figured if it's possible the BIOS were modified, then maybe somebody had hit the switch.
Some of our cards work fine, so I hope your next one is a good one! (The timings with the Samsung VRAM look best)
 
Status
Not open for further replies.
Top