• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

The Ultimate Realtek HD Audio Driver Mod for Windows 10

ScrooW

New Member
Joined
Jan 15, 2019
Messages
20 (0.16/day)
Location
Brasil
@Dj Urko


Does this new driver contain only the soundblaster integration or is there something else? corrections, improvements, etc.
 

charincol

New Member
Joined
Mar 13, 2019
Messages
4 (0.06/day)
These will not install on my version of Windows. In fact, I can't get any newer Realtek audio drivers to install. They all cause this error.
Error.png
My version of Windows is:
Ver.png
Windows build:
Build.png

My motherboard in an Asus Prime Z390-A with S1220A CODEC.

This is a fresh install of Windows.

The problem doesn't exist with any Win 10 Redstone 5 Builds, Pro or Enterprise.

MODS: Please move if this belongs in a different thread.
 
Joined
Aug 24, 2018
Messages
339 (1.26/day)
These will not install on my version of Windows. In fact, I can't get any newer Realtek audio drivers to install. They all cause this error.
View attachment 118642
My version of Windows is:
View attachment 118643
Windows build:
View attachment 118644

My motherboard in an Asus Prime Z390-A with S1220A CODEC.

This is a fresh install of Windows.

The problem doesn't exist with any Win 10 Redstone 5 Builds, Pro or Enterprise.

MODS: Please move if this belongs in a different thread.
Are you trying modded drivers? Latest mods require a later version of Windows 10.
Stock hda drivers should most probably still be compatible.
 
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@charincol your build version is very old this drivers working only in 19h1 latest insider builds you must to update your windows
 

LJWsan

New Member
Joined
Feb 4, 2019
Messages
6 (0.06/day)
erm why when install driver always have sys exception error: rtkvhd64.sys ?
 
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@LJWsan you have laptop? in my laptop I had also this error and I dont know for what reason... but after updated windows to latest insider I have no more this problem
 

charincol

New Member
Joined
Mar 13, 2019
Messages
4 (0.06/day)
It's not just the modded drivers.

8496, from my ASUS driver disc, and 8507, from ASUS website, still give the Windows wrong version error. I gave as much info up front to reduce the question back and forth. I've already figured out there was an issue with Enterprise 2016 being "too old".
@charincol your build version is very old this drivers working only in 19h1 latest insider builds you must to update your windows
As I said, I already know there isn't an issue trying to install this MOD, or any newer Realtek drivers in Redstone 5 and later builds. I would rather use Enterprise 2016 than 2019 for as long as possible. I think it's kind of crazy to call it "very old" when there are millions, possibly hundreds of millions, of people still using Windows 7.

I'm asking here as I'm hoping I can get better help locating the latest drivers that will work for me as actual support from Realtek sucks donkey toes.

I've been able to determine that 8432 will still install on Enterprise 2016, but as I stated above, 8496, from my ASUS driver disc will not.

So, I have 2 questions:

1) Does anyone know if it's just a matter of the installer having a forced version check (which MS and Realtek can go screw themselves over), and
2) Does anyone still have the 8432 MOD drivers from DjUrko, specifically you, DjUrko?

Thanks in advance.
 
Joined
Aug 24, 2018
Messages
339 (1.26/day)
It's not just the modded drivers.

8496, from my ASUS driver disc, and 8507, from ASUS website, still give the Windows wrong version error. I gave as much info up front to reduce the question back and forth. I've already figured out there was an issue with Enterprise 2016 being "too old".

As I said, I already know there isn't an issue trying to install this MOD, or any newer Realtek drivers in Redstone 5 and later builds. I would rather use Enterprise 2016 than 2019 for as long as possible. I think it's kind of crazy to call it "very old" when there are millions, possibly hundreds of millions, of people still using Windows 7.

I'm asking here as I'm hoping I can get better help locating the latest drivers that will work for me as actual support from Realtek sucks donkey toes.

I've been able to determine that 8432 will still install on Enterprise 2016, but as I stated above, 8496, from my ASUS driver disc will not.

So, I have 2 questions:

1) Does anyone know if it's just a matter of the installer having a forced version check (which MS and Realtek can go screw themselves over), and
2) Does anyone still have the 8432 MOD drivers from DjUrko, specifically you, DjUrko?

Thanks in advance.
Your issue is independent of modded drivers and thus needs to be in a separate thread.
1. You can try to install the driver manually via device manager. Use stock drivers.
 
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@charincol Really I dont know for what reason you dont want to update your Windows to latest insider build. You must to know that windows build 14393 has more bugs than 15063 and 15063 has more bugs than build 17063. Windows 7 is obsolete. I thing that it has insider builds for enterprise editions just thing about that and those who garde windows 7 is some special offices, enterprises and banks because they are not sure if their data will be safe after updating. I thing that you dont use special data like that so go to insider builds if its possible for your pc because if Microsoft stopping support for your build you will lose your windows license if its activated already. I will look for older versions of my driver mod to upload but I thing that is for build 15063 not 14393 just because Microsoft are doing some changes in Realtek drivers. So thing about what I tell you and 19h1 final release will coming soon you can stay with this build until the next final release 20h1.
 

charincol

New Member
Joined
Mar 13, 2019
Messages
4 (0.06/day)
Your issue is independent of modded drivers and thus needs to be in a separate thread.
1. You can try to install the driver manually via device manager. Use stock drivers.
You've completely missed what I want. I've been installing drivers via Device Manager since Win95. Furthermore, I already tried that. The same drivers that give the Windows wrong version installer message, are determined to be inferior to the default MS HD Audio Drivers when installed thru Device Manager.

As I've stated above, and I'll reiterate here, I have no problem installing ANY driver, stock or MODDED, higher than, and including version 8496 on Win 10 Redstone 5 (Ver 1807). Since you assume I'm a newb at things PC related due to my post count, here's a screenshot of DjUrko's latest drivers installed on the highest current revision of Redstone 5 (non-insider's edition).
Combined.png

Notice the date installed, 03/10/2019, 2-3 days before I posted here.

If I was a programmer, I'd answer my question 1 myself.

I already said it was a possibility my post might be in the wrong thread, but I was hoping DjUrko might be able to shed some light on whether the inability to install was an issue with the Realtek installer, or Windows since it appears he's decompiled/recompiled the installer. I could be wrong.

It would still be really great if my question 2 could be answered.
 
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@charincol this is not my driver mod that you are installed is Alan F. mod driver so what is your windows build finally? 17763 or 14393?
 

charincol

New Member
Joined
Mar 13, 2019
Messages
4 (0.06/day)
@charincol this is not my driver mod that you are installed is Alan F. mod driver so what is your windows build finally? 17763 or 14393?
Gosh, just checked audio version numbers and you're right. My mistake. I thought I downloaded that from here. I've been going to so many websites in the last few days trying to figure this out that I must have mixed it up. Duh me. However, you're reply above is very helpful.

I can actually run both on the same PC, from the same partition, due to my software InstantRecovery. It's completely legal and follows MS's licensing terms as only one install can run at a time, but I can switch back and forth, and revert back to before I installed any audio drivers very quickly. If you have the MOD for 14393, that would be great. If not, that's OK too.

To answer your question about not wanting to use the "latest and greatest" OS revision from Microsoft - that's an answer that's too long for this thread. However, there are other factors with my PC not related to audio that may force me to ultimately use build 17763.
 

ScrooW

New Member
Joined
Jan 15, 2019
Messages
20 (0.16/day)
Location
Brasil
@Dj Urko

Regarding your new driver, does it only work (DTS) with test mode enabled?

If I disable test mode and restart it says it did not find compatible hardware.

----
EDIT:

I saw now why DTS does not detect the hardware, everything related to Realtek has dropped hahaha, loudspeakers / headphones and even the microphone is as if the driver had been removed I was normally testing there when I resolve to exit the windows test mode and reboot...
 
Last edited:
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@ScrooW normally its working I had no problem. I have disabled test mode bud the integrity checks stays always disabled
 
Joined
Aug 24, 2018
Messages
339 (1.26/day)
Gosh, just checked audio version numbers and you're right. My mistake. I thought I downloaded that from here. I've been going to so many websites in the last few days trying to figure this out that I must have mixed it up. Duh me. However, you're reply above is very helpful.

I can actually run both on the same PC, from the same partition, due to my software InstantRecovery. It's completely legal and follows MS's licensing terms as only one install can run at a time, but I can switch back and forth, and revert back to before I installed any audio drivers very quickly. If you have the MOD for 14393, that would be great. If not, that's OK too.

To answer your question about not wanting to use the "latest and greatest" OS revision from Microsoft - that's an answer that's too long for this thread. However, there are other factors with my PC not related to audio that may force me to ultimately use build 17763.
To be clear, you have downloaded a copy of the latest stock driver (from a source such as tenforums) and tried to install?
If it does not install, try opening ini files of the driver with notepad. You might see any possible driver blocks as these are usually placed in the ini files.
P.s. Create a separate thread for your problem.
 

ScrooW

New Member
Joined
Jan 15, 2019
Messages
20 (0.16/day)
Location
Brasil
@Dj Urko

I understood, unfortunately before seeing your answer already installed the previous version.

In your opinion it is worth installing this new version based on quality because the only APO's that use are the Dolby Atmos/DDP/DTS.
 

Mason76

New Member
Joined
Jan 19, 2019
Messages
15 (0.12/day)
@charincol this is not my driver mod that you are installed is Alan F. mod driver so what is your windows build finally? 17763 or 14393?
hi!my windows ltsc in no microsoft store/
i dont make ininstall appx,how i want ininstall you mod\can you build exe mod driver including all sound mod&
 

ScrooW

New Member
Joined
Jan 15, 2019
Messages
20 (0.16/day)
Location
Brasil
hi!my windows ltsc in no microsoft store/
i dont make ininstall appx,how i want ininstall you mod\can you build exe mod driver including all sound mod&
There is how to install the store and consequently install apps out of it, just search on Google: "store Windows 10 ltsc or LTSB"
 
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@Mason76 Sorry its no possible to make exe in the moment so you must learn how to install it in Test mode, it is not so much difficult also it has a Guide to install. its just take a little bit more time to install the plugins one by one if you have it already installed and dont flood the same thing much times...
 

KirinCorleone

New Member
Joined
Mar 14, 2019
Messages
5 (0.07/day)
Hey @Dj Urko Great Mod! Everything went smooth. Except that my Sound Blaster Connect 2 still gives me the "Your Audio Device cannot be Detected. Please check your connection" error. Rest everything works. And I only want the Sound Blaster Connect to work, lol. :D

Help?
 
Joined
Apr 20, 2017
Messages
295 (0.39/day)
@KirinCorleone I know how to fix this i will upload two packages one with sound blaster 720 and one with sound blaster Cinema 5
 
Last edited:
Top