• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

ThinkStation S30 Power Connection

Joined
Sep 28, 2005
Messages
2,304 (0.39/day)
Location
Calgary Alberta, Canada
System Name PCGR
Processor Intel 10500 ES
Motherboard MSI Z490 Gaming Plus
Cooling Snowman MT4 Dual Fan
Memory 2x8GB DDR4 3600 Corsair Vengeance
Video Card(s) Gigabyte RX 6800XT Gaming OC
Storage 1x 1tb ADATA XPG 8200 Pro NVME | 1x 1TB WD Blue HDD
Display(s) BenQ 24" 1080P
Case MSI MPG 110M
Audio Device(s) Onboard
Power Supply Cooler Master 550W MWE 80+ Gold
Software Windows 10 64bit Pro
Hello again brothers and sisters of TPU.

So I am doing a case swap of the ThinkStation S30. For the most part everything looks good. Issue is, the powersupply it comes with, while great, the cables are short. So I have to use another Powersupply.

The issue is the motherboard has a 4pin connection neart he PCIE slot. Is it really necessary? I heard some say it isn't needed but others saying it will be needed for a better GPU (I will be placing a GTX 970 4GB in it).

Would I need it?
 
Joined
Sep 28, 2005
Messages
2,304 (0.39/day)
Location
Calgary Alberta, Canada
System Name PCGR
Processor Intel 10500 ES
Motherboard MSI Z490 Gaming Plus
Cooling Snowman MT4 Dual Fan
Memory 2x8GB DDR4 3600 Corsair Vengeance
Video Card(s) Gigabyte RX 6800XT Gaming OC
Storage 1x 1tb ADATA XPG 8200 Pro NVME | 1x 1TB WD Blue HDD
Display(s) BenQ 24" 1080P
Case MSI MPG 110M
Audio Device(s) Onboard
Power Supply Cooler Master 550W MWE 80+ Gold
Software Windows 10 64bit Pro
im having too many issues with this damn setup.

I moved everything over to a new case. And now when trying to load Windows installation from the USB, it just doesn't work. After the bios does its thing and goes to boot sequence, it either goes to black screen or a cursor top left corner and just stays that way. Doesn't progress.

At whits end here with this S30 system. Any ideas?
 
Top