• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Throttlestop Tweaks for Low Latency?

SUPER!

New Member
Joined
Nov 30, 2020
Messages
4 (0.08/day)
Like the title says above, are there further tweaks I can do with Throttlestop that can further improve the performance of my CPU? I am specifically aiming the achieve the lower possible latency I can on the CPU and I've already tweaked some settings accordingly. I am using a version of the Bitsum High Performance power plan that disables core parking as well. Temperature and power draw are not an issue to me and I've also attached my current settings down below. I don't any experience any kind of throttling when doing any sort of demanding task. Thanks for the help!
 

Attachments

  • tstopFIVR2.png
    tstopFIVR2.png
    63.6 KB · Views: 31
  • tstopcstates.png
    tstopcstates.png
    19.5 KB · Views: 36
  • tstopTPL.png
    tstopTPL.png
    20.3 KB · Views: 30
  • tstopFIVR.png
    tstopFIVR.png
    63.4 KB · Views: 34
  • tstop.png
    tstop.png
    45.3 KB · Views: 32
  • tstopoptions.png
    tstopoptions.png
    42.1 KB · Views: 32
Last edited:
Joined
Nov 11, 2016
Messages
973 (0.64/day)
System Name The de-ploughminator
Processor I7 9900K @ 5.0Ghz
Motherboard Gigabyte Z370 Gaming 5
Cooling Custom Watercooling
Memory 4x8GB G.Skill Trident Neo 3600mhz 15-15-15-30
Video Card(s) RTX 3090 + Bitspower WB
Storage Plextor 512GB nvme SSD
Display(s) LG 34GN850-B
Case Lian Li 011D Dynamic
Audio Device(s) Creative AE-5
Power Supply Corsair RM1000
Try increasing the Core offset without touching the Cache, verify with Cinebench R20 score for each additional voltage offset.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,714 (0.59/day)
If your computer does not have a proven clock modulation throttling problem, there is no reason to check the Clock Mod box. If you run a log file and the Mod column always shows 100.0, there is no reason to have ThrottleStop constantly checking and setting this.

The Set Multiplier value is not used when Speed Shift Technology is being used. If you see SST in green, do not check Set Multiplier. It will not do anything.

There is no need to set the Turbo Time Limits to the maximum value. The default 28 second value is OK.

Disabling the C states causes more heat and blocks the higher multipliers. Doing this does give you a very steady 34.00 multiplier which is exactly what you are looking for. As long as your laptop does not overheat and thermal throttle, everything is good. If you want, you can change the PROCHOT Offset value in the Options window from 5 to 0. This will raise the thermal throttling temperature to the Intel default value which is 100°C. That will give you a little more headroom before thermal throttling begins if things get warm.

When idle, your average C0% on the main screen should be under 0.5%. Concentrate on this to make sure there are no background processes interfering with your CPU. Too much background activity can cause latency. The CPU will be busy processing some background crap when it could be working on the task that is important to you. Here is what the holy grail looks like.


No one understands how efficient Windows 10 is when setup properly. Try using O&O Shutup10 to take care of bad stuff like Windows 10 telemetry.
 
Last edited:

SUPER!

New Member
Joined
Nov 30, 2020
Messages
4 (0.08/day)
Try increasing the Core offset without touching the Cache, verify with Cinebench R20 score for each additional voltage offset.
From my previous testing I've found that setting this to anything lower usually leads to my system completely freezing under load. I think I've managed to set the voltage offset to a value that is just a little lower than the maximum.

If your computer does not have a proven clock modulation throttling problem, there is no reason to check the Clock Mod box. If you run a log file and the Mod column always shows 100.0, there is no reason to have ThrottleStop constantly checking and setting this.

The Set Multiplier value is not used when Speed Shift Technology is being used. If you see SST in green, do not check Set Multiplier. It will not do anything.

There is no need to set the Turbo Time Limits to the maximum value. The default 28 second value is OK.

Disabling the C states causes more heat and blocks the higher multipliers. Doing this does give you a very steady 34.00 multiplier which is exactly what you are looking for. As long as your laptop does not overheat and thermal throttle, everything is good. If you want, you can change the PROCHOT Offset value in the Options window from 5 to 0. This will raise the thermal throttling temperature to the Intel default value which is 100°C. That will give you a little more headroom before thermal throttling begins if things get warm.

When idle, your average C0% on the main screen should be under 0.5%. Concentrate on this to make sure there are no background processes interfering with your CPU. Too much background activity can cause latency. The CPU will be busy processing some background crap when it could be working on the task that is important to you. Here is what the holy grail looks like.


No one understands how efficient Windows 10 is when setup properly. Try using O&O Shutup10 to take care of bad stuff like Windows 10 telemetry.
Thanks for your response, I've set everything to the values that you've said since most of those options are unnecessary. I did not know I could change the PROCHOT Offset value, its definitely a very useful tweak! Also a quick question, setting the timer resolution to "0" in Throttlestop will provide me the lowest value possible if I am correct? I have found that setting it to a low value with HPET turned off in Windows but on in BIOS helps with the overall snappiness of the system.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,714 (0.59/day)
timer resolution
Using ThrottleStop to set the AC Timer Res Request value to 0 results in a timer resolution of 0.5 ms. That is as good as it gets.

With the 8th and 9th Gen CPUs, some users get better overall results by lowering the cache undervolt. This allows them to increase the CPU core undervolt significantly. They end up with better temps or better performance. Try setting the cache to -125 mV and then try increasing only the core in steps of -25 mV. Run Cinebench each time and see how it goes.

Setting the cache to -140 mV is likely on the razor edge of stability. Try running some light load 1 and 2 Thread TS Bench tests. With C states disabled, you might not have stability issues with setting the cache too low like many users experience.

Edit - You can increase the cache ratio Min value. This might cause too much heat though. In the FIVR window I like to run the cache min and max at the same value.
 

SUPER!

New Member
Joined
Nov 30, 2020
Messages
4 (0.08/day)
Using ThrottleStop to set the AC Timer Res Request value to 0 results in a timer resolution of 0.5 ms. That is as good as it gets.

With the 8th and 9th Gen CPUs, some users get better overall results by lowering the cache undervolt. This allows them to increase the CPU core undervolt significantly. They end up with better temps or better performance. Try setting the cache to -125 mV and then try increasing only the core in steps of -25 mV. Run Cinebench each time and see how it goes.

Setting the cache to -140 mV is likely on the razor edge of stability. Try running some light load 1 and 2 Thread TS Bench tests. With C states disabled, you might not have stability issues with setting the cache too low like many users experience.

Edit - You can increase the cache ratio Min value. This might cause too much heat though. In the FIVR window I like to run the cache min and max at the same value.
I set my cache to -125mV and was able to bring my core down to -175.8mV. It seems to be stable so far from the testing I've done with OCCT, TS Bench, and Cinebench. I also raised my cache ratio to 33 (the screenshot is old) thanks to the PROCHOT offset while keeping my PC consistently under 100 C in real world loads. Would you know of anything else I can do or change? Overall I am seeing some pretty good results and I'm definitely closer to squeezing every last bit of power from this CPU I can without overclocking.
 

Attachments

  • tsfivrnew.png
    tsfivrnew.png
    62.6 KB · Views: 19
Last edited:

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,714 (0.59/day)
It seems to be stable
It is usually too much cache undervolt that causes instability. A little less cache undervolt and some more core undervolt seems to work well for many users.

I think you are getting the most out of your CPU. All your tricks have it running exactly as you want it to run. Make sure there are not too many useless background tasks running and your computer should be good for music production or whatever else you are up to.
 

SUPER!

New Member
Joined
Nov 30, 2020
Messages
4 (0.08/day)
It is usually too much cache undervolt that causes instability. A little less cache undervolt and some more core undervolt seems to work well for many users.

I think you are getting the most out of your CPU. All your tricks have it running exactly as you want it to run. Make sure there are not too many useless background tasks running and your computer should be good for music production or whatever else you are up to.
Thanks again for your help! I've been using Throttlestop for 3-4 years now and still learned a few things today. As for the background programs, I had a few tabs and foreground apps open when taking the screenshot. With everything closed I get the 0.0% C0 values. I have definitely noticed a change in programs in FL Studio, etc. No clicks or pops whatsoever. Take care and thanks again for your work on this amazing program!
 
Top