• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Trying to salvage a 6950

Joined
Aug 22, 2018
Messages
11 (0.38/day)
Likes
9
#1
Received in 2011 but never worked or RMA'ed due to really bad luck. It gives an red VGA LED on the Asus Sabertooth P67, in both slots

I've tried
- pulling and restoring the original BIOS, flashing it from a different source to ensure no BIOS Corruption
- flashing different 6950 but compatible 6950 BIOSes
- booting it as a 2nd card, windows automatically installed it + catalyst
- checking its GPU-Z output, a bit jumbled but it refuses to run on anything besides PCI-E 1.1
- cleaning the PCI-E Slot after examining it
- cleaning the PCI-E risers lightly with an eraser
- HDMI, DVI, VGA via converters to no luck, and different cables
- without nvidia drivers, or AMD drivers

Haven't tried
- flashing a different BIOS for the mobo, there was a ban on flashed cards and that might be the issue
- adjusting the PCI-Express in the BIOS (option isn't available), found threads where it worked

Please help. Its non-ref like in the image below
 

Attachments

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,828 (5.57/day)
Likes
7,107
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,828 (5.57/day)
Likes
7,107
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#4
Yeah, 2 different machines but clinging on to hope it might be their nvidia drivers/originally corrupt BIOS
Drivers do not interfere with post of a gpu.

Give us white stickers on back of card please, all of them.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,828 (5.57/day)
Likes
7,107
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#6
Camera Quality is horrendous so I'll back it up with text, I apologize for the delay
P/N: 288-4E186-000SA SKU: 11188-00
Unfortunately you need to contact sapphire for the correct bios, our database does not have that card.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
22,828 (5.57/day)
Likes
7,107
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
#8
Thank you for all the help. I'll contact them, fingers crossed.
Yeah i went through official and unverified bios files that had 800/1250 and no card matched up.
 
Joined
Oct 17, 2012
Messages
8,665 (4.00/day)
Likes
10,952
Location
Massachusetts
System Name Americas cure is the death of Social Justice & Political Correctness
Processor i5 8600k
Motherboard Asrock Z370 Extreme 4
Cooling Corsair H-110i GTX
Memory 2x 4Gb Crucial Sport LT
Video Card(s) MSI GTX 980 Gaming
Storage Samsung 850 evo 250Gb
Display(s) Dell Ultra Sharp Widescreen 24" 1200P
Case Fractal Design Meshify-C
Power Supply Seasonic Focus+ 750 Gold
Mouse Logitech G502 spectrum
Keyboard AZIO MRGB Kaith Blue
Software Win 10 Professional 64 bit
Benchmark Scores Congrats USA!! on the Travel Ban.....
Joined
Oct 22, 2014
Messages
6,420 (4.49/day)
Likes
3,820
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E5-2680 10c/20t 2.8GHz @ 3.0GHz
Motherboard Asrock X79 Extreme 11
Cooling Coolermaster 240 RGB A.I.O.
Memory G. Skill 16Gb (4x4Gb) 2133Mhz
Video Card(s) Nvidia GTX 710
Storage Sandisk X 400 256Gb
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Software W10 Home Premium 64 bit
#11
Post GPU-z screenshot, that may help here.
 
Joined
Oct 22, 2014
Messages
6,420 (4.49/day)
Likes
3,820
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E5-2680 10c/20t 2.8GHz @ 3.0GHz
Motherboard Asrock X79 Extreme 11
Cooling Coolermaster 240 RGB A.I.O.
Memory G. Skill 16Gb (4x4Gb) 2133Mhz
Video Card(s) Nvidia GTX 710
Storage Sandisk X 400 256Gb
Display(s) AOC 22" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Software W10 Home Premium 64 bit
#13
Joined
Aug 22, 2018
Messages
11 (0.38/day)
Likes
9
#14
Unfortunately no dice. I even unlocked it unnecessarily and got 'ROM Unlocked'. Flashed the BIOS above and still red VGA LED. A mysterious side-effect though is that the computer initially fails the memory boot and then succeeds in the immediate second one. I've always suspected that the motherboard had issues with (the) non-QVL memory.

I am going to wait for Sapphire tech/subsidiary to send the SKU-specific ROM and fingers crossed.
 
Top