• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Undervolting i7 9750H

tojemojeime24

New Member
Joined
Aug 26, 2020
Messages
6 (0.01/day)
so i have a problem with using throttlestop(my cpu is i7 9750h, it is such a good thing to use but in my case, fps goes down from 400 to 200(sometimes to 100) and it becomes unplayable... what can i do to get my temps down and fps up, temps went from 90 to 75 and i like it but fps...
1598452388042.png
1598452429429.png
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
The 9750H is a 45W processor that can easily run at 60W or more. You have set both of your turbo power limits to 32W. That will reduce maximum performance. Set your power limits back to their default values, at least 45W for the long turbo power limit and 60W for the short turbo power limit.

Set the core and cache offset voltages both to -100 mV. If you only set the core offset voltage, and leave the cache at +0.0000, your undervolt will not work.

Set Speed Shift Max back to 45. If your laptop runs too hot, create a ThrottleStop profile with reduced turbo ratio limits instead.

Check the FIVR - Disable and Lock Turbo Power Limits option.

Laptops with the 9750H run extremely hot. That is normal. Some people disassemble their laptops so they can replace the thermal paste. When this procedure is done on an assembly line, it is not always done right.

Check the Nvidia GPU box in the Options window if you have an Nvidia GPU. This is useful information when trying to determine why your computer is throttling. You need to see whether the problem is the CPU or the GPU that is throttling.

Turn on the ThrottleStop Log File option and go play a game for at least 15 minutes. When finished, exit your game and then exit ThrottleStop. Open up your ThrottleStop / Logs folder. Attach your log file to your next post so I can see how your laptop is performing.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
CPU and GPU performance looks fairly consistent while you are playing. Were your FPS consistent during that log file? The CPU is mostly running at 4000 MHz and the GPU at about 1860 MHz. There is some PL2 power limit throttling showing up in the log file. Did you adjust your power limits higher yet? CPU and GPU temps are OK so you can go higher.

Did you set the core and cache voltage offsets?
 

tojemojeime24

New Member
Joined
Aug 26, 2020
Messages
6 (0.01/day)
Did you set the core and cache voltage offsets? I have set them to -99.6, thats fine right? FPS was pretty good during this session but i know it can go so much higher...I did everything u said, were can i adjust power limits , what is pl2..? btw ty so much for this help... :love:
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
PL2 is the short term turbo power limit. The throttling caused by this during your log file was very slight. The long and short turbo power limits are adjusted near the top of the TPL window. Your original screenshot shows these both at 32. Did you adjust these? They can go higher for more performance but that also creates more heat. You get to decide how you want your laptop to run.
 

tojemojeime24

New Member
Joined
Aug 26, 2020
Messages
6 (0.01/day)
I have put it to 45, I found it ok

should i change these cores active thing and do you maybe know how can i put throttlestop to start every time i turnn on pc
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
Use the Task Scheduler to start ThrottleStop when Windows starts.


I found it ok
If your laptop is running OK, no need to change anything.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
If you follow the guide exactly, it works.

Delete the task you created and follow each step in the guide.
 

tojemojeime24

New Member
Joined
Aug 26, 2020
Messages
6 (0.01/day)
my problem is back, again very laggy during gaming(drops from 300 to 100 fps in a second) could you give me the TPL tab settings
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
I do not own a 9750H. I have no magic settings. Run another log file. If your FPS is dropping that much, the log file should show something. Your CPU might be too hot and thermal tbrottling or the voltage regulators might be too hot.
 

Netherscourge

New Member
Joined
Aug 13, 2020
Messages
11 (0.02/day)
Try this:

In FIVR:

1. Set your IccMax slider for both Core and Cache to 250.00.
2. Set your Power Plane PPO Current limit to 140.
3. Lower your voltage offset on both the CPU and Cache to -125

In TPL:
1. Change your TPL Boosts to 70 Long and 90 Short and uncheck the clamp.
2. Change your Speed shift to Min 1 and Max 45.
3. Change your Intel CPU power balance to 16 and your Intel GPU power balance to 16. Leave the TDP balance at 0.

TS Main Screen - the only three things that should be checked are SpeedShift, Speed Step and C1E.

Clear all your Limit alerts, clear your Max Temps and uncheck ProChot if it has a check in it - now rerun your benchmarks.

Your goal is No Errors during the TS Bench, no PL or EDP throttling and AVERAGE temps under 90. (You might hit 90 briefly, which is fine. As long as your running steady under 90, you're good to go).

NOTE - when you first boot up your laptop, you will almost always trigger power alerts because Throttlestop doesn't start undervolting until AFTER you log into your laptop or PC. That's normal. You want to clear your PL limit alerts before any testing, so as not to be confused.

If that works and all you get is thermal throttling, try dropping your CPU freqs - running 12 cores at 4.0ghz will get hot. Maybe drop the Freq range to 40, 39, 38, 37, 36, 35. People hate dropping CPU speed, but consider your rated CPU base freq is actually 2.6GHz, not 4.5GHz.

Hope this helps! This is what my CPU is set at.
 
Joined
May 7, 2020
Messages
235 (0.40/day)
As above, but use Core:Cache ratio of 2:1. Increase Core offset to -200mV.
 

PPDeluXe

New Member
Joined
Aug 31, 2020
Messages
3 (0.01/day)
I had tried to undervolt myself, and thought I was doing okay. I got a CINEBENCH score of 2806 but was receiving thermal errors throughout.

Try this:

In FIVR:

1. Set your IccMax slider for both Core and Cache to 250.00.
2. Set your Power Plane PPO Current limit to 140.
3. Lower your voltage offset on both the CPU and Cache to -125

In TPL:
1. Change your TPL Boosts to 70 Long and 90 Short and uncheck the clamp.
2. Change your Speed shift to Min 1 and Max 45.
3. Change your Intel CPU power balance to 16 and your Intel GPU power balance to 16. Leave the TDP balance at 0.

TS Main Screen - the only three things that should be checked are SpeedShift, Speed Step and C1E.
As above, but use Core:Cache ratio of 2:1. Increase Core offset to -200mV.

After using the above tips from Netherscourge and AOne I received no errors and an average CINEBENCH score of around 2950.

I am super happy with these results, so thank you very much.

I am just wonder, is there be a certain Speed Shift - EPP range that I can play around with to see different results? It's currently set at 128.

Also, I still reached temps up to 98 degrees during the cinebench, but no warning, is that safe? Have the above settings somehow change the tolerance of that warning, because I used to receive warnings at those temps?
 

Attachments

  • tottlestopCineBenchLog.txt
    14.6 KB · Views: 159
Joined
May 7, 2020
Messages
235 (0.40/day)
If you have no warning, all should be OK. The temps are high, but it depends on your room temperature. If it's above 30 C, it's probably normal. Check the differences between CPU temp cores. If they're above 12-15 degrees Celsius, maybe you should consider changing the thermal paste (the factory applied usually sucks).
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
@PPDeluXe - The Intel default thermal throttling temperature is 100°C. You should not see any throttling or any warnings before your CPU reaches this temperature. Some laptop models lower this a few degrees. Post a screenshot of ThrottleStop. It will show on the main screen what your laptop is set to. Your log file shows just a tiny hint of throttling so I am going to guess that your laptop has set the PROCHOT temperature to 98°C.

Post a screenshot of the Options window too. The PROCHOT Offset value in the Options window can be used to control the maximum temperature as long as it is not locked. This is probably set to 2. (100°C - 2 = 98°C)

but no warning
I am pretty sure that towards the end of your Cinebench run when the multiplier starts to drop below 40.00, you should see the word PROCHOT on the main screen turn red. This shows that thermal throttling has occurred. When done testing, if this is red, you can click on it and it will reset this information within the CPU. Your CPU is well protected regardless of your ThrottleStop settings so no worries.

If you use the Task Manager and increase the Windows priority of Cinebench, you might be able to reach the 3000 point level. Also minimize the background tasks. Get the C0% under 0.5% before you run Cinebench.

An EPP setting of 0 is for maximum CPU speed. A setting of 80 is a good compromise. I prefer 80 to 128. You might not need to set this in ThrottleStop. Windows 10 can control EPP. Clear the Speed Shift EPP box in ThrottleStop and switch Windows power profiles. Watch in the FIVR monitoring table to see what EPP value the CPU is using. Some laptops set this automatically to an appropriate value.
 
Last edited:

PPDeluXe

New Member
Joined
Aug 31, 2020
Messages
3 (0.01/day)
Check the differences between CPU temp cores. If they're above 12-15 degrees Celsius, maybe you should consider changing the thermal paste (the factory applied usually sucks).
This is something I should definitely consider in the future, thank you.

Your log file shows just a tiny hint of throttling so I am going to guess that your laptop has set the PROCHOT temperature to 98°C.
PROCHOT 97°C, amazing guess :) You people always impress with your knowledge and analytical skills.

For reference to the below, I have an HP Omen 15" laptop i7-9750, GTX 1660 Ti
@unclewebb This morning I noticed that after all the startup had completed, I'm idling at 4000MHZ+ which seems to me like the turbo is constantly enabled. Disabling the turbo in TS works, but it shouldn't even be turbo'ing and wasn't behaving like this before yesterday's tests.
I tried removing the undervolt by deleting the .ini file and shutting down the computer, but this didn't work.

Out of further curiosity to see if I could get back to normal, I restored the BIOS back to default. This too did not work.

My GPU is idling between 300-360MHz but I'm not sure if this is normal or not because I never bothered to look before.

Is there any way to truly get my settings back to default? I really want to undervolt but I also want to be able to revert.

Thanks for your help
 

Attachments

  • Specs.png
    Specs.png
    33.4 KB · Views: 332
  • biosinfo.png
    biosinfo.png
    37.3 KB · Views: 296
  • Idle.png
    Idle.png
    539.7 KB · Views: 313

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
which seems to me like the turbo is constantly enabled.
Intel CPUs are designed to use full turbo boost whenever they have something to do. This is normal. It is never a good idea to hold an Intel CPU to 800 MHz if it has a task that it needs to complete. The quicker it gets background tasks processed, the larger percentage of time the cores can spend in the low power C7 state. A core in C7 is disconnected from the internal clock and it is disconnected from the voltage rail so it is sitting idle at 0 MHz and 0 volts. This is how modern CPUs save power.

Your idle screenshot shows that your computer is nowhere near idle.

1598974185566.png


Big difference.

The Windows power plan controls your CPU speed. Open the Windows Power Options and set the Power Plan to Balanced. Windows 10 has a slider in the notification area that you can adjust to fine tune the power plan.

Your CPU speed is not the problem. Applications have been added to your computer that are loading the CPU when they should not be. They do not go idle so your CPU is not idle. How much time does your idle CPU spend in the C0 state processing background tasks? When properly setup, Windows 10 and ThrottleStop are extremely efficient. Many other apps are not.


Here is an interesting paper by some smart guys at Berkeley. They found that slowing a CPU down was not the answer.
 

PPDeluXe

New Member
Joined
Aug 31, 2020
Messages
3 (0.01/day)
Thanks so much for your informative reply, @unclewebb

I guess the best thing for me to do is start from a clean windows install, then work from there :)
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
4,173 (0.84/day)
a clean windows install
I use this method.

I use O&O Shutup10 to disable some of the more offensive bits and pieces of Windows 10.

Use the ThrottleStop C0% data to keep a close eye on what your computer is up to. Anytime you install something new, check to see if the idle C0% has changed. Some software is so poorly written that it is like dragging a boat anchor behind your car.
 

Netherscourge

New Member
Joined
Aug 13, 2020
Messages
11 (0.02/day)
I had tried to undervolt myself, and thought I was doing okay. I got a CINEBENCH score of 2806 but was receiving thermal errors throughout.




After using the above tips from Netherscourge and AOne I received no errors and an average CINEBENCH score of around 2950.

I am super happy with these results, so thank you very much.

I am just wonder, is there be a certain Speed Shift - EPP range that I can play around with to see different results? It's currently set at 128.

Also, I still reached temps up to 98 degrees during the cinebench, but no warning, is that safe? Have the above settings somehow change the tolerance of that warning, because I used to receive warnings at those temps?

Glad it helped! I actually kept going and was to juggle the offsets a bit more. I lowered my CPU Core offset to -250.00 and bumped my CPU Cache Offset to -115.2. That's the absolute lowest I can go on both before I get errors. It's different for every CPU though - they are not all created equal. -125/-125 is a solid baseline though. Some people suggest a 2:1 ratio, which is pretty close to mine. Mine wound up being 2.17 : 1

My Cinebench score is 2507, but I have a 1650, not a 1660ti.

My Max GPU temp was 60C and max CPU temp was 87 just now during the test. No throttling.

***One interesting thing I have noticed - if I keep Throttlestop minimized in the systray during Cinebench, I stay under 90C. If I have the TS window open with the Limit window, during Cinebench to monitor the temps and limit in real time, I can get up to 92C.

***Another interesting thing - if I do the "Boralus Test" in World of Warcraft with TS minimized in the systray, I hit 60FPS with no throttling whatsoever and temps stay in the low 80Cs. If I do it with with the TS window open in front of the WoW game window, I get Power Throttling and an occasional game crash to desktop.

- Not sure what's up with that? I've repeated this multiple times with the similar results - leaving TS open in front of whatever app or game I'm running causes performance issues. But if I keep it in the systray, there's no performance hit at all and everything works great.

^EDIT - never mind. The issue seems to be gone. Just installed two HP software component updates this morning. Wondering if that fixed it? /shrug
 
Last edited:

madseason

New Member
Joined
Jan 6, 2021
Messages
1 (0.00/day)
Hi,
I went through this topic, tried different settings, but it did not go so well.
I have a dell xps 15 with this CPU. Did the thermal paste change, some thermal pads - temps are under control, under load in Cinebench r23 it mostly stays under 95, with peaks to 100.
Difference between undervoling and not is only 100 points. Am I doing something wrong? Is this sore even good or bad?

Under FIVR Core and Cache are booth set to -99.6 and IccMax to 255.75

I use it most of time with as workstation with my EGPU - 3060Ti and external monitor. So iGPU and dGPU are disabled, as there are some issues with it while gaming with eGPU.
And it has been tested while "docked" with eGPU.

This shows that this CPU gets to 45th percentile.

 

Attachments

  • 2021_01_06_16_25_32_Turbo_FIVR_Control.png
    2021_01_06_16_25_32_Turbo_FIVR_Control.png
    179.5 KB · Views: 133
Last edited:
Joined
May 24, 2020
Messages
41 (0.07/day)
Your goal is No Errors during the TS Bench, no PL or EDP throttling
hey man. i know im kind of digging in the forums here but i found your guide and really wanted to give it a try since i got the same CPU, but whatever i do i really cant seem to NOT get the EDP or PL warnings. And after following the guide, it sadly ended in no success. what could be done from here? i've already repasted, which seems to be working atleast a bit.
 

Attachments

  • 1.6.21 replying to thread.PNG
    1.6.21 replying to thread.PNG
    108 KB · Views: 139

Faide

New Member
Joined
Nov 17, 2020
Messages
27 (0.07/day)
Hi,
I went through this topic, tried different settings, but it did not go so well.
I have a dell xps 15 with this CPU. Did the thermal paste change, some thermal pads - temps are under control, under load in Cinebench r23 it mostly stays under 95, with peaks to 100.
Difference between undervoling and not is only 100 points. Am I doing something wrong? Is this sore even good or bad?

Under FIVR Core and Cache are booth set to -99.6 and IccMax to 255.75

I use it most of time with as workstation with my EGPU - 3060Ti and external monitor. So iGPU and dGPU are disabled, as there are some issues with it while gaming with eGPU.
And it has been tested while "docked" with eGPU.

This shows that this CPU gets to 45th percentile.

Your FIVR panel is showing that its locked and the top right table is showing no offset on core and cache which i believe means your bios is not letting you undervolt the CPU.
 
Top