• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Unlocked ACER nitro 5 and i7-9750h

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
@theoverpowered - You can increase the Package TDP Limit from 45.0 to 55.0 in the BIOS but this might not make any difference. Some laptops will enforce a 45W limit and even with an unlocked BIOS, there is nothing you can do about it.

After you make this change, try running ThrottleStop. If you were previously using this program, delete the ThrottleStop.INI configuration file so it can read the default values from your CPU. Post some screenshots so I can recommend what you can try changing.
 

theoverpowered

New Member
Joined
Oct 30, 2020
Messages
10 (0.12/day)
@theoverpowered - You can increase the Package TDP Limit from 45.0 to 55.0 in the BIOS but this might not make any difference. Some laptops will enforce a 45W limit and even with an unlocked BIOS, there is nothing you can do about it.

After you make this change, try running ThrottleStop. If you were previously using this program, delete the ThrottleStop.INI configuration file so it can read the default values from your CPU. Post some screenshots so I can recommend what you can try changing.
I have no idea where this option is in bios. TS show 55w at PL1 but he is drops to 45 after short turbo.
the good thing is i changed Primary Plane in bios to 175 from 128 and its working i dont experience throttling or performance cut like before.
 

Attachments

  • das.png
    das.png
    70 KB · Views: 37

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
Your BIOS screenshot shows Package TDP Limit near the top. It is set to 45.

Also try using the FIVR - Disable and Lock Turbo Power Limits feature.
 

theoverpowered

New Member
Joined
Oct 30, 2020
Messages
10 (0.12/day)
yea but i dont know where i can change this XD
I was looking for an option for the TDP package and found nothing

screen showing powerlimits 1/2, fivr disable doesnt help still 45. Maybe its a CTDP Bios Control?
 

Attachments

  • powerlimits.jpg
    powerlimits.jpg
    3 MB · Views: 34

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
i dont know where i can change this

1606252639132.png


If this does not work then this power limit is probably generated internally by the EC. There is no way around this type of throttling. An unlocked BIOS will not help.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
@theoverpowered - Did you try changing the Package TDP Limit that I showed you? Your video shows that this is still set to 45W and Power Limit 1 is now also set to 45W.

When you change something in the BIOS, you will need to delete the ThrottleStop.INI configuration file before running ThrottleStop. You need to do this so ThrottleStop can read its default values from the CPU which are the values that the BIOS would have set. If you do not do this, ThrottleStop will use whatever values you previously saved in ThrottleStop and will ignore any changes you made in the BIOS.

PL1 but he is drops to 45 after short turbo.
I have already said that there is not likely anything in the BIOS that is going to fix this problem. The 45W limit is forced internally by the EC. This is a limit that ThrottleStop, Intel XTU and the BIOS do not have access to.
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
what you think about this method ?
That is a great method if it works on your computer. Setting IMON Slope to 50 is the important one. This tricks the CPU so ot only reports half as much power consumption compared to normal. No more power limit throttling.

Post some screenshots if this solves your problem.
 

theoverpowered

New Member
Joined
Oct 30, 2020
Messages
10 (0.12/day)
im scary to change anything in this bios. I'm afraid the laptop won't get up. I don't know if I should try. :/
 

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
im scary to change anything in this bios.
An unlocked BIOS is wonderful in theory but you can never be sure if saving something is going to be OK. You might end up with an expensive brick if something goes wrong. Go search EBay for a BIOS re-programmer in case something goes wrong. Are those extra watts worth the risk?
 

theoverpowered

New Member
Joined
Oct 30, 2020
Messages
10 (0.12/day)
Holy crap i did it
Set IMON Slope to 50 Set
IMON Offset to 63999 (that was max option)
Set IMON Prefix to "-",

he thinks 45w at 4.0 :D
 

Attachments

  • full 4.0 unlocked.png
    full 4.0 unlocked.png
    209.2 KB · Views: 42

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
A column of 40.00 multipliers from top to bottom is a thing of beauty. Good work.

IMON Offset to 63999
It is possible that you can reduce this value to bring the power consumption number down some more. Right now the TS Bench is showing 45W at 85°C. A more stressful test will need more watts and will still need to throttle.

That might be OK though. No need to get too greedy but something to keep in mind if you ever wake up at night wondering, what could it really do with some more juice? :D
 

theoverpowered

New Member
Joined
Oct 30, 2020
Messages
10 (0.12/day)
The fact that I did it was a complete accident, I was about to let go, I found a thread on another forum about acer predator also with this processor. They said to set offset 65535, my max is 63999 . So i did it. Anyway the lowering offset not help at 51k i had a throttle to 38.00 multiplier. I will stay at 63999. ;)

Edit:
At startup Windows i see alot yellow limits flags in throttlestop thermal pl1/2 EDP other, they are gone when i apply my voltages so my question is should i change in bios CPU configuration the boot mode turbo performance or just lock lower multiplier to prevent that?
 
Last edited:

unclewebb

ThrottleStop & RealTemp Author
Joined
Jun 1, 2008
Messages
2,712 (0.59/day)
At startup
Limit reasons lighting up yellow during boot up is normal and nothing to be concerned about. As long as you can maintain the full multiplier during a stress test, that is all that is important.

You could try setting the IMON slope to 40. This might help. :D
 
Top