• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Unlocked Realtek HD Audio Drivers for Windows 10 (Dolby Digital Live/DTS Interactive)

Joined
Jan 18, 2016
Messages
117 (0.05/day)
Location
Brasil
System Name Windows 10: Pro Insider x64
Processor i5-3570
Motherboard MSI P67s-C43 B3
Cooling Stock
Memory 16GB DDR3 1333mHz
Video Card(s) GTX 680
Storage 2x Seagate 1TB 6Gbs 1x SSD 128GB
Display(s) LG 23" FLATRON E2355
Case THERMALTAKE CHASER MK-I
Audio Device(s) Receiver Onkyo Tx-NR 757
Power Supply C3 TECH 750W
Mouse THERMALTAKE PHERON
Keyboard A4TECH LED MULTIMEDIA
Maybe. I tested on build 16184 with mod file from Unlocked Realtek HD Audio Drivers Windows 7, 8,10, page #1681. When I click on test a sound on DTS and DDL, no error( fail to a tone) .

Send me unlocked .DLL (2.81) pls
 
Joined
Apr 20, 2017
Messages
296 (0.14/day)
Send me unlocked .DLL (2.81) pls
Thank you very much I hope that you like me and thank me for the mod can you test my mod second archive and send screenshots of your spdif device to see are you have dolby digital output and dolby digital live output or not the archive is Dj Urko - realtek_hda_8090_Dolby_Harman_SRS_PCEE4viaSPDIF&HDMI you must have dolby home theater 4 and and dolby digital plus home theatre so dont forget to install dolby tuning and profile creator first I dont have spdif device so I need to someone who can test my mod its only for dolby digital live Link to Download is https://1drv.ms/f/s!AkGtxiGigudSo2xfdo7zyDlHd-qg
 
Joined
Jan 18, 2016
Messages
117 (0.05/day)
Location
Brasil
System Name Windows 10: Pro Insider x64
Processor i5-3570
Motherboard MSI P67s-C43 B3
Cooling Stock
Memory 16GB DDR3 1333mHz
Video Card(s) GTX 680
Storage 2x Seagate 1TB 6Gbs 1x SSD 128GB
Display(s) LG 23" FLATRON E2355
Case THERMALTAKE CHASER MK-I
Audio Device(s) Receiver Onkyo Tx-NR 757
Power Supply C3 TECH 750W
Mouse THERMALTAKE PHERON
Keyboard A4TECH LED MULTIMEDIA
Thank you very much I hope that you like me and thank me for the mod can you test my mod second archive and send screenshots of your spdif device to see are you have dolby digital output and dolby digital live output or not the archive is Dj Urko - realtek_hda_8090_Dolby_Harman_SRS_PCEE4viaSPDIF&HDMI you must have dolby home theater 4 and and dolby digital plus home theatre so dont forget to install dolby tuning and profile creator first I dont have spdif device so I need to someone who can test my mod its only for dolby digital live Link to Download is https://1drv.ms/f/s!AkGtxiGigudSo2xfdo7zyDlHd-qg

I will try
 
Joined
Mar 27, 2017
Messages
158 (0.08/day)
Sound Blaster works perfectly here


I installed sound blaster x-fi MB5. could not get it to work like the picture in your post. what should I do?

upload_2017-5-1_14-59-6.png


upload_2017-5-1_14-59-34.png
 
Joined
Mar 1, 2017
Messages
1,081 (0.51/day)
Location
Rio de Janeiro, Brazil
System Name Home PC/Lenovo IdeaPad S145-15API
Processor AMD Phenom II X4 960T (Quad-Core)/AMD Ryzen 5 3500U (4C/8T)
Motherboard Gigabyte GA-880GM-UD2H (Rev 1.3)/Lenovo Motherboard
Cooling DeepCool Gammaxx L120T/Stock
Memory 11GB/8GB
Video Card(s) GT 730 1GB/AMD Radeon RX Vega 8 (Onboard)
Storage [1x GoldenFir SSD 256GB + 1x HDD 1TB]/[1x Netac SSD M.2 NMVe 256GB + 1x GoldenFir SSD SATA3 1TB]
Case Cooler Master Storm Scout/Stock
Audio Device(s) AAF Optimus Sound
Power Supply 600W/Stock
Benchmark Scores Mikrotik RB760iGS with 1Gb/s Up/Down
I installed sound blaster x-fi MB5. could not get it to work like the picture in your post. what should I do?

View attachment 87350

View attachment 87351

The solution is here.

https://www.mediafire.com/folder/3g2zrvifx2qad/3.-_Activador
http://download1346.mediafire.com/wqs5t052hb0g/hbimbfmd310ccfo/2.-GenKGA3.exe.7z

CAUTION: First, run the GenKGA4.exe file and extract the files to the preconfigured directory. Then open the GenKGA3.exe.7z file and extract the GenKGA3.exe file to the Local Disk of the system (example C: \), along with the RUN.bat file and execute both, respectively (1st - GenKGA3.exe; - RUN.bat). Then restart the computer and you're done, just try it. (DO NOT FORGET TO DISABLATE YOUR ANTI-VIRUS BEFORE STARTING THE PROCESS, BY TREATING A POSITIVE FLASK).

Download GenKGA4.exe & GenKGA3.exe.7z Files Only

You do not need to uninstall the audio driver or Sound Blaster
 
Last edited:
Joined
Dec 13, 2014
Messages
382 (0.13/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education x64 21H2
wow, Alan's realtek x-fi mb5 mod driver worked, even with a very old Realtek ALC861 audio chipset on my old Intel motherboard, though I had to modify the hdxrt.inf file to include my hardware ID on it because the INF file originally didn't have it (it begins with "HDAUDIO\FUNC_01&VEN_10EC&DEV_0861")

the sound blaster x-fi mb5 package included in the modded realtek package is kinda outdated. get the latest version of x-fimb5 from either Gigabyte or Sagernotebook.com which is v1.00.19 (and is compatible with Win10 anniversary update & higher as well as with Win7 & Win8.x):
http://www.sagernotebook.com/drivers/audio/P6x0HX/win10/04_SBX.exe
http://download.gigabyte.us/FileList/Driver/mb_driver_audio_xfi-mb5.zip
http://download.gigabyte.eu/FileList/Driver/mb_driver_audio_xfi-mb5.zip
I use these newer versions rather than the one included in the modded realtek driver package

to answer byu1's question of what Sound Blaster X-FI MB5 does, look at this page:
http://www.creative.com/oem/products/software/x-fimb5.asp
X-FI MB5 was released only to PC manufacturers & board makers like Acer, Dell, Gigabyte & Sager.

My Realtek control panel is different and doesn't have any SRS option (used your patched installer)

WTF

View attachment 85336

you are using an ASUS motherboard or laptop, Derek12? what kind?
On my friend's custom built PC with an ASUS M5A78L-M LE/USB3 board, I get an ASUS specific realtek audio control panel (a black one) no matter what version of audio drivers (modded or unmodded) - the control panel thingy is hardcoded in the audio drivers based on your realtek audio hardware device ID and cannot be changed.
 
Last edited by a moderator:
Joined
Jan 12, 2010
Messages
1,526 (0.32/day)
System Name Custom Built
Processor AMD Ryzen 5 3600
Motherboard Asus PRIME A520M-A
Cooling Stock heatsink/fan
Memory 16GB 2x8GB Corsair Vengeance LPX 2400MHz
Video Card(s) MSI 1050Ti 4GB
Storage KINGSTON SNVS250G 256GB M.2 + 2 data disks
Display(s) Dell S2421NX
Case Aerocool CS103
Audio Device(s) Realtek
Power Supply Seasonic M12II-520 EVO
Mouse Logitech MX Master 2S
Keyboard Logitech
Software Windows 11 Pro 64-bit
you are using an ASUS motherboard or laptop, Derek12? what kind?
On my friend's custom built PC with an ASUS M5A78L-M LE/USB3 board, I get an ASUS specific realtek audio control panel (a black one) no matter what version of audio drivers (modded or unmodded) - the control panel thingy is hardcoded in the audio drivers based on your realtek audio hardware device ID and cannot be changed.

Correct :) I am using an Asus motherbard! and that patched driver doesn't work there as no SRS button is avaliable in that interface :(
 
Joined
Dec 13, 2014
Messages
382 (0.13/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education x64 21H2
yep. the link is dead. searched all over the web, could not find a working one.

the GenKGA3.exe file is bundled inside moonshinenite's modded realtek audio driver package (I know because I've used his modded drivers before):
https://1drv.ms/u/s!Ag7Jjz6jWP5Nin_u96m33DwIooPz
you have to download the entire package and use a file archiving tool like 7zip to extract the GenKGA3 file
 
Joined
Mar 27, 2017
Messages
158 (0.08/day)
wow, Alan's realtek x-fi mb5 mod driver worked, even with a very old Realtek ALC861 audio chipset on my old Intel motherboard, though I had to modify the hdxrt.inf file to include my hardware ID on it because the INF file originally didn't have it (it begins with "HDAUDIO\FUNC_01&VEN_10EC&DEV_0861")

the sound blaster x-fi mb5 package included in the modded realtek package is kinda outdated. get the latest version of x-fimb5 from either Gigabyte or Sagernotebook.com which is v1.00.19 (and is compatible with Win10 anniversary update & higher as well as with Win7 & Win8.x):
http://www.sagernotebook.com/drivers/audio/P6x0HX/win10/04_SBX.exe
http://download.gigabyte.us/FileList/Driver/mb_driver_audio_xfi-mb5.zip
http://download.gigabyte.eu/FileList/Driver/mb_driver_audio_xfi-mb5.zip
I use these newer versions rather than the one included in the modded realtek driver package

to answer byu1's question of what Sound Blaster X-FI MB5 does, look at this page:
http://www.creative.com/oem/products/software/x-fimb5.asp
X-FI MB5 was released only to PC manufacturers & board makers like Acer, Dell, Gigabyte & Sager.


Yes I have 1.0019 originally downloaded from station-drivers.com

http://www.station-drivers.com/index.php?option=com_remository&Itemid=353&func=select&id=415&lang=en

I just tried the step from alan Finote from post #57. still same error.

should I uninstall the existing one try one of listed?
 
Joined
Dec 13, 2014
Messages
382 (0.13/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education x64 21H2
byu1 & ifpmaximus34:

try moonshitenite's modded drivers from his 7960 driver package from the link (that's where I got the genkga3.exe file). first try 7960, if that one doesn't make x-fimb5 work, then try the 7747 version - that one does work on my system for sure.
You need to remove both existing realtek audio drivers & x-fimb5 software before installing his modded drivers & x-fi mb5.

Also, right after installing the Sound Blaster X-FI MB5 software, do not restart the computer right away. When given the choices to restart right now or restart later after installing x-fi mb5, choose to restart later and immediately run all the genkga files (genkga4.exe, genkga3.exe, dat.exe & last but not least the run.bat files) from moonshinenite's "activador" folder. then restart the computer and load x-fi mb5.

still I want to know the hardware device IDs for your Realtek HD Audio devices:

I've gotten X-FI MB5 to work with my old Intel motherboard with ALC861 audio using this ID:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0861&SUBSYS_8086C601


Correct :) I am using an Asus motherbard! and that patched driver doesn't work there as no SRS button is avaliable in that interface :(

You need to install a separate SRS control panel app from DJ Urko's modded realtek audio driver package.

Here's the ASUS Realtek audio manager app on my friend's ASUS M5A78L-M LE/USB3 motherboard:
asus-realtek-audio-cpl(m5a78l-m-le-usb3)[2].png


his board uses Realtek ALC887 audio with the following hardware ID:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_10438576
Always installed thru the HDXRT4.INF file because that specific ID is mentioned on there
 
Last edited:

ifpmaximus34

New Member
Joined
Jan 25, 2017
Messages
15 (0.01/day)
buy1 & ifpmaximus34:

try moonshitenite's modded drivers from his 7960 driver package from the link (that's where I got the genkga3.exe file). first try 7960, if that one doesn't make x-fimb5 work, then try the 7747 version - that one does work on my system for sure.
You need to remove both existing realtek audio drivers & x-fimb5 software before installing his modded drivers & x-fi mb5.

Also, right after installing the Sound Blaster X-FI MB5 software, do not restart the computer right away. When given the choices to restart right now or restart later after installing x-fi mb5, choose to restart later and immediately run all the genkga files (genkga4.exe, genkga3.exe, dat.exe & last but not least the run.bat files) from moonshinenite's "activador" folder. then restart the computer and load x-fi mb5.

still I want to know the hardware device IDs for your Realtek HD Audio devices:

I've gotten X-FI MB5 to work with my old Intel motherboard with ALC861 audio using this ID:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0861&SUBSYS_8086C601




You need to install a separate SRS control panel app from DJ Urko's modded realtek audio driver package.

Here's the ASUS Realtek audio manager app on my friend's ASUS M5A78L-M LE/USB3 motherboard:
View attachment 87504

his board uses Realtek ALC887 audio with the following hardware ID:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_10438576
Always installed thru the HDXRT4.INF file because that specific ID is mentioned on there

here is my id:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_104386C7&REV_1003
HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_104386C7
also i have windows 10 x64 home edition creator update latest updates if that helps
 
Last edited:
Joined
Apr 20, 2017
Messages
296 (0.14/day)
here is my id:
HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_104386C7&REV_1003
HDAUDIO\FUNC_01&VEN_10EC&DEV_0887&SUBSYS_104386C7
also i have windows 10 x64 home edition creator update latest updates if that helps
but the problem is that SRS premium sound and x-fi mb5 cannot work together
 
Joined
Dec 13, 2014
Messages
382 (0.13/day)
Processor AMD Phenom II X4 925
Motherboard Gigabyte GA-78LMT-USB3 R2
Memory 4 GB DDR3 1333Mhz
Audio Device(s) onboard Realtek ALC892
Power Supply Seasonic S12II 620w (SS-620GB)
Software Windows 10 Education x64 21H2
but the problem is that SRS premium sound and x-fi mb5 cannot work together

that's ok - I can live with that; it's always been that way. i don't need the SRS stuff when I have X-FI MB5 installed on some realtek audio chipsets that can handle it.

this recent screenshot of my friend's asus m5a78l-m le/usb3 board with x-fimb5 working might make byu1 & ifpmaximus34 scratch their heads:

asus-realtek-xfimb5-working.png


the sbx pro studio options are colored which means it's working. by the way, his computer is using Win10 v1607 (anniversary update) and realtek audio driver R2.81 (6.0.1.8036) & made a copy of the HDXMB3H.INF file and edited it to include his specific ID on there; I pretty much did my own mod. I may update his machine to the v1703 release when some of the creators update bugs get worked out.

I also used the specified version of mbapo264.dll file seen in the screenshot to make x-fi mb5 work. newer versions of the mbapo232.dll & mbapo264.dll files (v1.2.16.102 & higher) have audio id restrictions on them and support fewer realtek audio chipsets.
 
Last edited:
Joined
Mar 1, 2017
Messages
1,081 (0.51/day)
Location
Rio de Janeiro, Brazil
System Name Home PC/Lenovo IdeaPad S145-15API
Processor AMD Phenom II X4 960T (Quad-Core)/AMD Ryzen 5 3500U (4C/8T)
Motherboard Gigabyte GA-880GM-UD2H (Rev 1.3)/Lenovo Motherboard
Cooling DeepCool Gammaxx L120T/Stock
Memory 11GB/8GB
Video Card(s) GT 730 1GB/AMD Radeon RX Vega 8 (Onboard)
Storage [1x GoldenFir SSD 256GB + 1x HDD 1TB]/[1x Netac SSD M.2 NMVe 256GB + 1x GoldenFir SSD SATA3 1TB]
Case Cooler Master Storm Scout/Stock
Audio Device(s) AAF Optimus Sound
Power Supply 600W/Stock
Benchmark Scores Mikrotik RB760iGS with 1Gb/s Up/Down
wow, Alan's realtek x-fi mb5 mod driver worked, even with a very old Realtek ALC861 audio chipset on my old Intel motherboard, though I had to modify the hdxrt.inf file to include my hardware ID on it because the INF file originally didn't have it (it begins with "HDAUDIO\FUNC_01&VEN_10EC&DEV_0861")

the sound blaster x-fi mb5 package included in the modded realtek package is kinda outdated. get the latest version of x-fimb5 from either Gigabyte or Sagernotebook.com which is v1.00.19 (and is compatible with Win10 anniversary update & higher as well as with Win7 & Win8.x):
http://www.sagernotebook.com/drivers/audio/P6x0HX/win10/04_SBX.exe
http://download.gigabyte.us/FileList/Driver/mb_driver_audio_xfi-mb5.zip
http://download.gigabyte.eu/FileList/Driver/mb_driver_audio_xfi-mb5.zip
I use these newer versions rather than the one included in the modded realtek driver package

to answer byu1's question of what Sound Blaster X-FI MB5 does, look at this page:
http://www.creative.com/oem/products/software/x-fimb5.asp
X-FI MB5 was released only to PC manufacturers & board makers like Acer, Dell, Gigabyte & Sager.



you are using an ASUS motherboard or laptop, Derek12? what kind?
On my friend's custom built PC with an ASUS M5A78L-M LE/USB3 board, I get an ASUS specific realtek audio control panel (a black one) no matter what version of audio drivers (modded or unmodded) - the control panel thingy is hardcoded in the audio drivers based on your realtek audio hardware device ID and cannot be changed.

ERPGUY53, LINK UPDATED WITH YOUR REALTEK CHIP HARDWARE ID INCLUDED:
"HDAUDIO\FUNC_01&VEN_10EC&DEV_0861"

"OBS: TEST MODE MUST BE ENABLED OR DISABLE DRIVER SIGNATURE ENFORCEMENT IN YOUR SYSTEM; COMMAND FOR TEST MODE: bcdedit -set TESTSIGNING ON and restart, REVERT TEST MODE: bcdedit -set TESTSIGNING OFF and restart"

http://www.mediafire.com/file/03l4bmtk1chi7l4/Realtek_SBX.7z

"SOUND BLASTER VERSION INCLUDED IN THIS PACKAGE: 1.00.19"
 
Last edited:
Joined
Mar 1, 2017
Messages
1,081 (0.51/day)
Location
Rio de Janeiro, Brazil
System Name Home PC/Lenovo IdeaPad S145-15API
Processor AMD Phenom II X4 960T (Quad-Core)/AMD Ryzen 5 3500U (4C/8T)
Motherboard Gigabyte GA-880GM-UD2H (Rev 1.3)/Lenovo Motherboard
Cooling DeepCool Gammaxx L120T/Stock
Memory 11GB/8GB
Video Card(s) GT 730 1GB/AMD Radeon RX Vega 8 (Onboard)
Storage [1x GoldenFir SSD 256GB + 1x HDD 1TB]/[1x Netac SSD M.2 NMVe 256GB + 1x GoldenFir SSD SATA3 1TB]
Case Cooler Master Storm Scout/Stock
Audio Device(s) AAF Optimus Sound
Power Supply 600W/Stock
Benchmark Scores Mikrotik RB760iGS with 1Gb/s Up/Down
that's ok - I can live with that; it's always been that way. i don't need the SRS stuff when I have X-FI MB5 installed on some realtek audio chipsets that can handle it.

this recent screenshot of my friend's asus m5a78l-m le/usb3 board with x-fimb5 working might make byu1 & ifpmaximus34 scratch their heads:

View attachment 87529

the sbx pro studio options are colored which means it's working. by the way, his computer is using Win10 v1607 (anniversary update) and realtek audio driver R2.81 (6.0.1.8036) & made a copy of the HDXMB3H.INF file and edited it to include his specific ID on there; I pretty much did my own mod. I may update his machine to the v1703 release when some of the creators update bugs get worked out.

I also used the specified version of mbapo264.dll file seen in the screenshot to make x-fi mb5 work. newer versions of the mbapo232.dll & mbapo264.dll files (v1.2.16.102 & higher) have audio id restrictions on them and support fewer realtek audio chipsets.


This method did not work here
 
Joined
Jan 18, 2016
Messages
117 (0.05/day)
Location
Brasil
System Name Windows 10: Pro Insider x64
Processor i5-3570
Motherboard MSI P67s-C43 B3
Cooling Stock
Memory 16GB DDR3 1333mHz
Video Card(s) GTX 680
Storage 2x Seagate 1TB 6Gbs 1x SSD 128GB
Display(s) LG 23" FLATRON E2355
Case THERMALTAKE CHASER MK-I
Audio Device(s) Receiver Onkyo Tx-NR 757
Power Supply C3 TECH 750W
Mouse THERMALTAKE PHERON
Keyboard A4TECH LED MULTIMEDIA
ERPGUY53, LINK UPDATED WITH YOUR REALTEK CHIP HARDWARE ID INCLUDED:
"HDAUDIO\FUNC_01&VEN_10EC&DEV_0861"

"OBS: TEST MODE MUST BE ENABLED OR DISABLE DRIVER SIGNATURE ENFORCEMENT IN YOUR SYSTEM; COMMAND FOR TEST MODE: bcdedit -set TESTSIGNING ON and restart, REVERT TEST MODE: bcdedit -set TESTSIGNING OFF and restart"

http://www.mediafire.com/file/03l4bmtk1chi7l4/Realtek_SBX.7z

"SOUND BLASTER VERSION INCLUDED IN THIS PACKAGE: 1.00.19"



Dolby digital live & dts connect????
 

PedroBurito

New Member
Joined
May 6, 2017
Messages
3 (0.00/day)
Hi guys,
i had to reinstall after a HDD failure and now i cant get the patched drivers to work.
Its win 10 build 1703 (creators update?), test mode is enabled.
I used the driver package i had from the previous install and made sure the rltkapo64.dll is patched.
Stereo is working just fine but if i want to set the optical output to DTS it fails, saying
---------------------------
Error!
---------------------------
Format not supported by the device.
---------------------------
OK
---------------------------

The test playback for DTS and DD in the Supported Formats tab is working, the one in the Advanced tab where one can choose the default is not.

fun fact: the install on the broken HDD was also build 1703, but was an update, not a fresh install like this. There i'm pretty sure i did not have the "Spatial sound" option in any of the playback device properties nor when right-clicking the windows volume control icon

Mainboard is P8P67 with an ALC892
The driver package is Asus_Realtek_Audio_V7848_20160617, but the realtek R280 and R281 also fail with the same error.
Any help would be appreciated. I dont want or need any of the virtual surround or srs stuff. Just plain DTS would be great.

PS: i dont really get whats up with all the soundblaster XFI stuff? is this related?

edit: spelling
 
Last edited:
Joined
Mar 1, 2017
Messages
1,081 (0.51/day)
Location
Rio de Janeiro, Brazil
System Name Home PC/Lenovo IdeaPad S145-15API
Processor AMD Phenom II X4 960T (Quad-Core)/AMD Ryzen 5 3500U (4C/8T)
Motherboard Gigabyte GA-880GM-UD2H (Rev 1.3)/Lenovo Motherboard
Cooling DeepCool Gammaxx L120T/Stock
Memory 11GB/8GB
Video Card(s) GT 730 1GB/AMD Radeon RX Vega 8 (Onboard)
Storage [1x GoldenFir SSD 256GB + 1x HDD 1TB]/[1x Netac SSD M.2 NMVe 256GB + 1x GoldenFir SSD SATA3 1TB]
Case Cooler Master Storm Scout/Stock
Audio Device(s) AAF Optimus Sound
Power Supply 600W/Stock
Benchmark Scores Mikrotik RB760iGS with 1Gb/s Up/Down
Hi guys,
i had to reinstall after a HDD failure and now i cant get the patched drivers to work.
Its win 10 build 1703 (creators update?), test mode is enabled.
I used the driver package i had from the previous install and made sure the rltkapo64.dll is patched.
Stereo is working just fine but if i want to set the optical output to DTS it fails, saying
---------------------------
Error!
---------------------------
Format not supported by the device.
---------------------------
OK
---------------------------

The test playback for DTS and DD in the Supported Formats tab is working, the one in the Advanced tab where one can choose the default is not.

fun fact: the install on the broken HDD was also build 1703, but was an update, not a fresh install like this. There i'm pretty sure i did not have the "Spatial sound" option in any of the playback device properties nor when right-clicking the windows volume control icon

Mainboard is P8P67 with an ALC892
The driver package is Asus_Realtek_Audio_V7848_20160617, but the realtek R280 and R281 also fail with the same error.
Any help would be appreciated. I dont want or need any of the virtual surround or srs stuff. Just plain DTS would be great.

PS: i dont really get whats up with all the soundblaster XFI stuff? is this related?

edit: spelling

Go to the Windows Registry, under "HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ Current Version \ Audio", create a 32-bit DWORD entry named DisableProtectedAudioDG and set the value to 1. Then reboot your PC and try testing again.
 
Joined
Mar 1, 2017
Messages
1,081 (0.51/day)
Location
Rio de Janeiro, Brazil
System Name Home PC/Lenovo IdeaPad S145-15API
Processor AMD Phenom II X4 960T (Quad-Core)/AMD Ryzen 5 3500U (4C/8T)
Motherboard Gigabyte GA-880GM-UD2H (Rev 1.3)/Lenovo Motherboard
Cooling DeepCool Gammaxx L120T/Stock
Memory 11GB/8GB
Video Card(s) GT 730 1GB/AMD Radeon RX Vega 8 (Onboard)
Storage [1x GoldenFir SSD 256GB + 1x HDD 1TB]/[1x Netac SSD M.2 NMVe 256GB + 1x GoldenFir SSD SATA3 1TB]
Case Cooler Master Storm Scout/Stock
Audio Device(s) AAF Optimus Sound
Power Supply 600W/Stock
Benchmark Scores Mikrotik RB760iGS with 1Gb/s Up/Down
Joined
Jan 18, 2016
Messages
117 (0.05/day)
Location
Brasil
System Name Windows 10: Pro Insider x64
Processor i5-3570
Motherboard MSI P67s-C43 B3
Cooling Stock
Memory 16GB DDR3 1333mHz
Video Card(s) GTX 680
Storage 2x Seagate 1TB 6Gbs 1x SSD 128GB
Display(s) LG 23" FLATRON E2355
Case THERMALTAKE CHASER MK-I
Audio Device(s) Receiver Onkyo Tx-NR 757
Power Supply C3 TECH 750W
Mouse THERMALTAKE PHERON
Keyboard A4TECH LED MULTIMEDIA
Hi guys,
i had to reinstall after a HDD failure and now i cant get the patched drivers to work.
Its win 10 build 1703 (creators update?), test mode is enabled.
I used the driver package i had from the previous install and made sure the rltkapo64.dll is patched.
Stereo is working just fine but if i want to set the optical output to DTS it fails, saying
---------------------------
Error!
---------------------------
Format not supported by the device.
---------------------------
OK
---------------------------

The test playback for DTS and DD in the Supported Formats tab is working, the one in the Advanced tab where one can choose the default is not.

fun fact: the install on the broken HDD was also build 1703, but was an update, not a fresh install like this. There i'm pretty sure i did not have the "Spatial sound" option in any of the playback device properties nor when right-clicking the windows volume control icon

Mainboard is P8P67 with an ALC892
The driver package is Asus_Realtek_Audio_V7848_20160617, but the realtek R280 and R281 also fail with the same error.
Any help would be appreciated. I dont want or need any of the virtual surround or srs stuff. Just plain DTS would be great.

PS: i dont really get whats up with all the soundblaster XFI stuff? is this related?

edit: spelling
@Pedro Burito
MS Brocken DDL & DTS in this build!

Now fixed in insider build 16184
 
Last edited:
Top