1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

USB drive "Access denied" error

Discussion in 'Storage' started by jasper1605, Apr 21, 2011.

  1. jasper1605

    Nov 6, 2009
    1,271 (0.43/day)
    Thanks Received:
    Hey all,

    I'm using an OCZ diesel 4gb usb memory stick to transfer some stuffs between my house computer and the school computers and I tried to open up the drive through My Computer on the school's computers and it continually says access denied. It's never done that before so I'm slightly confused. I opened up its properties and it just has everything as blank. Is this a sign that the data on the stick went corrupt, or is the drive in the death process OR is this just another wonderful example of how wonderfully terrible my school's computers are?

    Thanks :)

    Edit: I just switched to a different computer in the school and it works now??? I'm definitely not complaining but now am more curious? Anyone up for posing possible reasons as to why? I know I read that there are a few viruses or 3rd party apps that can conflict with USB drives. Unfortunately, I can't test anything because all admin stuffs are blocked.
    Last edited: Apr 21, 2011
  2. newtekie1

    newtekie1 Semi-Retired Folder

    Nov 22, 2005
    24,156 (5.51/day)
    Thanks Received:
    Indiana, USA
    It could be a sign of the drive going bad, or it could just be a problem with the USB port on the first computer. Either way, I'd make sure you have backups of anything on the drive(you should do this with any external storage device).
    10 Year Member at TPU More than 25k PPD

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)