• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Very annoying Gigabyte 7950 BIOS problem

Joined
Aug 14, 2014
Messages
2 (0.00/day)
Likes
0
#1
So i bought a Gigabyte 7950 used and finally made my first build yesterday. Everything went fine except for the fact that the video card REFUSES to display from hdmi. I had to scrounge through a bucket for a dvi to hdmi adapter cable.

Confused by why this would be, i googled the issue and it turns out the previous owner FLASHED BOTH BIOS on the card to the SAME VERSION. F43! Which on all these pages, it says it lowers voltage, core clocks, and locks HDMI!

https://rumorscity.com/2013/12/04/how-to-flash-gigabyte-7950-to-f43-bios-at-1-09v/

https://bitcointalk.org/index.php?topic=197871.0

so my question is how the hell do i update OFF of this bios to a regular version? I've tried the FX1 and FY1 at the website

http://www.gigabyte.com/products/product-page.aspx?pid=4121#bios

But they all just say incompatible, with either easyBoost or vga@bios
 
Joined
May 3, 2014
Messages
615 (0.38/day)
Likes
121
System Name Sham Pc
Processor i5-2500k @ 4.33
Motherboard INTEL DZ77SL 50K
Cooling 2 bay res. "2L of fluid in loop" 1x480 2x360
Memory 16gb 4x4 kingstone 1600 hyper x fury black
Video Card(s) hfa2 gtx 780 @ 1306/1768 (xspc bloc)
Storage 1tb wd red 120gb kingston on the way os, 1.5Tb wd black, 3tb random WD rebrand
Display(s) cibox something or other 23" 1080p " 23 inch downstairs. 52 inch plasma downstairs 15" tft kitchen
Case 900D
Audio Device(s) on board
Power Supply xion gaming seriese 1000W (non modular) 80+ bronze
Software windows 10 pro x64
#2
id use ati flash to flash the bios.
sounds like the previous owner was a bit coin miner though.
 
Joined
May 9, 2013
Messages
718 (0.37/day)
Likes
502
Location
Nykoebing Mors, Denmark
System Name the little fart
Processor Intel I7-5820K
Motherboard MSI X99S Gaming 7
Cooling Polimatech Megahelem push/pull bitfenix Spectre 120mm pro
Memory 16 GB Crucial Sport 2400Mhz DDR 4
Video Card(s) Sapphire R9 290 Tri-x OC
Storage 1 Crucial MX100 512GB SSD,1 Seagate Momentus XT 500GB, 1 1,5TB WD Black Caviar, 1 4TB WD RED HD
Display(s) IIyama E2607WSD
Case Custom Lian-Li PC-50R
Audio Device(s) Audio boost 2(realtek)
Power Supply Thermaltake DPS G 1050 watt Digital PSU
Software windows 10 64 bit
#4
Joined
May 9, 2011
Messages
1,924 (0.72/day)
Likes
950
Location
Mainland Britain
System Name H2o Box
Processor Intel(R) Xeon e5-2690 v2 Stock 3.0 GHz @ 3.399
Motherboard MSI X79A-G43 Plus (MS-7760) v3
Cooling CPU EK Block & Phobya G-Changer 360 V2.0 RAD H2o VGA "AlphaCool M18" Hybrid
Memory Gskill TridentX 16Gb 8-9-9-24 2T @ 1866Mhz [locked]
Video Card(s) Zotac GTX 1080ti AMP EXTREME
Storage HyperX Fury 120GB & Savage 480GB SSD, Seagate 250GB,250GB 7200rpm Kingston 64GB SSD
Display(s) Panasonic GT30 46'' 1080p 3D HDTV [Custom Resolution 4096*2304]
Case Corsair O-800D
Audio Device(s) Creative Sound Blaster X-Fi Titanium Fatal1ty Pro
Power Supply Be Quiet! [Dark Power Pro 11] 1200W CM replaced [7-4-2017]
Mouse Asus ROG
Keyboard Microsoft Digital Media 1.0A
Software Win 10 Pro 64Bit v 1809 / OS[build 17746.1000]
#5
Hi

Welcome to TPU

How would i do that? I've never worked with GPU bios updates so i have no clue
**If you are able to access windows with a spare vga card or onboard vga; Uninstall any AMD drivers for the vga card before the flash process**

Create a bootable flash drive

go here http://files.extremeoverclocking.com/browse.php?c=21

Download - HP USB Disk Storage Format Tool - v2.1.8 & Windows 98 System Files

click Primary Download unzip the files to a folder on your HDD; make sure your USB Memory stick is attached to your PC; open HP USB Disk

Storage Format Tool v2.1.8 ; select Create a DOS start-up disk/ select: using DOS system files located at: (these are the files you have just downloaded): browse to the files in win98boot; then start the process.

Download latest version of ATIFlash
here - http://www.techpowerup.com/downloads/2306/atiflash-4-17/

copy atiflash and [VbiosName].rom to the usb flash drives root directory

Set the motherboard bios to boot from usb *press F8 during boot; select from boot menu if option is available; this should boot to a win98 dos prompt

Type at the dos prompt - dir to view the content of the flash drive

Type at the dos prompt; atiflash -i 0 [see if adapter is at this address and is recognised]

Type at the dos prompt; atiflash -unlockrom 0 to unlock the gpu in adapter 0 [Note: 0 is the primary card PCIe slot one & 1 is the secondary PCIe slot two][*may be required]

Type at the dos prompt; atiflash -f -p 0 [VBiosName].rom [Note: 0 is the primary card PCIe slot one & 1 is the secondary PCIe slot two] [Note: when booting from onboard vga / igp also = primary position 0]

reboot once finished and remove the flash drive

reinstall AMD Catalyst Drivers

Note: if using a dual bios card Do Not flash the card while switch is in position two

ATIFLASH Commands here
Thanks go out to Crackerjack

atb

Law-II
 
Last edited:

Lejimmy_

New Member
Joined
Jul 13, 2018
Messages
1 (0.01/day)
Likes
1
#6
4 years later...THANK YOU!
I stayed stuck with this f43 bios with no hdmi but with your excellent tutorial, it's works. Thank you again!
 
Top