• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

very low transfer rate on small files from pc-smartphone

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
hi, i just bought a new smartphone and i'm trying to transfer the whatsapp folder from my pc to it. it took about an hour to transfer 2gb of files that are about 1-2mb in size each, and after an hour the transfer rate slowed down significaly and the the end time went up to 22 hours. on the other hand, large files (600mb X 2 files) got transfered in a few mintues.
is it normal or do i have a defected device? is there a way to check it?
 
Joined
Sep 11, 2019
Messages
85 (2.02/day)
Processor i7 - 9700K
Motherboard Asus H370M Plus
Cooling Arctic Freezer 13
Memory 32GB G-Skill @ 2666Mhz CL15
Video Card(s) 5700 XT (Gigabyte Aftermarket)
Storage 970 EVO 500GB, 860 EVO 2TB, 840 Pro 256GB
Display(s) Samsung C32HG70 - 1440p, Freesync 2
Case Silverstone GD-07B
Audio Device(s) Schiit Modi 2 Uber - Schiit Magni 2 Uber - Sennheiser HD595's
Power Supply Seasonic Focus GX-750
Mouse Steelseries Sensei 310
Keyboard Corsair K70 LUX (Brown Switches), Razer Orbweaver Chroma Stealth
It’s all defective, smash everything to pieces with a hammer.

More seriously, how are we supposed to help when you’ve given us no information? You didn’t even bother to list what OS the phone is running, let alone the model, let alone anything related to your PC. Are you transferring to internal phone storage, or an SD card? Tried a different cable? Tried a different USB port on the computer?

Please give complete information with your questions folks.
 

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
thanks:
it's meizu 16th.
oporating systems: flyme 7.1.1OG (android 8.1.0) and Windows 10.
i'm transferring files from my pc to my smartphone's internal storage.
i tried a different cable and port and it's the same.

it seems to me like it's defective, because large files take a few mintues to transfer, while small files takes hours (and the transfer rate slows down significaly after around 30 minutes), but i have no idea what's going on.
 
Joined
Jun 7, 2019
Messages
19 (0.14/day)
System Name Times Killer
Processor Ryzen 9 3900X
Motherboard MSI B450-A Pro rev. 2.0
Cooling arctic freezer 33 TR4
Memory 2x 8gb Corsair 3200 mhz LPX for Ryzen @ 3600mhz
Video Card(s) Asus Strix Vega 56 Gaming OC , EVGA GTX 1070Ti ACX 3.0
Storage 2 X 1TB WD's 1X 4gb WB red 1x LG GH22NS70 DVD-RAM Drive
Display(s) HP 25X
Case Corsair Obsidian 750D W/ airflow kit
Audio Device(s) Asus Xonar DX / SoundblasterX AE-5
Power Supply Carsair 850-M
Mouse Logitech Proteus spectrum G502
Keyboard Logitech G213 Prodigy
Software Windows 10 home
yes it's normal, if it's off a mechanical drive. each file makes the hdd spin up and down..with small files it spends less time with it spinning more time changing and looking for files as opposed to large file where it can stay spun up at max transfer rate.
 
Joined
Sep 11, 2019
Messages
85 (2.02/day)
Processor i7 - 9700K
Motherboard Asus H370M Plus
Cooling Arctic Freezer 13
Memory 32GB G-Skill @ 2666Mhz CL15
Video Card(s) 5700 XT (Gigabyte Aftermarket)
Storage 970 EVO 500GB, 860 EVO 2TB, 840 Pro 256GB
Display(s) Samsung C32HG70 - 1440p, Freesync 2
Case Silverstone GD-07B
Audio Device(s) Schiit Modi 2 Uber - Schiit Magni 2 Uber - Sennheiser HD595's
Power Supply Seasonic Focus GX-750
Mouse Steelseries Sensei 310
Keyboard Corsair K70 LUX (Brown Switches), Razer Orbweaver Chroma Stealth
Some motherboards have a few USB ports which use a 3rd party chipset, and many of those 3rd party chipsets don’t play well with certain devices. You said you tried a different port, but I would make sure you’re using a port which is native to your motherboard’s main chipset. A USB 2.0 port would be your best bet (the phone uses a Type C connector, but it’s actually only USB 2.0 anyway).
 

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
Some motherboards have a few USB ports which use a 3rd party chipset, and many of those 3rd party chipsets don’t play well with certain devices. You said you tried a different port, but I would make sure you’re using a port which is native to your motherboard’s main chipset. A USB 2.0 port would be your best bet (the phone uses a Type C connector, but it’s actually only USB 2.0 anyway).
thanks, i tried all 3 ports and it's about the same.
another weird thing: when i stop the transfer after transfering some files, and then i try manually resume the transfer (copy paste all files in the folder again) i get the expected notice that some files already been copied, but then it doesn't transfer the rest after i'm telling it to not transfer the same files again.
 
Joined
Nov 11, 2004
Messages
4,320 (0.79/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Power Supply Corsair RM750
Mouse Logitech G500s
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/ztiub6
Small files, presumable slow storage in the phone, USB 2.0 and presumably a hard drive in your PC = slow transfer speeds.
 

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
Small files, presumable slow storage in the phone, USB 2.0 and presumably a hard drive in your PC = slow transfer speeds.
but it's not that small, it's 2mb files. does it explains why after 30 minutes the transfer end time downgraded from a few hours to a day? (also, i can't add files as explained in my previous message)
 
Joined
Nov 11, 2004
Messages
4,320 (0.79/day)
Location
Formosa
System Name Overlord Mk MXVI
Processor AMD Ryzen 7 3800X
Motherboard X570 Aorus Master
Cooling Corsair H115i Pro
Memory 32GB Viper Steel 3600 DDR4 @ 3800MHz 16-19-16-19-36
Video Card(s) Gigabyte RTX 2080 Gaming OC 8G
Storage 1TB WD Black NVMe (2018), 2TB Viper VPN100, 1TB WD Blue 3D NAND
Display(s) Asus PG27AQ
Case Corsair Carbide 275Q
Power Supply Corsair RM750
Mouse Logitech G500s
Keyboard Wooting Two
Software Windows 10 Pro
Benchmark Scores https://valid.x86.fr/ztiub6
but it's not that small, it's 2mb files. does it explains why after 30 minutes the transfer end time downgraded from a few hours to a day? (also, i can't add files as explained in my previous message)
Does your PC have a hard drive or SSD? If you have a hard drive, how fragmented is it?
It might be faster to copy the files to a microSD card, presuming you can add one to your phone and then plug that into a USB 3.0 card reader. Obviously a hard drive would still be a bottle neck.
 

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
thanks, i have ssd, and no micro sd card slot

also, this is really strange mailfunction. because of that i want to ask in other forums as well, but i don't know any. if anyone can recommend a few good forums, it'll be great.
 
Joined
Sep 11, 2019
Messages
85 (2.02/day)
Processor i7 - 9700K
Motherboard Asus H370M Plus
Cooling Arctic Freezer 13
Memory 32GB G-Skill @ 2666Mhz CL15
Video Card(s) 5700 XT (Gigabyte Aftermarket)
Storage 970 EVO 500GB, 860 EVO 2TB, 840 Pro 256GB
Display(s) Samsung C32HG70 - 1440p, Freesync 2
Case Silverstone GD-07B
Audio Device(s) Schiit Modi 2 Uber - Schiit Magni 2 Uber - Sennheiser HD595's
Power Supply Seasonic Focus GX-750
Mouse Steelseries Sensei 310
Keyboard Corsair K70 LUX (Brown Switches), Razer Orbweaver Chroma Stealth
22hrs for 2Gb comes out to something like < 30Kb/s. We can safely rule out the source drive unless it’s from the early 80’s.

The phone’s internal storage is also not running at those speeds, because it would be completely unusable. The issue is almost certainly software related. Looks like that phone is running a heavily modified custom version of Android. I’m not at all familiar with it (nor have I used Android in any meaningful way since 6.0), so unfortunately I can’t be of much help there.

I would test with a different computer if possible. Could still be some quirk with the USB controller and that particular phone.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
25,442 (6.32/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire NITRO+ RX 590 Special Edition 8 GiB DVI + HDMI
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Samsung SyncMaster T240 24" LCD (1920x1200 HDMI) + Samsung SyncMaster 906BW 19" LCD (1440x900 DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
USB is a shared bus. It's possible something else is consuming the bandwidth so next to nothing is left for phone transfer. Try unplugging everything USB from the computer except what is necessary.

How well does the computer and phone perform in general? Nothing extraordinary? For example, if the computer is really freakin' slow to do file transfers in general, you could have a bad SATA cable or bad SATA controller port. This causes a high error rate so much of the data fails error checking, gets discarded, and re-requested. I've seen hard drives operate in the kilobytes because of this. The computer works but it is painful to use.
 

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
Thank's. I thought the file transfer speed (starts normal) slows down after a short time because the cpu warms up. It starts from 50 and gows up to 70 in a few minutes.
Couldn't it be a problem of one of the read/write functiona of the phone''s flash drive?
 
Joined
Dec 3, 2009
Messages
1,221 (0.34/day)
Location
The Netherlands
System Name PC || Acer Nitro 5
Processor AMD FX-9590 || R5 2500U @ 35W
Motherboard Asus Sabertooth 990FX R 2.0 || default
Cooling Corsair H100i Push-Pull + frankenstein loop H80i modded onto 290|| Stock
Memory Samsung 30nm 4x4GB @ 1930MHz|| 2x8GB DDR4 @ 2400MHz
Video Card(s) AMD R9 290 @ 1175MHz / 1625MHz || RX 560X
Display(s) Samsung U28E590 4K & S23A750D 120Hz + others|| 15,6" 1080P IPS @ 100Hz Freesync enabled
Case Corsair 500R Fans Galore ||
Audio Device(s) Asus Xonar DX/XD ||
Power Supply Corsair AX860i || 135Watt 19V OEM adaptor
Software Win 10 64bit || Win 10 64bit
Sounds like it might be a "problem" with the file transfer protocol that somehow has to do some quite elaborate and time-consuming things before a file can be transferred.
I used to have the same problem with a Lumia 950 (a windows phone no less) and my Windows PC. I was never bothered enough by it to dive deep in a solution because i could just transfer everything via the cloud quite fast anyway.
You might want to look for a driver or some other software that supports your phone on your PC.
 

sltwtr

New Member
Joined
Aug 24, 2019
Messages
16 (0.26/day)
Sounds like it might be a "problem" with the file transfer protocol that somehow has to do some quite elaborate and time-consuming things before a file can be transferred.
I used to have the same problem with a Lumia 950 (a windows phone no less) and my Windows PC. I was never bothered enough by it to dive deep in a solution because i could just transfer everything via the cloud quite fast anyway.
You might want to look for a driver or some other software that supports your phone on your PC.
Thanks, where and what to look?...
I wouldn't be too bothered but I don't know if this problem is an indication to a malfuncton that will get worse iin time. Can you recommend other good forums so I can try to ask my question?
 
Joined
Dec 3, 2009
Messages
1,221 (0.34/day)
Location
The Netherlands
System Name PC || Acer Nitro 5
Processor AMD FX-9590 || R5 2500U @ 35W
Motherboard Asus Sabertooth 990FX R 2.0 || default
Cooling Corsair H100i Push-Pull + frankenstein loop H80i modded onto 290|| Stock
Memory Samsung 30nm 4x4GB @ 1930MHz|| 2x8GB DDR4 @ 2400MHz
Video Card(s) AMD R9 290 @ 1175MHz / 1625MHz || RX 560X
Display(s) Samsung U28E590 4K & S23A750D 120Hz + others|| 15,6" 1080P IPS @ 100Hz Freesync enabled
Case Corsair 500R Fans Galore ||
Audio Device(s) Asus Xonar DX/XD ||
Power Supply Corsair AX860i || 135Watt 19V OEM adaptor
Software Win 10 64bit || Win 10 64bit
Thanks, where and what to look?...
I wouldn't be too bothered but I don't know if this problem is an indication to a malfuncton that will get worse iin time. Can you recommend other good forums so I can try to ask my question?
The most knowledgeable and popular phone forum that I know of is the xda-developers forum.
I dont know whether anyone there can/will help you with your specific problem, but browsing their forums (if you can get the hang of the structure) might be enlightening enough in it's own right. You might even be able to find an alternative ROM (be very careful though) for your phone that is more to your liking on other fronts as well.

Best of luck!
 
Joined
Nov 18, 2010
Messages
4,723 (1.45/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor Intel 5960X @ 4.4GHz
Motherboard Gigabyte GA-X99-UD3
Cooling Custom Loop. 360+240 rads.
Memory 4x8GB Corsair Vengeance LPX 3000MHz 15-17-17-36 CR1
Video Card(s) ASUS 1080 Ti FE + water block
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB
Display(s) Philips PHL BDM3270
Case Phanteks Enthoo Evolv ATX Tempered Glass
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer Deathstalker
Software Windows 10 insider
It is normal for MTP protocol. That thing should die.

Try ADB pull via com port.
 
Top