• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Was my RX580 used for mining?

Metodiev_

New Member
Joined
Jan 29, 2020
Messages
1 (0.01/day)
Hello guys i recently, purchased a used Radeon RX580 8GB Nitro Plus ( Standard edition ). The problem is that the card stutters and lags in whatever game i can think of GTA 5, Fortnite, AC, Forza Horizon 4 and etc. No matter of the fps everything just stutters if not in game everything its fine but when i launch game card starts to coil whine a little bit depending on the game and i just have terrible unplayable performance with it. The previous owner of the card told me he used it 1 year for video editing, and his kids played some games on it. I can't be sure tho so i wanna ask you guys if you can help me fix this card, the card has dual bios button, currently its on the performance one, the right one not the left. I reinstalled windows installed brand new drivers, tried with old ones but nothing seems to get this card to work properly, and one more thing in some games there are artifacts on the screen showing and going off sometimes, my head question is can you tell me if the card was used for mining by a picture from GPU-Z? My PC specs are -

OS: Windows 10 Pro 64bit
CPU: Ryzen 5 1600x 3,60Ghz
MOBO: MSI B350 GAMING Plus
RAM: Crucial Ballistix Sport Red 16GB ( 2x8)
PSU: Antec HCG 620w 80 plus

My old gpu 1050ti, didn't haved those problems with this system.
 

Attachments

Joined
Mar 10, 2015
Messages
3,106 (1.62/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
If you are actually able to play games, it probably does not have a modded bios with memory timings optimiZed for mining. What is the GPU usage during gaming? And clocks during gaming?
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.44/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Hello guys i recently, purchased a used Radeon RX580 8GB Nitro Plus ( Standard edition ). The problem is that the card stutters and lags in whatever game i can think of GTA 5, Fortnite, AC, Forza Horizon 4 and etc. No matter of the fps everything just stutters if not in game everything its fine but when i launch game card starts to coil whine a little bit depending on the game and i just have terrible unplayable performance with it. The previous owner of the card told me he used it 1 year for video editing, and his kids played some games on it. I can't be sure tho so i wanna ask you guys if you can help me fix this card, the card has dual bios button, currently its on the performance one, the right one not the left. I reinstalled windows installed brand new drivers, tried with old ones but nothing seems to get this card to work properly, and one more thing in some games there are artifacts on the screen showing and going off sometimes, my head question is can you tell me if the card was used for mining by a picture from GPU-Z? My PC specs are -

OS: Windows 10 Pro 64bit
CPU: Ryzen 5 1600x 3,60Ghz
MOBO: MSI B350 GAMING Plus
RAM: Crucial Ballistix Sport Red 16GB ( 2x8)
PSU: Antec HCG 620w 80 plus

My old gpu 1050ti, didn't haved those problems with this system.
Did you completely remove the old GPU drivers? Reset game settings too?

Have you updated the motherboard chipset drivers?

@AlienIsGOD @INSTG8R @FordGT90Concept

Pull a gpu-z screenshot and a overlay and see what temperatures you have. How old is the psu too? What specific model number is on its dataplate?

Get a sku sticker shot from the side of the card heatsink please
 
Joined
Aug 20, 2007
Messages
12,995 (2.78/day)
System Name Pioneer
Processor Intel i9 9900k
Motherboard ASRock Z390 Taichi
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory G.SKILL TridentZ Series 32GB (4 x 8GB) DDR4-3200 @ 14-14-14-34-2T
Video Card(s) AMD RX 5700 XT (XFX THICC Ultra III)
Storage Mushkin Pilot-E 2TB NVMe SSD w/ EKWB M.2 Heatsink
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) VGA HDMI->Panasonic SC-HTB20/Schiit Modi MB/Asgard 2 DAC/Amp to AKG Pro K7712 Headphones
Power Supply SeaSonic Prime 750W 80Plus Titanium
Mouse ROCCAT Kone EMP
Keyboard WASD CODE 104-Key w/ Cherry MX Green Keyswitches, Doubleshot Vortex PBT White Transluscent Keycaps
Software Windows 10 Enterprise (yes, it's legit.)
If it had been used for mining, I would expect a modded bios. Which would mean it would only load with modded drivers.

No, I don't think so given this limited evidence.
 
Joined
Jun 29, 2019
Messages
41 (0.12/day)
Processor Ryzen 5 2600
Motherboard ASRock B350Pro4
Memory 2*4 GB DDR4 Patriot Elite 2666Mhz
Video Card(s) Sapphire RX580 Nitro+ 8GB
Storage 1TB WD BLUE
Display(s) Philips 223v
Case Zalman S3
Power Supply CoolerMaster MWE 500w
Well it still could have modded timings, I heard AMD removed the driver signature in the last few updates, and my HIS RX580 I bought used had modded timings but still could update drivers and worked normal.

I would recommend you to try to upload your BIOS to TPU DB with GPU-Z, if it has a modded BIOS it wont find a duplicate or will direct you to a unverified BIOS.

Besides that, it could be overheating and downclocking which would cause the stuttering or could be a bad PSU.
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.44/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
If it had been used for mining, I would expect a modded bios. Which would mean it would only load with modded drivers.

No, I don't think so given this limited evidence.
Just because clocks werent adjusted doesnt mean something else was, however modded bios dont always break driver detections.
 
Joined
Mar 10, 2015
Messages
3,106 (1.62/day)
System Name Wut?
Processor 3900X
Motherboard ASRock Taichi X570
Cooling Water
Memory 32GB GSkill CL16 3600mhz
Video Card(s) Vega 56
Storage 2 x AData XPG 8200 Pro 1TB
Display(s) 3440 x 1440
Case Thermaltake Tower 900
Power Supply Seasonic Prime Ultra Platinum
Just because clocks werent adjusted doesnt mean something else was, however modded bios dont always break driver detections.
My mining bioses wouldn't even start a 3d load without crashing. Pretty sure he doesn't jBe a mining bios.
 
Joined
Aug 20, 2007
Messages
12,995 (2.78/day)
System Name Pioneer
Processor Intel i9 9900k
Motherboard ASRock Z390 Taichi
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory G.SKILL TridentZ Series 32GB (4 x 8GB) DDR4-3200 @ 14-14-14-34-2T
Video Card(s) AMD RX 5700 XT (XFX THICC Ultra III)
Storage Mushkin Pilot-E 2TB NVMe SSD w/ EKWB M.2 Heatsink
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) VGA HDMI->Panasonic SC-HTB20/Schiit Modi MB/Asgard 2 DAC/Amp to AKG Pro K7712 Headphones
Power Supply SeaSonic Prime 750W 80Plus Titanium
Mouse ROCCAT Kone EMP
Keyboard WASD CODE 104-Key w/ Cherry MX Green Keyswitches, Doubleshot Vortex PBT White Transluscent Keycaps
Software Windows 10 Enterprise (yes, it's legit.)
Just because clocks werent adjusted doesnt mean something else was, however modded bios dont always break driver detections.
it's a sig check. It should ALWAYS break it if it's not a release driver.

I guess a crossflashed bios wouldn't, but, those aren't technically modded.
 
Joined
Sep 3, 2019
Messages
1,113 (4.00/day)
Location
Thessaloniki, Greece
System Name None
Processor Ryzen 5 3600 (PBO manual: PPT 105W, TDC 105A, EDC 1A, PBO Scalar auto)
Motherboard Gigabyte X570 Aorus Pro
Cooling Corsair H110i 280mm (Liquid metal for TIM)
Memory CorsairVengeanceLPX DDR4 2x8GB 3466MHz CL16-18-18-36 1T, cheap B-die, @3666 CL16-17-17-34 1T (1:1:1)
Video Card(s) MSI RX 5700XT Gaming X
Storage Samsung NVMe: 970Pro 512GB / SATA-III: 850Pro 1TB SSD, 860Evo 1TB SSD
Display(s) 24" EIZO FlexScan S2411W 1920x1200, 16:10 60Hz samsung S-PVA panel.
Case None
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W
Power Supply Corsair HX750i
Mouse Logitech MX Master
Keyboard Logitech G15 v2
Software Windows 10 Home 64bit (v1909)
I have used for gaming for a few months 1 ASUS dual 580 and 1 ASUS Rog strix 580 with enhanced timings only BIOS mod for mining. Both worked fine with "regular" AMD drivers in high/ultra game settings. GTA V was one of them.

If I see the BIOS I would know if this one was timings modded and by how much. There are many levels of timings enhancement...
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.44/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
I have used for gaming for a few months 1 ASUS dual 580 and 1 ASUS Rog strix 580 with enhanced timings only BIOS mod for mining. Both worked fine with "regular" AMD drivers in high/ultra game settings. GTA V was one of them.

If I see the BIOS I would know if this one was timings modded and by how much. There are many levels of timings enhancement...
I just know stock works lol
 
Joined
Sep 3, 2019
Messages
1,113 (4.00/day)
Location
Thessaloniki, Greece
System Name None
Processor Ryzen 5 3600 (PBO manual: PPT 105W, TDC 105A, EDC 1A, PBO Scalar auto)
Motherboard Gigabyte X570 Aorus Pro
Cooling Corsair H110i 280mm (Liquid metal for TIM)
Memory CorsairVengeanceLPX DDR4 2x8GB 3466MHz CL16-18-18-36 1T, cheap B-die, @3666 CL16-17-17-34 1T (1:1:1)
Video Card(s) MSI RX 5700XT Gaming X
Storage Samsung NVMe: 970Pro 512GB / SATA-III: 850Pro 1TB SSD, 860Evo 1TB SSD
Display(s) 24" EIZO FlexScan S2411W 1920x1200, 16:10 60Hz samsung S-PVA panel.
Case None
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W
Power Supply Corsair HX750i
Mouse Logitech MX Master
Keyboard Logitech G15 v2
Software Windows 10 Home 64bit (v1909)
I just know stock works lol
Sure it does... less headaches.

Unless this card was timings modded too tight, the stuttering could be something else... Or may be some (under)voltage modded too, who knows... This of course cant be seen by that GPU-z screenshot. It needs to be on-gaming monitored, but you know that already...

Before OP goes into flashing VBIOS we could just compare his VBIOS with stock and see whats what... if he is willing to upload it here.
I know its not all that complicated to flash today, but if that could be avoided, its nice IMO.

Offtopic...
I used to flash VBIOSs with floppy drives (on WinXP) back at the day, and sometimes even blindly... lol... fun times...
 

eidairaman1

The Exiled Airman
Joined
Jul 2, 2007
Messages
30,443 (6.44/day)
Location
Republic of Texas (True Patriot)
System Name PCGOD
Processor AMD FX 8350@ 5.0GHz
Motherboard Asus TUF 990FX Sabertooth R2 2901 Bios
Cooling Scythe Ashura, 2×BitFenix 230mm Spectre Pro LED (Blue,Green), 2x BitFenix 140mm Spectre Pro LED
Memory 16 GB Gskill Ripjaws X 2133 (2400 OC, 10-10-12-20-20, 1T, 1.65V)
Video Card(s) AMD Radeon 290 Sapphire Vapor-X
Storage Samsung 840 Pro 256GB, WD Velociraptor 1TB
Display(s) NEC Multisync LCD 1700V (Display Port Adapter)
Case AeroCool Xpredator Evil Blue Edition
Audio Device(s) Creative Labs Sound Blaster ZxR
Power Supply Seasonic 1250 XM2 Series (XP3)
Mouse Roccat Kone XTD
Keyboard Roccat Ryos MK Pro
Software Windows 7 Pro 64
Sure it does... less headaches.

Unless this card was timings modded too tight, the stuttering could be something else... Or may be some (under)voltage modded too, who knows... This of course cant be seen by that GPU-z screenshot. It needs to be on-gaming monitored, but you know that already...

Before OP goes into flashing VBIOS we could just compare his VBIOS with stock and see whats what... if he is willing to upload it here.
I know its not all that complicated to flash today, but if that could be avoided, its nice IMO.

Offtopic...
I used to flash VBIOSs with floppy drives (on WinXP) back at the day, and sometimes even blindly... lol... fun times...
I find what works lol.

I used to do mobo bios by 3.5 floppy
 
Top