• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Weird Stutter problem??

ImBlueDabiDa

New Member
Joined
Jun 2, 2019
Messages
3 (0.06/day)
Hi guys english is not my native language i hope i can explain my problem
My system is
Dell Alienware aw2518h [ Gsync ] 240hz
RTX 2070 msi
Ryzen 2700x
HDD 1Tb
SSD 500gb Samsung
SSD M.2 250gb Samsung evo
X470 Gaming plus mobo
16 Gigs Ram 3200mhz Gskill
700w +80 bronz FSP
logitech g402 mouse
logitech g710+ keyboard
logitech g633 headset

So my problem is some games feel really not smooth its like they stutter even with high fps
for example Rainbow Six Siege and overwatch works really well even if my fps drops there are no sign of stutter/freeze or lag like that(playing 160-240fps)
but in other games like Mordhau (avg. 100fps ), Leauge of Legend(avg 150fps), Killing Floor 2 (avg. 150fps)
in these games even if my fps drops like from 100 to 95 it stutters
What could my problem?

ım using Gsync + Vsync on (in Nvidia control panel/off in games) + RTSS 237 fps limit
What i Tried
Pre-rendered frames set to 1
Reformat/fresh install windows 10
Re-seat Ram
Re-seat Video Card
Roll Back Drivers
Fresh install gpu drivers with DDU
Updated Bios
Updated all drivers
Re-seat CPU
Fixed all Registry errors using CCLEANER
checked temps gpu and cpu they max 70c
 

Mussels

Moderprator
Staff member
Joined
Oct 6, 2004
Messages
47,071 (8.72/day)
Location
Australalalalalaia.
System Name LGBTBBQAMDRGBDIYPC
Processor Ryzen R7 2700X (stock/XFR OC)
Motherboard Aorus AX370-Gaming 5 (planned x570 upgrade when they come out)
Cooling Corsair H115i Pro W/ Corsair ML RGB fans
Memory 16GB DDR4 3200 Corsair Vengeance RGB Pro
Video Card(s) MSI GTX 1080 Gaming X (BIOS mod to Gaming Z) w/ NZXT Kraken x52 AIO
Storage 1TB Sasmsung 970 Pro NVME + 1TB Intel 6000 Pro NVME
Display(s) Phillips 328m6fjrmb (32" 1440p 144hz curved) + Sony KD-55X8500F (55" 4K HDR)
Case Fractal Design R6 Gunmetal Grey (Type C TG)
Audio Device(s) Razer Leviathan + Corsair Void pro RGB, Blue Yeti mic
Power Supply Corsair HX 750i (Platinum, fan off til 300W)
Mouse Logitech G903 + PowerPlay mousepad
Keyboard Corsair K65 Rapidfire
Software Windows 10 pro x64 (all systems)
Benchmark Scores Laptops: i7-4510U + 840M 2GB (touchscreen) 275GB SSD + 16GB i7-2630QM + GT 540M + 8GB
In the windows control panels power settings, disable the hard drive sleep timer.
When mechanical drives wake from sleep they can cause brief stutter, and it could very well be a contributor to your problems
(Drive sleeps, game needs new data, all drives get woken up, system stutters)

Edit power plan -> advanced options
 
Joined
May 15, 2007
Messages
761 (0.17/day)
System Name ZPM Hive | Aurora | Orion |
Processor R7 2700X | R5 2600 | Q6600 @ ??|
Motherboard GB X370 Gaming 3 | GB B450I Aorus Pro | XFX 780i SLI |
Cooling Fractal Design Celsius S36 | Wraith Stealth | TBC |
Memory 16GB T-Group 8Pack 3466 C14 | 16GB Corsair RGB 3000 C16 @ 3200 CL15 | 4GB OCZ Reaper DDR2 |
Video Card(s) Asus GTX1080Ti FE @ 2000/11000| Sapphire Pulse Vega 56 @ ~1600/950 | 2 x 8800 GTX SLI |
Storage 512GB Samsung 960 Evo / 2TB HD | Intel 760p NVME SSD / 512GB SP SSD | 256GB SSD / 500GB HD |
Display(s) Dell 1440p 144Hz G-Sync | AOC 25" 1080p 75hz Freesync | AOC 25" 1080p 75hz |
Case Corsair Carbide 275R |Metallic gear Neo-G Mini | CiT Dark Soul |
Audio Device(s) Onboard w/ Edifier 980T |
Power Supply Corsair HX1000i | EVGA GQ 750w | Thermaltake XT675w |
Mouse Corsair Harpoon RGB | Coolermaster RGB
Keyboard Vengeance K70 w/ Cherry Red | Coolermaster Memchanical RGB
Software Win 10 x64 | Win 10 x64 | Win XP SP3 |
Can you MSI Afterburner with the onscreen overlay to check and see what is happening to your CPU utilisation (maybe also clocks), GPU utilisation (also clocks), VRAM, RAM etc when the stutter occurs.

Your raw specs suggest you shouldn't have a problem but then stutter can be caused by a number of factors.
 
Joined
Nov 18, 2010
Messages
4,536 (1.43/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor Intel 5960X @ 4.4GHz
Motherboard Gigabyte GA-X99-UD3
Cooling Custom Loop. 360+240 rads.
Memory 4x8GB Corsair Vengeance LPX 2966MHz 16-17-17-35
Video Card(s) ASUS 1080 Ti FE + water block
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB
Display(s) Philips PHL BDM3270
Case Phanteks Enthoo Evolv ATX Tempered Glass
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer Deathstalker
Software Windows 10 insider
ım using Gsync + Vsync on (in Nvidia control panel/off in games) + RTSS 237 fps limit
It is prolly not related, but plain stupid to do it. Don't interact with various sync methods. Don't touch the nvidia control panel force mode as it bugs and leave that RTSS limiter and let one code handle it.

Imho it is monitor related as it switches at that FPS limit to double gear. As many doesn't have such panels it is vaguely tested at all.


EDIT:
Here is the best answer for you. There is no magic bullet and general settings.

 
Last edited:
Joined
Sep 17, 2014
Messages
9,443 (5.35/day)
Location
Too Long to fit in a single line here.
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
- Reset Nvidia control panel settings to defaults (most of it being 'application controlled')
- Vsync will try to lock your frames to 240 FPS. Impossible. You need to avoid using that altogether, and you can, because you have other options;
> Fast Sync - Low-input lag Vsync suitable for games that manage to run a high FPS -Drawback = occasional stutter is possible
> Gsync - Low-input lag Vsync suitable for normal/under screen refresh FPS -Drawback = support required
> Adaptive Sync - Slightly improved input-lag Vsync for very demanding titles (sub 30 FPS) that Gsync can't handle proper. -Drawback = its shit compared to above options.

> Framerate cap - lowest input lag possible, no Vsync.

Choose your poison. Don't mix them.
 
Joined
Nov 18, 2010
Messages
4,536 (1.43/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor Intel 5960X @ 4.4GHz
Motherboard Gigabyte GA-X99-UD3
Cooling Custom Loop. 360+240 rads.
Memory 4x8GB Corsair Vengeance LPX 2966MHz 16-17-17-35
Video Card(s) ASUS 1080 Ti FE + water block
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB
Display(s) Philips PHL BDM3270
Case Phanteks Enthoo Evolv ATX Tempered Glass
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer Deathstalker
Software Windows 10 insider
- Reset Nvidia control panel settings to defaults (most of it being 'application controlled')
- Vsync will try to lock your frames to 240 FPS. Impossible. You need to avoid using that altogether, and you can, because you have other options;
> Fast Sync - Low-input lag Vsync suitable for games that manage to run a high FPS -Drawback = occasional stutter is possible
> Gsync - Low-input lag Vsync suitable for normal/under screen refresh FPS -Drawback = support required
> Adaptive Sync - Slightly improved input-lag Vsync for very demanding titles (sub 30 FPS) that Gsync can't handle proper. -Drawback = its shit compared to above options.

> Framerate cap - lowest input lag possible, no Vsync.

Choose your poison. Don't mix them.
It applies to our non G or Freesync panels. With G sync it must have Vsync on auto in the panel as if the FPS will spike higher than 240FPS it will tear. Under 240FPS Gsync works, after casual vsync kicks in.

At such latencies... ie 240FPS is insane... the RTSS introduces latency, I don't use it as many games bugs with it. The ingame setting is the best. The guides around are meant for 100-144Hz users, when RTSS ir really needed, as GPU can push higher FPS sometimes than that, so it is needed. But at 240Hz... well...

Also I posted a link why it is all messed up due to game engines itself. Some work, some are inheritably capricious to force other sync methods than their own.
 
Joined
Sep 17, 2014
Messages
9,443 (5.35/day)
Location
Too Long to fit in a single line here.
Processor i7 8700k 4.7Ghz @ 1.26v
Motherboard AsRock Fatal1ty K6 Z370
Cooling beQuiet! Dark Rock Pro 3
Memory 16GB Corsair Vengeance LPX 3200/C16
Video Card(s) MSI GTX 1080 Gaming X @ 2100/5500
Storage Samsung 850 EVO 1TB + Samsung 830 256GB + Crucial BX100 250GB + Toshiba 1TB HDD
Display(s) Eizo Foris FG2421
Case Fractal Design Define C TG
Power Supply EVGA G2 750w
Mouse Logitech G502 Protheus Spectrum
Keyboard Sharkoon MK80 (Brown)
Software W10 x64
It applies to our non G or Freesync panels. With G sync it must have Vsync on auto in the panel as if the FPS will spike higher than 240FPS it will tear. Under 240FPS Gsync works, after casual vsync kicks in.

At such latencies... ie 240FPS is insane... the RTSS introduces latency, I don't use it as many games bugs with it. The ingame setting is the best. The guides around are meant for 100-144Hz users, when RTSS ir really needed, as GPU can push higher FPS sometimes than that, so it is needed. But at 240Hz... well...

Also I posted a link why it is all messed up due to game engines itself. Some work, some are inheritably capricious to force other sync methods than their own.
Ah yes ofcourse, but if you're above 120 FPS I would disregard Gsync altogether, Fast Sync is probably a better path to avoid issues.

Another option to help smoothness is even Adaptive Vsync at half refresh, also available in NVCPL as it will lock tear-free to 120hz. Then Gsync on top, might be the optimal setup.
 
Joined
Mar 18, 2015
Messages
2,010 (1.27/day)
Location
Long Island
Does the monitor have a ULMB option ? If so turn all sync's off and use it.

 

fernbrake533

New Member
Joined
Jun 20, 2019
Messages
1 (0.03/day)
This stuttering issue has the potential to be your headset, the g633. I have recently had the same problem. Try plugging it into the computer via the 3.5mm jack and see if this fixes the issue. The headset drivers and siege do not seem to mix well, so if you have any other audio devices to plug in to, do that. I personally have it plugged into my Blue Yeti
 
Top