• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Editorial Windows 10 1903 Has a Nasty Audio Stutter Bug Microsoft Hasn't Managed to Fix

Joined
Jul 5, 2013
Messages
8,172 (3.41/day)
If Microsoft changes an API then yes, drivers need to be fixed.
You're assuming the existing drivers wouldn't work fine as-is(which they do BTW), again this is a Microsoft problem, not a driver problem. Microsoft needs to fix it.
 
Joined
Mar 6, 2017
Messages
1,792 (1.70/day)
Location
North East Ohio, USA
System Name My Super Computer
Processor Intel Core i7 8700K
Motherboard Gigabyte Z370 AORUS Ultra Gaming
Cooling Corsair H55 AIO
Memory 2x8GB Crucial/Micron Ballistix Sport DDR4-2400
Video Card(s) ASUS GeForce GTX1060 6GB
Storage Samsung 970 EVO 500 GB NVMe SSD (System Drive), Samsung 860 EVO 500 GB SATA SSD (Game Drive)
Display(s) HP 2311x and Acer G206HQL
Case CoolerMaster MasterBox Lite 5 RGB
Audio Device(s) On-Board Sound
Power Supply EVGA Supernova 650 G3 Gold
Mouse Logitech M705
Keyboard Logitech Wave K350
Software Windows 10 Pro 64-bit
Benchmark Scores https://valid.x86.fr/liwjs3
You're assuming the existing drivers wouldn't work fine as-is(which they do BTW), again this is a Microsoft problem, not a driver problem. Microsoft needs to fix it.
Wait. What?
 
Joined
Sep 15, 2011
Messages
5,347 (1.75/day)
Processor Intel Core i7 3770k @ 4.3GHz
Motherboard Asus P8Z77-V LK
Memory 16GB(2x8) DDR3@2133MHz 1.5v Patriot
Video Card(s) MSI GeForce GTX 1080 GAMING X 8G
Storage 59.63GB Samsung SSD 830 + 465.76 GB Samsung SSD 840 EVO + 2TB Hitachi + 300GB Velociraptor HDD
Display(s) Acer Predator X34 3440x1440@100Hz G-Sync
Case NZXT PHANTOM410-BK
Audio Device(s) Creative X-Fi Titanium PCIe
Power Supply Corsair 850W
Mouse Anker
Software Win 10 Pro - 64bit
Benchmark Scores 30FPS in NFS:Rivals
X-Fi Titanium Pci-E still broken with those garbage Win10 releases....
 

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
7,874 (2.20/day)
Location
Rochester area
System Name RPC MK2
Processor Intel Core i5 9600K@ 4.8Ghz 1.32V
Motherboard Asrock z390 phantom gaming 4
Cooling Enermax ets-t50
Memory CMK16GX4M2B3000C15 16GB DDR4-3000
Video Card(s) EVGA GeForce RTX 2060 XC ULTRA GAMING
Storage 512GB Intel 545s ssd 500GB ADATA SU800 ssd 1TB WD blue
Display(s) Cheap VA panel
Case Phanteks P300
Audio Device(s) onboard
Power Supply HX 750i
Mouse M65 Pro RGB
Keyboard K70 RGB
Software Windows 10 +startisback
its hilarious how many people don't know creatives track record with there shit drivers
there drivers have been garbage since the sound blaster 16 in msdos

again you got driver problems blame the vendor vendors fault not Microsofts they are not the nanny for every lazy vendor that wants to code things like its still 2003

its been literally over 10 years since directsound was put down like the rabid dog it was ten years, and the vendors still have not bothered to get there shit together and use wasapi the right way



and yes the problems all of them are 100% driver and 100% the hardware vendors fault
there is low latency apis and paths that the vendors simply are not using
./thread

thx bta for another well written informational editorial =/
 
Joined
Mar 6, 2017
Messages
1,792 (1.70/day)
Location
North East Ohio, USA
System Name My Super Computer
Processor Intel Core i7 8700K
Motherboard Gigabyte Z370 AORUS Ultra Gaming
Cooling Corsair H55 AIO
Memory 2x8GB Crucial/Micron Ballistix Sport DDR4-2400
Video Card(s) ASUS GeForce GTX1060 6GB
Storage Samsung 970 EVO 500 GB NVMe SSD (System Drive), Samsung 860 EVO 500 GB SATA SSD (Game Drive)
Display(s) HP 2311x and Acer G206HQL
Case CoolerMaster MasterBox Lite 5 RGB
Audio Device(s) On-Board Sound
Power Supply EVGA Supernova 650 G3 Gold
Mouse Logitech M705
Keyboard Logitech Wave K350
Software Windows 10 Pro 64-bit
Benchmark Scores https://valid.x86.fr/liwjs3
Joined
Jul 5, 2013
Messages
8,172 (3.41/day)
its hilarious how many people don't know creatives track record with there shit drivers
What's more hilarious is people who claim this. I've been using Creatives cards since the 90's and have never had the horrific experiences people claim to have had.. Never even seen it.
there drivers have been garbage since the sound blaster 16 in msdos
This is oh so wrong.
 
Joined
Sep 15, 2011
Messages
5,347 (1.75/day)
Processor Intel Core i7 3770k @ 4.3GHz
Motherboard Asus P8Z77-V LK
Memory 16GB(2x8) DDR3@2133MHz 1.5v Patriot
Video Card(s) MSI GeForce GTX 1080 GAMING X 8G
Storage 59.63GB Samsung SSD 830 + 465.76 GB Samsung SSD 840 EVO + 2TB Hitachi + 300GB Velociraptor HDD
Display(s) Acer Predator X34 3440x1440@100Hz G-Sync
Case NZXT PHANTOM410-BK
Audio Device(s) Creative X-Fi Titanium PCIe
Power Supply Corsair 850W
Mouse Anker
Software Win 10 Pro - 64bit
Benchmark Scores 30FPS in NFS:Rivals
I guess we are blaming vendors too for MS destroying 3D Hardware sound on the PC...
 

OneMoar

There is Always Moar
Joined
Apr 9, 2010
Messages
7,874 (2.20/day)
Location
Rochester area
System Name RPC MK2
Processor Intel Core i5 9600K@ 4.8Ghz 1.32V
Motherboard Asrock z390 phantom gaming 4
Cooling Enermax ets-t50
Memory CMK16GX4M2B3000C15 16GB DDR4-3000
Video Card(s) EVGA GeForce RTX 2060 XC ULTRA GAMING
Storage 512GB Intel 545s ssd 500GB ADATA SU800 ssd 1TB WD blue
Display(s) Cheap VA panel
Case Phanteks P300
Audio Device(s) onboard
Power Supply HX 750i
Mouse M65 Pro RGB
Keyboard K70 RGB
Software Windows 10 +startisback
I guess we are blaming vendors too for MS destroying 3D Hardware sound on the PC...
despite how bta's entirely wrong editorial has made it sound its been dead for 13 years (since vista)


and yes actually DirectSound was depreciated due vendors doing stuff there own way which lead to compatibility issues, bugs and was generally a mess to maintain (or do you know remember the bs that was eax Aureal3d, cmp ect ect )


btw wasapi in shared mode supports sub 10ms buffers if the vendors would bother to use them

and btw there is nothing stopping vendors from implementing direct3d paths using openal, in fact, there is a wrapper for it(google it) ,creative did this yes real hardware accelerated openal then decided to not support it

hardware-accelerated audio-only existed because at the time processing audio was intensive for cpus of the era from a flexibility and functionality standpoint hardware acceleration is inferior in every way

so again not Microsofts problem

are we done now ?

in the future,@btarunr do some dam research before posting sudo-rants like this again
 
Last edited:
Joined
Jul 5, 2013
Messages
8,172 (3.41/day)
despite how bta's entirely wrong editorial has made it sound its been dead for 13 years (since vista)
Wow, just wow.. You did actually READ the editorial, right?
or do you know remember the bs that was eax Aureal3d, cmp ect ect
None of that was a mess if you knew how to use it. Seems clear by your statement that you didn't.
so again not Microsofts problem
The problems did NOT exist before an update and exists now. Since we all know Creative drivers haven't been changed then one can only conclude, based on the evidence, that this is EXCLUSIVELY a Microsoft problem.
are we done now ?
You tell us...
in the future,@btarunr do some dam research before posting sudo-rants like this again
Take your own advice.
 
Joined
Jul 21, 2016
Messages
32 (0.02/day)
Processor AMD Ryzen 5 2600 @ 3.9
Motherboard MSI B450 Tomahawk
Cooling Alpenföhn Brocken 3 140mm
Memory Patriot Viper 4 - DDR4 3400 MHz 2x8 GB
Video Card(s) Sapphire Radeon RX570 8 GB
Storage Samsung 830 128 GB, Samsung 860 500 GB, 2x Western Digital RED 4 TB
Display(s) Dell UltraSharp U2312HM
Case Cooler Master CM 690 II Advanced + Noiseblocker NB-eLoop B12 + 2x Coolink SWiF2 120mm fans
Audio Device(s) Creative Sound Blaster X-Fi Titanium HD
Power Supply Seasonic M12II-520 EVO 520W
Mouse Logitech MX310
Keyboard Lenovo USB
X-Fi Titanium Pci-E still broken with those garbage Win10 releases....
Is the XFTI_PCDRV_L11_2_40_0019 driver not workinkg for your card?
 
Joined
Aug 13, 2009
Messages
2,526 (0.66/day)
Location
Czech republic
Processor Core i7 3770K
Motherboard Gigabyte Z77X-UD3H
Memory 16GB
Video Card(s) Sapphire Radeon Rx 580 Nitro+ 8GB
Storage Samsung 850 PRO 256GB + Samsung 970 PRO 1TB
Display(s) Dell U2415
Case Fractal Design Define R6 Black
Audio Device(s) Creative Sound Blaster ZxR
Power Supply Seasonic PRIME Ultra 650W Gold
Mouse Roccat Kone EMP
Software Windows 10 x64
I might just wait for the 19H2 version looking at this shit. Hopefully it will be fixed by then.
 
Joined
May 17, 2017
Messages
14 (0.01/day)
Location
Brazil
System Name Balthus Dire/Darth Vader
Processor Intel Core i7 2600 @ 4.2ghz 1.34v/Core i7 3630QM
Motherboard Gigabyte ga-z77p-d3/HP Intel HM77
Cooling Zalman CNPX 10X Extreme/ HP DV6
Memory 2x8GB Corsair Cas9 1600mhz/ 2x8GB DDR3 1600mhz Samsung
Video Card(s) Gigabyte Geforce RTX 2060 OC/ Geforce GT 650M 2GB GDDR5
Storage 2x120 GB EVO 840 System, Hitachi 2TB 7200rpm Games, Raid1 3x1.5TB Seagate 5900rpm Data/ SSD 480GB
Display(s) Asus 27" VP278H Gaming LCD/15.6" FHD IPS LED panel
Case Chieftech Bravo Full ATX/ HP DV6 Metal
Audio Device(s) ALC1150/ IDT HD Audio
Power Supply Corsair 600W 80Plus/HP 120w PS
Mouse CM Storm Devastator/Logitech Wireless
Keyboard Corsair K55 /HP DV6
Software WIndows 10 Pro, QubesOS/Windows 10
My listening rig still rocks Windows XP Sp3 and a Creative X-Fi Xtreme Music! PCI dedicated hardware accelerated EAX card. Never had a problem with it...
 
Joined
Aug 26, 2015
Messages
14 (0.01/day)
Try enabling HPET and Disabledynamictick

bcdedit /set useplatformclock true
BCDEDIT /SET DISABLEDYNAMICTICK YES

Simply more accurate timing and disabling a power saving feature.
 
Joined
Feb 21, 2006
Messages
553 (0.11/day)
Location
Toronto, Ontario
System Name AMD Ryzen
Processor 3800X
Motherboard Asus Prime X570-Pro
Cooling Corsair H150i Pro
Memory 16GB Gskill Trident RGB DDR4-3200 14-14-14-34-1T
Video Card(s) GIGABYTE Radeon RX 580 GAMING 8GB
Storage Corsair MP600 1TB PCIe 4 / Samsung 860Evo 1TB x2 Raid 0
Display(s) HP ZR24w
Case Fractal Design Meshify S2
Audio Device(s) Creative X-Fi + Logitech Z-5500
Power Supply Corsair AX850 Titanium
Mouse Corsair Dark Core RGB
Keyboard Logitech G810
Software Windows 10 Pro x64 1903
My listening rig still rocks Windows XP Sp3 and a Creative X-Fi Xtreme Music! PCI dedicated hardware accelerated EAX card. Never had a problem with it...
Windows XP eww hope that computer is not connected to the internet.
 
Joined
Jul 5, 2013
Messages
8,172 (3.41/day)
Windows XP eww hope that computer is not connected to the internet.
That topic belongs in the thread below;
 
Joined
May 9, 2012
Messages
6,682 (2.37/day)
Location
Ovronnaz, Wallis, Switzerland
System Name Monster Panzer Max [MPM]/Nostalg33k/Fiio X5 3rd gen/Xiaomi Mi Box S/Honor View 20
Processor i5-6600K 3.9/E8500/RK3188/S905X 4X1.5 A53/Kirin 980 2xA76 (2.6 GHz)+2xA76 (1.92)+4xA53 (1.8GHz)
Motherboard Gigabyte Z170X Gaming 7/XFX 650i Ultra/Fiio/uh?/uh?
Cooling Corsair H115i /Alphacool Eisberg /uh?/Aluminum heatsink/Heatpipe
Memory 4x4gb HyperX Predator 2800 CL14/2gb DDR2 800/1gb/2gb LPDDR3/6gb LPDDR4X dual channel
Video Card(s) MSI GTX 1070 ARMOR 8gb OC/Asus 8800 Ultra/Mali 400MP4/Mali 450MP5/Mali G76MP10
Storage 120gb OCZ VertexIII,1tb/8gb SSHD,2xToshiba 1tb/none/32gb+64gb/8gb/128gb UFS 2.1
Display(s) Medion X58222 32"5ms OC 75hz 2880x1620/Philips 273E3LHSB 27"1ms 1920x1080/~4" 480x800/6.4 inch FHD+
Case Cougar Panzer Max/none/Aluminum and tempered glass/None/alu frame +back/front glass
Audio Device(s) Fiio Q1 Mark II+Logitec Z333/SB Audigy2 Platinum/dual AK4490EN /HDMI audio output/Trn V60/Fiio Fa1
Power Supply Seasonic M12II Evo 750 /Enermax Coolergiant 480/12v 1.5A/Aukey QC3.0 9-12V 1.96A
Mouse Asus ROG Spatha/touch/Xiaomi XMRM-006/touch
Keyboard GMMK TKL+Gateron Red+white keys/touch/none/touch
Software Win10 64/none/Android 5.1.1 custom/Android TV 8.1/Android 9.1.0
Benchmark Scores bench...mark? i do leave mark on bench sometime, to remember which one is the most comfortable. :o
no stutter whatsoever using a Fiio Q1 Mk II or X5 III with Fiio DAC driver ... didn't test with onboard tho ...
 

priess

New Member
Joined
Sep 1, 2019
Messages
1 (0.01/day)
Hi
I had this problem with my new Ryzen build .My creative zxr sound crashed after 10 min in games...only way i got it to work was turning off Digital live and activate it again in the soundblaster control panel… and then it crashed again and again :(
I tried realtek onboard audio and there is was no problem. Installed win 10 build 1903 from usb and Amd chipset driver 1.07.29.0115, and besides the sound, the system just runs like a dream :D
Finally found a solution :) i bypass the digital live by using the option " Play stereo mix to digital output "
Now there is no problems , seems to be the Digital Live not working properly… why ? doesn't have a clue… maybe the win 10 1903 build causing trouble or it is the Zxr who need's a major update
But another thing i noticed is that the annoying stuttering is gone



Amd 3900x
asus rog swift x570 f Gaming
Corsair mp600 PCIe 4.0
G.Skill TridentZ 3600 C16
asus rog strix 2080 gaming
acer predator x34a
 
Joined
Aug 2, 2012
Messages
583 (0.21/day)
Location
Netherlands
System Name TheDeeGee's PC
Processor Intel Core i7 4770K
Motherboard Gigabyte Z87X-UD5H
Cooling Noctua NH-U14S
Memory Crucial Ballistix Tactical LP 16GB
Video Card(s) MSI GTX 1070 AERO OC
Storage Crucial M4 256GB, 2x Western Digital 1TB 2,5"
Display(s) EIZO CX240
Case Antec P280
Audio Device(s) Creative SoundBlaster ZxR
Power Supply Seasonic P-760
Mouse Logitech G500s
Keyboard Logitech G710+
Software Windows 10 Pro 64-Bit
Creative Sound Blaster ZxR here, no such issues.
 
Last edited:
Joined
Feb 21, 2006
Messages
553 (0.11/day)
Location
Toronto, Ontario
System Name AMD Ryzen
Processor 3800X
Motherboard Asus Prime X570-Pro
Cooling Corsair H150i Pro
Memory 16GB Gskill Trident RGB DDR4-3200 14-14-14-34-1T
Video Card(s) GIGABYTE Radeon RX 580 GAMING 8GB
Storage Corsair MP600 1TB PCIe 4 / Samsung 860Evo 1TB x2 Raid 0
Display(s) HP ZR24w
Case Fractal Design Meshify S2
Audio Device(s) Creative X-Fi + Logitech Z-5500
Power Supply Corsair AX850 Titanium
Mouse Corsair Dark Core RGB
Keyboard Logitech G810
Software Windows 10 Pro x64 1903
New Soundblaster X Katana, have issue, like sound pops
Hmm I never knew this product existed but then again I'm not a soundbar guy.
 

buck2buck

New Member
Joined
Sep 2, 2019
Messages
1 (0.01/day)
Asus XONAR AE became a total rubbish after the latest MS WIN 10 update. Can't fix the unbelievable delay and sound crackles. Tried every possible solution. Very frustrating..
 
Joined
Apr 10, 2012
Messages
1,352 (0.47/day)
Location
78°55' N, 11°56' E
System Name -aLiEn beaTs-
Processor Intel i7 4770k OC 4.7GHz @ 1.28v | Cache 4.2GHz
Motherboard Asus Z87-Deluxe
Cooling Corsair H115i Pro RGB
Memory G.skill TridentX 2x8GB DDR3 2400MHz CL10|1T
Video Card(s) Zotac GTX 980TI AMP!Omega Factory OC 1418MHz
Storage Intel SSD 330, Crucial SSD MX300 & MX500
Display(s) Samsung C27FG73 144HZ
Case CoolerMaster HAF 932 USB3.0
Audio Device(s) X-Fi Titanium HD @ 2.1 Bose acoustimass 5
Power Supply Chieftec Ntro88+ 650W [52A]
Mouse Asus Rog strix evolve
Keyboard Logitech G19s
Software Windows 10 Pro RS5 64Bit
Benchmark Scores ► ♪♫♪♩♬♫♪♭
I had them with xfi titanium hd, but build after .264+ fixed it. Atm at .297 version.


Lol now I saw new .327 can have a issue with - cortana bing search, can cause high cpu usage cycles.. funny stuff this MS.. xD
 
Joined
Feb 21, 2006
Messages
553 (0.11/day)
Location
Toronto, Ontario
System Name AMD Ryzen
Processor 3800X
Motherboard Asus Prime X570-Pro
Cooling Corsair H150i Pro
Memory 16GB Gskill Trident RGB DDR4-3200 14-14-14-34-1T
Video Card(s) GIGABYTE Radeon RX 580 GAMING 8GB
Storage Corsair MP600 1TB PCIe 4 / Samsung 860Evo 1TB x2 Raid 0
Display(s) HP ZR24w
Case Fractal Design Meshify S2
Audio Device(s) Creative X-Fi + Logitech Z-5500
Power Supply Corsair AX850 Titanium
Mouse Corsair Dark Core RGB
Keyboard Logitech G810
Software Windows 10 Pro x64 1903
I had them with xfi titanium hd, but build after .264+ fixed it. Atm at .297 version.


Lol now I saw new .327 can have a issue with - cortana bing search, can cause high cpu usage cycles.. funny stuff this MS.. xD
Cortana was disabled the min I installed the 1903 build probably why I never noticed this.
 
Top