• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Windows 10 always resets my Time

Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
Hi,

Every time I restart or go into Linux then back to Windows it always resets and I have to update it via Internet. Why?
 
Joined
Jan 5, 2006
Messages
11,929 (2.08/day)
System Name Desktop / Laptop
Processor Intel i7 6700K @ 4.5GHz (1.270 V) / Intel i3 7100U
Motherboard Asus Z170 Pro Gaming / HP 83A3 (U3E1)
Cooling Noctua NH-U12A 2 fans + Thermal Grizzly Kryonaut + 5 case fans / Fan
Memory 16GB DDR4 Corsair Vengeance LPX 3000MHz CL15 / 8GB DDR4 HyperX CL13
Video Card(s) MSI RTX 2070 Super Gaming X Trio / Intel HD620
Storage Samsung 970 Evo 500GB + Samsung 850 Pro 512GB + Samsung 860 Evo 1TB x2 / Samsung 256GB M.2 SSD
Display(s) 23.8" Dell S2417DG 165Hz G-Sync 1440p / 14" 1080p IPS Glossy
Case Be quiet! Silent Base 600 - Window / HP Pavilion
Audio Device(s) SupremeFX Onboard / Realtek onboard + B&O speaker system
Power Supply Seasonic Focus Plus Gold 750W / Powerbrick
Mouse Logitech MX Anywhere 2 Laser wireless / Logitech M330 wireless
Keyboard RAPOO E9270P Black 5GHz wireless / HP backlit
Software Windows 10 / Windows 10
Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
Well dang so I need a new battery... But I'm about to replace my MB this X-Mas so
 
Joined
Jan 5, 2006
Messages
11,929 (2.08/day)
System Name Desktop / Laptop
Processor Intel i7 6700K @ 4.5GHz (1.270 V) / Intel i3 7100U
Motherboard Asus Z170 Pro Gaming / HP 83A3 (U3E1)
Cooling Noctua NH-U12A 2 fans + Thermal Grizzly Kryonaut + 5 case fans / Fan
Memory 16GB DDR4 Corsair Vengeance LPX 3000MHz CL15 / 8GB DDR4 HyperX CL13
Video Card(s) MSI RTX 2070 Super Gaming X Trio / Intel HD620
Storage Samsung 970 Evo 500GB + Samsung 850 Pro 512GB + Samsung 860 Evo 1TB x2 / Samsung 256GB M.2 SSD
Display(s) 23.8" Dell S2417DG 165Hz G-Sync 1440p / 14" 1080p IPS Glossy
Case Be quiet! Silent Base 600 - Window / HP Pavilion
Audio Device(s) SupremeFX Onboard / Realtek onboard + B&O speaker system
Power Supply Seasonic Focus Plus Gold 750W / Powerbrick
Mouse Logitech MX Anywhere 2 Laser wireless / Logitech M330 wireless
Keyboard RAPOO E9270P Black 5GHz wireless / HP backlit
Software Windows 10 / Windows 10
Well dang so I need a new battery... But I'm about to replace my MB this X-Mas so

Just replace it, it's cheap anyway and it may solve the problem and you could sell a good working motherboard.:)
 

Kursah

Super Moderator
Staff member
Joined
Oct 15, 2006
Messages
13,995 (2.57/day)
Location
Missoula, MT, USA
System Name Kursah's Gaming Rig 2018 - Ryzen+ Edition | SpartanCore | SpartanCore2
Processor R7 2700X @ Stock (3.7/4.35) w/PBO+XFR2 | i7 3770 3.4/3.9 Stock | i7 4770 3.4/3.9 Stock
Motherboard Asus ROG Strix X370-F Gaming | Intel DQ77MK | SuperMicro X10SLQ
Cooling Noctua NH-U14S Push-Pull + NT-H1 | Stock Intel Cooler + AC MX4 | Stock Intel Cooler + AC MX4
Memory 16GB (2x8) G.Skill DDR4-3200 | 16GB (4x4) Samsung DDR3-1600 | 32GB (4x8) Mushkin Stealth DDR3-1600
Video Card(s) MSI GTX980 Ti Gaming 6G LE @ Stock | Onboard Intel HD 4000 | Onboard Intel HD 4600
Storage SSD 250GB + 960GB, 1x2TB | 120GB SSD, RAID10 6x2TB (6TB) | 120GB SSD, RAID10 6x3TB (9TB)
Display(s) Samsung 32" TV IPS 1080p, Dell 23" U2312HM IPS 1080p | 19" Dell on KVM..mostly headless operation.
Case Corsair 600C - Stock Fans on Low | Lian Li Lancool PC-K7 - Cougar fans | Modified Lenovo TS430 Case
Audio Device(s) Aune T1 mk1 > AKG K553 Pro + HiFiMAN HE-350 (Equalizer APO + PeaceUI) | Not in use
Power Supply EVGA 750G2 Modular + APC Back-UPS Pro 1500 | EVGA KR500 80+ Bronze (Both) + APC Smart-UPS 1500
Mouse Logitech G502 | Dell USB Laser Mouse (KVM)
Keyboard Logitech G15 rv2 | Dell USB Keyboard (KVM)
Software Windows 10 Pro x64 | Windows Server 2012 R2 (Hyper-V) | Windows Server 2016 (Hyper-V)
Hi,

Every time I restart or go into Linux then back to Windows it always resets and I have to update it via Internet. Why?

Is your time zone set correctly in the OS? The OS has the ability to change the CMOS clock, so if you didn't setup your Windows Time correctly, then it is defaulted to Pacific Standard Time. It could also be a CMOS battery issue...but usually your time AND date will reset...so you'll see 12:00, January 1, 1979 or similar if the clock is resetting from a bad CMOS. If you shut your PC down, unplug it from the wall for say like 10 minutes, then plug back in and boot into BIOS, is your time/date wrong?
 
Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
It usually resets to like 3AM or something. I'll see if it changes though

Btw, I'm Central Day-Light Time in Alabama
 

rtwjunkie

PC Gaming Enthusiast
Supporter
Joined
Jul 25, 2008
Messages
13,906 (2.89/day)
Location
Louisiana -Laissez les bons temps rouler!
System Name Bayou Phantom
Processor Core i7-8700k 4.4Ghz @ 1.18v
Motherboard ASRock Z390 Phantom Gaming 6
Cooling All air: 2x140mm Fractal exhaust; 3x 140mm Cougar Intake; Enermax T40F Black CPU cooler
Memory 2x 16GB Mushkin Redline DDR-4 3200
Video Card(s) EVGA RTX 2080 Ti Xc
Storage 1x 500 MX500 SSD; 2x 6TB WD Black; 1x 4TB WD Black; 1x400GB VelRptr; 1x 4TB WD Blue storage (eSATA)
Display(s) HP 27q 27" IPS @ 2560 x 1440
Case Fractal Design Define R4 Black w/Titanium front -windowed
Audio Device(s) Soundblaster Z
Power Supply Seasonic X-850
Mouse Coolermaster Sentinel III (large palm grip!)
Keyboard Logitech G610 Orion mechanical (Cherry Brown switches)
Software Windows 10 Pro 64-bit (Start10 & Fences 3.0 installed)
It usually resets to like 3AM or something. I'll see if it changes though

Btw, I'm Central Day-Light Time in Alabama

Right, so like @Kursah said, what time zone is your clock in Windows set to? I have seen some machines change after a Feature update.
 

sneekypeet

Retired Super Moderator
Joined
Apr 12, 2006
Messages
28,945 (5.13/day)
System Name His
Processor Intel i9 7920X
Motherboard Asus Prime X299 Deluxe
Cooling Corsair H115i RGB Platinum
Memory Crucial Ballistix 3200MHz 64GB
Video Card(s) nVidia RTX 2080ti
Storage Samsung 960 Pro / Crucial MX300 750GB / Seagate 1TB Spinner
Display(s) Samsung 55" 4K 60hz
Case Cooler Master Cosmos C700P (Inverted Layout)
Audio Device(s) Realtek on board > Sony Receiver > Cerwin Vega's
Power Supply Thermaltake TPSG 1050W
Mouse Always Changing
Keyboard Always Changing
Software Windows 10 Pro 64
It usually resets to like 3AM or something.

Typically, if it were a flat BIOS battery, time would reset to 12:00AM, and the time and date is usually reverted to when the BIOS was made as well.

If my math is right, your clock should be set to GMT-6.
 
Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
Mine is (UTC-06:00) Central Time (US & Canada)
 
Joined
Jul 2, 2010
Messages
4,015 (0.98/day)
Location
UK
System Name PC
Processor AMD Ryzen 3600
Motherboard MSI B450 Mortar Max
Cooling Phanteks PH-TC12DX, 3 x NZXT FN 140mm, 1x NZXT FV V2 120mm
Memory 32gb DDR4 3200mhz
Video Card(s) ASUS R9 290 DCII-OC 4GB
Storage corsair mp600 1TB
Display(s) LG 27MB85Z 27" 1440p
Case NZXT Source 340
Power Supply Thermaltake 675w
Mouse Logitech G500S
Keyboard Logitech G510S
Software Windows 8.1 64 bit
Sounds like one of your OSs is using utc system clock and the other local time, change the setting in one of them.
 

peche

Thermaltake fanboy
Joined
Nov 7, 2014
Messages
6,709 (2.68/day)
Location
San Jose, Costa Rica
System Name Athenna
Processor intel i7 3770 *Dellided*
Motherboard GIGABYTE GA-Z68X-UD3H-B3 Rev. 1.1
Cooling Thermaltake Water 3.0 Pro + Tt Riing12 x2 / Tt ThunderBlade / Gelid Slim 120UV fans
Memory 16GB DRR3 Kingoston with Custom Tt spreaders + HyperX Fan
Video Card(s) GeForce GTX 980 4GB Nvidia Sample
Storage Crucial M4 SSD 64GB's / Seagate Barracuda 2TB / Seagate Barracuda 320GB's
Display(s) 22" LG FLATRON 1920 x 1280p
Case Thermaltake Commander G42 Window
Audio Device(s) On-board Dolby 5.1+ Kingston HyperX Cloud 1
Power Supply Themaltake TR2 700W 80plus bronce & APC Pro backup 1000Va
Mouse Tt eSports Level 10M Rev 1.0 Diamond Black & Tt Conkor "L" mouse pad
Keyboard Tt eSports KNUCKER
Software windows 10x64Pro
Benchmark Scores well I've fried a 775' P4 12 years ago, that counts?
Could be CMOS battery related.
i bet on this tooo, hour will be set at the moment the moment when the bios was used first time, no matter how weird this specific time could be...
 
Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
Weird... My battery keeps reseting to 20:00-8:00PM (I shutdown/Power-off the PSU) and wait 20sec and yep battery issue
 
Joined
Nov 18, 2010
Messages
5,375 (1.36/day)
Location
Rīga, Latvia
System Name HELLSTAR
Processor AMD RYZEN 5950X
Motherboard ASUS Strix X570-E
Cooling Custom Loop. Two 360ies + 280 rad. 8x Nidec Servo Gentle Typhoons. EK-Quantum Momentum monoblock.
Memory 4x8GB Corsair Vengeance LPX 3000MHz 15-15-15-36 CR1[16-18-18-32-50;TRFC560@3200MHz]]
Video Card(s) ASUS 1080 Ti FE + water block
Storage Optane 900P + Samsung PM981 NVMe 1TB + 750 EVO 500GB
Display(s) Philips PHL BDM3270 + Acer XV242Y
Case Phanteks Enthoo Evolv ATX Tempered Glass
Audio Device(s) Sound Blaster ZxR
Power Supply Fractal Design Newton R3 1000W
Mouse Razer Basilisk
Keyboard Razer BlackWidow V3 - Yellow Switch
Software Windows 11 insider
I have it too... in all my machines... haven't pinpointed what it is.
 
Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
Joined
Aug 20, 2007
Messages
15,980 (3.11/day)
System Name Pioneer
Processor Ryzen R7 5800X
Motherboard GIGABYTE Aorus Elite X570
Cooling Noctua NH-D15 + A whole lotta Sunon and Corsair Maglev blower fans...
Memory G.SKILL Ripjaws V Series 64GB (4 x 16GB) DDR4-3200
Video Card(s) EVGA GeForce RTX 3070 FTW3
Storage 2x Mushkin Pilot-E 2TB NVMe SSDs in RAID0
Display(s) 55" LG 55" B9 OLED 4K Display
Case Thermaltake Core X31
Audio Device(s) VGA HDMI->LG B9 OLED/Schiit Modi MB/Asgard 2 DAC/Amp to AKG Pro K712 Headphones
Power Supply Seasonic Prime Titanium 750W
Mouse Razer Deathadder v2
Keyboard Unicomp Model-M Keyboard
Software Windows 10 Enterprise (Product of work, yes it's legit)
Benchmark Scores www.3dmark.com/fs/25631365 www.3dmark.com/spy/20539287 www.3dmark.com/pr/1054199
It's Local Time vs UTC clock timekeeping, as @cheesy999 guessed.
 
Joined
Feb 23, 2016
Messages
55 (0.03/day)
Location
Manchester, England.
System Name Latest.
Processor AMD RYZEN 3900x
Motherboard Asus ROG STRIX X570-F GAMING (AM4)
Cooling Noctua NH-U12A
Memory 16Gb Team Group DDR4@3600mhz
Video Card(s) Palit RTX 3070 GamingPro
Storage 1Tb Corsair MP600 Samsung SSD 850 EVO 250Gb. Samsung SSD 960 1Tb and 2 x ST2000DX001-1CM64
Display(s) Iiyama G-Master GB2888UHSU
Case Cooler Master
Audio Device(s) Sound Blaster Z
Power Supply EVGA 850 Gold
Mouse Zelotes T-90
Keyboard Tecknet
Software W10 pro
I`ve had the same thing going on since the Creators Update, update not a clean install. I dual boot with Linux Mint which sets the right time, got a virtual W10 Insider Preview running in Mint that`s always got the correct time. Normal w10 an hour wrong every time. I even stopped my vpn from auto connecting, which made no difference. Haven`t tried a clean install yet.
 
Joined
Nov 28, 2012
Messages
1,978 (0.61/day)
System Name BoX-Server | 775PC
Processor I3 3.5GHZ (3150) | Modded Xeon E5450 (OC @3.60)
Motherboard ASRock B85M-ITX | ASUS P5Q-EM
Cooling stock | 92MM Heatsink RGB
Memory 8GB DDR3 | 8GB DDR2
Video Card(s) AMD 5450 | XFX GTX750Ti 2GB
Storage 120GB SSD 1TB WD | 120GB SSD 1TB Seagate 500GB HDD <<
Display(s) DELL 17" LCD 1280x1024 | ASUS 24" LCD IPS
Case CoolerMaster 110 | RoseWill ZIRCON
Audio Device(s) Onboard
Power Supply Rosewill 610WATT | Rosewill 550WATT
Mouse Input-Director| RoseWill FUSION C40
Keyboard Input-Director | RoseWill FUSION
Software Windows 10 Pro 64-Bit
Hmm does the Windows Media-Tool come with the update installed in the Latest ISO Build?
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.53/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
I`ve had the same thing going on since the Creators Update, update not a clean install. I dual boot with Linux Mint which sets the right time, got a virtual W10 Insider Preview running in Mint that`s always got the correct time. Normal w10 an hour wrong every time. I even stopped my vpn from auto connecting, which made no difference. Haven`t tried a clean install yet.
My guess is one of them isn't/is counting Daylight Savings Time (CST versus CDT). It's easier to get that wrong in Linux than Windows.


Hmm does the Windows Media-Tool come with the update installed in the Latest ISO Build?
How many hours off are we talking? Windows defaults to Pacific. (-8 GMT)
 
Last edited:
Joined
Feb 23, 2016
Messages
55 (0.03/day)
Location
Manchester, England.
System Name Latest.
Processor AMD RYZEN 3900x
Motherboard Asus ROG STRIX X570-F GAMING (AM4)
Cooling Noctua NH-U12A
Memory 16Gb Team Group DDR4@3600mhz
Video Card(s) Palit RTX 3070 GamingPro
Storage 1Tb Corsair MP600 Samsung SSD 850 EVO 250Gb. Samsung SSD 960 1Tb and 2 x ST2000DX001-1CM64
Display(s) Iiyama G-Master GB2888UHSU
Case Cooler Master
Audio Device(s) Sound Blaster Z
Power Supply EVGA 850 Gold
Mouse Zelotes T-90
Keyboard Tecknet
Software W10 pro
I`ve tried altering all the settings I can to fix in W10. Linux and virtual W10 are right every time. It`s only out 1 hour for me.

The media creation tool downloads the creators update.
 

FordGT90Concept

"I go fast!1!11!1!"
Joined
Oct 13, 2008
Messages
26,147 (5.53/day)
Location
IA, USA
System Name BY-2015
Processor Intel Core i7-6700K (4 x 4.00 GHz) w/ HT and Turbo on
Motherboard MSI Z170A GAMING M7
Cooling Scythe Kotetsu
Memory 2 x Kingston HyperX DDR4-2133 8 GiB
Video Card(s) Sapphire Radeon RX 5500 XT Pulse 8 GiB
Storage Crucial MX300 275 GB, Seagate Exos X12 TB 7200 RPM
Display(s) Nixeus NX-EDG274K (3840x2160@144 DP) + Samsung SyncMaster 906BW (1440x900@60 HDMI-DVI)
Case Coolermaster HAF 932 w/ USB 3.0 5.25" bay
Audio Device(s) Realtek ALC1150, Micca OriGen+
Power Supply Enermax Platimax 850w
Mouse SteelSeries Sensei RAW
Keyboard Tesoro Excalibur
Software Windows 10 Pro 64-bit
Benchmark Scores Faster than the tortoise; slower than the hare.
I'd boot one, check the BIOS time, boot the other, check the BIOS time. Isolate which one is actually changing the time.

What might be happening is that one is doing system time +1 hour where the other does system time += 1 hour. So one updating the system clock may be breaking the other. If that's the case, there really is no fixing it.

BIOS time should always be correct.
 
Top