1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Windows 7 Professional & Windows XP Pro Networking

Discussion in 'Networking & Security' started by computersolutions, Nov 12, 2009.

  1. computersolutions New Member

    Joined:
    Nov 12, 2009
    Messages:
    14 (0.00/day)
    Thanks Received:
    0
    Location:
    Wisconsin
    Hell, I am new to TPU forums so bear with me :). We had a time clock program that we used on Windows XP Pro that required the Data folder of the program (in program files) to be shared (by the host computer) and mapped to (by the client computers). We are now using 3 Windows 7 PC's and 2 Windows XP PC's. The Host Computer (Server) for this program is now on a Windows 7 machine, I am able to share the directory and map to it on the other 2 Windows 7 machines. My problem is I can see the directory on the 2 Windows XP machines but the XP machines won't allow me into the folder...access denied, make sure you have permission.

    As I said i'm new to the TPU forums (although I have been watching this site for a long time now) I will be greatful for any help anyone can provide. (Let me know if you need any more info)

    Mike
     
  2. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,817 (3.53/day)
    Thanks Received:
    5,629
    Location:
    Cheeseland (Wisconsin, USA)
    If the computers are in a workgroup, make sure that the workgroup names are the same for all machines. When MS went from XP to Vista, they changed the default workgroup name.
     
    10 Year Member at TPU
  3. computersolutions New Member

    Joined:
    Nov 12, 2009
    Messages:
    14 (0.00/day)
    Thanks Received:
    0
    Location:
    Wisconsin
    All of the computers are part of the same workgroup, I do a fair amount of computer work, but as you can imagine I haven't run across this problem yet (Windows 7 and all :p). Anything else you can suggest?
     
  4. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,817 (3.53/day)
    Thanks Received:
    5,629
    Location:
    Cheeseland (Wisconsin, USA)
    The only other thing I can think of is that when you share a folder there are two sets of permissions. Permissions on the folders/files themselves, and also permissions on the shares.
    Make sure the accounts on the XP computers have both file/folder access and also share access.

    I don't have a machine running 7, so I can't test it out here.

    Oh ... and Welcome to TPU !! :toast:
     
    10 Year Member at TPU
  5. computersolutions New Member

    Joined:
    Nov 12, 2009
    Messages:
    14 (0.00/day)
    Thanks Received:
    0
    Location:
    Wisconsin
    I went into advanced sharing and set the share to EVERYONE with full read/write permissions & also shared the folder on the network. I can access the folder and do what I need to on the other Windows 7 PC's just not the Windows XP ones. This program was used the same way before, just that the "server computer" was one of the XP machines. When it was done this way i could access the folder on all computers (XP & Windows 7).

    On another note the reason i'm even changing this in the first place is that the newest Windows 7 computer we have is the new "main" computer.

    Thanks for all the help so far :)

    Thanks Kreij :D
     
  6. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,817 (3.53/day)
    Thanks Received:
    5,629
    Location:
    Cheeseland (Wisconsin, USA)
    I use domains at work and early on discovered that "Everyone" does not mean everyone.
    Try giving each account full control access instead of using "Everyone".
     
    10 Year Member at TPU
  7. computersolutions New Member

    Joined:
    Nov 12, 2009
    Messages:
    14 (0.00/day)
    Thanks Received:
    0
    Location:
    Wisconsin
    There are 40 types of user accounts in Windows 7 :eek: :banghead: /cry
     
  8. Kreij

    Kreij Senior Monkey Moderator Staff Member

    Joined:
    Feb 6, 2007
    Messages:
    13,817 (3.53/day)
    Thanks Received:
    5,629
    Location:
    Cheeseland (Wisconsin, USA)
    I know what you mean. lol
    I'm not sure and I am just guessing here. Maybe try "Authenticated Users" with full permissions.
     
    10 Year Member at TPU
  9. kuroikenshi

    kuroikenshi

    Joined:
    Jun 26, 2008
    Messages:
    298 (0.09/day)
    Thanks Received:
    49
    Location:
    Japan
    Check your firewall settings and turn them off! If the firewall is up on either machine, you will see the computer there but you will not be able to access it.
     
  10. newtekie1

    newtekie1 Semi-Retired Folder

    Joined:
    Nov 22, 2005
    Messages:
    24,090 (5.53/day)
    Thanks Received:
    10,262
    Location:
    Indiana, USA
    Make sure you have also given the proper permissions under the security tab.
     
    computersolutions says thanks.
    10 Year Member at TPU Crunching for Team TPU More than 25k PPD
  11. p_o_s_pc

    p_o_s_pc F@H&WCG addict

    Joined:
    May 2, 2007
    Messages:
    13,002 (3.40/day)
    Thanks Received:
    2,189
    Location:
    Newark ohio
    make sure the password protected sharing is off so it just shares everything without a password.. Thats how i got mine to work using win 7 Ult. and XP pro
     
    10 Year Member at TPU
  12. computersolutions New Member

    Joined:
    Nov 12, 2009
    Messages:
    14 (0.00/day)
    Thanks Received:
    0
    Location:
    Wisconsin
    Thanks for all the suggestion guys. :) It wasn't the user account type that was giving me the issue. I had the permissions set correctly, it's just that i didn't have the second place changed. (The Security Tab) Even though I had it changed in the sharing to Everyone & Full Control I also needed to change the Security tab to match these setting (odd and annoying but at least I know this now)...thanks NEWTEKIE1 for that :D

    Thanks everyone else for the posts, but I had everything done I needed to do besides the post that newtekie1 had.

    Thanks a lot everyone
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)