• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Windows 7 x64 on Z490

Joined
Aug 3, 2011
Messages
1,073 (0.30/day)
Location
Walkabout Creek
System Name Halley's Comet
Processor 10900KF
Motherboard Z490 Vision D
Cooling EK CPU Hardline
Memory 2x8GB Gskill Royal
Video Card(s) 6800 XT Merc
Storage M.2 980 Pro 1TB
Display(s) Gigabyte G34WQC 34
Case Corsair 750D
Audio Device(s) Onboard
Power Supply Corsair AX1200
Mouse Asus Gladius
Keyboard Logitech G910
Software Win 10 x64 atm
Benchmark Scores It Chops : )
Hi guys,

I have been able to port my Win 7 x64 (from Z370) on an Asus TUF Z490. I have been having some problems installing the Lan and USB's. I have done a temporary fix buy installing a Lan card (will hardly ever use anyways) and a USB 3.0 card to get the Mouse and Keyboard going.

Now Id ideally like to get these two functions working without installing third party hardware/software.

Here is what I've done so far with the Lan. I've got it close to working but no quite...

I've followed this thread here: Windows 7 installed on z490E need working LAN driver Solved - Windows 7 Help Forums (sevenforums.com)

So I've modded the inf file but its only partially working : (

Devive.png


LAn.png


This is what happens when I manually install via device manager.

Update.png


And when I got to install the Chipset Driver/Lan etc

Install.png


Ok now for anybody wondering why I'm running Windows 7 its because all my older games run better and don't have issue's especially when they are unpatched. I also got plenty of Win 10 installs around the house.

So can anybody here help me get the USB's working and Lan? Is it a simple case of modifying the INF files? I'm not a big fan of running 3rd party Hardware/Software and like less clutter inside the HTPC case.

I have seen some threads where they have been able to get all things working on Win 7/Z490 and I've tried my best but will need some help from here unfortunately.

Thanks in advance : )
 
Joined
Oct 15, 2011
Messages
415 (0.12/day)
Location
Springfield, Vermont
System Name KHR-1
Processor Ryzen 7 3700X with Fclk and Uclk at 1:1
Motherboard MSI B450 Tomahawk
Memory 16 GB Corsair Vengeance LPX 3000 in XMP mode
Video Card(s) MSI Gaming X Radeon RX5600XT
Storage Samsung 970 Pro 512 GB NVMe SSD
Display(s) Acer KG271U bmiippx
Case Corsair 275R
Power Supply eVGA Supernova G3 750W
Mouse Logitech Pro (Hero)
Software Windows 10 x64 20H2
Hi guys,

I have been able to port my Win 7 x64 (from Z370) on an Asus TUF Z490. I have been having some problems installing the Lan and USB's. I have done a temporary fix buy installing a Lan card (will hardly ever use anyways) and a USB 3.0 card to get the Mouse and Keyboard going.

Now Id ideally like to get these two functions working without installing third party hardware/software.

Here is what I've done so far with the Lan. I've got it close to working but no quite...

I've followed this thread here: Windows 7 installed on z490E need working LAN driver Solved - Windows 7 Help Forums (sevenforums.com)

So I've modded the inf file but its only partially working : (

View attachment 199423

View attachment 199425

This is what happens when I manually install via device manager.

View attachment 199426

And when I got to install the Chipset Driver/Lan etc

View attachment 199427

Ok now for anybody wondering why I'm running Windows 7 its because all my older games run better and don't have issue's especially when they are unpatched. I also got plenty of Win 10 installs around the house.

So can anybody here help me get the USB's working and Lan? Is it a simple case of modifying the INF files? I'm not a big fan of running 3rd party Hardware/Software and like less clutter inside the HTPC case.

I have seen some threads where they have been able to get all things working on Win 7/Z490 and I've tried my best but will need some help from here unfortunately.

Thanks in advance : )
Why the heck is there an archaic 16-bit stub for the installer?!
 
Joined
Aug 21, 2015
Messages
373 (0.18/day)
Location
North Dakota
System Name Oswald
Processor i7-9700K
Motherboard MSI Z370-A PRO
Cooling be quiet! Pure Rock 2
Memory 16GB Patriot DDR4-3200
Video Card(s) Sapphire RX 470 8GB
Storage Samsung SM961 256GB, Toshiba DT01ACA200
Display(s) Sharp 46" TV
Case Antec Sonata SOLO
Power Supply Seasonic SSR-450RM
Mouse Logitech M185
Keyboard Some wireless Microsoft thing with a trackpad
Software Windows 10 Home
Benchmark Scores Cinebench R15: 1398
Have you tried the standalone Ethernet driver for Win7?

My next thought was trying 8.1 drivers for the chipset, but they do. Not. Appear. To. Exist. No manufacturer that I can find supplies 8.1 drivers for Z490 boards, and you can't even find standalone packages at Intel Download Center. :confused: The next thing to try would be to extract the chipset drivers and point device manager at the folder. If you haven't already, that is.
 
Joined
Aug 3, 2011
Messages
1,073 (0.30/day)
Location
Walkabout Creek
System Name Halley's Comet
Processor 10900KF
Motherboard Z490 Vision D
Cooling EK CPU Hardline
Memory 2x8GB Gskill Royal
Video Card(s) 6800 XT Merc
Storage M.2 980 Pro 1TB
Display(s) Gigabyte G34WQC 34
Case Corsair 750D
Audio Device(s) Onboard
Power Supply Corsair AX1200
Mouse Asus Gladius
Keyboard Logitech G910
Software Win 10 x64 atm
Benchmark Scores It Chops : )
Have you tried

I just downloaded and installed via your link and the adaptor still comes up with (code 39) sadly :(. It did install with no problems though is a positive.

I will take the other Lan adaptor (Realtek PCIe) out later today and try as it might have just updated that one but I would assume it should have installed the driver for both of them.

Thanks matey ;)

Edit: Pointed the device manager at those drivers and get the "Windows has determined the driver software for your device is up to date" message as pictured in my third picture.
 
Last edited:
Joined
Aug 21, 2015
Messages
373 (0.18/day)
Location
North Dakota
System Name Oswald
Processor i7-9700K
Motherboard MSI Z370-A PRO
Cooling be quiet! Pure Rock 2
Memory 16GB Patriot DDR4-3200
Video Card(s) Sapphire RX 470 8GB
Storage Samsung SM961 256GB, Toshiba DT01ACA200
Display(s) Sharp 46" TV
Case Antec Sonata SOLO
Power Supply Seasonic SSR-450RM
Mouse Logitech M185
Keyboard Some wireless Microsoft thing with a trackpad
Software Windows 10 Home
Benchmark Scores Cinebench R15: 1398
I just downloaded and installed via your link and the adaptor still comes up with (code 39) sadly :(. It did install with no problems though is a positive.

I will take the other Lan adaptor (Realtek PCIe) out later today and try as it might have just updated that one but I would assume it should have installed the driver for both of them.

Thanks matey ;)

Edit: Pointed the device manager at those drivers and get the "Windows has determined the driver software for your device is up to date" message as pictured in my third picture.

That makes sense for the ethernet driver, as the link was for the final Win7 release. Apologies if I'm misunderstanding what you have and have not tried, but did "point Device Manager at folder" work for the other unidentified devices? (simple communications, USB controller, unknown device)
 
Joined
Aug 3, 2011
Messages
1,073 (0.30/day)
Location
Walkabout Creek
System Name Halley's Comet
Processor 10900KF
Motherboard Z490 Vision D
Cooling EK CPU Hardline
Memory 2x8GB Gskill Royal
Video Card(s) 6800 XT Merc
Storage M.2 980 Pro 1TB
Display(s) Gigabyte G34WQC 34
Case Corsair 750D
Audio Device(s) Onboard
Power Supply Corsair AX1200
Mouse Asus Gladius
Keyboard Logitech G910
Software Win 10 x64 atm
Benchmark Scores It Chops : )
work for the other unidentified devices?

No. I have manually tried each one from device manager with no success. So to clarify, I will Right click my comp, manage, device manger and from each device update manually by searching for specified folder/ driver. Is this what you mean?
Thanks.
 
Joined
Aug 21, 2015
Messages
373 (0.18/day)
Location
North Dakota
System Name Oswald
Processor i7-9700K
Motherboard MSI Z370-A PRO
Cooling be quiet! Pure Rock 2
Memory 16GB Patriot DDR4-3200
Video Card(s) Sapphire RX 470 8GB
Storage Samsung SM961 256GB, Toshiba DT01ACA200
Display(s) Sharp 46" TV
Case Antec Sonata SOLO
Power Supply Seasonic SSR-450RM
Mouse Logitech M185
Keyboard Some wireless Microsoft thing with a trackpad
Software Windows 10 Home
Benchmark Scores Cinebench R15: 1398
No. I have manually tried each one from device manager with no success. So to clarify, I will Right click my comp, manage, device manger and from each device update manually by searching for specified folder/ driver. Is this what you mean?
Thanks.

Yup. Sounds like you're way ahead of me. :) That's the extent of my ideas, though... :(
 
Top