• We've upgraded our forums. Please post any issues/requests in this thread.

WinXP Pro SP3 --- AMD Radeon R7 260X card - is this normal?

Joined
Apr 28, 2011
Messages
501 (0.21/day)
Likes
61
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2xCorsair SSDs in RAID0+3 HDDs/2xIntel SSDs in RAID0+3 HDDs/Intel 480GB SSD+5+3TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Windows 10 Pro 64-bit Ver.1709 Fall Creators Update (Build 17025.1000, Insider Preview)
#1

Does not seem OK to me. I mean the missing OpenCL and DirectCompute checkboxes.
System has an Intel E2200 CPU, 2 GB of RAM, Gigabyte mobo, WinXP Pro SP3 32-bit, latest non-Beta AMD Radeon drivers.
If you need more info on my config/specs, please tell me.
 
Last edited:
Joined
Apr 19, 2009
Messages
783 (0.25/day)
Likes
961
Location
Romania
System Name Asus ROG G752VY
Processor i7-6700HQ
Memory 24GB DDR4 2133mhz
Video Card(s) nvidia 980m
Storage Samsung SSD 850 pro 2TB+1tb hdd 7200rpm
Software Mageia 6 + Windows 10
#2
My advice, go with win 7, from my experience the new hardware have a joke drivers for xp...
 
Joined
Aug 11, 2011
Messages
4,335 (1.87/day)
Likes
3,020
Location
Mexico
System Name STEAMBOX | GAMECUBE | EQC (Everyday Quad Core)
Processor i5 4590@3.7Ghz |i7 3770K@4Ghz -|- Athlon 5350@2.52Ghz
Motherboard GA-B85N PHOENIX | Asrock Z77E-ITX | Asus AM1I-A
Cooling Stock | Antec Kuhler 620 | Reeven Vanxie
Memory 2x4GB ADATA XPG 1600Mhz | 2x4GB Kingston 1866Mhz -|- 2x4GB Crucial Ballistix@1920Mhz
Video Card(s) RX 480 Nitro | Sapphire RX 480 w/Accelero Mono Plus | HD 8400 @ 720Mhz (IGP)
Storage LiteON 128GB mSATA+3TB Seagate | Seagate 1TBxSamung 64GB SSD (Intel RST) | Kingston v300 240GB
Display(s) Daewoo 49" 1080p | ASUS PA248Q 1920x1200 IPS
Case Corsair 250D | CoolerMaster Elite 110 | Acteck Fiji
Audio Device(s) Onboard
Power Supply Seasonic SS-660XP2 | Silverstone SFX-450 | 200w mini FLEX PSU
Software Windows 10 64bit
#3

Does not seem OK to me. I mean the missing OpenCL and DirectCompute checkboxes.
System has an Intel E2200 CPU, 2 GB of RAM, Gigabyte mobo, WinXP Pro SP3 32-bit, latest non-Beta AMD Radeon drivers.
If you need more info on my config/specs, please tell me.
Windows XP doesn't have DX11 so yes, this is normal.
 
Joined
Apr 28, 2011
Messages
501 (0.21/day)
Likes
61
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2xCorsair SSDs in RAID0+3 HDDs/2xIntel SSDs in RAID0+3 HDDs/Intel 480GB SSD+5+3TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Windows 10 Pro 64-bit Ver.1709 Fall Creators Update (Build 17025.1000, Insider Preview)
#4
My advice, go with win 7, from my experience the new hardware have a joke drivers for xp...
I am using Windows 8.1 32-bit on the same computer, but it failed with a "rug display" after one of the latest Windows Updates. Until I fix that, I need to use WinXP for now.
 
Joined
Apr 28, 2011
Messages
501 (0.21/day)
Likes
61
Location
Botevgrad, Bulgaria, Europe
System Name Main PC/OldPC/3rd PC
Processor Intel Core i7-3770K Ivy Bridge/Core i5-3470 Ivy Bridge/Core i3-4330 Haswell
Motherboard ASUS P8Z77-V/ASRock Z68 Pro3 Gen1/ASUS H81M2
Cooling Cooler Master Hyper 212 EVO
Memory 32GB Corsair Vengeance/32GB ADATA/16GB ADATA
Video Card(s) SAPPHIRE R9 290 Tri-X OC 4GB/MSI RX 480 8GB/SAPPHIRE R9 390 8GB
Storage 2xCorsair SSDs in RAID0+3 HDDs/2xIntel SSDs in RAID0+3 HDDs/Intel 480GB SSD+5+3TB HDDs
Display(s) Philips 274E5QHAB@HDMI + Philips 273EQH@DVI (both 27")
Case Fractal Design Define R4 Titanium
Audio Device(s) Kenwood Mini HiFi system/Microlab speakers/Philips HDMI (main)+LG TV monitor HDMI + Apple headphones
Power Supply Cooler Master Silent ProM 600 W (modular)
Mouse Microsoft Ergonomic Sculpt Desktop 2.0 (combo)@Razer Goliath mousepad (Medium speed)
Keyboard Microsoft Ergonomic Sculpt Desktop 2.0 (combo)
Software Windows 10 Pro 64-bit Ver.1709 Fall Creators Update (Build 17025.1000, Insider Preview)
#5
Windows XP doesn't have DX11 so yes, this is normal.
Do you mean to say DirectCompute and OpenCL are DirectX dependent? Did not know that.

IIRC, a GeForce card on the same PC showed them fine.
 
Joined
Aug 11, 2011
Messages
4,335 (1.87/day)
Likes
3,020
Location
Mexico
System Name STEAMBOX | GAMECUBE | EQC (Everyday Quad Core)
Processor i5 4590@3.7Ghz |i7 3770K@4Ghz -|- Athlon 5350@2.52Ghz
Motherboard GA-B85N PHOENIX | Asrock Z77E-ITX | Asus AM1I-A
Cooling Stock | Antec Kuhler 620 | Reeven Vanxie
Memory 2x4GB ADATA XPG 1600Mhz | 2x4GB Kingston 1866Mhz -|- 2x4GB Crucial Ballistix@1920Mhz
Video Card(s) RX 480 Nitro | Sapphire RX 480 w/Accelero Mono Plus | HD 8400 @ 720Mhz (IGP)
Storage LiteON 128GB mSATA+3TB Seagate | Seagate 1TBxSamung 64GB SSD (Intel RST) | Kingston v300 240GB
Display(s) Daewoo 49" 1080p | ASUS PA248Q 1920x1200 IPS
Case Corsair 250D | CoolerMaster Elite 110 | Acteck Fiji
Audio Device(s) Onboard
Power Supply Seasonic SS-660XP2 | Silverstone SFX-450 | 200w mini FLEX PSU
Software Windows 10 64bit
#6
DirectCompute is DX dependant yes, it was introduced with DX11.

OpenCL isn't but I'd guess that the Catalyst suite doesn't install OpenCL drivers with DX9. When you installed the drivers, did the Catalyst installer list the OpenCL drivers?

Check if you have these in your system:

SlotMaximizerBe.dll
SlotMaximizerAg.dll
amdocl.dll
OpenCL.dll
OpenVideo.dll
OVDecode.dll