• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Witcher 3 Stutter RTX 2080

JustVintage

New Member
Joined
Jun 26, 2020
Messages
2 (0.15/day)
My System in a nutshell: Ryzen 3700x, ASUS TUF Gaming X570-Plus, NH D15, 32gb Crucial Ballistix Sport LT3200@3733 CL16, Xilence Performance X 650W, MSI RTX 2080 Aero with an Accelero Xtreme III @2020mhz core / +600mhz ram and a G-sync screen

Windows 10 Enterprise 20H2 Build 19042

Running the game from a Samsung PCIE3 m.2 SSD.

With and without mods i get stutters. Framerates consistently around 80fps at highest settings.
Tried changing Low latency mode to ultra, completely re-installing driver and deleting previous settings, uninstalled geforce experience, disabled steam overlay, disabled any anti virus, updated bios, closed every window in the background, got 25% free space on ssd, updated afterburner.

I am officially out of ideas now.
 
Joined
Jan 5, 2016
Messages
31 (0.02/day)
Processor AMD R9 3900x
Motherboard Asrock Fatal1ty x470 Gaming-itx/ac
Cooling Corsair H110
Memory 2x16GB G.Skill TridentZ Neo DDR4 3733 C14
Video Card(s) Nvidia Titan RTX with EVGA Hybrid Kit
Storage Intel 660p 2TB NVMe(OS), two 5TB HDDs
Display(s) Dell U3415W (3840x1600)
Case Sliger Cerberus X
Power Supply Corsair SF750 Platinum
Mouse Corsair Vengeance M65
Keyboard Corsair Gaming K70 RGB
Software Windows 10 Pro 64-bit
I've had stutters in a few games over the years, never in Witcher 3 though. Generally, I've fixed the stutter by either changing the Power management mode to "Prefer Maximum Performance" in the Nvidia control panel, or setting a frame-rate limit in Rivatuner. Keep in mind I play on a 60hz monitor without Freesync or Gsync.
 
Top