1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

XFX 5850 dead or not after flash unlocked bios

Discussion in 'AMD / ATI' started by The_good_German, Oct 30, 2011.

  1. The_good_German

    The_good_German New Member

    Joined:
    Oct 30, 2011
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    UPDATE:

    Just found out that the HD-585X-ZAFC is a non reference card with cooler in the middle. So the questions is, do i need a special bios for non reference cards?


    Hello Folks,

    First of all, you guys have a great forum with some smart people. I used your wisdom several times already and now it seems to be to difficult to find an answer for my current problem:

    I do have;
    • biostar tp67xe
    • sandy 2600k at 4.3 ghz
    • 2x 4 gb corsair 2000 mhz ddr3
    • 1 HIS 5850 with Asus unlock bios
    • 1 xfx 5850 with asus unlock bios
    • 950 W silencer mk3 pc power and cooling 1x 12v rail

    I always use atiflash -p -f (index) from a bootable usb stick.

    Here is what I planned:
    I did order the xfx hd 5850 card 1 week ago and was running my system with the his card just fine and slightly oc'ed with msi AB.

    Off cause I wanted to play BF3 in Ultra with at least 40 fps average so I had to crossfire my HIS with the ordered XFX card. :D

    Here is what I did so far:
    1. replaced his card with xfx card to check function
    2. ran furmark on xfx with locked bios =fine
    3. wanted to unlock xfx card with atiflash and put the asus unlock bios on it
    4. after flash was done card has been rebooted and black screen, no bios beep either:banghead:
    5. i was waiting 30 sec and nothing happened, also no " no video signal window" just black screen:cry:
    6. took xfx into pci e slot 2 and his card back into 1 and put crossfire connector on it.
    7. system is booting and gpuz recognizes both cards but:
      XFX card misses a lot of information in Everest and gpuz compared to HIS card. see attached screenshots:

    I also downloaded the XFX stock rom from your DL section and flashed this one with no improvement. (system won't start up)


    I hope that you guys can help me determine if my XFX card is dead or if it is fixable.:respect:

    Thanks in advance.

    The good German
     

    Attached Files:

    Last edited: Oct 30, 2011
  2. theoneandonlymrk

    theoneandonlymrk

    Joined:
    Mar 10, 2010
    Messages:
    4,258 (1.63/day)
    Thanks Received:
    1,100
    Location:
    Manchester uk
    v2 and later are not refference versions so refference bioses wont work, ive not botherred however and can overclock beyond its limits still using saphire trixx with ULPS disabled in settings, id try force flashing it again it might not have worked right the second time , could be blown tho.

    forget about bioses i flashed my 5870 but my 5850 didnt need anymore then saphire trixx
     
    Crunching for Team TPU More than 25k PPD
  3. The_good_German

    The_good_German New Member

    Joined:
    Oct 30, 2011
    Messages:
    10 (0.00/day)
    Thanks Received:
    0


    Thanks for the response mrk. I want to know for sure if its blown? You saw the weird clocks (gpu 3400MHZ) in the gpuz screenshot and the missing info for rop's and texture.

    I do need a stock bios to be sure whether or not its broken.

    Here are the detailed card infos:
    HD-585x - ZA HD -585x -ZAFC V4.1
    Lets hope someone can help me with that.

    Oh and btw;

    The computer will start up all the way into windows as long as I have no driver installed. If I install a driver and have both cards in, the screen will turn black after the windows 7 spheres and before the pw screen.

    The good German

    Just received the stock bios for this card from XFX. Will let you know if that fixes my problem.
     
    Last edited: Oct 31, 2011
  4. The_good_German

    The_good_German New Member

    Joined:
    Oct 30, 2011
    Messages:
    10 (0.00/day)
    Thanks Received:
    0
    stock bios worked fine an the card is running again ...

    :toast:

    Will upload the stock bios....
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)