1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Acer 8920G screen Blank Urgent Help needed!!!

Discussion in 'General Hardware' started by Greek, Aug 27, 2010.

  1. Greek

    Greek New Member

    Joined:
    Oct 23, 2006
    Messages:
    572 (0.20/day)
    Thanks Received:
    3
    Location:
    Leicester, UK
    Hey guys, god its ben long since i posted here. I have a very annoying problem, a couple of months ago i ordered a battery of ebay for my laptop which fitted perfectly but turned out to be the wrong mAh, so as it was plugged itn it worked for 20 mins the the screen went really blank, i could just about see the windows that i had opened then it turned off, now ever since i got the original batterry and pluged it in it worked fine, but now my screen everytime i turn on my computer goes blank, the comes on again just before the login screen, to get it on i have to press fn +f6 but that keeps it on for 3 secs then it goes off again, sometimes it decides to work, but 90% of the time im there for half an hour pressing those two keys hoping it will stay on, so now to use it i have connected it to the TV with the HDMI cable and it works fine, please advice me on what to do or which seems to be the problem, im currently in greece for my gap year and im sure i will pay a fortune to sort it out as it's out of warranty but never the less if i at least had an idea of what the problem is i cud save a few quid/bucks.

    I have alo uploaded a video on rapidshare for anyone who wishes to see exactly what i mean.

    http://rapidshare.com/files/415527288/Acer8920g.mp4.html

    Any help or advice would be appreciated.

    Regards
    greg
  2. Greek

    Greek New Member

    Joined:
    Oct 23, 2006
    Messages:
    572 (0.20/day)
    Thanks Received:
    3
    Location:
    Leicester, UK
    Bump!!!
  3. kurosagi01

    kurosagi01

    Joined:
    Mar 21, 2009
    Messages:
    4,121 (2.13/day)
    Thanks Received:
    415
    Location:
    Northampton,UK
    I think the issue with your Acer laptop is that it could be the LCD on the laptop itself is either faulty or the ribbons that connects it to the mainboard came off or broke now,if it works on a external display then it must be either the screen itself of the laptop or the ribbons thats connecting to the screen of the motherboard hope this helps.
  4. Greek

    Greek New Member

    Joined:
    Oct 23, 2006
    Messages:
    572 (0.20/day)
    Thanks Received:
    3
    Location:
    Leicester, UK
    hey,
    thanks for the reply, i think that too, that it might be the screen or at least the cable, i mean its weird because at the minute im on the laptop and its turned on fine and it hasn't turned off. so wouldn't you say if it was the screen it wouldn't work what so ever. But I'm thinking its the cable loose or something and sometimes it gets a good connection sometimes it dont.

    Can i replace the ribbons or buy new ones?> and would you say are they easy to fit in.
  5. 95Viper

    95Viper

    Joined:
    Oct 12, 2008
    Messages:
    4,287 (2.04/day)
    Thanks Received:
    1,531
    Location:
    στο άλφα έως ωμέγα
  6. Greek

    Greek New Member

    Joined:
    Oct 23, 2006
    Messages:
    572 (0.20/day)
    Thanks Received:
    3
    Location:
    Leicester, UK
    hey,

    Thanks for the reply, im a bit scared of updating my BIOS because if it goes wrong im really screwed, im on Linux so the only way its to do it through DOS, and i don't think thats where the problem lies.
  7. simon_ski New Member

    Joined:
    Nov 20, 2010
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    ok folks,

    I think I have managed to solve this problem

    POWER ON THE LAPTOP

    whilst its booting up, you can use the FOLLOWING KEYS TO see picture on the screen:

    FN + F6

    Whilst its booting, also HIT F2, once your in the bios

    Go to:

    EXIT > LOAD SETUP DEFAULTS

    EXIT SAVING CHANGES > SELECT YES

    It should then reboot and ... now its working...SO FAR.

    After doing this, the screen stays on, operating system loads up fine.

    And I have done approx 10 restarts and also approx 5 power downs and then power on.

    Hope this helps


    :D
  8. mushy99 New Member

    Joined:
    Mar 14, 2011
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    ****- fix fix fix fix fix fix fix -****

    Confirmed that the BIOS is the issue. It gets corrupted. :)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page