1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

BIOS Mod for 5850

Discussion in 'AMD / ATI' started by mudy, Jan 10, 2010.

  1. mudy New Member

    Joined:
    Aug 13, 2009
    Messages:
    15 (0.01/day)
    Thanks Received:
    0
    Hey guys,

    I just got this Gigabyte Radeon 5850 (coz that was the only one available) because I read in many forums that you can OC this card atleast 800MHz without increasing the voltage. Hence, I downloaded these files to mod my BIOS:

    1. ATIWinFlash v2.0.1.7
    2. ATIFlash v3.79
    3. RBE v1.22
    4. ATITool v0.26

    But number 1, 2 and 4 doesn't work at all. I get error messages in ATIWinFlash when I link and run through RBE. But if i run the app standalone doesn't come up with anything. Regarding the ATIFlash, I get the error message file not found in the path (path = where I have the file). All files are being run under "admin" mode. Last but not the least the ATITool cannot install the driver properly no matter what I do and hence, when I run the tool comes up with nothing i.e. all the information box are blank!!!

    Are these typical or I have done something foolishly wrong?? any help will be much appreciated.

    My Spec:

    Core i7 920 D0 @4.2GHz on Air.
    EVGA Classified 760
    Gigabyte Radeon HD5850 x1 (Planning to crossfire if I can OC)

    thx in advance
  2. Mistral

    Mistral

    Joined:
    Feb 23, 2008
    Messages:
    397 (0.17/day)
    Thanks Received:
    58
    Location:
    Montreal
    If the over 775 overclock is what you're after, at least for now, you might have a better chance if instead of editing your own bios you flash the card with one from MSI or Asus.

    Anyway, that's what I've seen mentioned here and there...
  3. mudy New Member

    Joined:
    Aug 13, 2009
    Messages:
    15 (0.01/day)
    Thanks Received:
    0
    Thanks for taking the effort to reply on my thread! I have seen that but there few thiings I wanted to ask you guys regarding BIOS flashing - like the ones above - as to WHY the softwares aren't functioning as they're supposed to. Also I wanted to ask which is the best tool to overclock. Thanks for replyng though!!
  4. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    41,944 (11.76/day)
    Thanks Received:
    9,365
    1. ATIWinFlash v2.0.1.7 - this program barely works. use a DOS flasher.
    2. ATIFlash v3.79 - this is a DOS flasher. it wont work in windows.
    3. RBE v1.22 - this will work in windows
    4. ATITool v0.26 - old version. you need 0.27 beta
  5. mudy New Member

    Joined:
    Aug 13, 2009
    Messages:
    15 (0.01/day)
    Thanks Received:
    0
    Thanks for the info mate!! I just BIOS nodded my card with the MSI edition!! And OCed the card to 825/1125 @ stock volt!! Ran fine with 5-10 min extreme stabilty test through furmark will do the 60 min test and Heavnz Beanchmark 2morrow!! One last question is 3DMark Vantage a good stability test?? Also if u guys noticed (or can check it later) in the last Feature Test I get thin Cris-cross lines!!! Maybe DX11 thing or maybe driver level issue!!!

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page