1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

C&C: TFD, many many problems

Discussion in 'Games' started by xylomn, Dec 27, 2006.

  1. xylomn

    xylomn New Member

    Joined:
    May 13, 2006
    Messages:
    661 (0.23/day)
    Thanks Received:
    18
    Location:
    Swindon, England, United Kingdom
    I owned most of the C&C games but over the years of using them many of the discs got damaged beyond use..

    So as The First Decade was only £17.99 in HMV I picked up that to replace all of the broken/damaged ones... big mistake.

    Generals and Zero Hour crash at the splash screens and tiberian sun, and red alert 2 crash after about 5-10 mins of play....

    I've gave up with the C&C forums they load so damn slow and the search function just plain sucks.

    Anyone else experienced these problems and know any fixes, so far I have tried:

    1. Removing all overclocks
    2. Reinstalling
    3. Different Machines
    4. Updated all drivers and firmwares
    5. Won't work in compatibility mode (can't find dvd in that case)

    This is driving me up the wall :banghead:
  2. Saurian New Member

    Joined:
    Oct 16, 2006
    Messages:
    40 (0.01/day)
    Thanks Received:
    0
    Funny, it works fine for me in Vista. It's not trash.

    My problem in Vista is that Red Alert 2 and Renegade don't initialize properly, but I have full faith that that is Vista-only, not game problems.
  3. pt

    pt not a suicide-bomber

    Joined:
    Mar 11, 2006
    Messages:
    8,982 (3.03/day)
    Thanks Received:
    208
    Location:
    Portugal
    i love C&C games, since you paid for the game it should be legal to look for some backup on the net ;)

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page