1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

GPU-Z Log File "BUG" ?!

Discussion in 'GPU-Z' started by Simondererste, Mar 21, 2014.

  1. Simondererste New Member

    Joined:
    Mar 21, 2014
    Messages:
    1 (0.00/day)
    Thanks Received:
    0
    tl;dr: "extra" functional characters in the log-file from GPU-Z causes blank lines in LibreOffice Calc(maybe excel too).

    As i tried to make a benchmark of a game i stumbled over a little problem with the log-file of GPU-Z.
    Importing the .txt LogFile into LO(LibreOffice) Calc resulted into blank lines between each data set(red lines in the image). First i thought it was because of the commas at the end of each data set but deleting them didn't solve the problem. With Notepad++ i finally could find the "bug" that causes those blank lines. Never used the option to show functional characters in Notepad++ but only Notepad recognized those blank lines(neither did the editor nor the LO Writer as you can see in the image). After i deleted the "CRs", the blank lines disappeared in Notepad++ and in LO Calc.
    Saving it once with LO Writer in the text format(writer asks you if you want to use odf or txt) "deleted" those "extra" functional chars from the file.
    So as a workaround i save the log-file once with LO Writer and then import it into LO Calc.
    If it isn't intended i hopefully see a fix in an upcoming update.
    GPU-Z_LogFile.jpg
     
  2. kn00tcn

    kn00tcn

    Joined:
    Feb 9, 2009
    Messages:
    892 (0.39/day)
    Thanks Received:
    185
    Location:
    Toronto
    confirming excel 2007 line breaks

    [​IMG]

    no empty lines in notepad or editplus or jane

    i do see something per 'line' when hex editing
     
  3. agent00skid

    Joined:
    May 6, 2012
    Messages:
    646 (0.58/day)
    Thanks Received:
    524
    Had that problem some time ago. Tracked it down to double CR's and a LF at the end of a line. Which in editors that treat both isolated CR's and CR,LF as newlines makes them jump two lines.

    Edit: Oh, and I worked around the issue by using Notepad++ and then in replace: "\r\r\n" with "\r\n"
     
    Last edited: Mar 22, 2014
    Crunching for Team TPU More than 25k PPD
  4. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,355 (3.81/day)
    Thanks Received:
    12,562
    GPU-Z is just putting 1x CR LF at the end of each line, like almost all other Windows software.

    Importing the sensor log into Excel worked fine here, check your import settings.

    [​IMG]
     
  5. agent00skid

    Joined:
    May 6, 2012
    Messages:
    646 (0.58/day)
    Thanks Received:
    524
    Just made a log with GPU-Z 0.7.7 on my laptop with Windows 7 SP1 and opened it in notepad++:
    [​IMG]
     
    Crunching for Team TPU More than 25k PPD
  6. W1zzard

    W1zzard Administrator Staff Member

    Joined:
    May 14, 2004
    Messages:
    15,355 (3.81/day)
    Thanks Received:
    12,562
  7. TomWoB New Member

    Joined:
    Jun 7, 2013
    Messages:
    12 (0.02/day)
    Thanks Received:
    13
    Location:
    Switzerland
  8. agent00skid

    Joined:
    May 6, 2012
    Messages:
    646 (0.58/day)
    Thanks Received:
    524
    Crunching for Team TPU More than 25k PPD

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page