1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Graphics card software errors - Vista

Discussion in 'General Software' started by techohead, Mar 12, 2007.

  1. techohead New Member

    Joined:
    Dec 1, 2006
    Messages:
    27 (0.01/day)
    Thanks Received:
    0
    hi to everyone, i was hoping someone here could help me out. i've just installed Windows Vista on my computer, and was in the process of installing all my hardware's software, when i came to my ATI radeon 9600XT. i installed the original drivers from the CD, and rebooted and i got incompatability error messages, saying my software was too old. i went to the ATI website and downloaded the latest catalyst 7.2 for my card. i installed this, rebooted and on startup i got errors saying that windows could not find CCC.Implementation or MOM.Implementation, none of my catalyst programs work, and without this software i can't configure my dual monitor settings... and the card will not function efficiently without this software... please help me...
     
  2. Jimmy 2004

    Jimmy 2004 New Member

    Joined:
    Jan 15, 2005
    Messages:
    5,491 (1.54/day)
    Thanks Received:
    267
    Location:
    England
    Try completely removing the drivers, and then reinstall the complete driver package from ATI (not just the driver itself everything including CCC, ~40MB package). Might have just been a bad install, but it sounds like you might not have installed the Catalyst Control Center.

    Edit: it looks like you can only install it with CCC - just do a reintall, might have gone wrong last time.
     
  3. techohead New Member

    Joined:
    Dec 1, 2006
    Messages:
    27 (0.01/day)
    Thanks Received:
    0
    Thanks for the advice, but i've already installed the complete package repeatedly, with all it's components, and i've tried combinations of the old a new software too, nothing seems to work... so i'm thinking of getting a new graphics card, the 9600XT isn't worth much anymore. but i'm still open to suggestions before i do something extreme (and probably stupid)
     
  4. Pinchy New Member

    Joined:
    Apr 29, 2006
    Messages:
    5,109 (1.64/day)
    Thanks Received:
    284
    Location:
    Sydney, Australia
    Did you download the Vista drivers from the ATI site? The drivers on your CD wouldnt have worked because Vista wasnt out back then. Hence, make sure you download the latest VISTA drivers.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page