1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

Raid 0 attempt gone bad. Cause for future concern?

Discussion in 'Storage' started by acperience7, Nov 30, 2010.

  1. acperience7

    Joined:
    Nov 26, 2007
    Messages:
    259 (0.10/day)
    Thanks Received:
    31
    I attempted a RAID 0 configuration yesterday with a Seagate and Western Digital. After a good hour of studying it all I went ahead and did setup the array.

    I ran into problems from the start, but long story short I managed to install Windows 7 x64. After enduring random unresponsive programs after I had the basics up and running I decided the speed, while nice, was not worth the slow OS response I saw. At that point I decided to go back to a regular non-RAID setup. [I used 64K block size and had Fast Initialization enabled (just FYI).]

    This is where my real problems began. After restoring my non-RAID configuration my system starting acting very weird. For ease of reading I'll use bullet points:
    • Slow post time
    • Chassis fan headers 1 & 2 power up then power off after post, then power the LED's on, but the fans only spin when physically aided.
    • System reports a failed overclock when there was no overclock
    • System crashed once after entering and exiting the bios.

    I began to diagnose, and in my panic I took out several parts at once:eek:, but when installing I put them back in one at a time testing each to see if if any of them was the cause for the trouble. No dice. I even tested the power supply and every rail checks out. Also ran extended tests on all hard drives with WD's Data Lifeguard tool, and they all check out.

    As of now it's up and running and performing perfectly again:wtf:.

    With that information I have a few questions:
    1. Do I have any reason to worry about my PC or any of it's components in the near future?
    2. I was offered an RMA from ASUS, but if I don't have to use it I don't want to. To those with similar experiences would it be best to RMA my board?
    3. After reinstalling my 2nd drive [of three] (the Seagate) my bios gave me information about which drives and devices were on each SATA port. This info was never available before and ever since I rebooted it has not come back. Is this another 'good' sign that I need to RMA it?

    On the note of RAID 0:
    • Was it a mistake to RAID two differing brands of HDD? Their specs are similar, but the WD does have that 2 processor feature.
     
  2. erocker

    erocker Super Moderator Staff Member

    Joined:
    Jul 19, 2006
    Messages:
    39,980 (12.96/day)
    Thanks Received:
    14,401
    Yes, RAID, especially RAID 0 should be done on two identical drives.
     
    acperience7 says thanks.
  3. Mussels

    Mussels Moderprator Staff Member

    Joined:
    Oct 6, 2004
    Messages:
    42,567 (11.39/day)
    Thanks Received:
    9,836
    i say dont worry about the system being weird, likely a loose connection.

    as for the RAID issues, erocker covered that.
     
    acperience7 says thanks.
  4. newtekie1

    newtekie1 Semi-Retired Folder

    Joined:
    Nov 22, 2005
    Messages:
    20,263 (6.10/day)
    Thanks Received:
    6,298
    With modern controllers, it doesn't matter. The controller will handle the different drives without problem, but one drive might have to wait while the other finished a task in the event that one drive is faster than the other.

    Most of your problems sound like some other kind of BIOS issue or setting.
     
    acperience7 says thanks.
    Crunching for Team TPU 50 Million points folded for TPU
  5. brandonwh64

    brandonwh64 Addicted to Bacon and StarCrunches!!!

    Joined:
    Sep 6, 2009
    Messages:
    18,781 (9.68/day)
    Thanks Received:
    6,239
    Location:
    Chatsworth, GA
    Yea the rule of thumb is to use the SAME model drives for raid and u shouldn't have any issues unless its a onboard raid issue. ive got two WD blue drives (same model number) in raid 0 in my I7 machine. I also have 2x WD 250GB sata drives (same model but there older than the blues) in my XEON HTPC machine and both machines are very fast using programs, starting windows, starting and installing programs.
     
    Crunching for Team TPU
  6. slyfox2151

    slyfox2151

    Joined:
    Jan 14, 2009
    Messages:
    2,611 (1.20/day)
    Thanks Received:
    525
    Location:
    Brisbane, Australia
    i setup a 4 disk raid0 with 2 WD greens and 2 seagate 7200.11s and had no problems... i also tried 2 WD blacks instead of the seagates and had no issues.



    this definetly sounds like either a bad bios config or lose connection... maybe both.
     
    acperience7 says thanks.
  7. fusionblu

    fusionblu

    Joined:
    Nov 3, 2010
    Messages:
    302 (0.20/day)
    Thanks Received:
    43
    Location:
    London, England, UK
    While I would like to point the finger at the fact that you are using non-identical HDDs for Raid-0 it is possible the whole thing may have gone wrong due to one of the HDDs being faulty and might need a good format (hopefully that might cure the problem... that's if it isn't hardware related...).

    Well that is the only other reasonable explaination I could think of other than the most obvious one with the HDDs being non-identical to each other.
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page