1. Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

SOLUTION to "BIOS not AHCI compliant" Vista x64 BSOD

Discussion in 'Motherboards & Memory' started by robal, Sep 4, 2008.

  1. robal

    robal

    Joined:
    Aug 5, 2008
    Messages:
    485 (0.22/day)
    Thanks Received:
    111
    Location:
    Hampshire, UK
    Hi,

    It's quite common problem that Vista x64 will not boot or even launch setup GUI when PC has 4GB of memory, while it runs fine with 2GB.

    Symptom:
    Vista x64 gives BSOD "STOP ERROR" "BIOS not ACPI compliant"

    Solution for Gigabyte GAMA790FXDS5:
    Loading "optimised defaults" in BIOS helps.
    The setting causing this issue is: DISABLE ON-CHIP SATA
    If you have 4GB, you can't disable SB600 SATA in BIOS !

    You can use your HDDs with jmicron "GSATA", but leave SB600 SATA enabled anyway.

    I hope that it helps someone.
    It took quite a lot of googling, contacting support to find this.
    I hope that other desperate people searching for this BSOD will find this forum and post.

    Note that this is other 4GB - related problem than infamous pre-SP1 (kb:929777) one.

    Cheers,
     

Currently Active Users Viewing This Thread: 1 (0 members and 1 guest)

Share This Page