• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

10c difference between CCD1 and CDD2 on AMD 5950x

Joined
Jan 4, 2013
Messages
792 (0.23/day)
Location
Denmark
System Name R9 5950x/Skylake 6400
Processor R9 5950x/i5 6400
Motherboard Gigabyte Aorus Master X570/Asus Z170 Pro Gaming
Cooling Arctic Liquid Freezer II 360/Stock
Memory 4x8GB Patriot PVS416G4440 CL14/G.S Ripjaws 32 GB F4-3200C16D-32GV
Video Card(s) 6900XT/R7
Storage Seagate 530 4TB, WD SN850 2TB, Aorus 2TB, Corsair MP600 1TB / 960 Evo 1TB
Display(s) 3x LG 27gl850
Case Custom builds
Audio Device(s) -
Power Supply Silverstone 1000watt modular Gold/1000Watt Antec
Software win10pro / Win10 Home / win7 / wista 64 bit and XPpro
I was planing af repaste of my cpu to se if there would be any difference - and to be honest - I could not remember if I had used my new Noctua NT-H2 paste on my own cpu or only on som machine I have build during the last couple of months... Doing testing afterwards - burn in if you can call it that - I noticed that there was a 10c difference between CCD1 and CDD2
1619778263418.png

Looking at some earlier test from februar I saw almost excatly the same difference between the two cores - with CCD1 up and about 78-80c and CCD2 almost 10c lower - now theres always a difference in mount and paste, but that seems more or less continuously.

My question is what do other dual CCDs Owners experience? E.g. 3900x/3950x and 5900x/5950x models?

Did the "burn in" with CPUz stress test
1619778722268.png
 

tabascosauz

Moderator
Supporter
Staff member
Joined
Jun 24, 2015
Messages
4,160 (1.65/day)
Location
Western Canada
Processor 5900X
Motherboard Crosshair VIII Impact (4201)
Memory 32GB 3800CL14 1.54V
Video Card(s) TUF RTX 3070 Ti 1980@0.931V
Case Cerberus
Power Supply SF750
Same behaviour on my 5900X, and I'm not on water. I'll upload some screenies tmr to show what I see. If I play MW that day, CCD1 maxes out 80-85C and CCD2 stays around 10C if not more cooler.

It's just a matter of usage usually. Which makes sense, CCD1 will always have the best cores on the chip, so Windows keeps tasks on those two cores (Core 0 and 1 for me). Sometimes Windows likes to use 1 core off CCD2 for background processing (I think it's like Core 7 or something for me), but even when Windows needs to fill 6 cores it will stay within CCD1 until it absolutely needs more cores than CCD1 can provide. Most days I'll see 13-15W max on Core 0 and 1, then around 10-11W max on Core 2-5, then single digit power draw for CCD2.

The max temp readings on Ryzen 5000 seem to almost always be transient spikes + 10-20C under single threaded load, never average or consistent temps. For example I have HWInfo open on my second screen and while CCD1 stays at 60-75C mostly, I'll occasionally see a spike up to 80-85C for a single polling interval and back down again.

What I instead found interesting was that in some all-core benchmarks I'd have CCD2 running consistently hotter by about 3C. All 12 cores under max load, same Vcore, etc. Never really figured out why, there's no mounting issue. Not an issue since benchmarks always top out at 70-72C max, I don't run PBO.
 
Joined
Oct 22, 2014
Messages
13,209 (4.78/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel Xeon E3-1260L v5
Motherboard MSI E3 KRAIT Gaming v5
Cooling Tt tower + 120mm Tt fan
Memory G.Skill 16GB 3600 C18
Video Card(s) Asus GTX 970 Mini
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
Could be due to the design, placement of the cores could benefit from an offset cooler mount.
 
Joined
Dec 29, 2010
Messages
2,621 (0.63/day)
Processor AMD 5900x
Motherboard Asus x570 Strix-E
Cooling Hardware Labs
Memory G.Skill 4000c17 2x16gb
Video Card(s) RTX 3090
Storage Sabrent
Display(s) Samsung G9
Case Phanteks 719
Audio Device(s) Fiio K5 Pro
Power Supply EVGA 1300 G2
Mouse Logitech G600
Keyboard Corsair K95
My CCD temps only differ by just 2c on average in cpuz and r20. In day to day usage it could differ by a 10-15c obviously but in consistent threaded tasks they're pretty close together.

r20
temp test r20.png


cpuz
temp test cpuz.png
 
Joined
Feb 6, 2021
Messages
1,185 (2.54/day)
Location
Germany
Processor A LOT... ( Alder Lake, Zen 3, Zen 2, Rocket Lake, Comet Lake... back to Bulldozer and Sandybridge.)
Motherboard A LOT... (Z490 Unify, Z590 Strix E, Z690 Pro A, B550 Strix F, B550 Tomahawk and older ones)
Cooling AIOs, NH D15, U12A/S, Fuma 2, one old Custom Loop from half a decade ago.
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB) Gear 1 CR1
Video Card(s) Almost all Ampere, two 6900XTs and other RDNA2, all Turing, all Pascal, Vegas, 980 Tis and older.
Storage Corsair MP 600 Pro 1TB, 2x Crucial P5 Plus 2TB, 2x Samsung 870 QVO 4TB (external)
Display(s) Gigabyte M32U 4K 144Hz / ASUS ROG STRIX XG27UQR 4K 144Hz / Dell S2721DGFA / ASUS VG279QM 280Hz
Case NZXT H510 Flow, H710, Corsair 4000D Airflow, Carbide 540, Fractal Design Meshify S2, Phanteks P500A
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a Sharkoon Gaming DAC Pro S V2
Power Supply bequiet! Dark Power Pro 12 1200w Titanium, Straight Power 1200W Plat., Corsair RM750x
Mouse G303 Shroud Edition, Model O, G903 Hero, G502 Hero SE, EC2-A
Keyboard Corsair K65 RGB Mini, ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
VR HMD Oculus Rift S
tiny littly bubble in the solder and you see results like that.
my 5900X had almost 25°C difference under high load. until it landed on ebay.
 
Joined
Jan 2, 2009
Messages
9,896 (2.03/day)
Location
Essex, England
System Name My pc
Processor Ryzen 5 3600
Motherboard Asus Rog b450-f
Cooling Cooler master 120mm aio
Memory 16gb ddr4 3200mhz
Video Card(s) MSI Ventus 3x 3070
Storage 2tb intel nvme and 2tb generic ssd
Display(s) Generic dell 1080p overclocked to 75hz
Case Phanteks enthoo
Power Supply 650w of borderline fire hazard
Mouse Some wierd Chinese vertical mouse
Keyboard Generic mechanical keyboard
Software Windows ten
My first 3900 had a 15-20 degree difference and it was caused by ccd0 using more voltage than it needed.

for example ccd1 each core was 7-8w under full load and ccd0 was 10-11 w so I RMAd and my current 3900 both CCD use 7-8w per core.
 
Joined
Sep 19, 2020
Messages
842 (1.39/day)
System Name WinTenDoh | AyeEmmDee Dark
Processor i7 12700K | R9 5950X
Motherboard MSI PRO Z690-A WiFI DDR4 | MSI B550 Unify
Cooling Noctua NH-D15 chromax.black | Noctua NH-D15s chromax.black
Memory G.Skill Trident Neo 32GB (16GBx2) 3600 14-14-14-34 | Team Dark Zα 64GB (16GBx4) 3600 18-22-22-42
Video Card(s) Powercolor RX 6900 XT Red Devil Ultimate | Sapphire RX 6800 XT Pulse
Display(s) Dell S3220DGF 1440p 165Hz
Case Phanteks P600s | Phanteks P400a
Audio Device(s) Schiit Sennheiser HiFiMan Beyerdynamic
Power Supply Seasonic Prime GX-1000 | Seasonic Prime TX-850
Mouse EVGA x17
Keyboard EVGA z15
Software Win 11 Pro | Win 10 Pro
I can echo what @tabascosauz and @thesmokingman have experienced.

I have a 3900x & 3950x that are running a constant all core load 24/7 and the average difference is 2C over an 86 hour period (time since the last reboot) with CCD1 having the higher temp. on both CPUs.

I don't even look at my 5800x because of temperature anxiety. :fear:
 
Joined
Jan 3, 2015
Messages
2,286 (0.85/day)
System Name The beast and the little runt.
Processor Ryzen 5 5600X - Ryzen 9 5950X
Motherboard ASUS ROG STRIX B550-I GAMING - ASUS ROG Crosshair VIII Dark Hero X570
Cooling Noctua NH-L9x65 SE-AM4a - NH-D15 chromax.black with IPPC Industrial 3000 RPM 120/140 MM fans.
Memory G.SKILL TRIDENT Z ROYAL GOLD/SILVER 32 GB (2 x 16 GB and 4 x 8 GB) 3600 MHz CL14-15-15-35 1.45 volts
Video Card(s) ASUS GTX 1650 Low Profile cooler - EVGA RTX 3080 FTW3 ULTRA GAMING
Storage 2 x Samsung 980 PRO 1 TB and one 2 TB - CRUCIAL MX300 2 TB SSD - WD RED 4 TB and WD GOLD 14 TB HDD
Display(s) Asus 27" TUF VG27AQL1A and a Dell 24" for dual setup
Case Phanteks Enthoo 719/LUXE 2 BLACK
Audio Device(s) ONBOARD on both boards
Power Supply Phanteks Revolt X 1200W
Mouse Logitech G903 Lightspeed Wireless Gaming Mouse
Keyboard Logitech G910 Orion Spectrum
Software WINDOWS 10 PRO 64 BITS on both systems
Benchmark Scores Se more about my 2 in 1 system here: kortlink.dk/2ca4x
Reading this thread. Gets me curious how my new 5950X will behave when I can get it up and running. Still awaiting the last parts to come home.

I Will be cooling it with noctua NH-D15 CHROMAX.BLACK with Thermal grizzly kryonaut extreme and swap the stock fans for noctua industrial IPPC 3000 RPM fans.
 

tabascosauz

Moderator
Supporter
Staff member
Joined
Jun 24, 2015
Messages
4,160 (1.65/day)
Location
Western Canada
Processor 5900X
Motherboard Crosshair VIII Impact (4201)
Memory 32GB 3800CL14 1.54V
Video Card(s) TUF RTX 3070 Ti 1980@0.931V
Case Cerberus
Power Supply SF750
@jesdals there's that temp delta between CCD1 and CCD2. If I run all-core benchmarks only, CCD2 is hotter by 3C always. If I just use the comp normally and do some gaming, Core 0 and 1 start being used and CCD1 starts outstripping CCD2 by 10-15C.

Bench temps:

5900x temps.png


Daily temps:

5900x normal temps.png

NH-C14S with a NF-A14 iPPC-2000.
 
Last edited:
Joined
Sep 3, 2019
Messages
2,354 (2.38/day)
Location
Thessaloniki, Greece
System Name PC alive since Aug 18th 2019
Processor Ryzen 5 3600 (PBO Enabled)
Motherboard Gigabyte X570 Aorus Pro, BIOS F32
Cooling Corsair H110i 280mm (Liquid metal for TIM)
Memory Corsair Vengeance LPX DDR4 2x8GB 3466MHz @3733MHz CL16-18-18-18-36 1T, B-die A0
Video Card(s) MSI RX 5700XT Gaming X
Storage Samsung NVMe: 970Pro 512GB (2019, OS drive) / SATA-III: 850Pro 1TB SSD (2015) 860Evo 1TB SSD (2020)
Display(s) 24" EIZO FlexScan S2411W 1920x1200, 16:10 60Hz samsung S-PVA 14-bit (16.7M/1.06B colors), 6ms G2G
Case None
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W, Logitech G35 headset
Power Supply Corsair HX750i
Mouse Logitech MX Master (Gen1)
Keyboard Logitech G15 (Gen2)
Software Windows 10 Home 64bit (20H2)
I was planing af repaste of my cpu to se if there would be any difference - and to be honest - I could not remember if I had used my new Noctua NT-H2 paste on my own cpu or only on som machine I have build during the last couple of months... Doing testing afterwards - burn in if you can call it that - I noticed that there was a 10c difference between CCD1 and CDD2
View attachment 198624
Looking at some earlier test from februar I saw almost excatly the same difference between the two cores - with CCD1 up and about 78-80c and CCD2 almost 10c lower - now theres always a difference in mount and paste, but that seems more or less continuously.

My question is what do other dual CCDs Owners experience? E.g. 3900x/3950x and 5900x/5950x models?

Did the "burn in" with CPUz stress test
View attachment 198628

HWiNFO can tell a lot if you look in the right place.
Your answer is here

HWiNFO_.png


CCD1 uses +25% power compared to CCD2. And also... where the heck is "Core 0 Power (SMU)"...???

It could be different binned CCDs of maybe your V/F curve settings (Optimizer).

I suggest to get the latest version of HWiNFO64 and use the "Snapshot CPU Polling" as its more accurate. Also you can turn on the tool tip function for the sensors.
 
Last edited:

tabascosauz

Moderator
Supporter
Staff member
Joined
Jun 24, 2015
Messages
4,160 (1.65/day)
Location
Western Canada
Processor 5900X
Motherboard Crosshair VIII Impact (4201)
Memory 32GB 3800CL14 1.54V
Video Card(s) TUF RTX 3070 Ti 1980@0.931V
Case Cerberus
Power Supply SF750
CCD1 uses +25% power compared to CCD2. And also... where the heck is "Core 0 Power (SMU)"...???

It's a known bug with pre-v.700 HWinfo when the system is running AGESA 1201 or newer. Same problem with the C-state residency numbers in that image. Man needs to update his HWInfo.
 
Joined
Jan 4, 2013
Messages
792 (0.23/day)
Location
Denmark
System Name R9 5950x/Skylake 6400
Processor R9 5950x/i5 6400
Motherboard Gigabyte Aorus Master X570/Asus Z170 Pro Gaming
Cooling Arctic Liquid Freezer II 360/Stock
Memory 4x8GB Patriot PVS416G4440 CL14/G.S Ripjaws 32 GB F4-3200C16D-32GV
Video Card(s) 6900XT/R7
Storage Seagate 530 4TB, WD SN850 2TB, Aorus 2TB, Corsair MP600 1TB / 960 Evo 1TB
Display(s) 3x LG 27gl850
Case Custom builds
Audio Device(s) -
Power Supply Silverstone 1000watt modular Gold/1000Watt Antec
Software win10pro / Win10 Home / win7 / wista 64 bit and XPpro
Gave the new HWinfo a try - still seeing the same picture - It doesent work with individual curve settings on my CPU - but could wonder if it would be possible to lower the difference with a bigger negative ofset on the CCD2 cores.
1619897112800.png
 
Joined
Dec 29, 2010
Messages
2,621 (0.63/day)
Processor AMD 5900x
Motherboard Asus x570 Strix-E
Cooling Hardware Labs
Memory G.Skill 4000c17 2x16gb
Video Card(s) RTX 3090
Storage Sabrent
Display(s) Samsung G9
Case Phanteks 719
Audio Device(s) Fiio K5 Pro
Power Supply EVGA 1300 G2
Mouse Logitech G600
Keyboard Corsair K95
You're using curve optimizer.... that's your problem I suspect. The cores are not getting the same voltage nor are they controlled by AMD's logic. I would test with at stock and see if the pattern continues.
 
Joined
Jan 4, 2013
Messages
792 (0.23/day)
Location
Denmark
System Name R9 5950x/Skylake 6400
Processor R9 5950x/i5 6400
Motherboard Gigabyte Aorus Master X570/Asus Z170 Pro Gaming
Cooling Arctic Liquid Freezer II 360/Stock
Memory 4x8GB Patriot PVS416G4440 CL14/G.S Ripjaws 32 GB F4-3200C16D-32GV
Video Card(s) 6900XT/R7
Storage Seagate 530 4TB, WD SN850 2TB, Aorus 2TB, Corsair MP600 1TB / 960 Evo 1TB
Display(s) 3x LG 27gl850
Case Custom builds
Audio Device(s) -
Power Supply Silverstone 1000watt modular Gold/1000Watt Antec
Software win10pro / Win10 Home / win7 / wista 64 bit and XPpro
You're using curve optimizer.... that's your problem I suspect. The cores are not getting the same voltage nor are they controlled by AMD's logic. I would test with at stock and see if the pattern continues.
Trying to disable curve optimizer shows the same difference - but with lower boost - will try if I can get individual core settings stable with the curve setting.
1619942828061.png
 
Joined
Sep 3, 2019
Messages
2,354 (2.38/day)
Location
Thessaloniki, Greece
System Name PC alive since Aug 18th 2019
Processor Ryzen 5 3600 (PBO Enabled)
Motherboard Gigabyte X570 Aorus Pro, BIOS F32
Cooling Corsair H110i 280mm (Liquid metal for TIM)
Memory Corsair Vengeance LPX DDR4 2x8GB 3466MHz @3733MHz CL16-18-18-18-36 1T, B-die A0
Video Card(s) MSI RX 5700XT Gaming X
Storage Samsung NVMe: 970Pro 512GB (2019, OS drive) / SATA-III: 850Pro 1TB SSD (2015) 860Evo 1TB SSD (2020)
Display(s) 24" EIZO FlexScan S2411W 1920x1200, 16:10 60Hz samsung S-PVA 14-bit (16.7M/1.06B colors), 6ms G2G
Case None
Audio Device(s) Sound Blaster Z <--optical link--> Logitech Z5500 5.1 500W, Logitech G35 headset
Power Supply Corsair HX750i
Mouse Logitech MX Master (Gen1)
Keyboard Logitech G15 (Gen2)
Software Windows 10 Home 64bit (20H2)
Trying to disable curve optimizer shows the same difference - but with lower boost - will try if I can get individual core settings stable with the curve setting.
View attachment 198861
Still this is not entirely stock judging by the 186W PPT. It's PBO Enabled with manual limits and speed override, right?

I think this is differently binned chiplets, if there is also a difference at pure stock settings.
 
Top