• Welcome to TechPowerUp Forums, Guest! Please check out our forum guidelines for info related to our community.

AMD Radeon RX6900 XT problems

flaubert71

New Member
Joined
Apr 13, 2021
Messages
12 (0.36/day)
Hello,


my hardware

-WS X299 SAGE / 10G
-Intel (R) Core (TM) i9-7980XE
-128 Gb Corsair Dominator platinum

Before installing the radeon rx 6900 xt a radeon VII was installed. With the AMD clean utility I removed the previous drivers in safe mode then I proceeded to install adrenalin 2020 21.3.1.

If I open GPU-Z, under the heading computing, OpenCL is without the check

If I run the openCL test with geekbench this stops at the SFFT worload and to get the score I have to cancel the test. Watch the video here:


Any help please?
 

Attachments

  • 2021-04-13_182206.png
    2021-04-13_182206.png
    29.9 KB · Views: 63
Joined
Sep 28, 2005
Messages
2,147 (0.38/day)
Location
Calgary Alberta, Canada
System Name PCGR
Processor Intel 10500 ES
Motherboard MSI Z490 Gaming Plus
Cooling Snowman MT4 Dual Fan
Memory 2x8GB DDR4 3600 Corsair Vengeance
Video Card(s) Gigabyte RX 6800XT Gaming OC
Storage 1x 1tb ADATA XPG 8200 Pro NVME | 1x 1TB WD Blue HDD
Display(s) BenQ 24" 1080P
Case MSI MPG 110M
Audio Device(s) Onboard
Power Supply Cooler Master 550W MWE 80+ Gold
Software Windows 10 64bit Pro
What gpu you had before?

I would use DDU to remove all drivers and retry installing latest drivers.

Uninstall current driver's as well before using DDU.
 
Joined
Jan 4, 2013
Messages
601 (0.20/day)
Location
Denmark
System Name R9 5950x/Skylake 6400
Processor R9 5950x/i5 6400
Motherboard Gigabyte Master X570/Asus Z170 Pro Gaming
Cooling Arctic Liquid Freezer II 360/Stock
Memory 4xGB Patriot PVS416G4440 CL14/G.S Ripjaws 32 GB F4-3200C16D-32GV
Video Card(s) 6900XT/R7
Storage WD SN850 2TB, Aorus 2TB Corsair MP600 / 960 Evo 1TB
Display(s) 3x LG 27gl850
Case Custom builds
Audio Device(s) -
Power Supply Silverstone 1000watt modular Gold/1000Watt Antec
Software win10pro / Win10 Home / win7 / wista 64 bit and XPpro
Thats odd
1618332463776.png

Same driver etc - can it be motherboard?
 

flaubert71

New Member
Joined
Apr 13, 2021
Messages
12 (0.36/day)
I uninstalled all the drivers with DDU and reinstalled drivers but unfortunately nothing has changed
 
Joined
Feb 6, 2021
Messages
353 (3.53/day)
Location
Germany
Processor Intel Core i9 10900KF 5.1 Ghz /4.9 GHz Cache (and a LOT of other CPUs)
Motherboard ASUS Z490 PRIME-A
Cooling Noctua NH-D15 Chromax. Black
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) RTX 3090 Gaming X Trio, 6900XT Merc and Nitro + & almost all Ampere, Turing, Pascal, Maxwell Cards
Storage Corsair MP600 1TB, Samsung 970 Evo Plus 500GB, 2x Samsung 870 QVO 4TB
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
make a backup or use a second drive and make a clean windows installation.
problem gone, it's your current Windows Installation/Software.
problem not gone, Hardware/Bios (?)
 

flaubert71

New Member
Joined
Apr 13, 2021
Messages
12 (0.36/day)
Reinstalled a fresh copy of windows 10. Now geekbench works but gpu-z always no tichet on OpenCL
 

Attachments

  • Annotazione 2021.png
    Annotazione 2021.png
    37.6 KB · Views: 28
  • Annotazione 2021-04-13 221841.png
    Annotazione 2021-04-13 221841.png
    51.4 KB · Views: 24
  • Annotazione 2021rh.png
    Annotazione 2021rh.png
    150.7 KB · Views: 29
  • Annotazione 2021r.png
    Annotazione 2021r.png
    28.5 KB · Views: 31
Joined
Feb 6, 2021
Messages
353 (3.53/day)
Location
Germany
Processor Intel Core i9 10900KF 5.1 Ghz /4.9 GHz Cache (and a LOT of other CPUs)
Motherboard ASUS Z490 PRIME-A
Cooling Noctua NH-D15 Chromax. Black
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) RTX 3090 Gaming X Trio, 6900XT Merc and Nitro + & almost all Ampere, Turing, Pascal, Maxwell Cards
Storage Corsair MP600 1TB, Samsung 970 Evo Plus 500GB, 2x Samsung 870 QVO 4TB
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
and this card was new, sealed and has the original bios installed?
 

flaubert71

New Member
Joined
Apr 13, 2021
Messages
12 (0.36/day)
Yes, bought it yesterday - condition is new - and the bios is the original
 
Joined
Feb 6, 2021
Messages
353 (3.53/day)
Location
Germany
Processor Intel Core i9 10900KF 5.1 Ghz /4.9 GHz Cache (and a LOT of other CPUs)
Motherboard ASUS Z490 PRIME-A
Cooling Noctua NH-D15 Chromax. Black
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) RTX 3090 Gaming X Trio, 6900XT Merc and Nitro + & almost all Ampere, Turing, Pascal, Maxwell Cards
Storage Corsair MP600 1TB, Samsung 970 Evo Plus 500GB, 2x Samsung 870 QVO 4TB
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
weird.
do you have under C: / Windows [search in the windows folder for "opencl"] DLLs for openCL?
i just mention this because i have seen a topic where someone had the same issue with an nvidia card and there were zero opencl DLLs and they were able to fix it later on.
 
Last edited:
Joined
Feb 6, 2021
Messages
353 (3.53/day)
Location
Germany
Processor Intel Core i9 10900KF 5.1 Ghz /4.9 GHz Cache (and a LOT of other CPUs)
Motherboard ASUS Z490 PRIME-A
Cooling Noctua NH-D15 Chromax. Black
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) RTX 3090 Gaming X Trio, 6900XT Merc and Nitro + & almost all Ampere, Turing, Pascal, Maxwell Cards
Storage Corsair MP600 1TB, Samsung 970 Evo Plus 500GB, 2x Samsung 870 QVO 4TB
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
i'd open a ticket to the AMD support and ask them.
since the card is working i'd not freak out about it but it is something that i would investigate and try to find a fix for.

if i'll find anything else i will let you know.
 

flaubert71

New Member
Joined
Apr 13, 2021
Messages
12 (0.36/day)
Sorry for this OT:

With RP0 active the fans stop spinning at 50 degrees - after a benchmark for example - and the GPU cooling occurs more slowly. What do you recommend? To use or not to use RP0?
 
Joined
Feb 6, 2021
Messages
353 (3.53/day)
Location
Germany
Processor Intel Core i9 10900KF 5.1 Ghz /4.9 GHz Cache (and a LOT of other CPUs)
Motherboard ASUS Z490 PRIME-A
Cooling Noctua NH-D15 Chromax. Black
Memory G.Skill Trident Z Neo 3600 Mhz CL16 (2x16GB)
Video Card(s) RTX 3090 Gaming X Trio, 6900XT Merc and Nitro + & almost all Ampere, Turing, Pascal, Maxwell Cards
Storage Corsair MP600 1TB, Samsung 970 Evo Plus 500GB, 2x Samsung 870 QVO 4TB
Display(s) Samsung Odyssey G7 32"
Case Fractal Design Meshify S2 White TG / Noctua NF-A14 iPPC-3000RPM Fans
Audio Device(s) Bose Companion Series 2 III, Sennheiser GSP600 running through a SoundblasterX G6
Power Supply bequiet! Dark Power Pro 12 1200w Titanium
Mouse Glorious PC Gaming Race Model O, G903 Hero, G502 Hero SE, Deathadder V2, EC2-A
Keyboard ASUS ROG Strix Scope TKL DLX, Corsair K95, Logitech G815
Sorry for this OT:

With RP0 active the fans stop spinning at 50 degrees - after a benchmark for example - and the GPU cooling occurs more slowly. What do you recommend? To use or not to use RP0?
i am not a fan of zero RPM modes.
i use a custom fancurve that has the fans at 20-25% at idle and a decent but not too loud curve.
 
Joined
Oct 22, 2014
Messages
11,951 (4.98/day)
Location
Sunshine Coast
System Name Black Box
Processor Intel i5-9600KF
Motherboard NZXT N7 Z370 Black
Cooling Cooler Master 240 RGB AIO / Stock
Memory Thermaltake Toughram 16GB 4400MHz DDR4 or Gigabyte 16GB 3600MHz DDR4 or Adata 8GB 2133Mhz DDR4
Video Card(s) Asus Dual 1060 6GB
Storage Kingston A2000 512Gb NVME
Display(s) AOC 24" Freesync 1m.s. 75Hz
Case Corsair 450D High Air Flow.
Audio Device(s) No need.
Power Supply FSP Aurum 650W
Mouse Yes
Keyboard Of course
Software W10 Pro 64 bit
Joined
May 31, 2016
Messages
2,702 (1.49/day)
Location
Currently Norway
System Name Bro2
Processor Ryzen 2700X
Motherboard MSI X470 Gaming Carbon
Cooling Corsair h115i pro rgb
Memory 32GB G.Skill Flare X 3200 CL14 @ 2933Mhz CL14
Video Card(s) Powercolor 6900 XT Red Devil 1.1v@2400Mhz
Storage M.2 Samsung Evo 970 250MB/ Samsung 860 Evo 1TB
Display(s) LG 27UD69 UHD / LG 27GN950
Case Fractal Design G
Audio Device(s) realtec 5.1
Power Supply Corsair AXi 760W / Seasonic 750W GOLD
Mouse Logitech G402
Keyboard Logitech slim
Software Windows 10 64 bit
Did you upgrade windows recently? What build are you using?
I'd strongly recommend to reinstall windows or at least try windows recovery or troubleshooting and fix. This helps.
You can also try reset this PC option.
 

flaubert71

New Member
Joined
Apr 13, 2021
Messages
12 (0.36/day)
I installed a fresh copy of windows 19 Enterprise 20H2 Build 19042.928

Made some benchmarks
 

Attachments

  • Annotazione 2021-04-14 091107.png
    Annotazione 2021-04-14 091107.png
    1.1 MB · Views: 15
  • Annotazione 2021-04-14 091612.png
    Annotazione 2021-04-14 091612.png
    1.1 MB · Views: 16
  • Annotazione 2021-04-14 092109.png
    Annotazione 2021-04-14 092109.png
    1.1 MB · Views: 15
  • Annotazione 2021-04-14 095751.png
    Annotazione 2021-04-14 095751.png
    32 KB · Views: 14
Top